[Support] Linuxserver.io - Nextcloud

Recommended Posts

13 hours ago, Ray said:

What is gained by updating the docker container if we updated Nextcloud through its GUI?

The underlying image should be updated, at the very minimum whenever an update nextcloud is released and preferably more regularlry.


In the case of version changes to nextcloud, there may be changed/additional dependencies. On the subject of more regular refreshes, if there is a security issue with one of the dependencies or an update to say nginx or php for example, just updating the app in an existing container will not pick those up. 

Link to comment

Hi.  I opened terminal, and did those commands earlier 🙂  Was a risk for me.  Now I'm thinking if it broke my Unraid, I won't be able to fix it.  I don't have Apache Docker.  I do have letsencrypt docker.  I thought that will have an Apache server.  So I followed instructions from Collabora website, https://nextcloud.com/collaboraonline/, and followed the Video.  It says he has Apache, so he skipped that step.  I thought I have it too.  So I guess I don't.  How did you guys got Collabora working with your Nextcloud?  What's the best way to proceed?


@uldise, I saw on another post that you got Collabora installed by enabling docker-hub search.  I do not see Collabora by CA.  

Edited by jang430
Link to comment

I only see it after clicking get more results from docker-hub.  Will install now.  Don't know next step though.  I followed gridrunner's instructions, and created proxynet as Network Type for the docker.  Shall I also put this on proxynet So they all see each other?

Edited by jang430
Link to comment

OK.  So far, I've installed Collabora docker successfully.   It asked for domain, and I gave the subdomain I created for Nextcloud, and not for Collabora.  Is this correct?  After doing this, I went into Nextcloud, and downloaded Collabora App.  Then I went to Apps, Office & Text, Collabora Online App, and went to Admin, Collabora Online, and specified the subdomain I created for collabora.  


I still see the screenshot below:


Link to comment

updated Docker and now I am getting this when attempting to log into the WebUI, I have already removed and reinstalled the Docker as 1st step. I am attempting to connect through a VPN currently so i am not sure if that has anything to do with it. It used to work previously but its been a while since i  have needed to log in for anything.


I am not sure which logs i should be looking for to troubleshoot this.


edit: also logged into a machine on my local network (no vpn) and tried from there, same error.



Edited by unsainted
added notation
Link to comment

Hi @uldise


Saw your instructions:

Installed Collabora from CA DockerHub.  


I have xxxcloud.duckdns.org so I can access my Nextcloud.  It's working.  

I have xxxoffice.duckdns.org, don't know where or how to use this yet.


This is how my Docker tab currently looks.  Maybe you can help shed some light how to get Collabora working.




What port settings should be set?


I also went into nextcloud, In settings, collabora online, I had https://xxxoffice.duckdns.org in Collabora Online Server.  


I'm running linuxserver.io's letsencrypt and nextcloud docker.  To be able to use letsencrypt with nextcloud, I had to go change some conf files from linuxserver.io.  Do I need to do this here?  Thanks.

Link to comment
17 minutes ago, jang430 said:

What port settings should be set?


I also went into nextcloud, In settings, collabora online, I had https://xxxoffice.duckdns.org in Collabora Online Server.  

i think your port settings is just fine.

first - if you access Nextcloud over https, then Collabora must be on https too.

second - can you sucessfully open https://xxxoffice.duckdns.org from outside? for me, it opens just a blank page, but no error. if no, you should set your reverse proxy to do so.

Link to comment

I access nextcloud from outside via https.  I don't know how to get Collabora on https.  I've prepared a subdomain for it, named, xxxoffice.duckdns.org (example only).


When I go to https://xxxoffice.duckdns.org, I reach the following page.  It's supposed to be page from nginx, I think?  Don't know what to do next.


Link to comment

The docker for this updated last night and now nothing is working for me anymore. The logs seem to be littered with the following after the update:



PHP Fatal error: Uncaught Doctrine\DBAL\DBALException: Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2006] MySQL server has gone away in /config/www/nextcloud/lib/private/DB/Connection.php:64
Stack trace:
#0 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect()
#1 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion()
#2 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform()
#3 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\DBAL\Connection->getDatabasePlatform()
#4 /config/www/nextcloud/lib/private/DB/Connection.php(151): Doctrine\DBAL\Connection->setTransactionIsolation(2)
#5 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php(172): OC\DB\Connection->__construct(Array, Object(Doctrine\DBAL\Driver in /config/www/nextcloud/lib/private/DB/Connection.php on line 64

Anyone else seeing this and have any idea what it's going on about?

Link to comment
6 hours ago, allanp81 said:

The docker for this updated last night and now nothing is working for me anymore. The logs seem to be littered with the following after the update:


Anyone else seeing this and have any idea what it's going on about?

Seems that nextcloud doesn't play nice with mysql 8. I fixed it by following the guide here: https://help.nextcloud.com/t/nextcloud-13-php-7-1-mysql-8-error-500/34443/3


I had to edit the my.cnf file in the mysql docker (/etc/mysql/my.cnf) and add the following line to the [mysqld] section:

Link to comment
4 hours ago, jang430 said:

What does that mean?

i mean, collabora is ok then..

and you have problem with you ngix reverse proxy, cos if you enter https://xxxoffice.duckdns.org, you should see this the same "OK".

sorry, i have no ngix experience at all, i have an Apache as main webserver.


Link to comment

My current conf file for Nextcloud is way different than this.  It doesn't show path to ssl certificate, etc.  So I think just by changing the Internal IP may not do it.  Though I believe my conf file may be simplified a bit.  


The following is the conf file for nextcloud


# make sure that your dns has a cname set for nextcloud
# edit your nextcloud container's /config/www/nextcloud/config/config.php file and change the server address info as described
# at the end of the following article: https://blog.linuxserver.io/2017/05/10/installing-nextcloud-on-unraid-with-letsencrypt-reverse-proxy/

server {
    listen 443 ssl;

    server_name xxxcloud.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    location / {
        include /config/nginx/proxy.conf;
        resolver valid=30s;
        set $upstream_nextcloud nextcloud;
        proxy_max_temp_file_size 2048m;
        proxy_pass https://$upstream_nextcloud:443;

Link to comment


After the last update i get HTTP ERROR 500

And the following in nginx log:

[error] 306#306: *70 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Declaration of OC\Files\Storage\Local::copyFromStorage(OCP\Files\Storage $sourceStorage, $sourceInternalPath, $targetInternalPath) must be compatible with OC\Files\Storage\Common::copyFromStorage(OCP\Files\Storage $sourceStorage, $sourceInternalPath, $targetInternalPath, $preserveMtime = false) in /config/www/nextcloud/lib/private/Files/Storage/Local.php on line 43" while reading response header from upstream, client:, server: _,request: "PROPFIND /remote.php/webdav/ HTTP/1.0", upstream: "fastcgi://", host: 


Does somebody have the same problem?


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.