Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

2422 posts in this topic Last Reply

Recommended Posts

3 hours ago, L0rdRaiden said:

How is the updating process of this docker? will the docker automatically get the 15.0.2 or do I need to do something?

I followed the manual instructions via the link on the first post.  It does state you can use the web interface also, but I couldn't find any proof that was the preferred method after reading this entire thread.  I did have to re-install all of my apps for some reason, not sure why, but I did follow the directions exactly as provided.  Re-adding the apps was very simple, configuration settings relating to those apps appear to have been retained.  So I'm now on 15.0.2.

Edited by jbear

Share this post


Link to post
On 1/4/2019 at 1:43 PM, BDLR said:

Nextcloud and SABNZBD issue:  Nextcloud missing files after SABNZBD download

 

Hey Guys,

In Nextcloud I created a folder called "Howard Stern" and in SABNZBD I created a path to that folder.   I also added a category in SABNZBD to have those downloads moved to that folder.  SABnazbd is moving the file correctly and I can see it the files in that path but NEXTCLOUD is not showing those files in the WEBUI.    

 

Can any advise on the fix?   (I tried to show hidden files option and that didnt work)

 

 

 

 

Note sure if anyone replied on this, but files can't be added to Nextcloud by copying them directly into the user profile in the file folder.  You must leverage webdav, web interface etc.  Alternatively, iI you do choose to add them in this manner, you would need to invoke the occ tool from the command line, there is a parameter to add them to the database with files:scan.  Not sure if this would make sense or not.

 

Hope this helps.

 

Share this post


Link to post

You can also download the external drive app within next cloud (or whatever it’s called) and map to a share or folder on your system. Or your user path for all shares, if that floats your boat.

Share this post


Link to post
On 1/10/2019 at 7:32 PM, Darksurf said:

having an issue with this docker. I kind of want to blame unraid for this though. All my other dockers are working fine. In fact, this docker is working. The problem is I'm not getting a port mapping from the host to the docker and I can't even specify one completely. You can see in my attachment that I attempt to create a port map, but the options don't give me a place to choose a docker port, only a host port. and if you look in dockers tab, you see there's no mappings meanwhile the other dockers have no issues.

 

 

Screenshot_20190110_192656.png

Screenshot_20190110_192813.png

 OK, I just realized the issue. Evidently UNRAID is not aware that proxynet is a bridge. I had to select the default bridge and it then gave me a container port option! After setting the container port option, I was able to set the network interface back to the proxynet bridge and it worked!

Share this post


Link to post
8 hours ago, jbear said:

I followed the manual instructions via the link on the first post.  It does state you can use the web interface also, but I couldn't find any proof that was the preferred method after reading this entire thread.  I did have to re-install all of my apps for some reason, not sure why, but I did follow the directions exactly as provided.  Re-adding the apps was very simple, configuration settings relating to those apps appear to have been retained.  So I'm now on 15.0.2.

ok, thanks I did it, but if I update nextcloud manually when the docker updates by itself what is updating really?

Share this post


Link to post

After i updatet some Apps, i get an internal Server Error.

Can i disable all apps with one command ?

Share this post


Link to post
On 9/28/2018 at 2:42 PM, Konijntjes said:

When i did enter the docker container with ssh and did run the following command the error message was gone

 

sudo -u abc php /config/www/nextcloud/occ db:add-missing-indices

 

Only the "The "Referrer-Policy" HTTP header is not set to "no-referrer", "no-referrer-when-downgrade", "strict-origin" or "strict-origin-when-cross-origin". This can leak referer information." message to go

 

This help me fix upgrading to ver 15

Share this post


Link to post

Hi

 

I have some issues with autoupload. It does not work.

I have tried the following.

Delete my account, clear nextcloud cache, delete nextcloud, restart Samsung S7, install nextcloud but still does not work.

 

Any ideas and suggestions? Appreciate all help

Share this post


Link to post

Sorry to bother, I did try searching for this and found others with the issue but not a resolution.

 

I had 13.0.0 installed, updated to 14.x and then 15.0.2 after that - all via WebUI and that went very smoothly.

 

I just now have these warnings, before the upgrades I didn't have any warnings or issues here listed, I also still continue to get an A+ rating on the Nextcloud security scan, but I would like to resolve all of these issues listed here for good measure.

 

EDIT - got the tables updated w/ the sudo -u -abc command in the docker shell, but still not sure why the refer-policy is kicking that back, i had thought i had that issue on 13.x originally and fixed it. I'll have to look around some more, but if someone has a link or info handy feel free to send it my way!

 

Any help is appreciated!

 

image.thumb.png.a4ef418c64832179412f0c05a9274bec.png

Edited by CorneliousJD

Share this post


Link to post

Ok, so far I am still really struggling with this error.

 

Quote

The "Referrer-Policy" HTTP header is not set to "no-referrer", "no-referrer-when-downgrade", "strict-origin", "strict-origin-when-cross-origin" or "same-origin". 

I have searched around and found that the setup I followed had me put this in my reverse proxy (LetsEncrypt container) in my nextcloud site-config.

### Add HTTP Strict Transport Security ###
add_header Strict-Transport-Security "max-age=63072000; includeSubdomains";

Reasoning behind this I guess is that Nextcloud's own NGINX will issue those headers now after the update, and having them both cancels them out.

I've tried removing that from my LetsEncrypt site config and restarting both containers and no dice, the error still shows up.

 

Not sure what I'm doing wrong here - the post I initailly followed to set this all up is here: https://blog.linuxserver.io/2017/05/10/installing-nextcloud-on-unraid-with-letsencrypt-reverse-proxy/

Share this post


Link to post

Trying to setup NextCloud with Duckdns, letsencrypt, and MariaDB dockers.  Not sure when setting one of these up I missed something or not.  After setting all dockers up, when going to the WebUI for NextCloud, I am receiving the following message.

 

Welcome to our server

The website is currently being setup under this address.

For help and support, please contact: me@example.com

 

I should mention that I followed SpaceInvator One’s two guides for setting this up.  

 

Any ideas what’s going on? 

Edited by JohnSracic

Share this post


Link to post
10 hours ago, JohnSracic said:

Trying to setup NextCloud with Duckdns, letsencrypt, and MariaDB dockers.  Not sure when setting one of these up I missed something or not.  After setting all dockers up, when going to the WebUI for NextCloud, I am receiving the following message.

 

Welcome to our server

The website is currently being setup under this address.

For help and support, please contact: me@example.com

 

I should mention that I followed SpaceInvator One’s two guides for setting this up.  

 

Any ideas what’s going on? 

Try this URL - check the ending with the Nextcloud config files.

 

https://blog.linuxserver.io/2017/05/10/installing-nextcloud-on-unraid-with-letsencrypt-reverse-proxy/

 

It has to match the domain name you're trying to access from (your public facing DuckDNS domain)

Share this post


Link to post
3 hours ago, CorneliousJD said:

Try this URL - check the ending with the Nextcloud config files.

 

https://blog.linuxserver.io/2017/05/10/installing-nextcloud-on-unraid-with-letsencrypt-reverse-proxy/

 

It has to match the domain name you're trying to access from (your public facing DuckDNS domain)

 

I was for sure missing the nextcloud file in the /config/nginx/site-confs/ directory.  I coped directly from the link you provided and changed the two lines...  Now when I start letsencrypt and look at the logs, i see 'nginx: [emerg] unexpected "{" in /config/nginx/site-confs/nextcloud.rtf:1'.  Looking at the code, there are two open brackets and two closing brackets.  What am I missing?  Here is my nextcloud file...

 

------------------------------------

 

server {

listen 443 ssl;

server_name [name].duckdns.org;

 

root /config/www;

index index.html index.htm index.php;

###SSL Certificates

ssl_certificate /config/keys/letsencrypt/fullchain.pem;

ssl_certificate_key /config/keys/letsencrypt/privkey.pem;

###Diffie–Hellman key exchange ###

ssl_dhparam /config/nginx/dhparams.pem;

###SSL Ciphers

ssl_ciphers 'ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-SHA256:kEDH+AESGCM:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:ECDHE-ECDSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-DSS-AES128-SHA256:DHE-RSA-AES256-SHA256:DHE-DSS-AES256-SHA:DHE-RSA-AES256-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128-SHA256:AES256-SHA256:AES128-SHA:AES256-SHA:AES:CAMELLIA:DES-CBC3-SHA:!aNULL:!eNULL:!EXPORT:!DES:!RC4:!MD5:!PSK:!aECDH:!EDH-DSS-DES-CBC3-SHA:!EDH-RSA-DES-CBC3-SHA:!KRB5-DES-CBC3-SHA';

###Extra Settings###

ssl_prefer_server_ciphers on;

ssl_session_cache shared:SSL:10m;

 

        ### Add HTTP Strict Transport Security ###

add_header Strict-Transport-Security "max-age=63072000; includeSubdomains";

add_header Front-End-Https on;

 

client_max_body_size 0;

 

location / {

proxy_pass https://xxx.xxx.x.xxx:444/;

        proxy_max_temp_file_size 2048m;

        include /config/nginx/proxy.conf;

}

}

 

 

Share this post


Link to post
22 minutes ago, JohnSracic said:

 

I was for sure missing the nextcloud file in the /config/nginx/site-confs/ directory.  I coped directly from the link you provided and changed the two lines...  Now when I start letsencrypt and look at the logs, i see 'nginx: [emerg] unexpected "{" in /config/nginx/site-confs/nextcloud.rtf:1'.  Looking at the code, there are two open brackets and two closing brackets.  What am I missing?  

Not too sure off hand, it may be something going off with mixing SpaceInvader One's guide with the one I linked. You may want to blow it out and start over with the guide I linked above, that worked well for me with no issues roughly 6/7 months ago when I setup my container. 

Share this post


Link to post
On 1/18/2019 at 8:31 PM, CorneliousJD said:

Ok, so far I am still really struggling with this error.

 

I have searched around and found that the setup I followed had me put this in my reverse proxy (LetsEncrypt container) in my nextcloud site-config.


### Add HTTP Strict Transport Security ###
add_header Strict-Transport-Security "max-age=63072000; includeSubdomains";

Reasoning behind this I guess is that Nextcloud's own NGINX will issue those headers now after the update, and having them both cancels them out.

I've tried removing that from my LetsEncrypt site config and restarting both containers and no dice, the error still shows up.

 

Not sure what I'm doing wrong here - the post I initailly followed to set this all up is here: https://blog.linuxserver.io/2017/05/10/installing-nextcloud-on-unraid-with-letsencrypt-reverse-proxy/

Well I did end up fixing this, but not in a way that I found many answers for, but this works and still gives me an A+ on the NextCloud security and I get the following in Nextcloud too! 

 

All I did to fix this on my end was going into my LetsEncrypt site-conf for nextcloud, and under the ### Add HTTP Strict Transport Security ### section I added this header line.

add_header Referrer-Policy no-referrer;

After saving this and restarting LE and Nextcloud and re-checking, all checks pass and I'm getting an A+ on the security check!

image.png

Share this post


Link to post

Hi, is it possible to use the "External Storage" plugin to map and access my Unraid share through Nextcloud?  Based on comments in this thread it would appear this is possible however I haven't had any luck getting this to work.

 

So far I’ve tried connecting as either SMB / CIFS with username/password and login - session. Also tried adding a “.” in for domain… no luck.

 

Has anyone gotten this to work? 

 

sc_2019121_155458_605.thumb.png.157ddac034091924cea16ba56ad3c755.png

 

P.S. Another option I'm thinking of trying is to map the shares to the docker container and then try using local.

Share this post


Link to post
35 minutes ago, unRaide said:

Hi, is it possible to use the "External Storage" plugin to map and access my Unraid share through Nextcloud?  Based on comments in this thread it would appear this is possible however I haven't had any luck getting this to work.

 

So far I’ve tried connecting as either SMB / CIFS with username/password and login - session. Also tried adding a “.” in for domain… no luck.

 

Has anyone gotten this to work? 

 

sc_2019121_155458_605.thumb.png.157ddac034091924cea16ba56ad3c755.png

 

P.S. Another option I'm thinking of trying is to map the shares to the docker container and then try using local.

External storage works when you set the paths properly. It threw me for a small loop when I first set it up, but I use it without issue.

Share this post


Link to post
5 minutes ago, 1812 said:

External storage works when you set the paths properly. It threw me for a small loop when I first set it up, but I use it without issue.

Any tips you can share on how to set it up :) 

 

Ive tried numerous combinatorics... basically just looking to access either a specific share or the entire /mnt/user/ folder.

Share this post


Link to post
6 minutes ago, unRaide said:

Any tips you can share on how to set it up :) 

 

Ive tried numerous combinatorics... basically just looking to access either a specific share or the entire /mnt/user/ folder.

As this is external storage and nextcloud is accessing via SMB over network, the share must be accessible on the network (as set in Share settings).

Internal paths won't work, and I would personally create a non-root user to access those shares.

Assuming the share is exported to network, it should look like /media/ not /mnt/media/

Share this post


Link to post
46 minutes ago, unRaide said:

Any tips you can share on how to set it up :) 

 

Ive tried numerous combinatorics... basically just looking to access either a specific share or the entire /mnt/user/ folder.

 

Edit docker settings for Nextcloud 

Add path/port/variable

Give it a name, then how you want it presented inside the container (ex:/thiscrap) then the path on unRaid share you want available. If you’re just doing online viewing, set to read only if you like (I don’t think it will complain)

save

container should restart

 

Login to nextcloud web gui

Go to settings by clicking on the letter on the top right corner

Scroll down to administration section, click external storages

click add storage

select local

under configuration-location put in the container mapping you used before (/thiscrap)

Give  it a folder name, add users or groups, then save.

 

And done.

Share this post


Link to post

Yep, that did it... thanks again @1812!!!

 

I added the path as RW/Slave based on something I remember SpaceInvader One saying in the Krusader setup tutorial, so hopefully thats ok 👍

Share this post


Link to post
21 minutes ago, unRaide said:

Yep, that did it... thanks again @1812!!!

 

I added the path as RW/Slave based on something I remember SpaceInvader One saying in the Krusader setup tutorial, so hopefully thats ok 👍

Just means that anyone with access to the folder in nextcloud can add/modify/erase files to that share/path. If you’re fine with that then it’s no biggie.

 

glad to help! 

Share this post


Link to post

I've found that when accessing Nextcloud via my iOS phone client externally that it takes approximately 30-60 seconds to "wake up" and connect with the server--until then it appears like a non-responsive hung app and clicking various areas of the Nextcloud iOS app do nothing.  Internally it connects immediately via the app and website; externally it connects immediately via a browser--this change probably happened close to the 15.0 upgrade.  Anyone seen this before and have any insights or places to start looking?  Thanks!

Share this post


Link to post

Hey could someone assist me in setting up the nextcloud shares correctly?
Currently I have the following setup:
/data <-> /mnt/user/nextcloud
This share is set to cache disk "yes" because I don't want to keep users files on the cache disk but on the array. BUT this includes the owncloud.db file, which is in constant access by nextcloud, thus keeping my disks spun up almost all the time.
How would I setup nextcloud to leave the db file on the cache but move the user folders to the array when the mover runs.
I have smb shares mounted into the nextcloud shares as well, but these only have read access.
Could I tell nextcloud to create and keep user folders in a different location?
Edit: In windows I would just create a junction for every home share and point that to a location on the array.

Edited by shrtrnd

Share this post


Link to post

I just discovered nextcloud and I am trying to move all my files into nextcloud

 

I set my data folder to be /mnt/user/cloud-data/

 

I used mv in the web terminal on unraid to move all my files from my old share into /mnt/user/cloud-data/<username>/files/

 

the files are not showing up in nextcloud

 

I googled this issue and everyone is saying to run the command 

occ files:scan

 

i found the occ script in /config/www/nextcloud/ but I cant get it to run from within the docker exec

 

any help?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.