Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

2365 posts in this topic Last Reply

Recommended Posts

14 minutes ago, bobokun said:

Anyone else get this error when updating the nextcloud to the latest version? 16.0.2

image.thumb.png.1d53f1d718117a1612c7864bf8ff619b.png

 

The documentation is there in the text, so probably better to click the link.

Share this post


Link to post
5 minutes ago, saarg said:

 

I have no more suggestions. Others have successfully updated, so it's something local to you.

Might be better to ask on the nextcloud forum.

 

You tried to update using all versions from 14.0.0 up to 14.0.13?

I tried 14.0.0 somehow after upgrading I checked the config.php it says 14.0.19. I will try the other 14.0 version.

For what I read here so far, I was getting impression that everyone who upgraded uses the latest-* instead of nextcloud-*

Share this post


Link to post
5 minutes ago, pingmanping said:

I tried 14.0.0 somehow after upgrading I checked the config.php it says 14.0.19. I will try the other 14.0 version.

For what I read here so far, I was getting impression that everyone who upgraded uses the latest-* instead of nextcloud-*

 

Latest obviously doesn't seem to work for you, so no harm in trying other versions.

Might be you config.php is from when you tried updating earlier. There also aren't any version 14.0.19 as far as I see. Maybe try to change it to the version you are running?

 

Share this post


Link to post
21 minutes ago, saarg said:

 

Latest obviously doesn't seem to work for you, so no harm in trying other versions.

Might be you config.php is from when you tried updating earlier. There also aren't any version 14.0.19 as far as I see. Maybe try to change it to the version you are running?

 

I typo'd the 14.0.19. It is supposed to be 14.0.0.19 after the upgrade

Share this post


Link to post
50 minutes ago, saarg said:

 

The documentation is there in the text, so probably better to click the link.

I got the same error after the latest 16.0.2 update. It also shows it's on 16.0.2 and an update to 16.0.2 is available. The files it complains about are the following:

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results
=======
- viewer
	- EXTRA_FILE
		- cypress/fixtures/video.mkv
		- cypress/fixtures/video.webm
		- cypress/fixtures/image-small.png
		- cypress/fixtures/image3.jpg
		- cypress/fixtures/video.ogv
		- cypress/fixtures/video2.mp4
		- cypress/fixtures/image1.jpg
		- cypress/fixtures/image2.jpg
		- cypress/fixtures/image.png
		- cypress/fixtures/image.bmp
		- cypress/fixtures/video1.mp4
		- cypress/fixtures/image.gif
		- cypress/fixtures/image4.jpg
		- cypress/fixtures/image.svg
		- cypress/integration/video.mkv.spec.js
		- cypress/integration/image.gif.spec.js
		- cypress/integration/video.ogv.spec.js
		- cypress/integration/videos.spec.js
		- cypress/integration/image.svg.spec.js
		- cypress/integration/image-small.png.spec.js
		- cypress/integration/video.mp4.spec.js
		- cypress/integration/images.spec.js
		- cypress/integration/video.webm.spec.js
		- cypress/integration/image.png.spec.js
		- cypress/integration/files.spec.js
		- cypress/start.sh
		- cypress/plugins/index.js
		- cypress/support/commands.js
		- cypress/support/index.js
		- cypress/utils/index.js
		- cypress/stop.sh
		- cypress.json
- files_rightclick
	- EXTRA_FILE
		- README.md

None of the 2 addons (rightclick, pictureviewer) where marked with updates or with incompatible versions before the update. Never had an issue upgrading Nextcloud before. @bobokun What files are causing the issue for you? Any idea how to fix this?

Share this post


Link to post

I've had that message about integrity check. Fixed it by removing and reinstalling the apps/plugins. 

Share this post


Link to post

@Niklas for "files_rightclick" I did the same. Removing and reinstalling fixed it, but the mentioned "viewer" addon is marked as official app and can only be stopped and not uninstalled.

Share this post


Link to post
37 minutes ago, pingmanping said:

I typo'd the 14.0.19. It is supposed to be 14.0.0.19 after the upgrade

 

You might have some apps installed that prevents the update.

Did you try googling the error specific to the upgrade?

And do you restart the container after the update?

Share this post


Link to post
5 minutes ago, bastl said:

Deleting "/config/www/nextcloud/apps/viewer/cypress" and "/config/www/nextcloud/apps/viewer/cypress.json" as mentioned on github fixed it for me.

 

https://github.com/nextcloud/server/issues/16229

 

Made a backup of the folder and the json file, just in case.

Deleting those files/folders worked for me as well. Thanks!

Share this post


Link to post
47 minutes ago, saarg said:

 

You might have some apps installed that prevents the update.

Did you try googling the error specific to the upgrade?

And do you restart the container after the update?

Yes, all I found was database related.

Yes, I restarted the container.

This is not related to Unraid being version 6.5.3, right?

Share this post


Link to post
45 minutes ago, pingmanping said:

Yes, all I found was database related.

Yes, I restarted the container.

This is not related to Unraid being version 6.5.3, right?

Don't think so no. Did you try the suggestions above your post?

Share this post


Link to post
Posted (edited)

I managed to update to version 15.0.9 and everything is running fine (still with the container version 16.0.1-ls22).

only one warning about missing indices and one about big-init conversion which should be resolved on the command line (instructions given in the warning).

Only one question:

As the two commands that are required ('occ db:add-missing-indices' and 'occ db:convert-filecache-bigint') are database related, am I right to assume that those commands have to be run in the mariaDB container? Or do they need to be used in the nextcloud docker ?

 

I'd like to have all lights green before finally updating to version 16 ;)

 

Edited by Kevek79
addition

Share this post


Link to post
1 hour ago, Kevek79 said:

I managed to update to version 15.0.9 and everything is running fine (still with the container version 16.0.1-ls22).

only one warning about missing indices and one about big-init conversion which should be resolved on the command line (instructions given in the warning).

Only one question:

As the two commands that are required ('occ db:add-missing-indices' and 'occ db:convert-filecache-bigint') are database related, am I right to assume that those commands have to be run in the mariaDB container? Or do they need to be used in the nextcloud docker ?

 

I'd like to have all lights green before finally updating to version 16 ;)

 

 

You of course run those commands in the nextcloud container. occ is a nextcloud command.

Look at the update post for the correct user command and path for occ.

Share this post


Link to post
6 hours ago, saarg said:

 

You of course run those commands in the nextcloud container. occ is a nextcloud command.

Look at the update post for the correct user command and path for occ.

Thank you for the clarification.

Share this post


Link to post
13 hours ago, bastl said:

Deleting "/config/www/nextcloud/apps/viewer/cypress" and "/config/www/nextcloud/apps/viewer/cypress.json" as mentioned on github fixed it for me.

 

https://github.com/nextcloud/server/issues/16229

 

Made a backup of the folder and the json file, just in case.

Worked - thanks.

 

Another questions, I get this highlighted:

The "Strict-Transport-Security" HTTP header is not set to at least "15552000" seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips ↗.

How can I adjust this?

 

Regards

Share this post


Link to post
On 6/21/2019 at 1:47 PM, giusemr said:

Hello everyone, 

 

I tried to give my nextcloud setup a fresh install: fresh mariadb, fresh nextcloud docker and also removed everything (even hidden files) from the shares (appdata/nextcloud & Datashare). Following the guides from spaceinvaderone and linuxserver.io, the DB setup and first installation from nextcloud works. But then nextcloud tries to redirect me to my files page and I get a 302 redirect to /apps/files/ page that doesn't end. It doesn't matter if I take the stock config.php file an try to access directly or through the proxy with modified config.php. The result is the error "Too many redirects". On some issue discussion on github someone said there might be a permission issue with the files but I checked the config folder and the share folder and it's all set to "nobody:users".

 

I also found an issue on github which describes exactly my issue (https://github.com/nextcloud/server/issues/11203). My nginx logs inside the nextcloud container are also filled with this output.


GET /apps/files/ HTTP/1.1" 302

Has anyone an idea if this is related to the linuxserver image or to the nextcloud software?

 

I appreciate your help.

Thanks in advance.

I fixed this issue, inside the proxy config from the letsencrypt container I had changed the redirect port to 444 ( My host port) this lead to infinite redirects between the proxy and nextcloud.

Share this post


Link to post
1 hour ago, Toobie said:

Another questions, I get this highlighted:


The "Strict-Transport-Security" HTTP header is not set to at least "15552000" seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips ↗.

How can I adjust this? 

You have to add-it/uncomment it in the default site-config.

nano /config/nginx/site-confs/default

Mine looks like the following. You should find the section if you scroll down a bit. Not sure if I added the line or if you only have to uncomment it.

grafik.png.6f3fca3112db5a93308922d091952651.png

 

Share this post


Link to post
Posted (edited)

I am now getting this when trying to run nexcloud

 

This version of Nextcloud is not compatible with > PHP 7.2.
You are currently running 7.3.6

 

 

I have not updated PHP

Edited by Blade

Share this post


Link to post

I had the same versioning issue as most here - Once I was upgraded to 16, everything seemed to work, until i tried to access in my android app.

 

It seems now that my DNS is no longer being recognized.  I can connect on my local network with the IP:port, but when i try to connect (local or not) with my DynDNS:port i am getting a "The Server took too long to respond" error.

 

I never made any changes in nextcloud previously to use the DNS.  It is configured on my unraid server to use for any traffic (I know it is worked, as my OpenVPN is using it as well and I can connect with no problems.)

 

Is there some issue with Nextcloud and using DDNS, rather than IP?  I have tried a few different nextcloud apps, all get the same error.  Also does not work from a browser, so there is clearly something wrong with the request being passed through the DDNS to Nextcloud.

Share this post


Link to post
10 minutes ago, Blade said:

I am now getting this when trying to run nexcloud

 

This version of Nextcloud is not compatible with > PHP 7.2.
You are currently running 7.3.6 

 

 

I have not updated PHP

This happened before for people updating within the docker container with an older docker tag. Maybe search this thread back a bit for that error you will find some people reporting it like the following

 

Share this post


Link to post
1 hour ago, dmoney517 said:

I had the same versioning issue as most here - Once I was upgraded to 16, everything seemed to work, until i tried to access in my android app.

 

It seems now that my DNS is no longer being recognized.  I can connect on my local network with the IP:port, but when i try to connect (local or not) with my DynDNS:port i am getting a "The Server took too long to respond" error.

 

I never made any changes in nextcloud previously to use the DNS.  It is configured on my unraid server to use for any traffic (I know it is worked, as my OpenVPN is using it as well and I can connect with no problems.)

 

Is there some issue with Nextcloud and using DDNS, rather than IP?  I have tried a few different nextcloud apps, all get the same error.  Also does not work from a browser, so there is clearly something wrong with the request being passed through the DDNS to Nextcloud.

Solved my own issue.  needed to update my port fowarding (changed port by mistake when installing new version) and update config.php to accept the DNS address as trusted domain.

Share this post


Link to post
1 hour ago, bastl said:

You have to add-it/uncomment it in the default site-config.


nano /config/nginx/site-confs/default

Mine looks like the following. You should find the section if you scroll down a bit. Not sure if I added the line or if you only have to uncomment it.

grafik.png.6f3fca3112db5a93308922d091952651.png

 

 

Worked - thanks mate.

Another questions, I know it may already asked but I cannot find it in my configuration.

 

I wanted to change the background and nextcloud is giving me "upload_max_filesize" error

In which file do I have to make changes?

Share this post


Link to post
12 minutes ago, Toobie said:

I wanted to change the background and nextcloud is giving me "upload_max_filesize" error

Should be below the security header section somewhere

grafik.png.63f6f279b79415a183d6108e03bee444.png

 

Share this post


Link to post
2 minutes ago, bastl said:

Should be below the security header section somewhere

grafik.png.63f6f279b79415a183d6108e03bee444.png

 

found it, already set to 10G - so thats not the right one.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.