Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

2365 posts in this topic Last Reply

Recommended Posts

Posted (edited)

@Toobie I remember there was also a option in the admin panel of nextcloud in the settings somewhere, where you could define the max upload size. Can't find it anymore 🤨

 

Edited by bastl

Share this post


Link to post
Just now, bastl said:

@Toobie I remember there was also a option in the admin panel of nextcloud in the settings somewhere, where you could define the max upload size. Can't find it anymore 🤨

 

I also remember that there was an option, I also looked through the settings without success :/

 

Share this post


Link to post

@Toobie check /config/nginx/nginx.conf if there is a following line in the http section. I think on default it's set to 1MB and I changed it to 0

 

grafik.png.904f7dd102d38a04bb61f46864491947.png

 

 

Share this post


Link to post
2 minutes ago, bastl said:

@Toobie check /config/nginx/nginx.conf if there is a following line in the http section. I think on default it's set to 1MB and I changed it to 0

 

grafik.png.904f7dd102d38a04bb61f46864491947.png

 

 

Do you mean appdata/nextcloud/nginx/nginx.conf ?

I already have the same value there..

Share this post


Link to post

@Toobie YES. If you wanna edit this way. Thats the file. If you do it with the console into the docker itself it should be /config/nginx/nginx.conf

Share this post


Link to post
3 hours ago, bastl said:

This happened before for people updating within the docker container with an older docker tag. Maybe search this thread back a bit for that error you will find some people reporting it like the following

 

Worked perfectly - thank you so much

Share this post


Link to post
18 hours ago, saarg said:

 

You of course run those commands in the nextcloud container. occ is a nextcloud command.

Look at the update post for the correct user command and path for occ.

Thanks a lot @saarg - I'm now on the current versions of nextcloud and the respective docker container and everything is running great.

Now I need to learn whats new in nextcloud 16 ;)

Share this post


Link to post

Hi


So I'm a year overdue for re-working some of my old setup prior to going UnRaid and I'm seemingly a bit stuck.

I've set up MariaDB and configured a nextcloud user, database and password. MariaDB is set up to run on the Unraid server primary IP.

Nextcloud has been set up with a dedicated IP.

Unfortunately, I can't seem to connect.

Initially I got a DB password error, which I sussed down to be caused by an old password being present in the cache, since removed.

However, when I try to connect to the database from nextcloud I get the following;

image.png.087a4c84493190be05da09b6ebe5dbfc.png

Do I need to do something specifically for the MariaDB or for the NextCloud container for them to be able to communicate? I've tried searching, but all guides I've found don't have them running on separate IP's, and I really adore that feature.

Cheers for any help that can be provided here..

Share this post


Link to post
3 minutes ago, Froberg said:

Hi


So I'm a year overdue for re-working some of my old setup prior to going UnRaid and I'm seemingly a bit stuck.

I've set up MariaDB and configured a nextcloud user, database and password. MariaDB is set up to run on the Unraid server primary IP.

Nextcloud has been set up with a dedicated IP.

Unfortunately, I can't seem to connect.

Initially I got a DB password error, which I sussed down to be caused by an old password being present in the cache, since removed.

However, when I try to connect to the database from nextcloud I get the following;

image.png.087a4c84493190be05da09b6ebe5dbfc.png

Do I need to do something specifically for the MariaDB or for the NextCloud container for them to be able to communicate? I've tried searching, but all guides I've found don't have them running on separate IP's, and I really adore that feature.

Cheers for any help that can be provided here..

 

This is how the security works when you create a custom network and set an IP for the container. You can't connect to the host bridge.

So you need to set up mariadb in the same custom network as nextcloud.

Share this post


Link to post

Ah, that makes sense. Thanks for explaining it even though it's not a NextCloud issue. I'll give that a whirl, cheers.

Share this post


Link to post
On 7/3/2019 at 3:08 PM, Kevek79 said:

I also was running into the PHP issue described above and reverted the nextcloud docker back to 16.0.1-ls22 and boom, nextcloud is up and running again. Mac Desktop Client is reconnected and in sync.

 

As the current version of nextcloud is 16 i think I should upgrade my system ;)

Currently I am running version 14.0.3

From what I understand I should be able to upgrade to 15.0.8 from within the Web GUI (at least that is the zip file that is in the stable channel).

But if I start the updater it stops in the first step because of unexpected files .DS_Store and ._.DS_Store

I understand that such files are normaly produced by Mac-OS but I have no idea how to proceed form here.

Any hints?

 

edit

Does the file Check performed by the updater check the content of the appdata/nextcloude folder? Because I shared the appdata folder via smb while configuring some dockers and therefore have left some of these .DS_Store files also in the appdata/nextcloud folder. If I remove them via krusader, should help pass the test from the updater?

 

SOLVED:

Deleted the .DS_Store files in the appdata/nextcloud folder and ran the GUI Updater, currently nextcloud instance is running version 15.0.9.1 - Yipee

I am getting this identical error updating from 16.0.1 to 16.0.2. I have SCOURED where you describe the DS files are found and can't seem to locate them. Any advice? I have tried browsing appdata/nextcloud via SMB on network AND FTP and tried showing hidden files. Is their anyway to easily locate these DS files? Any help would be fantastic 😞

Share this post


Link to post
48 minutes ago, blaine07 said:

I am getting this identical error updating from 16.0.1 to 16.0.2. I have SCOURED where you describe the DS files are found and can't seem to locate them. Any advice? I have tried browsing appdata/nextcloud via SMB on network AND FTP and tried showing hidden files. Is their anyway to easily locate these DS files? Any help would be fantastic 😞

I used krusader (docker container) to get into appdata/nextcloud and deleted all DS_Stre files I could find.

also look in the subfolders

 

Share this post


Link to post
Posted (edited)
I used krusader (docker container) to get into appdata/nextcloud and deleted all DS_Stre files I could find.

also look in the subfolders

 

Yea it's a whole another issue but cant get krusader to startup. Have tried on both Mac and Windows client. Even used FTP from phone to look at not finding them.

 

Any idea if manual update instructions in OP are current and up to date? As I understand it doesn't check for such unnecessary files? I could go that route to avoid this issue a little longer?

 

EDIT: Solved; had to reinstall Binhex-Krusader

 

 

 

Edited by blaine07

Share this post


Link to post
2 hours ago, blaine07 said:

Yea it's a whole another issue but cant get krusader to startup. Have tried on both Mac and Windows client. Even used FTP from phone to look at not finding them.

 

Any idea if manual update instructions in OP are current and up to date? As I understand it doesn't check for such unnecessary files? I could go that route to avoid this issue a little longer?

 

EDIT: Solved; had to reinstall Binhex-Krusader

 

 

 

 

The update instructions have nothing to do with the issues you have. And yes, the instructions are up to date.

Share this post


Link to post
 
The update instructions have nothing to do with the issues you have. And yes, the instructions are up to date.
I know the update instructions have nothing to do with what I was doing BUT I had read manually updating circumvents extra files check that GUI runs to update with(& point it kept failing at) is all. So I asked if they was up to date as I was considering pursuing that avenue of updating so I wouldn't get hung up. I got everything updated without having to go manual; Krusader WAS able to see all the DSSTORE files. Thanks mate!!

Sent from my SM-G975U using Tapatalk

Share this post


Link to post
Posted (edited)

is anyone successfully using the Mail app within nextcloud?

Are there any dependencies needed to be installed additionally.

Can't get the app to show any emails in my inbox (folders are shown instantly but no content)

 

Has anyone encountered similar issues ?

I am running v16.0.2

 

edit:

tried to connect to another (much smaller) imap-inbox and it worked - somewhat :(

Tried to view some emails, but no pictures are shown, even if I hit the respective button to show them

when trying to download an attachment I got an error message (displayed on a page looking like my login screen)

 

at that point I looked into the nextcloud log and recognized a bunch of errors that were recorded during me testing the mail app.

most of them are related to "Horde_Imap_Client_Exception_ServerResponse"

 

Would it help to upload any diagnostics? Do I miss something completely here (dependencies, db configuration, php-config, etc.)?

 

Contact and Calender app are working like a breeze and I thought I give the Mail-app a try to round up the services, but so far this looks not good :(

 

Edited by Kevek79
Additional Info

Share this post


Link to post
Posted (edited)

Currently getting the following error:

This version of Nextcloud is not compatible with > PHP 7.2.
You are currently running 7.3.6.

 

Anything on my side or did something go wrong with the image?

Edited by Symon

Share this post


Link to post
Currently getting the following error:
This version of Nextcloud is not compatible with > PHP 7.2.
You are currently running 7.3.6.
 
Anything on my side or did something go wrong with the image?
Almost positive this is mentioned a page or two back.

Sent from my SM-G975U using Tapatalk

Share this post


Link to post

Question - Nextcloud related:

I made a share folder for some friends to drop me a couple of files.
The maximum of filesize he can upload is about 10mb, not more.
Is this a normal limit or can I amend this somewhere?

Sent from my MI 6 using Tapatalk

Share this post


Link to post
4 hours ago, Toobie said:

Question - Nextcloud related:

I made a share folder for some friends to drop me a couple of files.
The maximum of filesize he can upload is about 10mb, not more.
Is this a normal limit or can I amend this somewhere?

Sent from my MI 6 using Tapatalk
 

Are you running nextcloud with reverse proxy via letsencrypt?

If so I would guess that this is because of a limit in one of the nginx config files.

 

Best bet is /appdata/letsencrypt/nginx/proxy.conf but there are a couple of other config files that set the same parameter.

 

Parameter to look for is 'client_max_body_size' which is most probably set to 10m.

You could either set that to 0 to disable limitations or set a bigger limit.

Share this post


Link to post
Posted (edited)

I am suddenly getting error 522 when i try to access the nextcloud webui and i can't connect to my server using the domain name. I am connected using the windows app on my PCs with the IP address and it is functioning normally, but trying to connect using the domain name on my phone or laptop (https://nextcloud.mydomainname.com) times out. I also tried connecting via ip address on these devices and it connects, but when i try to log in, error 522.

 

EDIT: I just discovered that on the andorid app, If I try to connect with IP address, I get error 522, but I have an option to "Use old login method" which then works.

 

This was working literally an hour ago. I did a graceful shutdown of the server because of weather, and it was working at the time. After bringing the server back online I get the error. No configuration changes made. Letsencrypt logs show "nginx: [error] lua_load_resty_core failed to load the resty.core" but from my research, is not relevant.

 

SOLVED: turns out my external IP changed + configuration error in duck dns docker (an extra space in from of the token in the token field) stopping duck dns from updating. No idea why that was an issue now and not for the initial configuration, but its working now so I'm happy.

Edited by baconborn

Share this post


Link to post
Posted (edited)

I am having an issue getting to nextcloud's WEBui. Nextcloud is running but it opens a blank page.

 

The log reports:

 

 

ErrorWarningSystemArrayLogin


[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 10-adduser: executing...

-------------------------------------
_ ()
| | ___ _ __
| | / __| | | / \
| | \__ \ | | | () |
|_| |___/ |_| \__/


Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donate/
-------------------------------------
GID/UID
-------------------------------------

User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
[cont-init.d] 20-config: exited 0.
[cont-init.d] 30-keygen: executing...
using keys found in /config/keys
[cont-init.d] 30-keygen: exited 0.
[cont-init.d] 40-config: executing...
[cont-init.d] 40-config: exited 0.
[cont-init.d] 50-install: executing...
[cont-init.d] 50-install: exited 0.
[cont-init.d] 60-memcache: executing...
[cont-init.d] 60-memcache: exited 0.
[cont-init.d] 99-custom-files: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-files: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

 

Edited by darrenyorston

Share this post


Link to post
11 hours ago, Kevek79 said:

Are you running nextcloud with reverse proxy via letsencrypt?

If so I would guess that this is because of a limit in one of the nginx config files.

 

Best bet is /appdata/letsencrypt/nginx/proxy.conf but there are a couple of other config files that set the same parameter.

 

Parameter to look for is 'client_max_body_size' which is most probably set to 10m.

You could either set that to 0 to disable limitations or set a bigger limit.

I found the client_max_body_size 0; in two files:

letsencrypt/nginx/nginx.conf

letsencrypt/nginx/proxy-confs/nextcloud.subdomain.conf

 

The value 10m was set in the proxy.conf - changed now to 0.

client_body_buffer_size 128k is also written there - does changing this value have any affect?

Share this post


Link to post
51 minutes ago, Toobie said:

I found the client_max_body_size 0; in two files:

letsencrypt/nginx/nginx.conf

letsencrypt/nginx/proxy-confs/nextcloud.subdomain.conf

 

The value 10m was set in the proxy.conf - changed now to 0.

client_body_buffer_size 128k is also written there - does changing this value have any affect?

Is your upload issue solved with changing the client-max-body-size value? 

Share this post


Link to post
7 minutes ago, Kevek79 said:

Is your upload issue solved with changing the client-max-body-size value? 

Seems so - yes.

 

Thank you.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.