[SUPPORT] pihole for unRaid - Spants repo


Recommended Posts

35 minutes ago, PeteAsking said:

Must be your setup because I just reinstalled as a test and the template works perfectly and updates lists etc no issue.

Can you share your docker config screen/settings? 

 

I thought it was related to the Settings > Docker > Advanced view > Host access to custom networks. Mine was initially disabled.

 

Stopped Docker > Changed to enabled > Started docker > Force updated the pihole docker. It still doesn't see the internet or that it has an IPv4 address assigned to it according to my diag.

 

I think the key section of my debug diag log is this:

Quote

*** [ DIAGNOSING ]: Networking
[✗] No IPv4 address(es) found on the br0 interface.

[✗] No IPv6 address(es) found on the br0 interface.

 

Pihole docker settings

Quote

Network Type: Custom : br0

Fixed IP address (optional): 192.168.1.2              Subnet: 192.168.1.0/24

...

ServerIP: 192.168.1.2

...

INTERFACE: br0

 

 

Link to comment
15 hours ago, eisen4 said:

Can you share your docker config screen/settings? 

 

I thought it was related to the Settings > Docker > Advanced view > Host access to custom networks. Mine was initially disabled.

 

Stopped Docker > Changed to enabled > Started docker > Force updated the pihole docker. It still doesn't see the internet or that it has an IPv4 address assigned to it according to my diag.

 

I think the key section of my debug diag log is this:

 

Pihole docker settings

 

 

No problem, my config is on a vlan so bear in mind you wont be doing that presumably and thus the networking is simpler in your case:

Screenshot from 2022-02-03 09-27-18.png

Screenshot from 2022-02-03 09-27-32.png

Screenshot from 2022-02-03 09-27-43.png

Link to comment

Just fyi I noticed a mistake in my config, the ServerIP further down which seths the hostname record etc should be 192.168.7.5, and I incorrectly listed it in my ss above as 192.168.2.22. I corrected that now. It doesnt change much or stop the docker working but in case you are confused I have something on that IP and was obviously not paying too much attention when typing in that field when I redid it.

Link to comment

I think the difference between your setup and mine is on the br0.7 config. I only have my default br0. No VLANs enabled. Attempting to give my instance of pihole a different IP worked to access the interface, but I think I probably need to configure it via VLANs for it to work.

 

In the meantime, I just put pihole on an old model B. Would rather have it in unraid.

 

What's your config for networking? 

 

 

Screen Shot 2022-02-03 at 10.29.55 AM.png

Link to comment
1 hour ago, eisen4 said:

I think the difference between your setup and mine is on the br0.7 config. I only have my default br0. No VLANs enabled. Attempting to give my instance of pihole a different IP worked to access the interface, but I think I probably need to configure it via VLANs for it to work.

 

In the meantime, I just put pihole on an old model B. Would rather have it in unraid.

 

What's your config for networking? 

 

 

Screen Shot 2022-02-03 at 10.29.55 AM.png

My networking is such that I have a vlan (vlan 7) where the docker resides and my firewall has rules to allow this out to the internet and between vlans as required. This is not required unless you have vlans also. If you do then you would need to ensure your firewall rules apply correctly to allow traffic from the various ip's etc

Link to comment

After enabling Pi-hole on my network, and distributing DNS settings via my router, I'm getting a Privacy Warning on my Wifi network, and some iphones are saying they need to turn off Private Relay. I saw there is a way to fix that by disabling something in the config. I was wondering if there is something different I need to do in the docker config since I'm not running this on a Raspberry.

Link to comment
11 hours ago, markc99 said:

After enabling Pi-hole on my network, and distributing DNS settings via my router, I'm getting a Privacy Warning on my Wifi network, and some iphones are saying they need to turn off Private Relay. I saw there is a way to fix that by disabling something in the config. I was wondering if there is something different I need to do in the docker config since I'm not running this on a Raspberry.

If you block apples domains it interferes with their functioning of those features.

Link to comment
  • 1 month later...
2 hours ago, Neidhard said:

Yesterday there was still the possibility to specify a fixed IP here. This option is now gone and I can no longer start PiHole with the IP.
The network type "Custom" is also no longer available.

Unbenannt.png

Bridge network gives you that option

Link to comment

I'm stuck right at the very start. My server's home IP address is 192.168.1.10 and I access the server from most of my devices using a WireGuard VPN tunnel to IP 10.253.0.1. What IP do I need to give this docker to make it work? Leaving it at the default, the web ui tries to default do 192.168.1.1 which I can't access over the VPN. And if I try to access it using 10.253.0.1:443 or 80, just brings me to my unRAID instance, naturally.

Link to comment
On 1/10/2022 at 10:14 AM, Andiroo2 said:

 

Success!  I deleted the ../appdata/pihole/ directory completely and pulled a new image.  No go.  Then I changed the IP from .99 to .98 and it worked.  Something must be using .99 on my network already, even though my Unifi controller shows it as available.  More research to come, but for now my backup Pihole is running.  Thanks!

 

Follow up on this one.  My Unifi setup had created an internal honeypot on 192.168.1.99, but this wasn't listed in the clients section of the router.  This is why I thought it was available when I deployed Pihole to the same address.  Just in case anyone else has this issue in the future with their Unifi setup.

Link to comment
On 7/5/2020 at 4:44 AM, dalben said:

What's the easiest way to setup a cron job in the container?  Or uses the server's crontab to trigger a command in the container?

 

I'm trying to sync 2 Pihole installs, one on a Raspberry PI, and this container. The final step is to run "pihole restartdns reload-lists" in the container to read the sync'd db and custom.list.  Any ideas would be appreciated.

 

For those interested, I just copy (rsync) the gravity.db and custom.list from the RPI directly to the appdata/pihole/ directory on unraid.  The restart command will read the new files in.  I'm simply using cron to kick off the push at 30min past the hour and I want to run the script here at 32min past the hour.  I'm sure there are sexier ways of achieving this but this is already maxing out my technical abilities.  This also assumes the docker version of pihole is running v5.

Do you have now a sexier way to sync 2 piholes?
Do you have an idea how to use two piholes if I can only setup one DNS in my Router?

Link to comment
5 minutes ago, Konfitüre said:

Do you have now a sexier way to sync 2 piholes?
Do you have an idea how to use two piholes if I can only setup one DNS in my Router?

There might be something here:

 

On your DHCP server, you could put the address of pihole 1 as DNS 1 and pihole 2 as DNS 2. The way DNS works on LAN, DNS 1 and DNS 2 are both active, your clients will use both of them at random in parallel, it's not the case that they use 1 and only 2 if 1 fails. So that would give you an active/active HA setup.

Link to comment
4 minutes ago, norp90 said:

There might be something here:

On your DHCP server, you could put the address of pihole 1 as DNS 1 and pihole 2 as DNS 2. The way DNS works on LAN, DNS 1 and DNS 2 are both active, your clients will use both of them at random in parallel, it's not the case that they use 1 and only 2 if 1 fails. So that would give you an active/active HA setup.

The problem is that my router can only have one local DNS

Link to comment
10 minutes ago, Konfitüre said:

The problem is that my router can only have one local DNS

Could you setup your network so that one of the piholes is the DHCP server, have it set itself and teh 2nd as the DNS servers? Not perfect, if first fails network will still work but DHCP would be down.

Link to comment
43 minutes ago, norp90 said:

Could you setup your network so that one of the piholes is the DHCP server, have it set itself and teh 2nd as the DNS servers? Not perfect, if first fails network will still work but DHCP would be down.

I can try but I would prefer to keep dhcp for my router 😕

Link to comment
  • 3 weeks later...
On 3/24/2022 at 6:24 AM, Konfitüre said:

The problem is that my router can only have one local DNS

 

If your router is like mine (ASUS) then it only lets you set one DNS server in the DHCP settings because it then sets itself as the secondary.

 

So, if you want two piholes running, then

  • Set router's DHCP DNS server to pihole1. This then sets the DHCP DNS backup to the router.
  • Set the router's first DNS server to pihole2 and its second server to some external fallback, if you want that.

With this set up, if pihole1 goes down then DNS requests will get sent, via your router, to pihole2. Not ideal as you'll lose the requesting client on pihole2, but at least you're still handling the DNS.

Link to comment
  • 4 weeks later...
Posted (edited)

 

Hi All!

I've been having issues getting this container configured.  When I define an IP address I still get this error  "Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use."

 

I don't see where else to define the container IP.  I do have to use clean up app data every time I install otherwise it fails with another error message.

image.png

image.png

Edited by Wachuwamekil
Link to comment
  • 1 month later...
  • 2 weeks later...

For those having the issue with the container not working "

FTL failed to start due to cannot read /etc/dnsmasq.d/sedb0CBl7: Permission denied"

the issue for me was with the container data still being there when removing the container.
I had to manualy remove the "pihole" data from the appdata folder.

Link to comment

I can’t get this to work for the life of me. I have a bunch of dockers working perfectly. Pihole just doesn’t want to, apparently. I’ve tried assigning an IP with bridge mode, but it seems to never actually work. If I do that with any other container, it’s fine. I’ve followed every recent suggestion in this topic. No dice.

 

is there anything that could break this container with recent updates?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.