[SUPPORT] pihole for unRaid - Spants repo


904 posts in this topic Last Reply

Recommended Posts

On 2017-6-10 at 3:31 PM, ebnerjoh said:

Hi,

 

I got it running with virtual ip address for the Docker. 

 

But now a question: how is PiHole updated in the Docker?

 

Br,

Johannes

 

Hi

 

When the docker is updated by the docker owner, the template automatically shows that an update is ready (I am not building the docker....just supplying the template). Some of the changes to pihole need dockerfile changes so it best to wait until he updates the docker for all.

Link to post
  • Replies 903
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

See Spaceinvader One's setup video here:        I wrote the template that pulls in the Official Docker Container from PiHole. I swapped over from my unofficial one a long

Hi, I wanted to use this pihole docker as my second dns server, i already have a hardware raspberry pi as my main pihole dns, but having a backup is always good. I was wondering how i could

I just wanted to share a trick I used to have hostnames show up in the Pihole Dashboard for my local devices instead of IP addresses. Like this:     First make a copy of the /etc/

Posted Images

On 2017-6-14 at 10:04 AM, zin105 said:

/usr/bin/docker: Error response from daemon: driver failed programming external connectivity on endpoint pihole (570cd8e0a526d172f2b62b8a03dcba2c28c145fbb6561c961d63358fe9eca731): Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use.

I get this when I try to create the docker. When I do netstat -tlpnu | grep 53 then I can see 2 instances of this;


tcp        0      0 192.168.122.1:53        0.0.0.0:*               LISTEN                                                                  12023/dnsmasq
udp        0      0 192.168.122.1:53        0.0.0.0:*                                                                                       12023/dnsmasq

But I have no clue where dnsmasq is comming from.

 

 

would this help you? I think that KVM/VM subsystem can use port 53.... 

 

Link to post
  • 1 month later...
On 12/18/2016 at 4:04 AM, bluepr0 said:

 

thanks for your reply, just tried it but it does the same; docker and web ui it's working but not receiving queries

Have you ever resolved this?? I also have the same issue where my web UI is working and DNS is running but I'm not receiving any queries.

 

Starting dnsmasq
dnsmasq: started, version 2.77 cachesize 10000
dnsmasq: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth no-DNSSEC loop-detect inotify
dnsmasq: using nameserver 8.8.4.4#53
dnsmasq: using nameserver 8.8.8.8#53
dnsmasq: read /etc/hosts - 7 addresses
dnsmasq: read /etc/pihole/black.list - 0 addresses
dnsmasq: read /etc/pihole/local.list - 2 addresses
dnsmasq: read /etc/pihole/gravity.list - 442884 addresses

Link to post
On 23/07/2017 at 4:56 AM, bobokun said:

Have you ever resolved this?? I also have the same issue where my web UI is working and DNS is running but I'm not receiving any queries.

 

Starting dnsmasq
dnsmasq: started, version 2.77 cachesize 10000
dnsmasq: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth no-DNSSEC loop-detect inotify
dnsmasq: using nameserver 8.8.4.4#53
dnsmasq: using nameserver 8.8.8.8#53
dnsmasq: read /etc/hosts - 7 addresses
dnsmasq: read /etc/pihole/black.list - 0 addresses
dnsmasq: read /etc/pihole/local.list - 2 addresses
dnsmasq: read /etc/pihole/gravity.list - 442884 addresses

 

have you set the clients to use pihole? 

2 ways to do this - 

1) on your router, set the dns servers to point to the unraid box (or pihole IP address if you have changed it)

2) turn off dhcp on the clients if you have not chosen (1) and manually add the pihole server ip as the dns server address

Link to post
23 minutes ago, LordShad0w said:

I failed to install this properly, so I reverted all my settings and now my plex docker refuses to show the webUI. Can someone please advise?

 

 

 

Pihole should be fairly easy to use. Either run it on the server and use the servers ip address for the dns server for the clients.If this doenst work (you have another dns service on the unraid server) use the set separate IP address for a docker instance detailed a couple of posts back.

 

If you want to disable pihole on one of all clients, just change their settings to use dhcp to get their settings from the router or change their dns settings to google 8.8.8.8 and 8.8.4.4 and reboot clients.

 

Pihole doesnt affect plex directly - it may just be your dns settings on the clients 

Link to post
1 minute ago, LordShad0w said:

I honestly don't know what broke. :(
I just need to get plex working again. I'm already well into burning th candle at both ends and I am away on business for a week. My wife is gonna kill me...

try clearing your browser cache or try private mode....

Link to post
Quote


*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 8
6 10000 /config/Library/Application Support
10000
Jul 24 04:39:24 Tower syslog-ng[16]: syslog-ng starting up; version='3.5.3'
Plex Media Server is already running. Will not start...
6 10000 /config/Library/Application Support
10000
*** Shutting down runit daemon (PID 8)...
Jul 24 04:40:25 Tower syslog-ng[16]: syslog-ng shutting down; version='3.5.3'
*** Killing all processes...
*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 8
Jul 24 04:40:25 Tower syslog-ng[15]: syslog-ng starting up; version='3.5.3'
6 10000 /config/Library/Application Support
10000

That is all I get in the Plex docker log

 

Link to post
1 minute ago, LordShad0w said:

no errors in the plex docker logs and yes, everything else on the firetv works as intended

 

 

any other plex clients you can try? Other than a server reboot, Im not sure what to suggest ...

Link to post
Just now, LordShad0w said:

I already rebooted the server. Twice. :(
It only happened after I installed and then uninstalled pihole.

 

 

you just installed and uninstalled on the server? did you do anything to the clients?

do you have any other clients you can try?

I cant see how it could affect it .... 

Link to post
3 minutes ago, LordShad0w said:

I only installed/uninstalled on the server and set the #1 DNS on my router to the ip specified. I then changed the router DNS ip back to the original settings, saved, rebooted everything and now plex is boned. 

 

that is weird. I wonder if plex stores an ip address in its settings. I will remote in to mine and take a look

Link to post

The plex logs are at: (on my machine)

 

/mnt/user/appdata/plexmediaserver/Library/Application Support/Plex Media Server/Logs/

 

and the file:

Plex (anonymous).log

 

Does anything look strange with this file on your machine?

Link to post
Quote

ERROR - Error parsing allowedNetworks '192.168.1': Invalid argument
Jul 24, 2017 02:27:43.018 [0x7efd94f2b700] DEBUG - We're going to try to auto-select an audio stream for account 1
ERROR - SQLITE3:0x10, 8, statement aborts at 28: [UPDATE gnsdk_collection SET "coll_name"=?,"coll_data"=? WHERE "rowid"=6;] attempt to write a readonly database
Jul 24, 2017 03:08:24.150 [0x7efd9763b700] ERROR - Gracenote: Exception at line 1036, error -1870069755 (Resource is read-only)
Jul 24, 2017 03:08:24.175 [0x7efda5fff700] ERROR - SQLITE3:0x10, 8, statement aborts at 28: [UPDATE gnsdk_collection SET "coll_name"=?,"coll_data"=? WHERE "rowid"=6;] attempt to write a readonly database
Jul 24, 2017 03:08:24.178 [0x7efda5fff700] ERROR - Gracenote: Exception at line 1036, error -1870069755 (Resource is read-only)
Jul 24, 2017 03:08:24.178 [0x7efdd04a4840] DEBUG - Captured session 18.
Jul 24, 2017 03:08:24.204 [0x7efdd04a4840] DEBUG - Captured session 19.
 

This is what I found in the main plexmediaserver.log one

Edited by LordShad0w
Link to post
1 hour ago, spants said:

 

have you set the clients to use pihole? 

2 ways to do this - 

1) on your router, set the dns servers to point to the unraid box (or pihole IP address if you have changed it)

2) turn off dhcp on the clients if you have not chosen (1) and manually add the pihole server ip as the dns server address

 

Figured out what was wrong...it was stupid on my end. I'll post here so others won't make the dumb mistake like I did. In the template it shows that port 53 was assigned twice (Host 1 and Host 2) However I remember reading in this thread saying it's a duplicate and no need for one of those so I stupidly deleted the Host Port 2. Now I realized you need both (One is for UDP and one for TCP)

oCYYThQ.png

Edited by bobokun
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.