[Support] for atribe's repo Docker images


Recommended Posts

SpeedTestForInfluxDB seems to no longer work. I downgraded from influx 2 back to 1.8.6 since it broke too many things.

 

But the speed test is no longer working (was working before) and

get the following in the logs:

 

Loading Configuration File config.ini
Configuration Successfully Loaded
2021-06-09 20:32:17,631 - DEBUG: Testing connection to InfluxDb using provided credentials
2021-06-09 20:32:17,634 - DEBUG: Successful connection to InfluxDb
2021-06-09 20:32:17,634 - INFO: Starting Speed Test For Server None
2021-06-09 20:32:17,664 - DEBUG: Setting up SpeedTest.net client
Traceback (most recent call last):
File "/src/influxspeedtest.py", line 8, in <module>
collector.run()
File "/src/influxspeedtest/InfluxdbSpeedtest.py", line 173, in run
self.run_speed_test()
File "/src/influxspeedtest/InfluxdbSpeedtest.py", line 121, in run_speed_test
self.setup_speedtest(server)
File "/src/influxspeedtest/InfluxdbSpeedtest.py", line 71, in setup_speedtest
self.speedtest = speedtest.Speedtest()
File "/usr/local/lib/python3.7/site-packages/speedtest.py", line 1091, in __init__
self.get_config()
File "/usr/local/lib/python3.7/site-packages/speedtest.py", line 1174, in get_config
map(int, server_config['ignoreids'].split(','))
ValueError: invalid literal for int() with base 10: ''
Loading Configuration File config.ini
Configuration Successfully Loaded
2021-06-09 20:50:45,047 - DEBUG: Testing connection to InfluxDb using provided credentials
2021-06-09 20:50:45,050 - DEBUG: Successful connection to InfluxDb
2021-06-09 20:50:45,050 - INFO: Starting Speed Test For Server None
2021-06-09 20:50:45,058 - DEBUG: Setting up SpeedTest.net client
Traceback (most recent call last):
File "/src/influxspeedtest.py", line 8, in <module>
collector.run()
File "/src/influxspeedtest/InfluxdbSpeedtest.py", line 173, in run
self.run_speed_test()
File "/src/influxspeedtest/InfluxdbSpeedtest.py", line 121, in run_speed_test
self.setup_speedtest(server)
File "/src/influxspeedtest/InfluxdbSpeedtest.py", line 71, in setup_speedtest
self.speedtest = speedtest.Speedtest()
File "/usr/local/lib/python3.7/site-packages/speedtest.py", line 1091, in __init__
self.get_config()
File "/usr/local/lib/python3.7/site-packages/speedtest.py", line 1174, in get_config
map(int, server_config['ignoreids'].split(','))
ValueError: invalid literal for int() with base 10: ''

Link to comment
On 4/2/2021 at 8:10 PM, B0rax said:

@canadje: It works for me. all the latest updates. I needed to change the location of influxdb data storage though. it also helps to change the web path to the correct port so you can use the influxdb webui.

Is it possible to share your setting?
I only have my influx settings like:

image.png.79c7d7e7297d453ed937577c3c37d0a2.png

Or do I need to change something in my Grafana settings?

I don not understand what to change to use influxdb 2.0 with Grafana?

Also my webui of influxdb is not working

 

Edited by canedje
Link to comment

Something weird has been going on with Grafana.

 

A short time ago, it updated to V8.0 which broke a bunch of my value mappings.  I managed to fix those under new templates.

 

Today there was another update for Grafana Docker and now it's back at version 7.5.8 which isn't even on their release page: https://grafana.com/docs/grafana/latest/release-notes/

 

This change back from 8.0 broke some of my dashboard panels again.

 

 

for now I've gone and put in "grafana/grafana:8.0.2" as my repository to force the version as the default seems to not be consistent with what version it grabs and v7 to v8 changes a lot of the panel configs.

 

 

image.thumb.png.1426c6c1e356b71206ed4c122f0b0803.png

 

 

Edited by axipher
Link to comment
  • 2 weeks later...

Updated Grafana recently and I guess it went to v8.0.3. I didn’t have problems with my items (although it did change some of the coloring and formatting) but I’m now having Chrome and Chromium crashes on a couple of display systems. The Aw, Snap variety that don’t auto-recover. Anyone else dealing with this?

Link to comment
  • 2 weeks later...
  • 2 weeks later...

I am running the most recent version of Glances on unraid.  It actually updated the other day.  Today i have noticed that the docker will not start.  Receiving the below error in my docker log.  Anyone else seeing this or know how to fix?  

 

/usr/local/bin/python3: No module named glances

Link to comment
On 7/26/2021 at 5:46 AM, JohnSracic said:

I am running the most recent version of Glances on unraid.  It actually updated the other day.  Today i have noticed that the docker will not start.  Receiving the below error in my docker log.  Anyone else seeing this or know how to fix?  

 

/usr/local/bin/python3: No module named glances

Same error on my 6.9.2 box after the latest container update. Looks like there is already a GitHub issue targeting a fix in Glances 3.2.3 release: https://github.com/nicolargo/glances/issues/1905.

 

Workaround would be to add a version tag to the container config like this:

 

image.png.6b4bba52de9908f36fcc662a4e5daf8c.png

Edited by baccula
  • Like 3
Link to comment
  • 1 month later...
On 6/9/2021 at 1:53 PM, dandiodati said:

SpeedTestForInfluxDB seems to no longer work. I downgraded from influx 2 back to 1.8.6 since it broke too many things.

 

But the speed test is no longer working (was working before) and

get the following in the logs:

 

 

I just noticed that as of 8/25 at about 5am pt SpeedTest started working again.  I didn't (or don't remember) make any changes, it just started working.  Maybe take another look at yours.

Link to comment

I've been using Grafana flawlessly for over a year with InfluxDB and Varken behind the Ultimate Unraid Dashboard 1.5.

 

I'm not sure if it was a Docker container update for any of the three above, but now Plex data is not showing in the Grafana Dashboard. Attached is an example for "TV Shows added this week" All other Plex data (Streams, Clients, etc) is showing old or no data.

 

If it helps diagnose, all other Unraid data on the dashboard is working fine EXCEPT "data added to array" info for day, month, year. Its like that counter reset, I'm guessing the same time as the Varken data went wonky.

 

I've looked at the Varken and InfluxDB databases, rolled back their docker containers, no luck.

 

Any help or guidance appreciated.

 

image.thumb.png.8b74aa4cca85cbd6453ccb8b5070b15f.png

 

Link to comment
On 8/30/2021 at 9:07 PM, joshallen2k said:

I've been using Grafana flawlessly for over a year with InfluxDB and Varken behind the Ultimate Unraid Dashboard 1.5.

 

I'm not sure if it was a Docker container update for any of the three above, but now Plex data is not showing in the Grafana Dashboard. Attached is an example for "TV Shows added this week" All other Plex data (Streams, Clients, etc) is showing old or no data.

 

If it helps diagnose, all other Unraid data on the dashboard is working fine EXCEPT "data added to array" info for day, month, year. Its like that counter reset, I'm guessing the same time as the Varken data went wonky.

 

I've looked at the Varken and InfluxDB databases, rolled back their docker containers, no luck.

 

Any help or guidance appreciated.

 

image.thumb.png.8b74aa4cca85cbd6453ccb8b5070b15f.png

 

Anyone with any thoughts at all on this? Thanks!

Link to comment
  • 3 weeks later...

cant create container with grafana.ini ,tryed with variable GF_PATHS_CONFIG  /etc/grafana/grafana.ini  

but havining issure with permission,  tryed /mnt/user/appdata/grafana/etc/grafana/  or /mnt/user/appdata/grafana/etc/472 root but no luck 

any one made it up ?

 

image.thumb.png.53bcef458170b32c0245f075c5877b6b.png

 

 

image.png.791300bc8a0510715e1f91c757a8a7cb.png

Edited by Masterwishx
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.