[Support] Linuxserver.io - TVHeadend


1209 posts in this topic Last Reply

Recommended Posts

24 minutes ago, mgranger said:

Sorry I am not familiar with TVheadend yet.  What am I looking for here?

 

I'm away from home, but go in settings of tvheadend and find stream profiles and edit the profile named in the lag and set the option that says 0 somewhere to auto. 

Link to post
  • Replies 1.2k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: TVHeadend Application Site: https://tvheadend.org/ Docker Hub: https://hub.docker.com/r/linuxserver/tvheadend/ Github: https://github.com/linuxserver/docker-tvheadend

You need to install the driver to use your adapter. Then use /dev/dvb as the path for the device pass through. If you are using 6.9.x I don't know if the permissions are set correctly, so make sure no

You need to configure the grabber you want to use, then run it, then map epg source to the channel. There is a link in the first post to the readme on github which has information about configuring yo

Posted Images

Hi all,

 

first of all thanks for the great support here - i have learned much by reading .

 

No all is setup proper but i have one problem- i migrate from a standalone TVH and want to import my channel list and picons.

 

And i dont have any knowledge to do that.

 

How can I import anything on docker?

 

How can i browes thorugh the shares ?

 

Can I stop TVH in Docker?

 

I must delete and replace files in this folders:

 

/home/hts/.hts/tvheadend/input/

 /home/hts/.hts/tvheadend/channel/

 

Any tipp for me ?

Link to post
40 minutes ago, xsasx said:

Hi all,

 

first of all thanks for the great support here - i have learned much by reading .

 

No all is setup proper but i have one problem- i migrate from a standalone TVH and want to import my channel list and picons.

 

And i dont have any knowledge to do that.

 

How can I import anything on docker?

 

How can i browes thorugh the shares ?

 

Can I stop TVH in Docker?

 

I must delete and replace files in this folders:

 

/home/hts/.hts/tvheadend/input/

 /home/hts/.hts/tvheadend/channel/

 

Any tipp for me ?

Stop the docker and you'll find the files in the appdata folder you choose (defaults to /mnt/user/appdata/tvheadend I think) - I'd backup before deleting just in case.  A good way to backup  dockers is to use the CA backup plugin.

Once you've changed your files, restart the docker.

Link to post
2 hours ago, xsasx said:

Hi all,

 

first of all thanks for the great support here - i have learned much by reading .

 

No all is setup proper but i have one problem- i migrate from a standalone TVH and want to import my channel list and picons.

 

And i dont have any knowledge to do that.

 

How can I import anything on docker?

 

How can i browes thorugh the shares ?

 

Can I stop TVH in Docker?

 

I must delete and replace files in this folders:

 

/home/hts/.hts/tvheadend/input/

 /home/hts/.hts/tvheadend/channel/

 

Any tipp for me ?


picons are included.

Link to post

I am now trying to get the EPG setup.  I have typed the following in 

 

docker exec -it -u abc tvheadend /usr/bin/tv_grab_sd_json --configure

and I go through all the information as far as setting up the cache and username and password.   then after I get to the end I enable the module.  I then hit the button to rerun internal EPG grabbers but nothing seems to show up.  What am I missing here?

Link to post
20 minutes ago, mgranger said:

I am now trying to get the EPG setup.  I have typed the following in 

 


docker exec -it -u abc tvheadend /usr/bin/tv_grab_sd_json --configure

and I go through all the information as far as setting up the cache and username and password.   then after I get to the end I enable the module.  I then hit the button to rerun internal EPG grabbers but nothing seems to show up.  What am I missing here?

 

You looked at this guide?  I only use OTA EPG so can't help.

 

https://www.linuxserver.io/2017/02/19/how-to-set-up-tvheadend-with-your-dvb-t2-receiver/

 

If you're still having problems after following this, maybe @Stark can help.

Link to post
21 minutes ago, mgranger said:

I am now trying to get the EPG setup.  I have typed the following in 

 


docker exec -it -u abc tvheadend /usr/bin/tv_grab_sd_json --configure

and I go through all the information as far as setting up the cache and username and password.   then after I get to the end I enable the module.  I then hit the button to rerun internal EPG grabbers but nothing seems to show up.  What am I missing here?

 

Click the two up arrows in the bottom right and trigger a grab again to see if it's grabbing anything. There will be a summary at the end with new shows and total. 

You might also need to close the tab and open it again to show. 

Another thing is that you might need to choose the epg source for every channel. 

Link to post
1 hour ago, saarg said:

 

Click the two up arrows in the bottom right and trigger a grab again to see if it's grabbing anything. There will be a summary at the end with new shows and total. 

You might also need to close the tab and open it again to show. 

Another thing is that you might need to choose the epg source for every channel. 

 

Ok it looks like adding the epg source to every channel may do the trick.  I was hoping to avoid having to do this since I didn't have to do it in MythTV however I should only have to do it once when I set it up so I guess I will just live with it.  Thanks for the help 

Link to post
11 minutes ago, memphisto said:

I would like to stream for 1600 users. I think it's better to use the pcie card than usb. But I do not know how much one stream needs computing power.

 

It will be the network that will be your problem. Multiply a HD stream by 1600 and you will see that you have a problem.

You might want to look at other options to do this and will probably need to use multicast.

 

Is this for professional use? 

Link to post
Just now, memphisto said:

1600 user it's maximum peak. I think for real use is half or less. But you never know.

Is one time project, for accommodation facilities. I just wanna pass-through DVT2 streams to the network.

 

Even at half you will have a problem. You need multicast for this to work or set up multiple servers.

Link to post
3 minutes ago, memphisto said:

They use Cisco switches, so multicast is supported. So if i understand correctly, if we enable multicast on switches, from the server side looks like a couple streams, right?

 

I think you misunderstand me. Tvheadend doesn't support streaming to clients via multicast.

Maybe MuMuDVB supports this.

Link to post

I'm trying to set up an IPTV source in tvheadend but can't have it working.

 

With version 4.3, I get : 'no assigned adapters'

With version 4.2.5, I get : 'scan no data, failed'

 

However, the m3u url I'm providing to tvheadend works just fine with VLC. Any idea ?

Link to post
5 minutes ago, delivereath said:

I'm trying to set up an IPTV source in tvheadend but can't have it working.

 

With version 4.3, I get : 'no assigned adapters'

With version 4.2.5, I get : 'scan no data, failed'

 

However, the m3u url I'm providing to tvheadend works just fine with VLC. Any idea ?

 

Not enough info to say what's going wrong.

Is it multicast IPTV? If so, is the container set to use host networking?

Where and how did you add the m3u?

You create a Network and add the m3u in the URL field like below?

 

file:///config/get.m3u

 

Link to post

Not sure about multicast. I've anyway set the container to host network.

 

I went to network, then add, type 'IPTV Automatic Network', I entered a link to a custom m3u file which has a single channel. tvheadend is able to grab the file and parse it as it correctly lists the found channel in the muxes list.

 

Is there any way to enable a more verbose log ?

Link to post
12 minutes ago, delivereath said:

Not sure about multicast. I've anyway set the container to host network.

 

I went to network, then add, type 'IPTV Automatic Network', I entered a link to a custom m3u file which has a single channel. tvheadend is able to grab the file and parse it as it correctly lists the found channel in the muxes list.

 

Is there any way to enable a more verbose log ?

 

So the channel is in the muxes list. Then you have to map it to channels, then try to play it.

You are not at all clear when the error happens. It's hard to help when you don't provide much details.

Link to post

I can't map it to channels as tvheadend fails to scan the mux. When I force the mux scan, I only get 'scan no data, failed' in the console log. Is there any verbose log anywhere ?

 

Here is what I have in the found mux. In URL is a link to *.ts file :

e2be38e0efe169165ae6617061a1568dd616bd96

Edited by delivereath
Link to post
5 minutes ago, delivereath said:

I can't map it to channels as tvheadend fails to scan the mux. When I force the mux scan, I only get 'scan no data, failed' in the console log. Is there any verbose log anywhere ?

 

Here is what I have in the found mux. In URL is a link to *.ts file :

e2be38e0efe169165ae6617061a1568dd616bd96

 

If it's not scanning the mux correctly the channel is not found as you said in your previous post.

What is the source of the stream? Are you specifying a ts file stored somewhere? 

Link to post

No, I'm not specifying a ts file. I just placed a link to a m3u file in the URL of the network. The file has a single ts link. The file was correctly downloaded and parsed as tvheadend listed in the mux. But then it cannot scan it. Is there any detailed log ? Or a way to increase verbosity of the log ?

Link to post
14 minutes ago, delivereath said:

No, I'm not specifying a ts file. I just placed a link to a m3u file in the URL of the network. The file has a single ts link. The file was correctly downloaded and parsed as tvheadend listed in the mux. But then it cannot scan it. Is there any detailed log ? Or a way to increase verbosity of the log ?

 

So this is only a link to a ts file that you want tvheadend to download and play? If so, that is not how tvheadend works.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.