[Support] Linuxserver.io - TVHeadend


Recommended Posts

5 hours ago, ykmail05 said:

Hi, i'm trying to setup linuxserver/tvheadend container behind a reverse proxy. The docker image let us define an environment  parameter  to specify webroot for reverse proxy "-e RUN_OPTS". The question is what is the syntax to define the RUN_OPTS like "--http_root /tvheadend" in /etc/service.d/tvheadend/run .

What i'm tryin to set up is to acces the web interface at https://<DOMAIN>/tvheadend

 

 

You have to look at the tvheadend documentation for how to use --http_root. Then, add it to the RUN_OPTS variable. 

Link to comment
3 hours ago, saarg said:

 

You have to look at the tvheadend documentation for how to use --http_root. Then, add it to the RUN_OPTS variable.  

Did the --http_root config, it seems to work (got the logo on the browser tab) but nothing on the page (blank).

Edited by ykmail05
Link to comment
11 hours ago, vw-kombi said:

I got a notification for an update to this docker today.

I came here to find out what that may entail, if there are fixes/enhancements etc, or if there are any issues I need to be aware of.

Is this the right place ?  As I cant see any mention of it.

 

The latest tag (if you just use linuxserver/tvheadend in the repository field), is always built each Friday night. But there was an error in the tvheadend source making tvheadend not to compile on alpine Linux. The developer of tvheadend was on vacation, so it was fixed just now and we triggered a build as it had some fixes for epg. 

 

For changes on the latest tag, you have to check the tvheadend github page. 

Check out the the github link in the PP for changes to this container image (not often). The Friday night builds doesn't have any changeling as it's automatic built to get the latest dependencies in case of bugs or security fixes. 

Link to comment

Hi, when i want to use the --device... function for hardware transcoding (intel), possible to work side by side when already plex uses this feature ?

 

or only 1 access possible, no idea if thats equal to an hardware passthrough, then only 1 of course.

 

thanks ahead for an tipp ;)

Link to comment
30 minutes ago, alturismo said:

Hi, when i want to use the --device... function for hardware transcoding (intel), possible to work side by side when already plex uses this feature ?

 

or only 1 access possible, no idea if thats equal to an hardware passthrough, then only 1 of course.

 

thanks ahead for an tipp ;)

 

Try it and see what happens ?

I don't know how many streams the CPU can handle, so it might fail if you are transcoding too many streams at the same time. 

Link to comment
1 minute ago, alturismo said:

always max 1, just wanted to know if its even possible the 2 seperate dockers can use this feature ...

 

i added to TVH and it doesnt look like its used when i compare CPU usage with PLEX when using that feature.

 

You have to set it up in TVheadend also. It's not plug and pray ?

Link to comment

and thats the error in TVH

 

2018-07-31 16:05:38.303 transcode: 0003: Unable to open h264_vaapi encoder

so maybe blocked cause already loaded by PLEX, thats what my question was if TVH even could use hardware acc if PLEX docker also preloaded --device ...

Edited by alturismo
Link to comment
1 minute ago, alturismo said:

i added to EXTRA PARAMETER

 

--device=/dev/dri

 

and changed in TVH

 

image.png.1f3da93faa9d53e2aac5e8b33695efc5.png

 

anything else i forgot ?

 

I don't remember how to set it up and I'm away from home. 

But you are comparing cpu usage to transcoding with software? Or didn't you transcode the streams before you added the GPU? 

Link to comment
1 minute ago, alturismo said:

and thats the error in TVH

 


2018-07-31 16:05:38.303 transcode: 0003: Unable to open h264_vaapi encoder

so maybe blocked cause already loaded by PLEX, thats what my question was if TVH even could use hardware acc if PLEX docker also preloaded --device ...

 

I didn't know, hence the try it comment ?

Link to comment

as i see TVH doesnt load the vaapi correctly, i ll try l8 when plex is turned off if then TVH would load vaapi correctly.

 

Now i see TVH needs CPU power (cause software decoding) while PLEX using hardware acc ... no real CPU usage.

 

i will try with plex off and restart tvh to see if then TVH is able to use vaapi, then it would be clear if theres only 1 access possible ;)

 

thanks for trying

 

EDIT

 

tested now also with PLEX off, restarted TVH, no difference, same error, unable to open h264 vaapi ...

 

just as note 

Edited by alturismo
Link to comment
8 minutes ago, alturismo said:

as i see TVH doesnt load the vaapi correctly, i ll try l8 when plex is turned off if then TVH would load vaapi correctly.

 

Now i see TVH needs CPU power (cause software decoding) while PLEX using hardware acc ... no real CPU usage.

 

i will try with plex off and restart tvh to see if then TVH is able to use vaapi, then it would be clear if theres only 1 access possible ;)

 

thanks for trying

 

EDIT

 

tested now also with PLEX off, restarted TVH, no difference, same error, unable to open h264 vaapi ...

 

just as note 

 

Might need to chmod 777 /dev/dri to get it working though. 

Link to comment
5 minutes ago, alturismo said:

thats done already, working in PLEX fine ... so i assume something else wrong here ;)

 

nevermind, not a big deal, would be just nice if its possible to use it ;) cause TVH client mobile is by far stable compared to PLEX for live TV

 

I had it working when I tested it. I'll see if I get the time to test again. 

Link to comment
On 7/23/2018 at 5:26 AM, saarg said:

 

You have to look at the tvheadend documentation for how to use --http_root. Then, add it to the RUN_OPTS variable. 

 

I found instructions in this post to make a change so I can use this behind nginx.

 

I made the change like this as per a post here :

 

root@Tower:/etc/services.d/tvheadend$ more run
#!/usr/bin/with-contenv bash

IFS=" " read -r -a RUN_ARRAY <<< "$RUN_OPTS"

exec \
        s6-setuidgid abc /usr/bin/tvheadend -C -c /config "${RUN_ARRAY[@]}" --http_root="/tvheadend"

 

But when I restart the docker, nothing found on the normal url http://192.168.1.7:9981, or on what Iu assumed would be the new url http://192.168.1.7:9981/tvheadend

 

I guess I am doing something wrong ?

 

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.