Jump to content
linuxserver.io

[Support] Linuxserver.io - Oscam

60 posts in this topic Last Reply

Recommended Posts

linuxserver_medium.png

 

Application Name: Oscam

Application Site: http://www.streamboard.tv/oscam/

Docker Hub: https://hub.docker.com/r/linuxserver/oscam/

Github: https://github.com/linuxserver/docker-oscam

 

Please post any questions/issues relating to this docker you have in this thread.

 

If you are not using Unraid (and you should be!) then please do not post here, instead head to linuxserver.io to see how to get support.

Edited by linuxserver.io

Share this post


Link to post

Edit: Nevermind guys. It was set up as bridged...gotta be a host obviously. All running now.

 

Hey guys,

used to run Oscam on a raspi, now wanna use this docker. I copied my settings over pretty much, but even with some tinkering I cant get my clients to show up/connect. This might be port related, although even clients within the same network dont connect. The clients use cccam.

I'm confused by port 10000 used by the docker, anyway, here are some basic infos to ports and C-line:

Unraid machine ip(local): 192.168.178.56

WebIF:8888 (docker default)

Port:10000 (docker default,whatever this is used for)

CCcam Port in Oscam.conf: 49384

In the router, port 49384 gets redirected to 49384 on 192.168.178.56.

C-line on client:

C: 192.168.178.56 49384 username password

I tried forewarding 49384 to 10000 on 192.168.178.56 as well, since I have no idea what the second port is used for, but no luck as well.

Yes, the machine and client are in the same network.

 

Can anybody point me in the right direction ?

 

Edit: Im fairly sure its my C-Line...do i have to enter something other than the unraids machine ip ?

 

Share this post


Link to post

Edit: Nevermind guys. It was set up as bridged...gotta be a host obviously. All running now.

 

Hey guys,

used to run Oscam on a raspi, now wanna use this docker. I copied my settings over pretty much, but even with some tinkering I cant get my clients to show up/connect. This might be port related, although even clients within the same network dont connect. The clients use cccam.

I'm confused by port 10000 used by the docker, anyway, here are some basic infos to ports and C-line:

Unraid machine ip(local): 192.168.178.56

WebIF:8888 (docker default)

Port:10000 (docker default,whatever this is used for)

CCcam Port in Oscam.conf: 49384

In the router, port 49384 gets redirected to 49384 on 192.168.178.56.

C-line on client:

C: 192.168.178.56 49384 username password

I tried forewarding 49384 to 10000 on 192.168.178.56 as well, since I have no idea what the second port is used for, but no luck as well.

Yes, the machine and client are in the same network.

 

Can anybody point me in the right direction ?

 

Edit: Im fairly sure its my C-Line...do i have to enter something other than the unraids machine ip ?

The 10000 port is just the default one I put in and you can use whatever you like. The only thing you need to do is add a new port mapping for each port you are using in the template. No need to run it with host network.

 

Their should be no reason to do port forwarding in your local network.

Share this post


Link to post

That is weird though. If I have the same C-Line, and set up Oscam exactly the same, except changing the network from bridged to host...On bridged, I dont get any connection. On host, I do right away. Local network client.

If you'd like to investigate this, let me know. Otherwise, are there any disadvantages running it as host ?

Share this post


Link to post

It's not weird, if you map the correct posts with bridge it'll work.  Host doesn't require any ports to be mapped so will work regardless.

Share this post


Link to post

What would be the correct way to map it then, considering my first posts information ?  :-[

You add a new port in the template for each port you have in the c-lines.

So 49384 on both host and container port. The same for any other port you want to use.

Post a screenshot of the template after you done it with a list of ports if you want it confirmed that its right.

Share this post


Link to post

See how I added a new port

 

BHgXD63.png

Share this post


Link to post

Ohh! Sorry guys, I'm new to all this :D Working now, thanks for the help !

No need to be sorry  :)

Share this post


Link to post

Ohh! Sorry guys, I'm new to all this :D Working now, thanks for the help !

 

No worries, you can always remove the unused ports too...

Share this post


Link to post

Hello,

 

When I enable cccam or newcamd modules in oscam, I have the following errors in log and I cannot access Web interface:

- in case of cccam:

23:06:23 00000000 s (net) cccam: Bind request failed (Permission denied), waiting another 106 seconds

- in case of newcamd:

(net) newcamd: Bind request failed (Permission denied), waiting another 87 seconds

 

I tried with different Network modes, the same.

When I do telnet from unraid to the appropriate ports it says "Connection refused"

Might be Docker general network configuration issue?

 

Thank you in advance for your help,

Share this post


Link to post

Hello,

 

When I enable cccam or newcamd modules in oscam, I have the following errors in log and I cannot access Web interface:

- in case of cccam:

23:06:23 00000000 s (net) cccam: Bind request failed (Permission denied), waiting another 106 seconds

- in case of newcamd:

(net) newcamd: Bind request failed (Permission denied), waiting another 87 seconds

 

I tried with different Network modes, the same.

When I do telnet from unraid to the appropriate ports it says "Connection refused"

Might be Docker general network configuration issue?

 

Thank you in advance for your help,

 

Did you add the ports you use in the oscam template?

Share this post


Link to post

 

Did you add the ports you use in the oscam template?

 

Hi,

If you mean add ports while adding new container - yes, if I should add the ports to docker's xml file (which was stored later) - no.

On the other hand, when I disable the modules, I can access oscam interface at 8888 port

Share this post


Link to post

 

Did you add the ports you use in the oscam template?

 

Hi,

If you mean add ports while adding new container - yes, if I should add the ports to docker's xml file (which was stored later) - no.

On the other hand, when I disable the modules, I can access oscam interface at 8888 port

 

Tell me which ports you use, and a screenshot of the oscam template.

Share this post


Link to post

When I do telnet from unraid to the appropriate ports it says "Connection refused"

 

Can you telnet across to Oscam ports?  I didn't know that.  But I know nothing about Oscam I suppose.

Share this post


Link to post

When I do telnet from unraid to the appropriate ports it says "Connection refused"

 

Can you telnet across to Oscam ports?  I didn't know that.  But I know nothing about Oscam I suppose.

 

I don't think so...

Share this post


Link to post

 

Tell me which ports you use, and a screenshot of the oscam template.

 

I use port 876 for cccam.

Please look into attachment for the container set up.

 

Thank you

2016-10-06_00_12_30-Tower_UpdateContainer.png.aa375ac4c36d3d62c39dade11d53faf4.png

Share this post


Link to post

When I do telnet from unraid to the appropriate ports it says "Connection refused"

 

Can you telnet across to Oscam ports?  I didn't know that.  But I know nothing about Oscam I suppose.

 

I don't think so...

 

I think you can.

This is the easiest way to check, if a port (socket) of a server is available. For example start oscam and from unraid prompt write:

 

telnet 192.168.1.xxx 8888

 

If there is no error, it means that the port is available. Telnet will tell you: "Connected to 192.168.1.xxx".

 

You can start web browser or if you wrote HTTP request :) , you would receive HTML answer (Web page) from oscam.

The cccam module creates server socket that listens for incoming connections, in this case telnet is good tool to check, if the port is accessible.

Share this post


Link to post

 

Tell me which ports you use, and a screenshot of the oscam template.

 

I use port 876 for cccam.

Please look into attachment for the container set up.

 

Thank you

 

Who have you set the network to host? There should be no need to. Change it back to bridge and try again.

Share this post


Link to post

 

Tell me which ports you use, and a screenshot of the oscam template.

 

I use port 876 for cccam.

Please look into attachment for the container set up.

 

Thank you

 

Who have you set the network to host? There should be no need to. Change it back to bridge and try again.

 

I checked both 'host' and 'bridge' modes, in both cases the error occurred.

 

But I switched port from 876 to 8765 and it looks that the problem disappeared :)

It was late and I could not check the port accessibility, but at least, there were no error messages in the log.

 

Maybe the issue is related to ports lower than 1024. I do not know, if there are any restrictions in docker for ports.

 

I will check if the port is accessible and check if the solution works for other modules.

I will do a test with numbers like 877 or similar.

 

 

Share this post


Link to post

 

Tell me which ports you use, and a screenshot of the oscam template.

 

I use port 876 for cccam.

Please look into attachment for the container set up.

 

Thank you

 

Who have you set the network to host? There should be no need to. Change it back to bridge and try again.

 

I checked both 'host' and 'bridge' modes, in both cases the error occurred.

 

But I switched port from 876 to 8765 and it looks that the problem disappeared :)

It was late and I could not check the port accessibility, but at least, there were no error messages in the log.

 

Maybe the issue is related to ports lower than 1024. I do not know, if there are any restrictions in docker for ports.

 

I will check if the port is accessible and check if the solution works for other modules.

I will do a test with numbers like 877 or similar.

 

It might be that it's reserved for some other service. It's best to use higher port numbers than 1024 for dockers.

Share this post


Link to post

Hey guys,

Quick question, how do I add the --device tag to the docker? do I add a variable?

 

Greetings gl3nn

Share this post


Link to post

Hey guys,

Quick question, how do I add the --device tag to the docker? do I add a variable?

 

Greetings gl3nn

Either by adding a device clicking on the add port, variable, volume, device button (do not add the tag itself, only the device) or switch to advanced view and add the tag in the extra parameters box.

Share this post


Link to post

Intriguing. I already use OSCAM in my VU+ cable box with Virgin Media. What would would OSCAM as docker be used for? The intrigued part of me is imagining something using this Docker with Plex Media Server and a DVB-C card  (if such a thing exists), am I barking up the correct tree?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.