Jump to content
Kru-x

<Support> Kru-x - Wekan and MongoDB-wekan templates

61 posts in this topic Last Reply

Recommended Posts

Hi Kru-x, 

 

Thank you for responding so quickly, much appreciated. 

 

I did make sure that the, --link "mongodb:db" was included in the Wekan Container.

 

I believe I do have the right settings but I still get the message above indicating the site cannot be reached. I change the port to 5000.

812026610_4-9-201911-49-37AM.thumb.jpg.c802eef1be81d399a56f619aa77d0bfd.jpg

 

MongoDB Settings, 

436338252_4-9-201911-21-33AM.thumb.jpg.e608767a31e0054f67d7803bc3860b70.jpg

303079530_4-9-201911-21-24AM.thumb.jpg.740a690b75dc5b6e933bf64d7cf48fe2.jpg

 

Wekan Settings, 

658434250_4-9-201911-20-49AM.thumb.jpg.f437679b12292d7fc1d9adf83f45b008.jpg

 

 

Edited by kalor006

Share this post


Link to post

Hi, it was that I had used an template that should have been used with my mongoDB container, that changed. I have update the template, so try this.

 

Leave the mongo db as it is and delete the wekan template and the container when asked, add go to community applications and add the template from there, make sure the template are using from https://hub.docker.com/r/wekanteam/wekan/ (you see it in advanced settings).

 

Then adjust your settings as per your settings above, you don't have to use "mail url & mail from" just leave them blank until you want wekan to send mails. You can leave port 5555 if you have not assigned it to another container.

 

That should do it, let me know,

 

Kru-x

Edited by Kru-x
Spelling

Share this post


Link to post

Ah yes! its working now! Thank you so much Kru-x. 

 

I had installed this on a Centos 7 Server, I even used the sandbox version and I could never get the emails to work properly but now they are working as they should, thanks again.  

Share this post


Link to post

I have a stupid question. I have wekan mapped to my mongodb appdata folder. Is that where it is saving data? I need to look at a log but i dont know where to find it on my system

Share this post


Link to post

Hi,

 

No such as stupid .. 🙂 without knowing what you are looking for, the image itself do not need to be mapped to unraid or any folder within as the container only stores any info in the mongo-database, maybe I shouldn't have added that option. I am not sure what logs are kept but if there is any they are stored in the container itself, had a quick look and there is a few logfile is var/log.

Share this post


Link to post

I just came here to say THANK YOU!

 

Installed this in our small office on our unraid server! this board is AMAZING for planning small and big projects.

 

We love it, again thank you for this docker! 

Share this post


Link to post

Anybody got this working with a reverse proxy? As soon as I switch it over I lose the database.

I did notice that `--link` has (will be) been depreciated and tried to use the URL optionbut wasn't able to link it.

```- MONGO_URL=mongodb://wekandb:27017/wekan```

Share this post


Link to post
4 hours ago, Spladge said:

Anybody got this working with a reverse proxy? As soon as I switch it over I lose the database.

I did notice that `--link` has (will be) been depreciated and tried to use the URL optionbut wasn't able to link it.

```- MONGO_URL=mongodb://wekandb:27017/wekan```

It works fine, used it for years.

The -- link (if you mean in the setup, is a docker function ) and is used to link the two containers together. it should say --link "MongoDB:db" if "MongoDB" is your  mongo container. And where did you get the "Mongo_URL" from? My template is using  "ROOT_URL" and that should be set to "http://yoursite.com" to make it work behind your proxy.

 

Hope it helps,

Kru-x

Share this post


Link to post

I have it working fine locally, once I switch networks to the proxy network on both containers Wekan is unable to connect to the Mongo database.

I looked up the documentation for the docker being used and saw the "MONGO_URL" variable there. When I could not get the DB to link properly I looked up the --link documentation on docker and saw there that it is being depreciated (but will still work for now)

Root URL I have set, I might delete everything and try to start it again with reverse proxy from the start. Thank you Kru-x.

Share this post


Link to post

well it was working great til i pulled down a docker update.

 

now the docker barfs with this and wont start:

 

MongoError: database name must be a string
at Function.create (/build/programs/server/npm/node_modules/meteor/npm-mongo/node_modules/mongodb-core/lib/error.js:43:12)

at validateDatabaseName (/build/programs/server/npm/node_modules/meteor/npm-mongo/node_modules/mongodb/lib/operations/db_ops.js:720:22)
at new Db (/build/programs/server/npm/node_modules/meteor/npm-mongo/node_modules/mongodb/lib/db.js:181:3)
at MongoClient.db (/build/programs/server/npm/node_modules/meteor/npm-mongo/node_modules/mongodb/lib/mongo_client.js:268:14)
at packages/mongo/mongo_driver.js:186:25
at runWithEnvironment (packages/meteor.js:1286:24)

 

any ideas?

Share this post


Link to post
1 hour ago, normtodd said:

well it was working great til i pulled down a docker update.

 

now the docker barfs with this and wont start:

 


MongoError: database name must be a string
at Function.create (/build/programs/server/npm/node_modules/meteor/npm-mongo/node_modules/mongodb-core/lib/error.js:43:12)

at validateDatabaseName (/build/programs/server/npm/node_modules/meteor/npm-mongo/node_modules/mongodb/lib/operations/db_ops.js:720:22)
at new Db (/build/programs/server/npm/node_modules/meteor/npm-mongo/node_modules/mongodb/lib/db.js:181:3)
at MongoClient.db (/build/programs/server/npm/node_modules/meteor/npm-mongo/node_modules/mongodb/lib/mongo_client.js:268:14)
at packages/mongo/mongo_driver.js:186:25
at runWithEnvironment (packages/meteor.js:1286:24)

 

any ideas?

Hmm, it's above my knowledge. But I would try to delete both containers and add them again, as long as you don't delete the mongo DB folder the information within should be retained.

Sorry

Share this post


Link to post

I also am having this issue: "MongoError: database name must be a string"

 

Unfortunately I am currently using Wekan for a time critical project :(

 

I'll try rolling back any updates...

 

EDIT:

 

Switching from the "latest" Wekan image to the "devel" image under the mquandalle repo worked: https://hub.docker.com/r/mquandalle/wekan/builds

Edited by archerkg

Share this post


Link to post

fwiw i was able to finally the docker started by making a change to MONGO_URL variable in the wekan docker.

 

i should note that the --link mongodb:db which was populated in extra arguments (and was there on the docker update last night) has been removed completely.

 

HOWEVER IN MAKING THIS CHANGE IT CREATED A NEW DATABASE AND I LOST ALL PREVIOUS WORK

 

it may still be somewhere in mongo, but i dont know mongo like i know mysql, so who knows.

 

my dockers are set up in such as way so as they do not all share a proxynet, but instead have their own IP addresses.  for example mongodb docker is on 10.720.140

 

to make the wekan docker start, i changed the MONGO_URL to be:

 

mongodb://10.72.0.140:27017/db

instead of the previous MONGO_URL of

mongodb://db

I realize this change was not advisable as per one of the messages above, but this was the only way i could get it all to start.

 

i am almost positive this is not the correct way to do it, but this way it starts and the log files are all nominal

Share this post


Link to post

Please read release notes:

https://github.com/wekan/wekan/blob/master/CHANGELOG.md#v300-2019-07-25-wekan-release

 

Master branch now uses MongoDB 4.0.10, so it requires that you backup your old database https://github.com/wekan/wekan/wiki/Backup with mongodump and restore with --noIndesRestore included. Master branch has newest Meteor 1.8.1 and Wekan newest version v3.00, it requires new MongoDB version newest 4.0.10 or at least 3.6.x. Devel branch has old Meteor 1.6.x version that works with MongoDB 3.2.x and not newer MongoDB. 

Share this post


Link to post
On 7/26/2019 at 6:30 AM, archerkg said:

I also am having this issue: "MongoError: database name must be a string"

 

Unfortunately I am currently using Wekan for a time critical project :(

 

I'll try rolling back any updates...

 

EDIT:

 

Switching from the "latest" Wekan image to the "devel" image under the mquandalle repo worked: https://hub.docker.com/r/mquandalle/wekan/builds

Hi,

You should probably try to change the containers to the official ones, see the first post in this thread, I don't use mquandalle container anymore . On the other hand you got it to work with a solution I would have used if it goes haywire, and if it works why change ;-) if you are not like me wanting the absolute latest version.

Share this post


Link to post
On 7/26/2019 at 7:18 AM, normtodd said:

fwiw i was able to finally the docker started by making a change to MONGO_URL variable in the wekan docker.

 

i should note that the --link mongodb:db which was populated in extra arguments (and was there on the docker update last night) has been removed completely.

 

HOWEVER IN MAKING THIS CHANGE IT CREATED A NEW DATABASE AND I LOST ALL PREVIOUS WORK

 

it may still be somewhere in mongo, but i dont know mongo like i know mysql, so who knows.

 

my dockers are set up in such as way so as they do not all share a proxynet, but instead have their own IP addresses.  for example mongodb docker is on 10.720.140

 

to make the wekan docker start, i changed the MONGO_URL to be:

 


mongodb://10.72.0.140:27017/db

instead of the previous MONGO_URL of


mongodb://db

I realize this change was not advisable as per one of the messages above, but this was the only way i could get it all to start.

 

i am almost positive this is not the correct way to do it, but this way it starts and the log files are all nominal

See the above answer or my first post in this thread, the --link mongodb:db should be included. That's a docker function for the containers to link the containers to each other.

 

In your case I am not sure as I don't use separate networks but the MONGO_URL is for the the internal working ex. if you access wekan from a different ip address eg. if you are behind a reverse proxy.

 

How did your configuration look like b4 the "crash" as the data resides in the DB saved in your wekan DBfolder, in your case I would delete both containers (NOT the wekanDB folder) follow the instruction on the updated versions. And try to put your "mongodb://10.72.0.140:27017/db" in front of the --link. But if you got it to work, great. 

Share this post


Link to post
On 7/26/2019 at 7:23 AM, xet7 said:

Please read release notes:

https://github.com/wekan/wekan/blob/master/CHANGELOG.md#v300-2019-07-25-wekan-release

 

Master branch now uses MongoDB 4.0.10, so it requires that you backup your old database https://github.com/wekan/wekan/wiki/Backup with mongodump and restore with --noIndesRestore included. Master branch has newest Meteor 1.8.1 and Wekan newest version v3.00, it requires new MongoDB version newest 4.0.10 or at least 3.6.x. Devel branch has old Meteor 1.6.x version that works with MongoDB 3.2.x and not newer MongoDB. 

Im not sure if this is the problem for the moment as mine works fine, I think many people uses the old mquandalle's container and not the Wekanteam ones as described in the first post of this thread. But thanks for pointing me to the issue, good to know if it causes problems in the future.

Share this post


Link to post
34 minutes ago, Kru-x said:

See the above answer or my first post in this thread, the --link mongodb:db should be included. That's a docker function for the containers to link the containers to each other.

 

In your case I am not sure as I don't use separate networks but the MONGO_URL is for the the internal working ex. if you access wekan from a different ip address eg. if you are behind a reverse proxy.

 

How did your configuration look like b4 the "crash" as the data resides in the DB saved in your wekan DBfolder, in your case I would delete both containers (NOT the wekanDB folder) follow the instruction on the updated versions. And try to put your "mongodb://10.72.0.140:27017/db" in front of the --link. But if you got it to work, great. 

Sorry not MONGO_URL I meant ROOT_URL, 

Edited by Kru-x

Share this post


Link to post
On 7/25/2019 at 5:18 PM, normtodd said:

fwiw i was able to finally the docker started by making a change to MONGO_URL variable in the wekan docker.

 

i should note that the --link mongodb:db which was populated in extra arguments (and was there on the docker update last night) has been removed completely.

 

HOWEVER IN MAKING THIS CHANGE IT CREATED A NEW DATABASE AND I LOST ALL PREVIOUS WORK

 

it may still be somewhere in mongo, but i dont know mongo like i know mysql, so who knows.

 

my dockers are set up in such as way so as they do not all share a proxynet, but instead have their own IP addresses.  for example mongodb docker is on 10.720.140

 

to make the wekan docker start, i changed the MONGO_URL to be:

 


mongodb://10.72.0.140:27017/db

instead of the previous MONGO_URL of


mongodb://db

I realize this change was not advisable as per one of the messages above, but this was the only way i could get it all to start.

 

i am almost positive this is not the correct way to do it, but this way it starts and the log files are all nominal

 

I bet your old db/data are still there. On  your case, try changing to: mongodb://10.72.0.140:27017/admin

 

Share this post


Link to post

After updating today 30.09.19 we can no longer move cards by dragging them. Big issue for us, I was hoping to request that the docker version tot change to the "old" 3.44 as this new version has drag handle changes.

 

Lesson learned if nothing else, if it is working do not update.

 

more about this new "bug" can be read here - https://github.com/wekan/wekan/issues/2739 

Share this post


Link to post
1 hour ago, nik82 said:

After updating today 30.09.19 we can no longer move cards by dragging them. Big issue for us, I was hoping to request that the docker version tot change to the "old" 3.44 as this new version has drag handle changes.

 

Lesson learned if nothing else, if it is working do not update.

 

more about this new "bug" can be read here - https://github.com/wekan/wekan/issues/2739 

Hi Nik82,

 

Yea you are right and it is a bug that the wekan team would be aware about, sure it is going to be rectified within days. Meantime if you don't want to wait just put the version tag on the "repository" you want to use. ie, revert to the older container. Just add the version number after the repository like "wekanteam/wekan:v3.44". You can see all he version numbers in wekan teams image in docker hub.

 

Just keep an eye on it and delete version number to use the lastest build when the problem is fixed.

Share this post


Link to post
23 minutes ago, Kru-x said:

Hi Nik82,

 

Yea you are right and it is a bug that the wekan team would be aware about, sure it is going to be rectified within days. Meantime if you don't want to wait just put the version tag on the "repository" you want to use. ie, revert to the older container. Just add the version number after the repository like "wekanteam/wekan:v3.44". You can see all he version numbers in wekan teams image in docker hub.

 

Just keep an eye on it and delete version number to use the lastest build when the problem is fixed.

Thanks for the reply :)

 

Unfortunately I am to dumb to figure out how to do this, not a problem though we will just have to wait a couple of days until this has been resolved.

 

EDIT: Spoke to soon, found it and it works :D

 

Thank you!

 

 

If anyone else is as dumb as me here is the setting that Kru-x so nicely provided :)

 

just click edit on the docker and change this field.

 

image.thumb.png.8a7ff64f2a77113e540e532c31dae7d2.png

Edited by nik82

Share this post


Link to post

Hello,

 

I have it working on the local network, allfine.

 

How do I have to configure the letsencrypdt nginx proxy-conf for subdomains?

 

When I try to access it from the outside, I end on the standard nginx Message "Welcome to our Server"

 

Thank you very much for your help

 

Janndr

Share this post


Link to post
24 minutes ago, Janndr said:

Hello,

 

I have it working on the local network, allfine.

 

How do I have to configure the letsencrypdt nginx proxy-conf for subdomains?

 

When I try to access it from the outside, I end on the standard nginx Message "Welcome to our Server"

 

Thank you very much for your help

 

Janndr

Hi,

Not sure what you are asking? To set up a Nginx proxy server or the settings for Wekan to work in the setup with one?

 

Proxy server:

~ I recently switched and now use the brilliant "Nginx Proxy Manager" docker container (you find it in apps) for all my internal domains connected to internet.

 

Wekan setup:

~ The setting "Varible ROOT_URL:" is where you set the external/internal address you have, ex. https://cloud.mysite.com for external address, or http://192.168.1.100:3300 for internal only access

 

Hope it helps,

Kru-x

Share this post


Link to post

imageproxy.php?img=&key=e5eec7c5c933ca16I try to install this docker follow you guide. However, I get The command failed at the end. Any idea how can i fix it. I am on unraid 6.8.

 

image.thumb.png.4605161c6a6064d7e5021b0fefa8b025.pngimage.thumb.png.83a385f5db08b42dc68908bb36d940e8.png

Edited by tamito
Add more info

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.