VIDEO GUIDE***How to pass through an NVIDIA GPU as primary or only gpu in unRAID


SpaceInvaderOne

150 posts in this topic Last Reply

Recommended Posts

Hi Steve,

 

I've concentrated my efforts with OVMF, although I did try to fire up a few Seabios based VM's, with zero success.

 

I've just spent the last 20 minutes thinking about buying PCIe risers and a sacrificial Nvidia GT710 or other basic adapter, just so I can pass through the 3 GPU's that I actually care about. It will be a cheaper option than changing motherboard and CPU. That being said, my board and CPU do need to get replaced at some point. If I push all cores on the CPU, the system powers off. Already replaced the PSU, but I guess it's probably capacitors that are a bit too old on the board now, or a MOSFET or two are a little unhappy.

Link to post
  • Replies 149
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi Guys i have made a video tutorial on how to pass through an nvidia gpu as the primary or only gpu in the server. This guide is based off hupsters great work on dumping the bios of the gpu. Hop

GT 610 is a rebranded 5xx series card, so it will require Seabios, as I pointed out in another topic.

rahool, nobody confirmed so far that the dump for zotac 1060 3g mini works for them. lack of evidence does not means it's not working, it's just that probably nobody tried it yet, or bothered to reply

Posted Images

Mmh... How do you access the three GPUs? Do you have screens attached or using some form of remote desktop? Does the issue only happen if you run all three VMs in parallel or also individually? I still face some problems when running two Win VMs in parallel, which I don't face when not passing through the GPU.


If I may ask, what are you using three GPUs in paralle for and do you have experience with Gamestream?

Link to post

No displays attached. I've tried combinations of multiple GPU's attached to a single VM and separate VM's per GPU. I always hit a problem trying to pass through the first GPU - i.e. the one unRAID itself initialises.

 

I'm RDP'ing into the VM. Currently have one Win 10 VM with 2 GPU's attached to it. The 'main' GPU is just sitting in the machine, doing nothing useful.

 

I'm cryptomining with the GPU's, running Plex, using the box as a NAS and also running Server 2016 Essentials with a separate Win 10 VM for a bit of dev work. As long as I don't thrash the CPU, this machine is happy with month+ uptimes.

 

If this were anything other than a "let's see what we can do" box, I'd probably have replaced it with a Xeon machine from a few generations ago.

Link to post
  • 1 month later...

Do  I need to restart unraid if I am switchng a graphics card from one vm to another? I have  Windows 10 VM running with a GTX960 passed through. The performance isn't what I was hoping for so I created a windows 7 VM that is much snappier, but I can't get it to boot with the GTX960 from my Windows 10 VM passed through (that is with the windows 10 VM off). The VM icon, in unraid , will turn green but the screen won't turn on and one core will e pegged at 100%. Any help would be greatly appreciated.System info below.

 

unRAID 6.4.0-rc7a

Dual Xeon E5-2680v2

32GB RAM

GTX960 2GB

 

Link to post
  • 1 month later...

I am stuck on the infamous Error 43. I had the system working WITHOUT error 43 somehow yesterday but the entire server would crash. First I'd see a blue screen "internal video scheduler error" then during the dump the entire Unraid server would crash - and not reboot automatically.

 

So I fiddled a little bit with reinstalling the driver, running that sfc command as admin cmd ... to no avail whatsoever. 

 

Then I'm back to Error 43.

 

I have tried Hyper-V on and off, and I have tried SR-IOV on and off IOMMU of course is enabled. 

 

I did dump a rom and am passing it through successfully (if I make a typo or whatever I just get a black screen as opposed to at least move around in WIndows.)

 

I don't know what to do next :(

 

This is a Ryzen 5 system with Nvidia 1050 Ti

Edited by Henry Thomas
Link to post
  • 3 weeks later...
7 hours ago, tjb_altf4 said:

Is anyone running a single card passthru setup also able to drop back to unRAID console once the VM shutdowns and releases the GPU?

Curious if this is possible.
 

Not that I have seen. When the VM is stopped, the screen is blank / no signal.

Link to post

Hi All,

 

First - I love your videos and think I've watched almost every one.  There's no way I would have Windows 10 up and running without your help!

 

GPU: AMD RX 560 4GB (Gigabyte) v2.0

 

Just posting to see if anyone else has had graphical glitches in games and trouble with the HDMI audio when passing through this card.

I have dumped the rom via GPU-Z and added it to the XML, however this did not have any effect.

 

I have a more comprehensive post here: 

 

Best,

Rob

Link to post

Stuck with error code 43 passing through my 1080ti with self dumped vbios following the instructions in the first video. Disabled hyper-v with no luck. Also tried modding drivers to no avail :( Also tried editing the XML to include the kvm hidden state and vendor ID override. 

Link to post
  • 4 weeks later...

I’m also stuck with error 43.

 

Whats really weird is that i can actually pass-through my primary nvidia to the win10 vm. i didn’t do the bios dump and i don’t have on-board gpu. so, i’m supposed to get the “black screen” (and did so in the past). now, i can actually pass through my only gpu.

 

is “error 43” the new “black screen”?

 

any help appreciated!

Link to post

Can this post get stickied? Without this post, I was at a huge loss after switching from AMD to NVIDIA.

 

Please sticky this post!

 

...and thanks @gridrunner for the great videos and information you provide the community!

Edited by ksignorini
Link to post
  • 1 month later...
  • 5 weeks later...
  • 2 months later...

My setup:

Zotac GT710 1GB in primary slot, my only gpu in this system
Asus X99-WS/IPMI (no onboard video) 

I'm trying to pass this GT710 to a Win10 vm. IOMMU looks perfect on this motherboard, i have an isolated group with only my gpu and its audio (which i'm passing too). I dumped the bios and edited its header, but i get black screen on vm startup and the dreaded error 43 (the os boots fine, i can see everything else working through a Remote Desktop session). I tried both Hyper-V on and off and i tried a techpowerup vios too. 
I read something about the GPU not dumping correctly its vbios (or kvm unable to use a different vbios, can't remember which) if the card is plugged in the primary slot. Could someone give some clarification on that? Do you think i have no chance in passing this GPU with the right vbios without using a second card?
Right now i'm saving money for a proper gaming gpu and i will try to pass that once i have two cards to experiment with, but i would really like to have my vm up and running with a single gpu in the meanwhile. 

Thank you very much for your efforts, i do really like the idea of keeping this vbios list.

Link to post
  • 1 month later...

Hi guys, before I try this out I wanted to ask if doing this would still allow me to use the graphics card for all VM instances that I pass through the gpu on. And would Plex on Ubuntu still do hardware transcoding with the graphics card when I do this mod?

Link to post

Hey all i'm trying to get my GTX1050 to work trough my Win10 VM but i cant shake the stupid Code43. The VM runs fine i can get video np with VNC set and with google rdp when the GPU is used. I've done soo much googling over the past two days i'm exhausted. 
I've done the folowing:

Turned off Hyper-v

PCIe ACS Override setting enabled

VBIOS edit and XML 

Uninstalled the driver and installed ver 378.78 and set the hidden state in the XML    

I know ive done more just cant think of it at this point.. 

 

Any help is greatly appreciated. 

 

unRaid ver 6.6.5

Link to post

Is there a way to make sure the VM is using my GPU for Plex h/w transcoding and not my Xeon? Because the whole reason for this gpu was to offload some of the media workload to from my CPUs. Plex doesn't show which device is doing the transcoding.

Edited by naik
Link to post
23 hours ago, trurl said:

Looks like you left out something

I edited the post ;) Thanks a lot.

I'm trying to pass-through GT1030 without success...
i have one Asrock J4105M (uefi) + Gt1030 (uefi). I use the same process of that guide, i dump my bios and inject it at VM.
E get black screen for 1-3 secounds, and after goes back to terminal unraid.
Sometimes get terminal unraid window with strange color squares.

There are any possibility to fix it?
Best Regards

Edited by psycmos
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.