[SOLVED] How to stop Mover


Homerr

Recommended Posts

I've been searching and searching and have found a few commands to type in the terminal to no effect.  But I'm having this problem that mrjofus1959 posted in 2011 and there still doesn't seem to be any real implementation to the issue.

 

As I've been copying terabytes of data over to my new unRAID server there have been a couple of times where I would have liked to terminate the mover script so I could cleanly shutdown the system and add another precleared hard drive (from another system where I'm preclearing drives).  I have been searching for an answer in the forums but with no luck, so can anyone tell me if there's a nice clean way of killing the mover script and its rsync processes?  I tried just killing them from within top but that didn't seem to do the trick.  (FYI - Linux is new to me as far as working at this level of putting together a system.)  Thanks, Kevin

 

 

I am stuck in the loop now myself.  Can't stop the array to add space because I can't kill Mover.  This is VERY frustrating and seems like such a simple thing to add a 'Stop Mover' button.  Meanwhile I'm being spammed with red low disk space alerts every few minutes.  And I don't really know what I'm doing at the command line so I'm not going further there. 

 

As a new user to this product I can't understate how much this feels like a design flaw.

Link to comment

Yes, I tried 'killall rsync', that's from the thread I first referenced.  Nothing happened.  Seemed like it should have work.

 

I did search further and try another command promt input (can't find it atm) that seemed to just turn off the mover in the scheduler.

 

But scheduler did run until apparently it could fit no more on the array drives, each drive had less than 5mb left.

 

Still, I think a 'Stop Mover' button would be a great addition.  I know I was a bit stressed over this and how I was going to solve the issue while the Mover was running.

  • Like 1
Link to comment

Just an update, 'pkill mover' is nearing 3 hours and over 220gb moved and not stopped Mover yet!  :-\

 

This is all with larger 700mb to 10gb video files.

Ok probably have to do a

 

pkill find

 

as well.  Never had to stop the mover before.  We'll see about adding some kind of cancel control.  Not really recommended though.  Why do you want to cancel it?

  • Like 2
Link to comment

I want to stop the Mover so that I can stop the array to add another drive.  I don't have oodles of spare drive capacity and I'm still transferring data in to the array off one drive through another PC and then adding that drive in to the array.  Mover wants to do it's job and wants to move data, but it can take a few hours to over a day to do this.  Just makes this chaos of moving to this new OS a bit stressful and drawn out.  With a 'Stop Mover' button I could manage this transfer on my schedule instead of Mover's schedule.

 

I have some shares I was transferring in that had several hundred thousand of small files and other shares with large video files.  Mover was running terribly slow on the small file ones and I was figuring out the transfer rates where it was going to take up to 27 days to run everything through the Cache/Mover.  I posted elsewhere here and it was suggested I disable Cache for those shares with all the small files, I did this and that helped to bypass this issue.  Even with Cache/Mover dealing with only the larger video files it still can take hours and hours that the completion of does not necessarily align with not sleeping or being at work so I can lose near 8 hours of transfer time when I need to intervene.

 

I'm getting down to 2 more disks to add and I'm in a pinch of space I hoped not to be in.  A new disk will be answer to give me extra room that I need.

 

Honestly, knowing what I know now - I just wouldn't have even bothered with installing a cache disk for this initial setup.  I would have waited until all my data was transferred in (one drive inevitably is the 'slop' in the leap frog of getting data off drives, which could have been my drive I'm using as Cache drive).  Which kind of defeats some of the use of the cache in a way.  Once this initial phase is over I don't see it being a problem, but during this I feel like I keep bumping against Mover.  It's part of my learning curve.

 

Edit:  Yes, Mover did not stop and moved everything off the Cache by this morning.

Link to comment

Each user share can be set to not use the cache. In fact, that is the default setting. So while you are doing the initial data load you should just set the user shares to not use the cache disk. Then after you are done you can set them to use cache if you want.

 

Using cache then mover while filling up your array is actually going to be slower than just writing to the array as you have seen.

 

Personally I don't cache any user shares except the ones I have set to cache-only such as appdata. I don't care about write speed, and you may only care about it when writing a large amount of data, but if that is more than mover can move during your normal sleeping hours you are just making the process slower and more complicated.

 

Link to comment

The reason the mover is so slow is that for each and every file it must check if that file is "in use" before trying to move it from source to destination.  This is because there is no concept of "automatic file locking" - it's completely possible for one process to read a file that another process is writing.  The "in use" test is pretty expensive.

Link to comment
  • 3 weeks later...

Can this please be revisited?

 

None of the commands in this thread stopped the mover.

 

Somehow yesterday one of my shares got set to cache: prefer.  The only settings I changed yesterday were user permissions.

 

Now this morning I woke to notifications that my cache drive is FULL. And I cannot stop the mover!!!

Link to comment

Now the mover has gone through all the directories and files of the offending share and finished trying to move them to the cache (and failed due to being full). But the mover still says its running and I cannot stop it or the array.

 

edit: I held the power button and the server shut down. Powered back up and activated the mover to move the files BACK to the array.

 

The bigger question is how "Cache: prefer" got set on this share when I only changed permissions on the share yesterday.

And if the mover can indeed be stopped. None of the commands in this thread worked for me.

Link to comment

The bigger question is how "Cache: prefer" got set on this share when I only changed permissions on the share yesterday.

 

The only logical answer is that you changed it yourself, accidentally, while you were altering permissions. It's very easy to click on the wrong item if your attention lapses for a moment and it's my biggest gripe about using a GUI for administrative tasks.

Link to comment

So I am kind of in the same boat here.. the mover is running trying to move files onto the cache filling it up and I've turned off caching on my shares but can't kill the mover and I was in the middle of adding a second parity so I can't exactly restart either.. None of the commands in this thread kill the mover.. The rsyncs just keep coming back like zombies.. Are there any other commands that can be used?

Link to comment

Also I though the cache drive being enabled just ment that anything new would be wrote to cache then moved to the drives on a schedule. It appears that its trying to move everything from my storage to my cache drive and failing.

this is not true if you have set shares to the 'Prefer' setting.    That explicitly says that there are files on the data disk that you want to be moved to the cache disk whenever this becomes possible.    That is the only setting that can cause files to be automatically be moved in that direction.
Link to comment

Also I though the cache drive being enabled just ment that anything new would be wrote to cache then moved to the drives on a schedule. It appears that its trying to move everything from my storage to my cache drive and failing.

this is not true if you have set shares to the 'Prefer' setting.    That explicitly says that there are files on the data disk that you want to be moved to the cache disk whenever this becomes possible.    That is the only setting that can cause files to be automatically be moved in that direction.

And there are other cache settings, like No, Yes, and Only. Each user share can have different cache settings, and if you don't set this for a particular user share the default is No, which means it won't use cache at all.

 

There is a Help button in the upper right of the webUI which will explain the current page to you. When setting up your user shares turn Help on. It it much more flexible (complex) than you thought.

Link to comment

So I am kind of in the same boat here.. the mover is running trying to move files onto the cache filling it up and I've turned off caching on my shares but can't kill the mover and I was in the middle of adding a second parity so I can't exactly restart either.. None of the commands in this thread kill the mover.. The rsyncs just keep coming back like zombies.. Are there any other commands that can be used?

Check my post above to see what I did. Basically, let it go until it finishes trying (and failing) to move files to the cache. Verify by watching the log. Then manually shut down/reboot. Fix the offending share's cache settings. Finally, invoke the mover to move data back to the array.

 

There needs to be a way to stop the mover in situations like this.

Link to comment

Thanks.  I had the same issue of the cache filling up this morning after adding the cache drive yesterday and freaked out a bit.  After reading and researching into it I realized that "prefer" was not my preferred method of using the cache.  I did a gracefull shutdown via the CLI and then used the Move Now button.  Cache is back to normal.

Link to comment
  • JorgeB changed the title to [SOLVED] How to stop Mover

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.