Jump to content
jbrodriguez

[Plugin] ControlR

312 posts in this topic Last Reply

Recommended Posts

I'm having this exact same problem.
 
Nothing is installed except controlR, my windows VM. No dockers, no other plugins. Also I'm runing version 6.6.5
 
I seemed to have fixed this issue by forcing SSL from auto to Yes in Identification.  Have to enable HTTPS when adding the server from the phone app. Seems to be working okay.


Right, with ssl set to yes, you need to add the server securely in the app.

In any case, glad to know you sorted it out.


Sent from my iPhone using Tapatalk

Share this post


Link to post

The ability power on from the app stopped working for me.. is it working for anyone else running unraid 6.6.5?

Share this post


Link to post

Is the power on button disabled ?

 

The server version shouldn't have that much of an impact since it's a wake-on-lan packet basically.

 

It shouldn't be enabled until your server is powered down.

 

 

Edited by jbrodriguez

Share this post


Link to post
On 11/15/2018 at 10:00 AM, sudodrew said:

The ability power on from the app stopped working for me.. is it working for anyone else running unraid 6.6.5?

No problems here. I'am running 6.6.5.

Share this post


Link to post

I'm having problems with the Android App - I'm new to unRAID and to the app, so probably newbie error.

When I first tried the app, I saw "buttons" for power-down and a few others.  I believe I also saw info on each drive.

But now the main screen just has overall server quick stats and "started valid" and "update x min"

If I tap on it, I go to 2nd screen - same info in top blue area, left-right scrolling info on the two "starter valid" lines, and tabs for DOCKERS and VMS.  But NOTHING else.

I've installed the plugin and enabled the plugin server, but still not seeing everything on the app.

For now, my server is not password protected - is this the issue?  (I did have a PW on the server for a while, then removed it while I was doing dev/testing.)

Share this post


Link to post

Hi RobertP,

 

When you added the server, you entered some user other than root.

 

When that's the case, the UI becomes minimal, basically to control dockers/vm, with user permissions that you can set via the plugin's web interface.

 

If you delete the server in the app and add it back with root user, you'll see the full UI.

Share this post


Link to post

It says "root" - but as stated I had changed the password to null while I was doing some testing.  I just tried setting PW to a valid one and deleted/re-added the server and now I'm seeing everything.  So apparently the tool does not like logging in with a null password?

 

Share this post


Link to post

Glad it's working now !

 

I'll check the code about the no password root, I think the app probably switches to a non root/admin interface if no password is provided, but I don't quite remember if that's the case right now.

 

 

Share this post


Link to post
On 5/7/2018 at 5:58 AM, jbrodriguez said:

Oh ok, if you have SSL set to 'auto', the plugin interprets that ssl is on.

This needs to be pinned somewhere, I was so confused. By default unRAID has it set to Auto with no SSL certificate generated, so basically with default options your app doesn't work. I figured it out by actually creating a certificate and really going with https/ssl. I eventually changed it from Auto to Yes since I don't see disadvantage of using SSL anyway.

Share this post


Link to post
2 hours ago, dnLL said:

This needs to be pinned somewhere

Hi, it's written in the FAQ, from a user standpoint (what should I do as an app user), instead of from plugin's view (auto means ssl).

 

The last version of the app always connects to the plugin via ssl, regardless of the Unraid setting, so it shouldn't be a problem

 

You already solved it by doing ssl=yes, but I'm not sure what issue you were having.

 

Were you unable to add the server ?

Were you unable to access the additional features the plugin provides ?

Share this post


Link to post
19 hours ago, jbrodriguez said:

Hi, it's written in the FAQ, from a user standpoint (what should I do as an app user), instead of from plugin's view (auto means ssl).

 

The last version of the app always connects to the plugin via ssl, regardless of the Unraid setting, so it shouldn't be a problem

 

You already solved it by doing ssl=yes, but I'm not sure what issue you were having.

 

Were you unable to add the server ?

Were you unable to access the additional features the plugin provides ?

I was unable to add the server (the app by default was proposing an IPv6 server which is weird since IPv6 is disabled on my router and everywhere else, but even with entering my IPv4 it wouldn't see the server). SSL was disabled in unRAID (as it was by default on previous versions, not sure about now). I never enabled it until I had issues after downloading ControlR. By default SSL is set to Auto with no promoted certificate (so SSL is disabled with the Auto option).

 

Also, the FAQ says the following:

Quote

auto->add server via ip/hostname, https port (default is 443), secure switch on

Doesn't work if SSL isn't actually enabled (if you didn't promote a certificate, SSL won't work, the auto switch just sets it to No basically).

Edited by dnLL

Share this post


Link to post
4 hours ago, dnLL said:

the app by default was proposing an IPv6

Yes, that happens on some Android phones for some reason.

 

The app is just reading the phone's ip address from the network stack and proposing it (presumably less typing), but in some cases it picks up the IPv6 address.

 

Not sure why, Android phones and even provider's OS can be quite different.

 

As for auto, Unraid creates an SSL certificate and redirects http -> https transparently for the user, I'll check if that's still the case.

 

Or perhaps, new installs work a bit differently from older installs (fresh 6.6.x install vs upgrading to 6.6.x).

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now