[Plugin] ControlR


535 posts in this topic Last Reply

Recommended Posts

31 minutes ago, jbrodriguez said:

Thanks for the reply !

 

Could you try the following from the command line (edit your pwd as needed)


/usr/sbin/ipmi-sensors --comma-separated-output --output-sensor-state --no-header-output --interpret-oem-data --always-prefix -h 10.0.1.22 -u wgstarks -p redacted --session-timeout=5000 --retransmission-timeout=1000

It seems it doesn't like some parameter

Linux 4.14.13-unRAID.
Last login: Sat Jan 20 08:34:46 -0500 2018 on /dev/pts/0.
root@Brunnhilde:~# /usr/sbin/ipmi-sensors --comma-separated-output --output-sensor-state --no-header-output --interpret-oem-data --always-prefix -h 10.0.1.22 -u wgstarks -p redacted --session-timeout=5000 --retransmission-timeout=1000
10.0.1.22: 4,CPU Temp,Temperature,Nominal,35.00,C,'OK'
10.0.1.22: 71,System Temp,Temperature,Nominal,30.00,C,'OK'
10.0.1.22: 138,Peripheral Temp,Temperature,Nominal,33.00,C,'OK'
10.0.1.22: 205,PCH Temp,Temperature,Nominal,47.00,C,'OK'
10.0.1.22: 272,P1-DIMMA1 Temp,Temperature,Nominal,28.00,C,'OK'
10.0.1.22: 339,P1-DIMMA2 Temp,Temperature,N/A,N/A,C,N/A
10.0.1.22: 406,P1-DIMMB1 Temp,Temperature,Nominal,28.00,C,'OK'
10.0.1.22: 473,P1-DIMMB2 Temp,Temperature,N/A,N/A,C,N/A
10.0.1.22: 540,FAN1,Fan,Nominal,1100.00,RPM,'OK'
10.0.1.22: 607,FAN2,Fan,Nominal,1100.00,RPM,'OK'
10.0.1.22: 674,FAN3,Fan,Nominal,1100.00,RPM,'OK'
10.0.1.22: 741,FAN4,Fan,Nominal,1900.00,RPM,'OK'
10.0.1.22: 808,FANA,Fan,Nominal,1100.00,RPM,'OK'
10.0.1.22: 875,Vcpu,Voltage,Nominal,1.83,V,'OK'
10.0.1.22: 942,VDIMM,Voltage,Nominal,1.48,V,'OK'
10.0.1.22: 1009,12V,Voltage,Nominal,12.19,V,'OK'
10.0.1.22: 1076,5VCC,Voltage,Nominal,5.03,V,'OK'
10.0.1.22: 1143,3.3VCC,Voltage,Nominal,3.27,V,'OK'
10.0.1.22: 1210,VBAT,Voltage,Nominal,3.06,V,'OK'
10.0.1.22: 1277,5V Dual,Voltage,Nominal,5.05,V,'OK'
10.0.1.22: 1344,3.3V AUX,Voltage,Nominal,3.30,V,'OK'
10.0.1.22: 1411,1.2V BMC,Voltage,Nominal,1.26,V,'OK'
10.0.1.22: 1478,1.05V PCH,Voltage,Nominal,1.05,V,'OK'
10.0.1.22: 1545,Chassis Intru,Physical Security,Nominal,N/A,N/A,'OK'
root@Brunnhilde:~#

 

Link to post
  • Replies 534
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

ControlR is a companion plugin for the ControlR app.   Screenshot   Introduction This plugin allows you to set up user permissions for the ControlR app.   Oper

If 6.7 was imminent they wouldn't have bothered with 6.6.7.  Just sayin'  

Hi, yes, I'm tracking the issue in the app thread. I don't have a solution yet, because I'm unable to replicate the issue. Can you follow the steps in https://github.com/jbrodriguez/controlr

Posted Images



Thanks for the reply !
 
Could you try the following from the command line (edit your pwd as needed)
/usr/sbin/ipmi-sensors --comma-separated-output --output-sensor-state --no-header-output --interpret-oem-data --always-prefix -h 10.0.1.22 -u wgstarks -p redacted --session-timeout=5000 --retransmission-timeout=1000

It seems it doesn't like some parameter



I believe the -h, -u, -p need to be escaped. The new version starts for me but I don't see any ipmi commands
Link to post

You're obviously working on it, but I thought I'd chime in that I'm having issues with this as well.

On 1/16/2018 at 11:12 PM, wgstarks said:

This plugin doesn’t seem to be working with 6.4.0.

 

02890EDC-36E2-4B83-9295-DCEE75F07C41.thumb.png.4bbfb596f1d6b1e28e12c2b276952805.png

 

Controlr plugin is installed on the server.

By all appearances, it seems that the ControlR plugin starts. The app (Android) starts and works just fine except I cannot get logs.

 

It had been working after I upgraded to 6.4, but then I was having all sorts of issues with my server rebooting every 4-20 hours. I uninstalled almost all plugins just to see if I could get it running stably. It's now been up for 6 days, so I'm adding plugins back in 1 at a time. The ControlR plugin was one that I did not uninstall, but now that I think about it, it seemed to stop working right after I uninstalled everything else.

 

As I was typing this up, I thought maybe it was relying on something installed by NerdPack and that I'd uninstalled that. However, NP is still installed - these are the pieces I've got installed from it:

mcelog-153-x86_64-1.txz

perl-5.24.0-x86_64-1.txz

python-2.7.14a-x86_64-1.txz

screen-4.6.1s-x86_64-1.txz

utempter-1.1.6-x86_64-2.txz

A couple of items seem to have uninstalled themselves from NP when I upgraded, so maybe something is missing that ControlR needs?

 

I followed the instructions to stop the plugin from the GUI and execute:

cd /usr/local/emhttp/plugins/controlr
./controlr -certdir /boot/config/ssl/certs

This is what I got in my SSH window:



root@NAS:/usr/local/emhttp/plugins/controlr# ./controlr -certdir /boot/config/ssl/certs
I: 2018/01/24 20:17:55 app.go:55: controlr v2.7.2-317-a92dc4b-v2018.01.22 starting ...
I: 2018/01/24 20:17:55 app.go:63: No config file specified. Using app defaults ...
I: 2018/01/24 20:17:55 core.go:73: starting service Core ...
I: 2018/01/24 20:17:55 server.go:70: Starting service Server ...
I: 2018/01/24 20:17:55 server.go:89: Serving files from /usr/local/emhttp/plugins/controlr
I: 2018/01/24 20:17:55 server.go:139: Server started listening https on :2378
I: 2018/01/24 20:17:55 api.go:46: Starting service Api ...
I: 2018/01/24 20:17:55 api.go:90: Api started listening https on :2382
I: 2018/01/24 20:17:55 app.go:83: Press Ctrl+C to stop ...
echo: http: TLS handshake error from 192.168.1.52:41590: tls: first record does not look like a TLS handshake
echo: http: TLS handshake error from 192.168.1.52:41592: tls: first record does not look like a TLS handshake
echo: http: TLS handshake error from 192.168.1.52:41600: tls: first record does not look like a TLS handshake
echo: http: TLS handshake error from 192.168.1.52:41601: tls: first record does not look like a TLS handshake
echo: http: TLS handshake error from 192.168.1.52:41602: tls: first record does not look like a TLS handshake
echo: http: TLS handshake error from 192.168.1.52:41603: tls: first record does not look like a TLS handshake
echo: http: TLS handshake error from 192.168.1.52:41605: tls: first record does not look like a TLS handshake
echo: http: TLS handshake error from 192.168.1.52:41606: tls: first record does not look like a TLS handshake

The TLS handshake errors showed up each time I did something in the ControlR app on my phone.

 

I have not done anything with security on unRAID - I'm still running on port 80, I don't have any custom or manual certs. I'm leaving all that until after I get the server back to where it was and stable.

 

If there's anything else I can do to help you debug, I'm more than willing to do so, just let me know.

Link to post
9 hours ago, FreeMan said:

The TLS handshake errors showed up each time I did something in the ControlR app on my phone

 

Ok, so the problem is that the plugin thinks you have ssl enabled for your server and started on https, while you added the server on http on the ControlR app.

 

Please check the following

- Do you have either of these files on your server ?

/boot/config/ssl/certs/certficate_bundle.pem
/boot/config/ssl/certs/<server-name>_unraid_bundle.pem

- What does the USE_SSL line in /var/local/emhttp/var.ini read ?

- What does the USE_SSL line in /boot/config/ident.cfg read ?

Link to post
12 hours ago, jbrodriguez said:

 

Ok, so the problem is that the plugin thinks you have ssl enabled for your server and started on https, while you added the server on http on the ControlR app.

 

Please check the following

- Do you have either of these files on your server ?


/boot/config/ssl/certs/certficate_bundle.pem
/boot/config/ssl/certs/<server-name>_unraid_bundle.pem

- What does the USE_SSL line in /var/local/emhttp/var.ini read ?

- What does the USE_SSL line in /boot/config/ident.cfg read ?

 

In answer to your questions:



root@NAS:/boot/config/ssl/certs# ls -la
total 96
drwxrwxrwx 2 root root 32768 Jan 14 16:33 ./
drwxrwxrwx 3 root root 32768 Jan 14 16:33 ../
-rwxrwxrwx 1 root root  2835 Jan 14 16:33 NAS_unraid_bundle.pem*
root@NAS:/boot/config/ssl/certs# cat /var/local/emhttp/var.ini|grep USE_SSL
USE_SSL="auto"
root@NAS:/boot/config/ssl/certs# cat /boot/config/ident.cfg|grep USE_SSL
root@NAS:/boot/config/ssl/certs#

Link to post

Thanks FreeMan !

 

The plugin looks at var.ini which says ssl is on ("auto"), while ident.cfg says ssl is off (no entry).

 

Not sure why they're out of sync, but I'll start looking at ident.cfg, since it's arguably the source of truth in this matter.

Link to post

v2018.01.26 (2.7.3) is out !

 

- Quote ipmi-sensor params
- Use main ssl config file

 

I'm now quoting ipmi params as mentioned by dmacias, but haven't fully enabled ipmi yet.

 

I'll take another stab at it next week.

 

Using the main ssl config file (/boot/config/ident.cfg) should accurately identify whether ssl is on or off on the server.

Link to post
13 hours ago, jbrodriguez said:

v2018.01.26 (2.7.3) is out !

 

- Quote ipmi-sensor params
- Use main ssl config file

 

I'm now quoting ipmi params as mentioned by dmacias, but haven't fully enabled ipmi yet.

 

I'll take another stab at it next week.

 

Using the main ssl config file (/boot/config/ident.cfg) should accurately identify whether ssl is on or off on the server.

 

Sorry, Juan, that still didn't fix it - exact same result as before.

 

Thanks for the stab at it - if there's anything else I can provide to help solve the mystery, let me know.

Link to post
On 26.1.2018 at 12:55 PM, jbrodriguez said:

Hi,

 

Can you show the log (/boot/logs/controlr.log) ?

 

sorry for the delay.

 

I: 2018/01/29 13:13:42 app.go:57: controlr v2.7.3-323-f049c44-v2018.01.26 starting ...
I: 2018/01/29 13:13:42 app.go:65: No config file specified. Using app defaults ...
I: 2018/01/29 13:13:42 core.go:73: starting service Core ...

 

Link to post


I: 2018/01/29 18:13:21 app.go:89: Received signal: (terminated) ... shutting down the app now ...
I: 2018/01/29 18:13:21 api.go:105: stopped service Api ...
I: 2018/01/29 18:13:21 server.go:156: stopped service Server ...
I: 2018/01/29 18:13:21 core.go:137: stopped service Core ...
I: 2018/01/29 18:13:21 app.go:57: controlr v2.7.3-323-f049c44-v2018.01.26 starting ...
I: 2018/01/29 18:13:21 app.go:65: No config file specified. Using app defaults ...
I: 2018/01/29 18:13:21 core.go:73: starting service Core ...
I: 2018/01/29 18:15:36 app.go:57: controlr v2.7.3-323-f049c44-v2018.01.26 starting ...
I: 2018/01/29 18:15:36 app.go:65: No config file specified. Using app defaults ...
I: 2018/01/29 18:15:36 core.go:73: starting service Core ...
I: 2018/01/29 18:15:36 server.go:70: Starting service Server ...
I: 2018/01/29 18:15:36 server.go:89: Serving files from /usr/local/emhttp/plugins/controlr
I: 2018/01/29 18:15:36 server.go:139: Server started listening https on :2378
I: 2018/01/29 18:15:36 api.go:46: Starting service Api ...
I: 2018/01/29 18:15:36 api.go:90: Api started listening https on :2382
I: 2018/01/29 18:15:36 app.go:85: Press Ctrl+C to stop ...

 

when i disable UPS it run

Link to post

2018/01/29 18:53:48 app.go:89: Received signal: (terminated) ... shutting down the app now ...
I: 2018/01/29 18:53:48 api.go:105: stopped service Api ...
I: 2018/01/29 18:53:48 server.go:156: stopped service Server ...
I: 2018/01/29 18:53:48 core.go:137: stopped service Core ...
I: 2018/01/29 18:53:48 app.go:57: controlr v2.7.4-327-33467cd-v2018.01.29 starting ...
I: 2018/01/29 18:53:48 app.go:65: No config file specified. Using app defaults ...
I: 2018/01/29 18:53:48 app.go:214: debug:cert(Server1_unraid_bundle.pem)
I: 2018/01/29 18:53:48 app.go:150: debug:secure(true):cert(Server1_unraid_bundle.pem):usessl(yes):version(6.4.0)
I: 2018/01/29 18:53:48 app.go:166: debug:secure(true):cert(Server1_unraid_bundle.pem):usessl(yes):version(6.4.0)
I: 2018/01/29 18:53:48 app.go:186: debug:host(https://127.0.0.1/)
I: 2018/01/29 18:53:48 core.go:73: starting service Core ...
I: 2018/01/29 18:53:48 core.go:82: debug:getting mac/prefs/features
I: 2018/01/29 18:53:48 core.go:88: debug:creating plugins
I: 2018/01/29 18:53:48 core.go:264: debug:created system sensor
I: 2018/01/29 18:53:48 core.go:294: debug:no ups detected
I: 2018/01/29 18:53:48 core.go:93: debug:getting samples
I: 2018/01/29 18:53:48 utils.go:175: debug:executing:(/usr/bin/sensors):([-A])
I: 2018/01/29 18:53:48 core.go:96: debug:sensor samples:([{BOARD +47.0 C neutral} {CPU +47.0 C neutral}])
I: 2018/01/29 18:53:48 core.go:99: debug:ups samples:([])
I: 2018/01/29 18:53:48 server.go:70: Starting service Server ...
I: 2018/01/29 18:53:48 server.go:89: Serving files from /usr/local/emhttp/plugins/controlr
I: 2018/01/29 18:53:48 server.go:139: Server started listening https on :2378
I: 2018/01/29 18:53:48 api.go:46: Starting service Api ...
I: 2018/01/29 18:53:48 api.go:90: Api started listening https on :2382
I: 2018/01/29 18:53:48 app.go:85: Press Ctrl+C to stop ...
I: 2018/01/29 18:54:07 app.go:89: Received signal: (terminated) ... shutting down the app now ...
I: 2018/01/29 18:54:07 api.go:105: stopped service Api ...
I: 2018/01/29 18:54:07 server.go:156: stopped service Server ...
I: 2018/01/29 18:54:07 core.go:150: stopped service Core ...
I: 2018/01/29 18:54:07 app.go:57: controlr v2.7.4-327-33467cd-v2018.01.29 starting ...
I: 2018/01/29 18:54:07 app.go:65: No config file specified. Using app defaults ...
I: 2018/01/29 18:54:07 app.go:214: debug:cert(Server1_unraid_bundle.pem)
I: 2018/01/29 18:54:07 app.go:150: debug:secure(true):cert(Server1_unraid_bundle.pem):usessl(yes):version(6.4.0)
I: 2018/01/29 18:54:07 app.go:166: debug:secure(true):cert(Server1_unraid_bundle.pem):usessl(yes):version(6.4.0)
I: 2018/01/29 18:54:07 app.go:186: debug:host(https://127.0.0.1/)
I: 2018/01/29 18:54:07 core.go:73: starting service Core ...
I: 2018/01/29 18:54:07 core.go:82: debug:getting mac/prefs/features
I: 2018/01/29 18:54:07 core.go:88: debug:creating plugins
I: 2018/01/29 18:54:07 core.go:264: debug:created system sensor
I: 2018/01/29 18:54:07 core.go:285: debug:created apc ups
I: 2018/01/29 18:54:07 core.go:93: debug:getting samples
I: 2018/01/29 18:54:07 utils.go:175: debug:executing:(/usr/bin/sensors):([-A])
I: 2018/01/29 18:54:07 core.go:96: debug:sensor samples:([{BOARD +28.0 C neutral} {CPU +23.0 C neutral}])
I: 2018/01/29 18:54:07 utils.go:175: debug:executing:(/sbin/apcaccess):([])
I: 2018/01/29 18:54:19 app.go:57: controlr v2.7.4-327-33467cd-v2018.01.29 starting ...
I: 2018/01/29 18:54:19 app.go:65: No config file specified. Using app defaults ...
I: 2018/01/29 18:54:19 app.go:214: debug:cert(Server1_unraid_bundle.pem)
I: 2018/01/29 18:54:19 app.go:150: debug:secure(true):cert(Server1_unraid_bundle.pem):usessl(yes):version(6.4.0)
I: 2018/01/29 18:54:19 app.go:166: debug:secure(true):cert(Server1_unraid_bundle.pem):usessl(yes):version(6.4.0)
I: 2018/01/29 18:54:19 app.go:186: debug:host(https://127.0.0.1/)
I: 2018/01/29 18:54:19 core.go:73: starting service Core ...
I: 2018/01/29 18:54:19 core.go:82: debug:getting mac/prefs/features
I: 2018/01/29 18:54:19 core.go:88: debug:creating plugins
I: 2018/01/29 18:54:19 core.go:264: debug:created system sensor
I: 2018/01/29 18:54:19 core.go:294: debug:no ups detected
I: 2018/01/29 18:54:19 core.go:93: debug:getting samples
I: 2018/01/29 18:54:19 utils.go:175: debug:executing:(/usr/bin/sensors):([-A])
I: 2018/01/29 18:54:19 core.go:96: debug:sensor samples:([{BOARD +56.0 C neutral} {CPU +47.0 C neutral}])
I: 2018/01/29 18:54:19 core.go:99: debug:ups samples:([])
I: 2018/01/29 18:54:19 server.go:70: Starting service Server ...
I: 2018/01/29 18:54:19 server.go:89: Serving files from /usr/local/emhttp/plugins/controlr
I: 2018/01/29 18:54:19 server.go:139: Server started listening https on :2378
I: 2018/01/29 18:54:19 api.go:46: Starting service Api ...
I: 2018/01/29 18:54:19 api.go:90: Api started listening https on :2382
I: 2018/01/29 18:54:19 app.go:85: Press Ctrl+C to stop ...

 

Link to post

without UPS

 

I: 2018/01/29 19:15:30 app.go:57: controlr v2.7.4-327-33467cd-v2018.01.29 starting ...
I: 2018/01/29 19:15:30 app.go:65: No config file specified. Using app defaults ...
I: 2018/01/29 19:15:30 app.go:201: debug:cert(certificate_bundle.pem)
I: 2018/01/29 19:15:30 app.go:150: debug:secure(true):cert(certificate_bundle.pem):usessl(auto):version(6.4.0)
I: 2018/01/29 19:15:30 app.go:166: debug:secure(true):cert(certificate_bundle.pem):usessl(auto):version(6.4.0)
I: 2018/01/29 19:15:30 app.go:186: debug:host(https://127.0.0.1:442/)
I: 2018/01/29 19:15:30 core.go:73: starting service Core ...
I: 2018/01/29 19:15:30 core.go:82: debug:getting mac/prefs/features
I: 2018/01/29 19:15:30 core.go:88: debug:creating plugins
I: 2018/01/29 19:15:30 core.go:264: debug:created system sensor
I: 2018/01/29 19:15:30 core.go:294: debug:no ups detected
I: 2018/01/29 19:15:30 core.go:93: debug:getting samples
I: 2018/01/29 19:15:30 utils.go:175: debug:executing:(/usr/bin/sensors):([-A])
I: 2018/01/29 19:15:30 core.go:96: debug:sensor samples:([{FAN 344 rpm neutral} {BOARD +33.5 C neutral} {CPU +35.0 C neutral}])
I: 2018/01/29 19:15:30 core.go:99: debug:ups samples:([])
I: 2018/01/29 19:15:30 server.go:70: Starting service Server ...
I: 2018/01/29 19:15:30 server.go:89: Serving files from /usr/local/emhttp/plugins/controlr
I: 2018/01/29 19:15:30 server.go:139: Server started listening https on :2378
I: 2018/01/29 19:15:30 api.go:46: Starting service Api ...
I: 2018/01/29 19:15:30 api.go:90: Api started listening https on :2382
I: 2018/01/29 19:15:30 app.go:85: Press Ctrl+C to stop ...

 

with UPS enabled

 

I: 2018/01/29 19:15:39 app.go:57: controlr v2.7.4-327-33467cd-v2018.01.29 starting ...
I: 2018/01/29 19:15:39 app.go:65: No config file specified. Using app defaults ...
I: 2018/01/29 19:15:39 app.go:201: debug:cert(certificate_bundle.pem)
I: 2018/01/29 19:15:39 app.go:150: debug:secure(true):cert(certificate_bundle.pem):usessl(auto):version(6.4.0)
I: 2018/01/29 19:15:39 app.go:166: debug:secure(true):cert(certificate_bundle.pem):usessl(auto):version(6.4.0)
I: 2018/01/29 19:15:39 app.go:186: debug:host(https://127.0.0.1:442/)
I: 2018/01/29 19:15:39 core.go:73: starting service Core ...
I: 2018/01/29 19:15:39 core.go:82: debug:getting mac/prefs/features
I: 2018/01/29 19:15:39 core.go:88: debug:creating plugins
I: 2018/01/29 19:15:39 core.go:264: debug:created system sensor
I: 2018/01/29 19:15:39 core.go:285: debug:created apc ups
I: 2018/01/29 19:15:39 core.go:93: debug:getting samples
I: 2018/01/29 19:15:39 utils.go:175: debug:executing:(/usr/bin/sensors):([-A])
I: 2018/01/29 19:15:39 core.go:96: debug:sensor samples:([{FAN 346 rpm neutral} {BOARD +33.5 C neutral} {CPU +34.0 C neutral}])
I: 2018/01/29 19:15:39 utils.go:175: debug:executing:(/sbin/apcaccess):([])

 

Link to post

root@Server1:~# /sbin/apcaccess
APC      : 001,036,0877
DATE     : 2018-01-29 20:16:16 +0100
HOSTNAME : Server1
VERSION  : 3.14.14 (31 May 2016) slackware
UPSNAME  : Server1
CABLE    : USB Cable
DRIVER   : USB UPS Driver
UPSMODE  : Stand Alone
STARTTIME: 2018-01-28 05:29:15 +0100
MODEL    : Back-UPS XS 1400U
STATUS   : ONLINE
LINEV    : 230.0 Volts
LOADPCT  : 13.0 Percent
BCHARGE  : 100.0 Percent
TIMELEFT : 45.3 Minutes
MBATTCHG : 10 Percent
MINTIMEL : 10 Minutes
MAXTIME  : 0 Seconds
SENSE    : Medium
LOTRANS  : 155.0 Volts
HITRANS  : 280.0 Volts
ALARMDEL : No alarm
BATTV    : 27.2 Volts
LASTXFER : Automatic or explicit self test
NUMXFERS : 0
TONBATT  : 0 Seconds
CUMONBATT: 0 Seconds
XOFFBATT : N/A
SELFTEST : NO
STATFLAG : 0x05000008
SERIALNO : 3B1538X15621
BATTDATE : 2016-02-07
NOMINV   : 230 Volts
NOMBATTV : 24.0 Volts
NOMPOWER : 700 Watts
FIRMWARE : 926.T2 .I USB FW:T2
END APC  : 2018-01-29 20:16:18 +0100
root@Server1:~# /sbin/apcaccess status 127.0.0.1:3551
APC      : 001,036,0877
DATE     : 2018-01-29 20:16:44 +0100
HOSTNAME : Server1
VERSION  : 3.14.14 (31 May 2016) slackware
UPSNAME  : Server1
CABLE    : USB Cable
DRIVER   : USB UPS Driver
UPSMODE  : Stand Alone
STARTTIME: 2018-01-28 05:29:15 +0100
MODEL    : Back-UPS XS 1400U
STATUS   : ONLINE
LINEV    : 230.0 Volts
LOADPCT  : 13.0 Percent
BCHARGE  : 100.0 Percent
TIMELEFT : 47.5 Minutes
MBATTCHG : 10 Percent
MINTIMEL : 10 Minutes
MAXTIME  : 0 Seconds
SENSE    : Medium
LOTRANS  : 155.0 Volts
HITRANS  : 280.0 Volts
ALARMDEL : No alarm
BATTV    : 27.1 Volts
LASTXFER : Automatic or explicit self test
NUMXFERS : 0
TONBATT  : 0 Seconds
CUMONBATT: 0 Seconds
XOFFBATT : N/A
SELFTEST : NO
STATFLAG : 0x05000008
SERIALNO : 3B1538X15621
BATTDATE : 2016-02-07
NOMINV   : 230 Volts
NOMBATTV : 24.0 Volts
NOMPOWER : 700 Watts
FIRMWARE : 926.T2 .I USB FW:T2
END APC  : 2018-01-29 20:16:45 +0100
root@Server1:~#

 

Link to post
6 hours ago, jbrodriguez said:

Let me know if this one works

 

The controlr plugin starts now and the app sees logs and ups data. Nice!  

 

I'm not seeing any IPMI data yet, but I don't think that is fully enabled yet, right? Hopefully it will use all the same IPMI settings that the plugin does?

 

One small corner case for the app... when there is no parity drive installed there shouldn't be a 'check parity' option.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.