[Plugin] rclone


Waseh

906 posts in this topic Last Reply

Recommended Posts

Dumb question time, 

 

amazon photo storage 

 

can i use use recline to automatically sync all the photos(or all content as it’s only photos)  in one of my shares to amazons online photo storage, as it’s a final back up solution to store my photos, so ideally I would like this to be a automated system that runs when ever I upload a photo in to the share it will automatically sync and upload to the amazon account, 

 

is this possible, and how do I go about setting it up. 

 

Thanks 

Link to post
  • Replies 905
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

rclone Plugin   Hey everyone   This is a simple plugin which installs rclone on your unraid system. The plugins have now been merged so both the stable and beta branch are

Hey guys Sorry for the lack of updates in a (long) while ? Real life has been taking up a lot of time and my own install of rclone has been sufficient for my needs. However both the stable branch

Someone beat me to it. And probably explained it in a nicer way than i would have Reinstalling the plugin will also result in the newest version being pulled Take a look at the change log

Posted Images

Hey guys

Sorry for the lack of updates in a (long) while ? Real life has been taking up a lot of time and my own install of rclone has been sufficient for my needs.
However both the stable branch as well as the beta branch should now be able to survive a reboot even if no internet connection is available. Please test it out and see if it's working as intended. I also fixed the missing icon on the settings page.

 

Cheers

Link to post
14 hours ago, Waseh said:

Hey guys

Sorry for the lack of updates in a (long) while ? Real life has been taking up a lot of time and my own install of rclone has been sufficient for my needs.
However both the stable branch as well as the beta branch should now be able to survive a reboot even if no internet connection is available. Please test it out and see if it's working as intended. I also fixed the missing icon on the settings page.

 

Cheers

 

Thanks for all your work! I just used rclone config through Putty (terminal gives the same error) as I always do and it gives me the following error:


root@Unraid:~# rclone config
/usr/sbin/rclone: line 21: rcloneorig: command not found

 

So I can't configure anything at the moment. Is this a bug, or on my side?

 

Edit: did some further checks and mounting also does not work.

 

Edited by Kaizac
Link to post

That would suggest that the plugin didn't install correctly since only the wrapper seems to be present. 

 

Is this new behavior and/or is it connected to updating or installing on reboot while offline? 

Edited by Waseh
Link to post
Just now, Waseh said:

That would suggest that the plugin didn't install correctly since only the wrapper seems to be present. 

 

Is this new behavior and/or is it connected to updating/install on reboot while offline? 

 

New behaviour and I always install with internet connected. I'm not sure if I can force a reïnstall without losing all my configuration?

Link to post
1 minute ago, Waseh said:

Configs are kept even when uninstalling so you don't have to worry about removing and reinstalling the plugin :)

 

Thanks! I just deleted and reinstalled through the apps library and not it's working again. I will do a reboot again of my server to see if it works well this time. Will report back in about 5 minutes.

Link to post

Hi! I am trying to access my gdrive from this plugin and I am using spaceinvader's video as a rough guide. I am getting issues listing the directories as a test to make sure everything works. 

rclone lsd google
2018/08/27 12:01:50 ERROR : : error listing: directory not found
2018/08/27 12:01:50 Failed to lsd: directory not found

 

I set the remote to have access to everything during setup, I believe this was option 1 at the point. Is this an issue with the plugin or the version the plugin is using or something with rclone itself. If this isn't the plugins fault, and to this point I am not sure, it would still be nice to get a quick hand figuring out what I am doing wrong. If I explicitly set a directory such as 

rclone ls google:Client Data Backup

It does work and it lists the files as expected but I can't seem to LS or LSD the root. Should I try using the beta plugin instead? I may just be stupid here or I may be wasting your time with problems that I shouldn't be bringing to you but I am super new to Linux in general and this is my first time ever using rclone so I am not sure if the problem is me or not. If it is me then you can please just tell me to take a hike and I will, I promise. ?

Edited by cammelspit
Link to post
4 minutes ago, cammelspit said:

Hi! I am trying to access my gdrive from this plugin and I am using spaceinvader's video as a rough guide. I am getting issues listing the directories as a test to make sure everything works. 


rclone lsd google
2018/08/27 12:01:50 ERROR : : error listing: directory not found
2018/08/27 12:01:50 Failed to lsd: directory not found

 

I set the remote to have access to everything during setup, I believe this was option 1 at the point. Is this an issue with the plugin or the version the plugin is using or something with rclone itself. If this isn't the plugins fault, and to this point I am not sure, it would still be nice to get a quick hand figuring out what I am doing wrong. If I explicitly set a directory such as 


rclone ls google:Client Data Backup

It does work and it lists the files as expected but I can't seem to LS or LSD the root. Should I try using the beta plugin instead? I may just be stupid here or I may be wasting your time with problems that I shouldn't be bringing to you but I am super new to Linux in general and this is my first time ever using rclone so I am not sure if the problem is me or not. If it is me then you can please just tell me to take a hike and I will, I promise. ?

 

You forgot the ":". So type in rclone lsd google:

Link to post
Just now, cammelspit said:

Holy hell in a handbasket Batman! I now feel rather silly and I think you kindly for pointing out my silly syntax mistake! ?

 

Hahaha, I made that mistake numerous times myself so it's nice I can finally carry over this precious knowledge ;).

Link to post
  • 2 weeks later...
On 8/26/2018 at 2:21 PM, Kaizac said:

Just rebooted and everything seems to working as usual again. Never had that happen before, so it was definitely strange. Thanks for thinking along!

Same thing happened to me. I had to remove/reinstall a few times before it worked. 

Link to post

Im sort of stuck in limbo now, cant install and tried removing from the error tab of plugins.

When I try a re-install I get this (its not working, get rclone not found on my scripts or if I try to run it from ssh) :

 

plugin: installing: https://raw.githubusercontent.com/Waseh/rclone-unraid/beta/plugin/rclone.plg
plugin: downloading https://raw.githubusercontent.com/Waseh/rclone-unraid/beta/plugin/rclone.plg
plugin: downloading: https://raw.githubusercontent.com/Waseh/rclone-unraid/beta/plugin/rclone.plg ... done

+==============================================================================
| Skipping package rclone-2018.08.25-bundle (already installed)
+==============================================================================


Archive: /boot/config/plugins/rclone-beta/install/rclone-beta-latest.old.zip
Copy failed - rclone running
plugin: run failed: /bin/bash retval: 1

Edited by vw-kombi
Link to post

Hey guys

I've pushed an update that should make the install hang for a shorter amount of time if no internet connection is available as well as retrying downloading rclone if the rclone website is unresponsive.
Also i have added a check to see if the unpacking of the rclone archive was successful. This should make it easier to understand why an install failed as the "rclone running" error was triggering for other reasons as well. 

Cheers

Edited by Waseh
Link to post

OK - I tried again and this time I got this :

 

plugin: installing: https://raw.githubusercontent.com/Waseh/rclone-unraid/beta/plugin/rclone.plg
plugin: downloading https://raw.githubusercontent.com/Waseh/rclone-unraid/beta/plugin/rclone.plg
plugin: downloading: https://raw.githubusercontent.com/Waseh/rclone-unraid/beta/plugin/rclone.plg ... done

+==============================================================================
| Skipping package rclone-2018.08.25-bundle (already installed)
+==============================================================================


Downloading rclone
Downloading certs
Archive: /boot/config/plugins/rclone-beta/install/rclone-beta-latest.old.zip
Unpack failed - Please try installing/updating the plugin again
plugin: run failed: /bin/bash retval: 1

Updating Support Links

Link to post

What version of the plugin are you upgrading from? Also have you tried removing the plugin and installing it again? 

 

It doesn't seem to actually be downloading a functioning archive. 

Edited by Waseh
Link to post
5 minutes ago, Waseh said:

What version of the plugin are you upgrading from? Also have you tried removing the plugin and installing it again? 

 

It doesn't seem to actually be downloading a functioning archive. 

Im not sure what version.

 

Plugin is not showing as installed in installed plugins, none in error state either, so cant uninstall it.

 

It was installed about 3 weeks ago, then unraid was restarted about a week ago, then it is lost, which I think is the norm but I did read that it should survive an outage, then I tried to re-install it, that hung - prob as the website was not responding, then I am where I am currently - cant install it, cant uninstall it.

 

Im sure an unraid restart will rectify this - but I am not in a place where I can do that currently.  If you have anything I can try, please let me know.

Link to post

Try following this path /boot/config/plugins/rclone-beta/install/ and check the file size of the rclone-beta-latest.old.zip (should be around 7-8 mb) - then delete it and try installing the plugin again.

It probably won't install but it will clear up if the download is failing. 

Edited by Waseh
Link to post

I deleted  /boot/config/plugins/rclone-beta and all its contents, not quite what you stated....sorry....  re-install says this.

 

plugin: installing: https://raw.githubusercontent.com/Waseh/rclone-unraid/beta/plugin/rclone.plg
plugin: downloading https://raw.githubusercontent.com/Waseh/rclone-unraid/beta/plugin/rclone.plg
plugin: downloading: https://raw.githubusercontent.com/Waseh/rclone-unraid/beta/plugin/rclone.plg ... done

+==============================================================================
| Skipping package rclone-2018.08.25-bundle (already installed)
+==============================================================================


Downloading rclone
Downloading certs
Download failed - No existing archive found - Try again later
plugin: run failed: /bin/bash retval: 1

Updating Support Links

 

I initially had the rclone stable instalkled - maybe that is the issue - but if I try to install that again it says to uninstall the beta first - can I just blow away the beta folder under pluygins and ro-do the stable ?

 

further - I can see rclone-beta in settings - but not my scripts - which are under rclone plugin folder.

 

How can I remove the rclone-beta from a command line ?

 

Thanks.

 

Edited by vw-kombi
Link to post

That won't be enough unfortunately. 

You could try running these commands:

rm -rf /boot/config/plugins/rclone-beta/install

rm -f /usr/sbin/rcloneorig

rm -f /usr/sbin/rclone

rm -f /etc/ssl/certs/ca-certificates.crt

removepkg rclone-2018.08.25-bundle

 

However that still doesn't explain why the download is failing. I don't have any problems pulling the beta as of right now. 

Edited by Waseh
Link to post

I ran those commands, and then the normal rclone install no longer fails with 'beta installed, please remove', which is good - but it does does not quite install - also after doing the above, and/or the below, the rclone (original, not beta) is showing in settings now (which is good) - but the scripts are empty there - not an issue I guess as they are in the user scripts system still to run on array start, end and periodically as per space invaders setup video.  And the rclone command as root says 'command not found' - which I guess is expected as the install failed :

 

plugin: installing: https://raw.githubusercontent.com/Waseh/rclone-unraid/master/plugin/rclone.plg
plugin: downloading https://raw.githubusercontent.com/Waseh/rclone-unraid/master/plugin/rclone.plg
plugin: downloading: https://raw.githubusercontent.com/Waseh/rclone-unraid/master/plugin/rclone.plg ... done
plugin: downloading: https://raw.githubusercontent.com/Waseh/rclone-unraid/master/archive/rclone-2018.08.25-x86_64-1.txz ... done

+==============================================================================
| Installing new package /boot/config/plugins/rclone/install/rclone-2018.08.25-bundle.txz
+==============================================================================

Verifying package rclone-2018.08.25-bundle.txz.
Installing package rclone-2018.08.25-bundle.txz:
PACKAGE DESCRIPTION:
Package rclone-2018.08.25-bundle.txz installed.


Downloading rclone
Downloading certs
Archive: /boot/config/plugins/rclone/install/rclone-current.zip
Unpack failed - Please try installing/updating the plugin again
plugin: run failed: /bin/bash retval: 1

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.