Jump to content
Waseh

[Plugin] rclone

697 posts in this topic Last Reply

Recommended Posts

1 hour ago, drdebian said:

hi there... are there any known issues with the jottacloud remote? I can't seem to authenticate agains the jottacloud servers anymore with rclone...

 

rclone v1.48.0
- os/arch: linux/amd64
- go version: go1.12.6

 

2019/08/14 06:24:10 Failed to create file system for "ula-jottacloud:": couldn't get account info: failed to get endpoint url: error 401: org.springframework.security.authentication.AuthenticationCredentialsNotFoundException: Token mismatch! (Unauthorized)

 

I tried everything, including removing the remote from the config and recreating it... to no avail...

 

any help welcome!

Jotta changed their API two days ago. 

 

https://github.com/rclone/rclone/pull/3436

 

Should be fixed in next release

Share this post


Link to post
11 minutes ago, ProphetSe7en said:

The fix is actually live, we just need the plugin to be updated

Can't wait... In the meantine, Jottacloud's support sent me this:

 

Quote

Hi, 

Yes, we have done some changes regarding emails in our systems, and this means we no longer support emails in JFS-url's. This can cause progblems if you use third-party apps with Jottacloud if they still use this format. It should however be possible to use your username (not email). This is: 5a97557a9a20aa0133a13331

I tried it and it actually works, which is good enough until the updated plugin arrives... 

Share this post


Link to post
29 minutes ago, drdebian said:

Can't wait... In the meantine, Jottacloud's support sent me this:

 

I tried it and it actually works, which is good enough until the updated plugin arrives... 

Yes it works, but not sure how we can find our username since we only use email for login. Waseh

 

@Waseh
Can we get an update to the latest Beta version to include the fix added? Looks like the plugin is running an old beta version.

Edited by ProphetSe7en

Share this post


Link to post

I have 2 shares on Google drive working (one encrypted).

 

Is there any way to transfer the settings from those 2 shares to another computer ?

Do rclone store some configuration file I can transfer or I must re-create the same share on the other computer?

 

Thankyou
Gus

 

Edited by zzgus

Share this post


Link to post
I have 2 shares on Google drive working (one encrypted).
 
Is there any way to transfer the settings from those 2 shares to another computer ?
Do rclone store some configuration file I can transfer or I must re-create the same share on the other computer?
 
Thankyou
Gus
 
Just typo this into Terminal on unraid to find the location of the rclone.conf file:

rclone config file

Share this post


Link to post

SOLVED: unionfs has to be empty, including directories, when mounting. 

 

 

Everything has been working great with rclone since I set it up about a month ago. This weekend though, I've lost the unionfs mount. I've shutdown unraid and rebooted and it doesn't seem to want to come back. Manually running ( in background) my rclone_unmount script and then running my rclone_mount script ( in background) always yields the same error in the log. 

 

18.08.2019 08:50:01 INFO: Check rclone vfs already mounted.
fuse: mountpoint is not empty
fuse: if you are sure this is safe, use the 'nonempty' mount option
18.08.2019 08:50:01 CRITICAL: unionfs Remount failed.
Script Finished Sun, 18 Aug 2019 08:50:01 -0500

 

my mount mount_unionfs isn't empty as I have a movies directory there, the movies directory is empty though. Should I just add the nonempty mount option or is there a different best practice or is something else going on?

 

Any help is appreciated. 

Edited by sol
Solved

Share this post


Link to post
On 8/17/2019 at 11:12 PM, Stupifier said:

Just typo this into Terminal on unraid to find the location of the rclone.conf file:
 


rclone config file
 

 

Thankyou !!!

Gus

Share this post


Link to post

A bunch of people here seemed to be complaining about rclone and google photos support.........Well, its supported in latest version. Dunno if/when Unraid rclone beta plugin will pick it all up.
type rclone --version to figure out which version you're on.

 

 

 

Share this post


Link to post

Can't get this plugin to install:

 

plugin: installing: https://raw.githubusercontent.com/Waseh/rclone-unraid/beta/plugin/rclone.plg
plugin: downloading https://raw.githubusercontent.com/Waseh/rclone-unraid/beta/plugin/rclone.plg
plugin: downloading: https://raw.githubusercontent.com/Waseh/rclone-unraid/beta/plugin/rclone.plg ... done

+==============================================================================
| Skipping package rclone-2018.08.25-bundle (already installed)
+==============================================================================

Downloading rclone
Downloading certs
Download failed - No existing archive found - Try again later
plugin: run failed: /bin/bash retval: 1

Updating Support Links

 

Tried running the curl command on page 13 of this thread to no avail, but the server definitely isn't blocked - I can access it and download the zip on my desktop, and ping downloads.rclone.org from unRAID.

 

The Curl command works without the --connect-timeout option, but not with it.

 

root@Tacgnol-Core:/boot/config/plugins/rclone-beta/install# curl --connect-timeout 5 --retry 3 --retry-delay 2 --retry-max-time 30 -o /boot/config/plugins/rclone-beta/install/rclone-current.test.zip https://downloads.rclone.org/rclone-current-linux-amd64.zip
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:05 --:--:--     0
Warning: Transient problem: timeout Will retry in 2 seconds. 3 retries left.
  0     0    0     0    0     0      0      0 --:--:--  0:00:05 --:--:--     0
Warning: Transient problem: timeout Will retry in 2 seconds. 2 retries left.
  0     0    0     0    0     0      0      0 --:--:--  0:00:05 --:--:--     0
Warning: Transient problem: timeout Will retry in 2 seconds. 1 retries left.
  0     0    0     0    0     0      0      0 --:--:--  0:00:05 --:--:--     0
root@Tacgnol-Core:/boot/config/plugins/rclone-beta/install# curl --retry 3 --retry-delay 2 --retry-max-time 30 -o /boot/config/plugins/rclone-beta/install/rclone-current.test.zip https://downloads.rclone.org/rclone-current-linux-amd64.zip
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 11.0M  100 11.0M    0     0  2081k      0  0:00:05  0:00:05 --:--:-- 2366k

 

Edited by rtho782

Share this post


Link to post

@Waseh I know you have been absent from the forums since June, but I was hoping if you could find the time to update the Rclone-beta to the latest version.
At lot of improvements have been made since, it would breath new life into this awesome piece of tooling for unraid users. :)

Share this post


Link to post
42 minutes ago, Arndroid said:

@Waseh I know you have been absent from the forums since June, but I was hoping if you could find the time to update the Rclone-beta to the latest version.
At lot of improvements have been made since, it would breath new life into this awesome piece of tooling for unraid users. :)

Very true. Recent developments on rclone-beta have greatly improved rclone. It is much quicker and more efficient.

 

Hope to see Unraid rclone-beta see an update soon

Share this post


Link to post

Guys, I don't think you need Waseh to update the script to get latest version of rclone.

 

Having a look at the plugin code, I believe he sets it up to download whatever the latest version is at the time (of boot). So a restart will get you the latest version.

 

For example, below is my current version:

:~# rclone --version
rclone v1.49.0-007-g16e7da2c-beta

And below is from rclone beta website (https://beta.rclone.org/)

v1.49.0-007-g16e7da2c-beta—29/08/2019, 11:08:23
v1.49.0-008-ge2b5ed6c-beta—02/09/2019, 06:04:57

My last reboot happened to be on 01 Sep 2019, which is why my rclone version is v1.49.0-007 (latest on that day).

Edited by testdasi

Share this post


Link to post

Someone beat me to it. And probably explained it in a nicer way than i would have ;)

Reinstalling the plugin will also result in the newest version being pulled

Take a look at the change log

2017.09.23
Always pull newest version on install

I do concede that this could be stated somewhere more noticeable

Edited by Waseh

Share this post


Link to post

I have just exhausted rclones last chance on my system. I have had nothing but issues with it for over 6months. Again with absolutely nothing changing on the system. plex/unraid totally freeze when scanning the library that points to rclone/gsuite to the point I have to hard reset the server. Both Unraid and plex have been updated and plex has been reinstalled about 100000000000000000000000 times but it still happens ONLY when scanning through the mount.. I have had an absolute enough and am not giving this terrible system any more chances. What I am looking to know is what is the best method to download my data back to my hard drives? When I used Krusader it Fked up half my files and I had to redownload them. I have the string to upload to gsuite with terminal but I can not put a Download string together to download. Anyone able to help?

 

Share this post


Link to post
20 minutes ago, tmoran000 said:

I have just exhausted rclones last chance on my system. I have had nothing but issues with it for over 6months. Again with absolutely nothing changing on the system. plex/unraid totally freeze when scanning the library that points to rclone/gsuite to the point I have to hard reset the server. Both Unraid and plex have been updated and plex has been reinstalled about 100000000000000000000000 times but it still happens ONLY when scanning through the mount.. I have had an absolute enough and am not giving this terrible system any more chances. What I am looking to know is what is the best method to download my data back to my hard drives? When I used Krusader it Fked up half my files and I had to redownload them. I have the string to upload to gsuite with terminal but I can not put a Download string together to download. Anyone able to help?

 

Sounds like rclone just isn't for you. I've had a great experience personally and stream a huge collection with rclone/Plex/Unraid.

 

Anyway, read the rclone copy documentation for help download/uploading anything with rclone. Always helps to read the official documentation to get exactly what you are after :)

https://rclone.org/commands/rclone_copy/

Share this post


Link to post
35 minutes ago, Stupifier said:

Sounds like rclone just isn't for you. I've had a great experience personally and stream a huge collection with rclone/Plex/Unraid.

 

Anyway, read the rclone copy documentation for help download/uploading anything with rclone. Always helps to read the official documentation to get exactly what you are after :)

https://rclone.org/commands/rclone_copy/

I have read it and I cant seem to get the string to work. I keep getting an error that something in my command isn't working... That is why I am asking for help. You shouldn't assume when a question is asked its because they did not research first

Edited by tmoran000

Share this post


Link to post
12 minutes ago, tmoran000 said:

I have read it and I cant seem to get the string to work. I keep getting an error that something in my command isn't working... That is why I am asking for help. You shouldn't assume when a question is asked its because they did not research first

Provide the exact command you used and the actual error message

Share this post


Link to post

upgraded to 6.8rc1 tonight and am getting this error when script runs. 

 

2019/10/11 20:32:46 Fatal error: failed to mount FUSE fs: fusermount: exec: "fusermount": executable file not found in $PATH

 

any help would be appreciated

 

thanks

 

Share this post


Link to post
32 minutes ago, Viperkc said:

upgraded to 6.8rc1 tonight and am getting this error when script runs. 

 

2019/10/11 20:32:46 Fatal error: failed to mount FUSE fs: fusermount: exec: "fusermount": executable file not found in $PATH

 

any help would be appreciated

 

thanks

 

When what script runs? What command are you attempting to do when you see that error?

 

What is output of this:

rclone --version

 

Also, you could try uninstalling rclone-beta plugin, rebooting server, install rclone-beta plugin again. Then test your script/command

Share this post


Link to post

i did try to uninstall and reinstall plugin.

 

Just rolled back to 6.7 and all working fine again.

 

I see 6.8 has fuse 3.0 could that be the issue?

 

 

Share this post


Link to post
Just now, Viperkc said:

i did try to uninstall and reinstall plugin.

 

Just rolled back to 6.7 and all working fine again.

 

I see 6.8 has fuse 3.0 could that be the issue?

 

 

Dunno if fuse 3.0 is the issue....but I might be able to help diagnose if I know what exact "script" or command you are trying to run.

 

Also, what is output of this command:

rclone --version

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.