Jump to content
Squid

[Plugin] CA Application Auto Update

162 posts in this topic Last Reply

Recommended Posts

I don't know if you've already addressed this, but I got this email last night:

From: Console and webGui login account
Date: November 28, 2016 at 12:00:01 AM EST
To: root
Subject: cron for user root /usr/local/emhttp/plugins/ca.update.applications/scripts/updateApplications.php >dev/null 2>&1

/bin/sh: dev/null: No such file or directory

 

Already done

 

Sent from my LG-D852 using Tapatalk

 

Thank you.

Except the fix is in the .plg file and won't change anything for people who already had that installed (since its part of the one-time conversion from the old version of the plg to the new).  You just have to make a change (any change) on the plugin settings schedule.

Share this post


Link to post

6.2.4

 

I've updated. Fingers crossed :)

 

Cheers Man.

After work I'll be testing it with 6.2.4 in conjunction with CHBMB. 

 

Explanation:  There were some changes that bonienl had done to make dockerMan's routines work with scripts in 6.2  But it appears that the change in question didn't make it into one particular dockerMan file in 6.2, but was later added into 6.3

Share this post


Link to post

I've been getting this message in my syslog at midnight since the 2016.11.27 update:

 

Nov 29 00:00:01 Northolt crond[1551]: exit status 1 from user root /usr/local/emhttp/plugins/ca.update.applications/scripts/updateApplications.php >dev/null 2>&1

Nov 29 00:00:01 Northolt sSMTP[36811]: Creating SSL connection to host

Nov 29 00:00:01 Northolt sSMTP[36811]: SSL connection using ECDHE-RSA-AES128-GCM-SHA256

Nov 29 00:00:01 Northolt sSMTP[36811]: Authorization failed (535 5.7.8  https://support.google.com/mail/?p=BadCredentials n17sm64923259wjq.6 - gsmtp)

 

I don't have email notifications enabled so I'm wondering if it's related to the problem dlandon mentioned above.

 

EDIT: I've just noticed that there's a new (2016.11.28) version. I'll update and see if it goes away.

 

Share this post


Link to post

I've been getting this message in my syslog at midnight since the 2016.11.27 update:

 

Nov 29 00:00:01 Northolt crond[1551]: exit status 1 from user root /usr/local/emhttp/plugins/ca.update.applications/scripts/updateApplications.php >dev/null 2>&1

Nov 29 00:00:01 Northolt sSMTP[36811]: Creating SSL connection to host

Nov 29 00:00:01 Northolt sSMTP[36811]: SSL connection using ECDHE-RSA-AES128-GCM-SHA256

Nov 29 00:00:01 Northolt sSMTP[36811]: Authorization failed (535 5.7.8  https://support.google.com/mail/?p=BadCredentials n17sm64923259wjq.6 - gsmtp)

 

I don't have email notifications enabled so I'm wondering if it's related to the problem dlandon mentioned above.

 

EDIT: I've just noticed that there's a new (2016.11.28) version. I'll update and see if it goes away.

It won't  Just change any setting on the plugin settings to fix.

Share this post


Link to post

Guys, I was on the right track with 6.2.x and the docker update.  But, I had the wrong syntax.  28b disables the docker update routine on 6.2.  But quick tests with my modified syntax works.  Just have to wait again til I can get an updated container on my 6.2 system

Share this post


Link to post

Hi Squid..  Thanks again for all of your efforts!

 

Just wanted to give you the heads up, some of my Docker's were uninstalled this morning shortly after the auto-update. Of course all it took was to reinstall them, but i wanted to let you know.  See the attachment from my log file for more details.

updates.PNG.2c4f6fa0257cbefe8b72848fde27243b.PNG

Share this post


Link to post

I had a docker uninstall after an auto update.  It was  the official phpadmin docker from dockerhub. 

Share this post


Link to post

Hi Squid..  Thanks again for all of your efforts!

 

Just wanted to give you the heads up, some of my Docker's were uninstalled this morning shortly after the auto-update. Of course all it took was to reinstall them, but i wanted to let you know.  See the attachment from my log file for more details.

I had a docker uninstall after an auto update.  It was  the official phpadmin docker from dockerhub. 

I know....  Why I pumped out an update (2016.11.28b) to prevent the docker updates from running on 6.2.4.  The issue has been identified and fixed.  Just needs to be tested with the co-operation of lsio.

 

Issue was a very minor difference in the operation of dockerMan on 6.2.4 vs 6.3 (Actually, a bug fix that was implemented on 6.2.0, but the fix didn't make it into dockerMan on the 6.2 series, but was subsequently added to 6.3.x)

Share this post


Link to post

I'm getting emails from what looks like the CA Application  Auto Update:

 

Subject: cron for user root /usr/local/emhttp/plugins/ca.update.applications/scripts/updateApplications.php >dev/null 2>&1

 

Body: /bin/sh: dev/null: No such file or directory

 

I've never ... done anything to this plugin, not sure what I should do with this?

Share this post


Link to post

I've been getting this message in my syslog at midnight since the 2016.11.27 update:

 

Nov 29 00:00:01 Northolt crond[1551]: exit status 1 from user root /usr/local/emhttp/plugins/ca.update.applications/scripts/updateApplications.php >dev/null 2>&1

Nov 29 00:00:01 Northolt sSMTP[36811]: Creating SSL connection to host

Nov 29 00:00:01 Northolt sSMTP[36811]: SSL connection using ECDHE-RSA-AES128-GCM-SHA256

Nov 29 00:00:01 Northolt sSMTP[36811]: Authorization failed (535 5.7.8  https://support.google.com/mail/?p=BadCredentials n17sm64923259wjq.6 - gsmtp)

 

I don't have email notifications enabled so I'm wondering if it's related to the problem dlandon mentioned above.

 

EDIT: I've just noticed that there's a new (2016.11.28) version. I'll update and see if it goes away.

It won't  Just change any setting on the plugin settings to fix.

 

That worked for me. Thanks.

 

Share this post


Link to post

I'm getting emails from what looks like the CA Application  Auto Update:

 

Subject: cron for user root /usr/local/emhttp/plugins/ca.update.applications/scripts/updateApplications.php >dev/null 2>&1

 

Body: /bin/sh: dev/null: No such file or directory

 

I've never ... done anything to this plugin, not sure what I should do with this?

 

Has anyone come across this?

 

index.php?action=dlattach;topic=53693.0;attach=39036;image

Screen_Shot_2016-12-02_at_12_02.21_AM.png.8f47e5d943d07ea280ff0daec110b911.png

Share this post


Link to post

I'm getting emails from what looks like the CA Application  Auto Update:

 

Subject: cron for user root /usr/local/emhttp/plugins/ca.update.applications/scripts/updateApplications.php >dev/null 2>&1

 

Body: /bin/sh: dev/null: No such file or directory

 

I've never ... done anything to this plugin, not sure what I should do with this?

 

Has anyone come across this?

 

I think everyone was hoping you would think to look back a few days!  ;)  You know you really should read a little bit before posting.

Share this post


Link to post

I'm getting emails from what looks like the CA Application  Auto Update:

 

Subject: cron for user root /usr/local/emhttp/plugins/ca.update.applications/scripts/updateApplications.php >dev/null 2>&1

 

Body: /bin/sh: dev/null: No such file or directory

 

I've never ... done anything to this plugin, not sure what I should do with this?

 

Has anyone come across this?

 

I think everyone was hoping you would think to look back a few days!  ;)  You know you really should read a little bit before posting.

See search tips in my sig

Share this post


Link to post

Hi Squid..  Thanks again for all of your efforts!

 

Just wanted to give you the heads up, some of my Docker's were uninstalled this morning shortly after the auto-update. Of course all it took was to reinstall them, but i wanted to let you know.  See the attachment from my log file for more details.

I had a docker uninstall after an auto update.  It was  the official phpadmin docker from dockerhub. 

I know....  Why I pumped out an update (2016.11.28b) to prevent the docker updates from running on 6.2.4.  The issue has been identified and fixed.  Just needs to be tested with the co-operation of lsio.

 

Issue was a very minor difference in the operation of dockerMan on 6.2.4 vs 6.3 (Actually, a bug fix that was implemented on 6.2.0, but the fix didn't make it into dockerMan on the 6.2 series, but was subsequently added to 6.3.x)

 

Hey together,

 

I've still having this issue on 6.3 RC5.

Or i understand something wrong?

Share this post


Link to post

Works 100% for me.  Just check for updates and had the plugin update all of lsio weekly updates with no issue at all.  What exactly are you seeing

 

Sent from my SM-T560NU using Tapatalk

 

 

Share this post


Link to post

Works 100% for me.  Just check for updates and had the plugin update all of lsio weekly updates with no issue at all.  What exactly are you seeing

 

Sent from my SM-T560NU using Tapatalk

 

Worked perfectly for me too.  ;)

Share this post


Link to post

Coming here to pile on and say that auto update of docker apps worked great.  Now I have peace of mind that my app data and flash will be backed up every Saturday morning at 4 am, and I don't have to worry about updating Dockers anymore.  THANKS!

Share this post


Link to post

I don't know if you've already addressed this, but I got this email last night:

From: Console and webGui login account
Date: November 28, 2016 at 12:00:01 AM EST
To: root
Subject: cron for user root /usr/local/emhttp/plugins/ca.update.applications/scripts/updateApplications.php >dev/null 2>&1

/bin/sh: dev/null: No such file or directory

 

Already done

 

Sent from my LG-D852 using Tapatalk

 

Thank you.

Except the fix is in the .plg file and won't change anything for people who already had that installed (since its part of the one-time conversion from the old version of the plg to the new).  You just have to make a change (any change) on the plugin settings schedule.

 

Where am I suppose to make this change?  I've tried the Community Applications Auto Update Settings, Community Applications General Settings, and Scheduler but still receive the email.  TIA

Share this post


Link to post

Where am I suppose to make this change?  I've tried the Community Applications Auto Update Settings, Community Applications General Settings, and Scheduler but still receive the email.  TIA

Community Applications Auto Update, Plugin Section.  Make a change to the schedule, any change and apply it.  Problem will disappear

Share this post


Link to post

Where am I suppose to make this change?  I've tried the Community Applications Auto Update Settings, Community Applications General Settings, and Scheduler but still receive the email.  TIA

Community Applications Auto Update, Plugin Section.  Make a change to the schedule, any change and apply it.  Problem will disappear

 

I'm also suffering from this annoying email - and no matter what setting I change in the Auto Update section the updateApplications.sh file is *NOT* being created so I continue to receive the emails..  I've changed settings in each of the 4 sections (the Plugin Schedule part, the list of plugins, the Docker Schedule and the list of Dockers) - applying in between each one..

 

I have an updatePLG.sh but not updateApplications.sh in/usr/local/emhttp/plugins/community.applications/scripts ...

 

 

Share this post


Link to post

I fixed it by changing the email time from 12 to 1am.

 

Tried that - still no file being created.

 

 

Share this post


Link to post

Make sure both CA and CA Auto update are up to date.  If that doesn't fix it, then a reboot should after the updates

 

Not quite sure why you're still seeing that reference to Community Applications, unless there was a glitch on the server when the initial install of CA Auto update happened.

Share this post


Link to post

I was in the same boat, still getting the emails. I have restarted the server and will report back (if I remember) if I dont get an email :)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now