Jump to content
linuxserver.io

[Support] Linuxserver.io - Libresonic

16 posts in this topic Last Reply

Recommended Posts

linuxserver_medium.png

 

Application Name: Libresonic

Application Site: https://github.com/Libresonic/libresonic

Docker Hub: https://hub.docker.com/r/linuxserver/libresonic/

Github: https://github.com/linuxserver/docker-libresonic

 

Please post any questions/issues relating to this docker you have in this thread.

 

If you are not using Unraid (and you should be!) then please do not post here, instead head to linuxserver.io to see how to get support.

Edited by linuxserver.io

Share this post


Link to post

Hi,

 

I have successfully installed the LibreSonic Docker and so far it is working fine. 

 

Unfortunatley I am not able to get the DLNA-Server running, or at least my DLNA-Devices are not able to find the Server. 

I just enabled the checkbox for the Server. Do I also need to enter something in the LINK-Option?

 

 

libresonic.JPG

Share this post


Link to post

I don't think LibreSonic is dead, but yes it has been forked as AirSonic.

Sent from my LG-H815 using Tapatalk

Share this post


Link to post

Makes sense..

So if it seems as if AirSonic has more active development, do you feel LSIO will release and maintain a Docker for it? This is all preliminary, I get it, just had no idea of friction between devs, or AirSonic existing. 

Share this post


Link to post

just tried to update and it failed since the unraid 6.5.1 update this docker has been failing to update and self-destructed as a result

Share this post


Link to post
still fails to install on unraid 6.5.2
FWIW I'd recommend airsonic. But I can take a look see if I can reproduce this if you're set on sticking to libresonic. We may drop this container in the future in favour of airsonic though and without docker run command or logs it's difficult to help you.

Share this post


Link to post

Sorry in advance for a noob question... 

 

Is there a version of support for secure connections for libresonic.  I love this app, but the fact that it isn't secure concerns me.  Some friends suggested that I just use Organizr and access it via that to get my secure connection, which works for browser devices, but I am really attached to the subsonic app on my phone.  Not thinking that will work with Organizr and the app.

 

First to admit I am not strong in the networking aspect of unraid, so sorry if there was an easy solution, just couldn't find it on the project sites, reddit or this forum.

Share this post


Link to post

Take a look at my post above, and secondly, put it behind a reverse proxy. Although I'm not entirely clear what you mean by not secure....

Sent from my Mi A1 using Tapatalk

Share this post


Link to post

Working fine on 6.6.3.

 

Although I am struggling with this docker periodically spinning up discs every 20 or 40 mins - despite no file access requests coming from any client anywhere.

 

I've been testing all weekend on this. It's definitely this libresonic docker initiating the spin ups.

 

appdata is 100% on cache drive.

 

Shares are all set to use cache.

 

Directories are supposedly cached with the Dynamix Cache Directories plugin.

 

No other plugins, dockers, clients or cron jobs are initiating the spin ups.

 

I've been searching for a way to instruct Libresonic not to poll discs - nothing so far.

 

FWIW, Airsonic does the same thing. 

 

Ideas for a solution will be highly appreciated.

 

 

Share this post


Link to post

God, I hate libresonic.   

Everytime I update this docker I have to hold my breath that it does not break.

Unfortunatley I did an update and it broke.  Anyone else using this docker with the same problem? 

Share this post


Link to post
4 hours ago, eds said:

God, I hate libresonic.   

Everytime I update this docker I have to hold my breath that it does not break.

Unfortunatley I did an update and it broke.  Anyone else using this docker with the same problem? 

You need to be more specific than that if you want help. 

Share this post


Link to post

Sorry about that, you're right. 

 

Just frustrated, I like this program, but each time I do an update I have to hold my breath that it does not break.

 

I'm getting the classic "this site can't be reached. <IP ADDRESS>  refused to connect" when click the webui launcher.

 

The ip I have is  192.168.0.132:4040.  

 

I've attached a log.  Any help would be appreciated. 

libresonic.log

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.