Jump to content
linuxserver.io

[Support] Linuxserver.io - DuckDNS

68 posts in this topic Last Reply

Recommended Posts

2 minutes ago, aptalca said:

 

No, the container doesn't need any ports mapped because there are no incoming connections to this container. 

 

You can just set networking mode to bridge and not map any ports

Ok.  I'll change to bridge mode.  There were no pre-set options in the container for paths, etc.  I wasn't sure if you meant that I should be adding them.  Some containers that have paths specified, I've also been able to specify additional paths for other purposes.  For example in Plex specifying a path for movies.  Then creating another for tv shows.  Thanks for your help.

Edited by DoItMyselfToo

Share this post


Link to post
1 hour ago, DoItMyselfToo said:

Ok.  I'll change to bridge mode.  There were no pre-set options in the container for paths, etc.  I wasn't sure if you meant that I should be adding them.  Some containers that have paths specified, I've also been able to specify additional paths for other purposes.  For example in Plex specifying a path for movies.  Then creating another for tv shows.  Thanks for your help.

 

Nope, no paths needed either. Just supply the subdomain and the token as environment variables and that's it

Share this post


Link to post

I set up 2 new subdomains at duckdns and manually set the IPs to 127.0.0.1 for testing.

 

I installed the docker on my backup machine, gave it 10 minutes and nothing changed (even after a logout/login at duckdns). I restarted the docker and it updated the IP immediately. I set it back to 127.0.0.1, waited 5 minutes and it updated to the correct IP again.

 

Installed it on my primary server, did the same IP test and it updated correctly the first time.

 

Now I just need to advertise the new domain to everyone who's accessing my server and away I go. no more changeip.com or their Homing Beacon app running on my Win10 machine.

 

Thanks to LSIO for another great docker.

Share this post


Link to post

Hi,

 

is it possible duckdns point vpn ip (via privoxy) instead isp ip?

Share this post


Link to post
32 minutes ago, garion said:

Hi,

 

is it possible duckdns point vpn ip (via privoxy) instead isp ip?

Why would you want to do that?

Share this post


Link to post
3 minutes ago, jonathanm said:

Why would you want to do that?

Forget it. It was a silly question because vpn has no full portfordwarding so it can’t work.

 

the idea was act as a filter. I have a calibre web in unraid and sometimes I connect in unprotected public WiFi’s via duckdns subdomain.

 

I know I can install an OpenVPN server in unraid and connect with my phone to my internal  unraid ip + calibre port (and deleting virtual server port fordward in the router).

 

maybe there is another way to increase security. I have read some about nginx as reverse proxy but not sure if it’s the right way.

Share this post


Link to post
15 minutes ago, garion said:

Forget it. It was a silly question because vpn has no full portfordwarding so it can’t work.

 

the idea was act as a filter. I have a calibre web in unraid and sometimes I connect in unprotected public WiFi’s via duckdns subdomain.

 

I know I can install an OpenVPN server in unraid and connect with my phone to my internal  unraid ip + calibre port (and deleting virtual server port fordward in the router).

 

maybe there is another way to increase security. I have read some about nginx as reverse proxy but not sure if it’s the right way.

Nginx reverse proxy is the right way for that. Check out the letsencrypt image. It works with duckdns

  • Like 1

Share this post


Link to post

Hi 

 

I'm having issue updating my ip with this docker.

 

Duckdns manually set to 192.0.2.1 to verify function.

Docker freshly installed via CA.

 

Docker does run but it never updates the IP.

Previous posts speak about a log, where can i find that?

Main server logs shows nothing related.

 

Consoling into the docker and running /app/duck.sh returns the following:

/app/duck.conf: line 1: <mytoken>: command not found
Something went wrong, please check your settings  Sun Nov 25 22:11:28 CET 2018

Running the command in duck.sh manually does return OK and correctly updates the IP.

 curl -s "https://www.duckdns.org/update?domains=<mydomain>&token=<mytoken>&ip="

duck.sh

#!/usr/bin/with-contenv bash

. /app/duck.conf
RESPONSE=`curl -s "https://www.duckdns.org/update?domains=$SUBDOMAINS&token=$TOKEN&ip="`
if [ "$RESPONSE" = "OK" ]; then
echo "Your IP was updated at "$(date)
else
echo "Something went wrong, please check your settings  "$(date)
fi

 

What am I missing?

Any suggestions @aptalca?

 

Thanks!

/Zoc

Edited by Zoc

Share this post


Link to post
52 minutes ago, Zoc said:

Duckdns manually set to 192.0.2.1 to verify function.

What does that mean? Did you set it on the duckdns website? 

 

Check the container log. What does that say? 

Share this post


Link to post
On 11/25/2018 at 11:22 PM, aptalca said:

What does that mean? Did you set it on the duckdns website? 

 

Check the container log. What does that say? 

Hi @aptalca

 

Yes, it means I manually set the IP on duckdns.org to track when it actually updates.

 

The log is full of the same error message:

/app/duck.conf: line 1: <mytoken>: command not found
Something went wrong, please check your settings  Wed Nov 28 20:05:00 CET 2018
/app/duck.conf: line 1: <mytoken>: command not found
Something went wrong, please check your settings  Wed Nov 28 20:10:00 CET 2018

(docker logs duckdns)

 

/Zoc

Share this post


Link to post
1 hour ago, Zoc said:

Hi @aptalca

 

Yes, it means I manually set the IP on duckdns.org to track when it actually updates.

 

The log is full of the same error message:


/app/duck.conf: line 1: <mytoken>: command not found
Something went wrong, please check your settings  Wed Nov 28 20:05:00 CET 2018
/app/duck.conf: line 1: <mytoken>: command not found
Something went wrong, please check your settings  Wed Nov 28 20:10:00 CET 2018

(docker logs duckdns)

 

/Zoc

It sounds like your duckdns.conf is messed up somehow. It is only supposed to contain two lines, and two items each, separated by an equal sign, no spaces. Check to see if it's the correct format. You can also pm me the contents (I believe duckdns lets you recreate the token) 

 

Also, are there any special characters in your token other than hyphen? 

  • Upvote 1

Share this post


Link to post

There we have it!

 

There was somehow a space introduced in the beginning of the token when the container was installed.

This then apparently followed me around when i reinstalled.

 

Sometimes the simple things..

 

Thanks @aptalca!

Share this post


Link to post
9 hours ago, Zoc said:

There we have it!

 

There was somehow a space introduced in the beginning of the token when the container was installed.

This then apparently followed me around when i reinstalled.

 

Sometimes the simple things..

 

Thanks @aptalca!

Glad to hear it works now

Share this post


Link to post

Hi, I set up the container and the IPv4 update works perfectly and I can reach nextcloud no problem at all. But it seems that in the default configuration my IPv6 is not updated. Is there a way to update the IPv6 as well?

Share this post


Link to post
10 hours ago, Cathnan said:

Hi, I set up the container and the IPv4 update works perfectly and I can reach nextcloud no problem at all. But it seems that in the default configuration my IPv6 is not updated. Is there a way to update the IPv6 as well?

 

Ipv6 is not supported in this image

Share this post


Link to post

my duckdns IP is being updated with my docker networking address as opposed to my ethernet card's DHCP assigned IP address.  

 

 

Share this post


Link to post
7 hours ago, Horyd said:

my duckdns IP is being updated with my docker networking address as opposed to my ethernet card's DHCP assigned IP address.  

 

 

Post a screenshot of your settings

Share this post


Link to post
On 11/29/2018 at 7:34 AM, Zoc said:

There we have it!

 

There was somehow a space introduced in the beginning of the token when the container was installed.

This then apparently followed me around when i reinstalled.

 

Sometimes the simple things..

 

Thanks @aptalca!

If you copy and paste the token from duckdns it has a space in front of it. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now