Jump to content
rpowers

Nightly email error

8 posts in this topic Last Reply

Recommended Posts

Hi Everyone,

 

I've been getting a nightly error email and I don't know what it means or how to fix.  Can someone help?

 

cron for user root /usr/local/emhttp/plugins/ca.update.applications/scripts/updateApplications.php >dev/null 2>&1/bin/sh: dev/null: No such file or directory

 

Thanks in advace,

 

Ryan

 

Share this post


Link to post

Change a setting any setting in auto update settings (plugins)

 

Sent from my LG-D852 using Tapatalk

 

Share this post


Link to post

I have this problem as well.

 

I don't know when it started, but it has been about a couple of weeks-ish.

 

I do see a

"Warning: Invalid argument supplied for foreach() in /usr/local/emhttp/plugins/ca.update.applications/include/exec.php on line 100"

on the CA Plugin Auto Update Settings page.

 

I included a screen shot so you can see my options.

error.jpg.aa29e0c99acaf2ca949c08ee90a63649.jpg

Share this post


Link to post

Well, you found a bug in there that I've got to figure out why its showing up  (best guess is that you have docker enabled, but don't have any containers installed)

 

But to fix the cron email, change any setting on the plugin page (ie: up the time by one minute) and apply

Share this post


Link to post

I think doing the update fixed the error message on the setting screen.  Also I have a 13 dockers (11 running).

 

I changed the scheduled times for docker/plugin updates so I can see which one is giving me the error.  With my luck the process of trying to diagnose it will fix the issue.  (I hate that when that happens)

Share this post


Link to post

I changed the scheduled times for docker/plugin updates so I can see which one is giving me the error.  With my luck the process of trying to diagnose it will fix the issue.  (I hate that when that happens)

The spurious email error is from the plugin settings, and is a simple typo on my part that on new installations (ie: remove and reinstall) is fixed.  For existing installations, a setting change will also fix it.

 

TBH, I didn't anticipate the number of people who would be seeing this, as I expected most people to automatically go and adjust the plugin update time right away, so I never added into the code for the .plg file to outright look for installations that have that typo present and then fix it -> lol  PITA for a one off fix  But with the continuing posts about this, I may reconsider it.

 

This slipped through my testing, as all I was really looking for was that on the update from Community Applications having this module built in to it to this where the modules are all separate was to make sure that the cron job was indeed being created, and CA proper wouldn't have any references to the cron job itself.  I never noticed that I missed a "/" on the initial cron job (as first thing I do is change the default time to something more suitable for my own purposes).

 

tldr:  My Bad  It's all my fault  :'(

Share this post


Link to post

Where's pluginCop and Docker Police when you need them?!?      ;)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.