[Support] Linuxserver.io - Booksonic


Recommended Posts

8 hours ago, huladaddy said:

I can't seem to get booksonic-air working behind a nginx reverse proxy. I am using a .conf modeled after the airsonic .conf that is working fine for me. I just get a 502 Bad Gateway.

 

this is what i'm using with air

 

# make sure that your dns has a cname set for booksonic and that your booksonic container is not using a base url

server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name booksonic.*;

    include /config/nginx/ssl.conf;

        client_max_body_size 0;

    location / {
        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_booksonic booksonic-air;
        proxy_pass http://$upstream_booksonic:4040;
    }
}

 

 

Link to comment

Virtually the same as I am using. I can get there locally without going through the reverse proxy. What am I missing?

 

# make sure that your dns has a cname set for booksonic and that your booksonic container is not using a base url

server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name audiobooks.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    # enable for ldap auth, fill in ldap details in ldap.conf
    #include /config/nginx/ldap.conf;

    # enable for Authelia
    #include /config/nginx/authelia-server.conf;

    location / {
        # enable the next two lines for http auth
        #auth_basic "Restricted";
        #auth_basic_user_file /config/nginx/.htpasswd;

        # enable the next two lines for ldap auth
        #auth_request /auth;
        #error_page 401 =200 /ldaplogin;

        # enable for Authelia
        #include /config/nginx/authelia-location.conf;

        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_app booksonic-air;
        set $upstream_port 4040;
        set $upstream_proto http;
        proxy_pass $upstream_proto://$upstream_app:$upstream_port;

    }
}

 

I figured this out. Had Network Type set to Bridge instead of Custom: proxynet

Edited by huladaddy
update
Link to comment
  • 4 months later...

I can't get http or https to work.  I can not figure out how to configurre NGINX with a docker variable CONTEST_PATH

 

1508408453_ScreenShot2021-06-12at10_00_12AM.png.9ba96e60d6ba657afb3e3b6183c778c1.png

 

with Context_Path booksonic = http://sub.dommain.com:4040/booksonic - I can't configure Nginx with a sub after port.

w/o Context_Path = http://sub.domain.com:4040 - this works but then settings and other menus can not be accessed.

 

239082962_ScreenShot2021-06-12at9_50_11AM.png.53418a54bdd355da1e9d5816da736d89.png

 

- Router is port forwarded to 4040

- Latest version of Unraid | ROG CROSSHAIR VIII HERO (WI-FI) | AMD Ryzen 9 3900X 12-Core @ 3800 MHz

- NO-IP subdomain = audio and DNS pointing to domain.com.

 

The URL is http://10.10.1.5:4040/booksonic/ - HOW do I configure this in Nginx, I can not figure it out.  With the variable everything works but I get BAD GATEWAY when accessing it with my domain.

 

 

Link to comment
36 minutes ago, Mystic said:

I can't get http or https to work.  I can not figure out how to configurre NGINX with a docker variable CONTEST_PATH

 

1508408453_ScreenShot2021-06-12at10_00_12AM.png.9ba96e60d6ba657afb3e3b6183c778c1.png

 

with Context_Path booksonic = http://sub.dommain.com:4040/booksonic - I can't configure Nginx with a sub after port.

w/o Context_Path = http://sub.domain.com:4040 - this works but then settings and other menus can not be accessed.

 

239082962_ScreenShot2021-06-12at9_50_11AM.png.53418a54bdd355da1e9d5816da736d89.png

 

- Router is port forwarded to 4040

- Latest version of Unraid | ROG CROSSHAIR VIII HERO (WI-FI) | AMD Ryzen 9 3900X 12-Core @ 3800 MHz

- NO-IP subdomain = audio and DNS pointing to domain.com.

 

The URL is http://10.10.1.5:4040/booksonic/ - HOW do I configure this in Nginx, I can not figure it out.  With the variable everything works but I get BAD GATEWAY when accessing it with my domain.

 

 

You don't use context path for subdomain. It's only for subfolder.

Link to comment

Thanks for the response and confirmation of what I figured....  Now the challenge is why Booksonic will not permit access to any settings features. 

 

When I remove the context path from the docker and log in.  As the admin, I get the following:

  1. Login from docker app the URL consist of the http://ip:port and everything works...  Click on setting and I can configure.
  2. Login from my domain the URL is http://sub.domain.com:port and when I click on setting, nothing happens.

 

Any Idea's?

Edited by Mystic
Link to comment
1 hour ago, Mystic said:

Thanks for the response and confirmation of what I figured....  Now the challenge is why Booksonic will not permit access to any settings features. 

 

When I remove the context path from the docker and log in.  As the admin, I get the following:

  1. Login from docker app the URL consist of the http://ip:port and everything works...  Click on setting and I can configure.
  2. Login from my domain the URL is http://sub.domain.com:port and when I click on setting, nothing happens.

 

Any Idea's?

Why are you using the port when using your domain? You are reverse proxying it, right?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.