How do you enable NFSv4 on v6.2.4


atom

14 posts in this topic Last Reply

Recommended Posts

I'm running unRAID v6.2.4 and trying to mount a share via NFSv4 from a linux client but it doesn't seem to be enabled/supported.

 

# mount -t nfs4 nas:/mnt/disk1 /mnt/disk1
mount.nfs4: Protocol not supported

# rpcinfo -s nas
   program version(s) netid(s)                         service     owner
    100000  2,3,4     local,udp,tcp                    portmapper  superuser
    100024  1         tcp,udp                          status      32
    100003  3         udp,tcp                          nfs         superuser
    100021  4,3,1     tcp,udp                          nlockmgr    superuser
    100005  3,2,1     tcp,udp                          mountd      superuser

 

EDIT: So it looks like NFSv4 requires a bit of work to be functional on Slackware.

http://www.linuxquestions.org/questions/slackware-14/does-slackware-14-1-or-current-have-nfsv4-support-4175550162/

 

Assuming that's correct, can a mod/dev look into this? Or correct me in the event I'm wrong.

Link to post
  • 2 weeks later...
  • 9 months later...
  • 3 months later...
  • 1 year later...
  • 4 weeks later...

Hi,

 

I installed a NFS-Ganesha container and can now provide NFS4. Technically it works and it solved the issues I had with NFS3. Nevertheless, it is a bolt-on, which is a work-around for something which should be provided by Unraid in the first place.

 

I can see that there is a lot of work going into Unraid and I really appreciate all the new ideas and fixes being rolled out in a comparably high-frequent manner. I'm glad I came across it months ago and I think it is a very competitive NAS OS. If it wasn't that, I wouldn't use it. It would be good to see NFS4 natively in Unraid one day, so that this 100MB bolt-on work-around container can go, eventually.

 

Regards

 

Carsten

Link to post
  • 2 weeks later...

This definitely needs to happen. It has been promised for over 3 years. Or, at least, the Doc needs to be changed to reflect that we still only have NFSv3 and NFSv4 cannot be enabled. I tried to edit the wiki, but I don't have permissions.

 

buzz

Link to post
On 12/13/2019 at 8:02 AM, DerCarsten said:

I installed a NFS-Ganesha container and can now provide NFS4.

Hey. Could you provide some information on how you set this up? Do you disable NFS sharing on Unraid and instead have it be done via the container?

Link to post

Hi Khadgar,

 

no, I kept the native Unraid NFS v3 share untouched.

 

I've installed the container with a custom Network Type (Custom: eth0) and set a Fixed IP address in the Unraid GUI. The new address must not be used by any other device in your subnet. The one I used is outside the DHCP range of the DHCP server, so collisions later on will be avoided.

 

Regards

 

Carsten

grafik.png

Link to post
  • 11 months later...
  • 2 weeks later...
  • 3 months later...
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.