[Support] Linuxserver.io - Ombi


570 posts in this topic Last Reply

Recommended Posts

It will require a new configuration, however you can use your existing appdata folder as the data for the different versions will not overwrite one another.

Therefore you can upgrade/downgrade by tagging the release you use is the current plan, but I don't think we've finalised anything quite yet.

Sent from my LG-H815 using Tapatalk

Link to post
  • Replies 569
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

That 'asshole' would be me.        Please keep in mind that I have a full time demanding job, a child, a 10 month old and a wife outside of what I do in ombi. All of my free time i

Ran into this too and it looks like this is the issue. Look at my post there (currently the last one) for a fix you can do without having to install anything into your container. It looks like they ad

Application Name: Ombi Application Site: https://ombi.io Docker Hub: https://hub.docker.com/r/linuxserver/ombi/ Github: https://github.com/linuxserver/docker-ombi   Please

Posted Images

15 minutes ago, Nem said:

any idea when the template on the community applications page will be updated? It still seems to install v2

 

Template will pull latest.  Have you checked for container updates?

Link to post
17 minutes ago, Negatron said:

If we upgrade to this new version, will all of our existing requests still be there? Or do those all get lost?

The answer is 2 posts above your post.  Support threads can be read as well as posted in. ;)

It needs a new config.  Records of requests will be lost from Ombi, but will still exist in Radarr/Sonarr etc

Edited by CHBMB
Link to post

I upgraded to V3 and its much faster and the settings page is improved for sure.  However I'm using the lets encrypt docker as a reverse proxy and now I'm just getting a page that says Loading.... with external access.  I've got the base url in there and haven't changed any ngix settings.  Any ideas?

Edited by esk1
Link to post

@aptalca  - I saw your comment on the .dotnet issue over at github https://github.com/tidusjar/Ombi/issues/1650#issuecomment-341549757

 

I'm still having issues with my plex server w/SSL.  When I try to load the libraries I get:

Access to the path '/root/.dotnet/corefx/cryptography/x509stores/ca' is denied. - Permission denied

Here's some of the log, let me know if you need more:

Error thrown when attempting to obtain the plex libs
System.UnauthorizedAccessException: Access to the path '/root/.dotnet/corefx/cryptography/x509stores/ca' is denied. ---> System.IO.IOException: Permission denied
--- End of inner exception stack trace ---
at System.IO.UnixFileSystem.CreateDirectory(String fullPath)
at System.IO.Directory.CreateDirectory(String path)
at Internal.Cryptography.Pal.DirectoryBasedStoreProvider.Add(ICertificatePal certPal)
at System.Security.Cryptography.X509Certificates.X509Store.Add(X509Certificate2 certificate)
at Internal.Cryptography.Pal.ChainPal.SaveIntermediateCertificates(X509ChainElement[] chainElements, HashSet`1 downloaded)
at Internal.Cryptography.Pal.ChainPal.BuildChain(Boolean useMachineContext, ICertificatePal cert, X509Certificate2Collection extraStore, OidCollection applicationPolicy, OidCollection certificatePolicy, X509RevocationMode revocationMode, X509RevocationFlag revocationFlag, DateTime verificationTime, TimeSpan timeout)
at System.Security.Cryptography.X509Certificates.X509Chain.Build(X509Certificate2 certificate, Boolean throwOnException)
at System.Security.Cryptography.X509Certificates.X509Chain.Build(X509Certificate2 certificate)
at System.Net.Security.CertificateValidation.BuildChainAndVerifyProperties(X509Chain chain, X509Certificate2 remoteCertificate, Boolean checkCertName, String hostName)
at System.Net.Http.CurlHandler.SslProvider.VerifyCertChain(SafeX509StoreCtxHandle storeCtx, EasyRequest easy)
at System.Net.Http.CurlHandler.SslProvider.VerifyCertChain(IntPtr storeCtxPtr, IntPtr curlPtr)
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1.ConfiguredTaskAwaiter.GetResult()
at System.Net.Http.HttpClient.<FinishSendAsyncBuffered>d__58.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Ombi.Api.OmbiHttpClient.<SendAsync>d__5.MoveNext() in C:\projects\requestplex\src\Ombi.Api\OmbiHttpClient.cs:line 61
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Ombi.Api.Api.<Request>d__6`1.MoveNext() in C:\projects\requestplex\src\Ombi.Api\Api.cs:line 34
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Ombi.Api.Plex.PlexApi.<GetLibrarySections>d__12.MoveNext() in C:\projects\requestplex\src\Ombi.Api.Plex\PlexApi.cs:line 74
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Ombi.Controllers.External.PlexController.<GetPlexLibraries>d__9.MoveNext() in C:\projects\requestplex\src\Ombi\Controllers\External\PlexController.cs:line 105

 

I've created an issue on the ombi github page:  https://github.com/tidusjar/Ombi/issues/2046

Edited by Dephcon
Link to post
19 hours ago, aptalca said:

Put this in right underneath the location block but outside of it :

 


if ($http_referer ~* /ombi/) {
        rewrite ^/dist/(.*) $scheme://$host/ombi/dist/$1 permanent;
}

I was having this issue and used the code mentioned and now although it seems to load it never shows anything other than a grey screen. Just FYI

 

    location /ombi {
        include /config/nginx/proxy.conf;
        proxy_pass http://192.168.1.18:3579/ombi;
    }
    
    if ($http_referer ~* /ombi/) {
        rewrite ^/dist/(.*) $scheme://$host/ombi/dist/$1 permanent;
    }

 

Is that correctly used in the letsencrypt config?

Edited by tazire
Link to post

I have not used Ombi in some time.  Since the last time I used it I can assume there have been update and I and all other users are no longer able to login.  I guess it upgraded to v3.  So how do I get back into Ombi?  I have tried everything and every password and nothing.

Link to post
I was having this issue and used the code mentioned and now although it seems to load it never shows anything other than a grey screen. Just FYI
 
    location /ombi {
        include /config/nginx/proxy.conf;
        proxy_pass http://192.168.1.18:3579/ombi;
    }
    
    if ($http_referer ~* /ombi/) {
        rewrite ^/dist/(.*) $scheme://$host/ombi/dist/$1 permanent;
    }
 
Is that correctly used in the letsencrypt config?
No, they should all be in the same code block contained by { }

You have extra brackets.

Sent from my LG-H815 using Tapatalk

Link to post
I have not used Ombi in some time.  Since the last time I used it I can assume there have been update and I and all other users are no longer able to login.  I guess it upgraded to v3.  So how do I get back into Ombi?  I have tried everything and every password and nothing.
With V3 you need to do a fresh setup

Sent from my LG-H815 using Tapatalk

Link to post
1 minute ago, CHBMB said:

With V3 you need to do a fresh setup

Sent from my LG-H815 using Tapatalk
 

I uninstalled V2 and then installed V3 but it just brings me to the login screen.  Is there an initial default login?  Because none of my logins are working that once worked with V2.

Link to post
1 hour ago, NeoDude said:

I'm getting an error when attempting to import users from plex...

 


User name '' is invalid, can only contain letters or digits.

Any ideas?

 

That's a question for ombi devs

Link to post
On 3/7/2018 at 4:25 AM, damato300x7 said:

I uninstalled V2 and then installed V3 but it just brings me to the login screen.  Is there an initial default login?  Because none of my logins are working that once worked with V2.

Yeah, same for me. It's asking to log in but I can't find a default login anywhere. Tried the usuals.

Link to post
1 hour ago, bobbintb said:

Yeah, same for me. It's asking to log in but I can't find a default login anywhere. Tried the usuals.

 

when you first install v3, it should launch a wizard to set up the server and to create an admin account.  I dont believe theres a default admin account

 

I had a similar problem when I installed v3 - think there were some settings or cache that was retained from my previous v3-preview container. Try clearing your cache or reinstalling the container (manually delete the appdata config directory)

Link to post
8 hours ago, Lebowski said:

Anyone had any luck getting emby to work on v3? it connects and tests okay but it wont sync the library up.

 

Library syncs are on a timer via cron. You can also go to the media server settings and trigger a manual update

Link to post

If anyone else is forcing SSL on their Plex server(you should be  :ph34r:) you might run into some issues with v3.  There's a tentative fix for this on github, hopefully something can be done at the container level soon:

https://github.com/tidusjar/Ombi/issues/2046#issuecomment-370919536

 

docker exec -it ombi /bin/bash

chmod 755 /root -R
chgrp abc /root/.dotnet -R

 

Edited by Dephcon
Link to post
8 hours ago, aptalca said:

 

Library syncs are on a timer via cron. You can also go to the media server settings and trigger a manual update

seems to be doing nothing for me. I have been able to import users from Emby, Couch and Sonaar requests work fine, just wont sync library. 

Link to post
3 hours ago, rmilyard said:

I just installed Ombi v3.  I have it pretty much setup.  However is there any docs how to customize this?  Like mails etc.  How remove author donate link or change it?  My friends keep clicking wrong one.

 

That's not docker related. You should ask in ombi forum 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.