LSI SAS 2208 - Possible to use with unRAID?

Recommended Posts

I apologize if this a bit of a newb question, but I've been trying all night and still just can't seem to get things setup.


I have an Intel S2600GL 2U server. 12 SATA / SAS hot swap bays on the front, two internal SATA for SSD's, Dual Xeon E5 2670's (upgraded), 128GB of DDR3 ECC RAM (upgraded). Previously I was just running Windows Server 2016 to get things setup and start tinkering with. Recently discovered unRAID, really want to check it out as it sounds perfect for what I want to do.


I have 1 HGST Ultrastar 3TB Drives, 1 WD Green 3TB, and 1 Seagate 3TB drive - all almost full. I ordered 5 HGST Ultrastar 3TB Drives to expand upon and to do a proper unRAID install with. Plan to have Dual Parity drives, and 18TB of total usable space, with a few bays leftover for future expansion. As well as two SSD's - a 120GB cache drive, and one dedicated to Docker Apps / VM's.


Previously with just Windows Server, I had a single RAID0 Virtual drive for each of my three 3TB drives. Windows detected them all no problem.


However, with unRAID I cannot for the life of me get it to detect any of my drives, other than the two internal SSD's - so every drive connected to the backplane. Those drives go through a Intel RMS25CB080 hardware RAID card, which runs the LSI SAS 2208 chipset.


06:00.0 RAID bus controller [0104]: LSI Logic / Symbios Logic MegaRAID SAS 2208 [Thunderbolt] [1000:005b] (rev 05)
Subsystem: Intel Corporation RMS25CB080 RAID Controller [8086:3513]
09:00.0 Serial Attached SCSI controller [0107]: Intel Corporation C602 chipset 4-Port SATA Storage Control Unit [8086:1d6b] (rev 06)
Subsystem: Intel Corporation C602 chipset 4-Port SATA Storage Control Unit [8086:3583]
Kernel driver in use: isci
Kernel modules: isci


From what I can see after searching online, there is no "IT Mode" to flash for this chipset. According to Intel's own specifications, it supports a variety of RAID configs, but specifically not JBOD. However, you can manually enable JBOD mode through the CLI following this tutorial. Which I've done, everything executes sucessfully, and upon reboot it still doesn't detect the drives. So individual RAID0 virtual drives doesn't work, and neither does "JBOD pass through" from what I've tried. I have seemingly altered every possible setting in the RAID BIOS, and on the motherboard BIOS as well, all to no avail.


Is what I'm trying to accomplish even doing even possible? Has anybody had any luck with this card? Or should I just give up on using this controller and buy a normal HBA? If so, does anyone have any suggestions given my current hardware?


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.