Jump to content
linuxserver.io

[Support] Linuxserver.io - Radarr

468 posts in this topic Last Reply

Recommended Posts

8 hours ago, Rick Sanchez said:

Hosted? 

 

It's a brand new install.

 

I said hosed.....

 

If it's a brand new install, then just delete the appdata and start from scratch then.

Share this post


Link to post

Hi all,

New to unRAID and was fiddling around with it a bit today and had Radarr working but now it is 100% unreachable. I had it working with Jackett and Deluge, and downloaded a test file to see how it would work and everything was perfect. Then I went to open the WebUI just now and Google Chrome is giving me the "This site can’t be reached, 192.168.0.69 refused to connect."

 

Because it was just a new install and I didn't feel like troubleshooting I reinstalled it and the same thing is happening. Deluge and Jackett are working fine from linuxserver.io and the logs for Radarr don't show any errors or warnings, so I'm a bit stumped here.

 

Let me know if you need any more of my information to help troubleshoot.

 

Thanks!

radarrlog.txt

Edited by htpc1602

Share this post


Link to post

@htpc1602 You changed the port in the Radarr webui to 9797.  You should never do that, Leave it at 7878 and change the port mapping to 9797 if you need to change the port.

 

Delete all your appdata and try again

  • Upvote 1

Share this post


Link to post

I was confused because I have another instance of Radarr running on a different computer and I didn't want them to conflict (even though they were running on two different computers....don't try unRAID out for the first time at 2am - whoops!).

 

Following your instructions, I deleted Radarr, changed the appdata share for a minute so that I could see it in Windows, and deleted the Radarr folder. After reinstalling, Radarr had the same issue so I did the same steps but restarted the array after uninstalling Radarr and it worked!

Thanks for your help and instruction.

 

 

Share this post


Link to post

Finally, have a 'proper' error:

Import failed, path does not exist or is not accessible by Radarr: /downloads/movies/

 

But it is accessible?

 

/downloads = /mnt/cache/appdata/Downloads/complete/movies/

 

Share this post


Link to post
Finally, have a 'proper' error:
Import failed, path does not exist or is not accessible by Radarr: /downloads/movies/

 
But it is accessible?
 
/downloads = /mnt/cache/appdata/Downloads/complete/movies/
 

But what is the path mappings from your download client

Sent via Tapatalk because my wife thinks I spend too much time on the computer

Share this post


Link to post
19 hours ago, Squid said:

But what is the path mappings from your download client

Sent via Tapatalk because my wife thinks I spend too much time on the computer
 

 

/downloads = /mnt/cache/appdata/Downloads/complete/
 

Share this post


Link to post
19 hours ago, Rick Sanchez said:

/downloads = /mnt/cache/appdata/Downloads/complete/movies/

!=

12 minutes ago, Rick Sanchez said:

/downloads = /mnt/cache/appdata/Downloads/complete/

That's why. The two aren't the same.

Share this post


Link to post
10 hours ago, jonathanm said:

!=

That's why. The two aren't the same.

 

It's not that. It has to be that to function correctly.

 

This error has returned:

Task Error: database is locked

 

Sonarr reports:

 

 

[GET /api/log]: database is locked database is locked

 

 

Error occurred while executing task CheckForFinishedDownload: database is locked
database is locked

 

Edited by Rick Sanchez

Share this post


Link to post
On 7/18/2018 at 1:49 AM, Squid said:



Sent via Tapatalk because my wife thinks I spend too much time on the computer
 

 

Epic signature! ??

Share this post


Link to post

 

How we suggested you set up the mappings is correct and the only way to have it work properly.  THIS explains why

 

Database being locked I'd guess you may need to restart the appdata for sonarr over again, but you might get more ideas on sinarr project page.

 

Sent via Tapatalk because my wife thinks I spend too much time on the computer

 

 

 

 

Edited by Squid

Share this post


Link to post

Its worked for months without change. 

 

I've never had everything like:

 

SAB: /mnt/cache/appdata/downloads/complete/

Radarr: /mnt/cache/appdata/downloads/complete/

 

It's always been:

 

SAB: /mnt/cache/appdata/downloads/complete/

Radarr: /mnt/cache/appdata/downloads/complete/movies

 

 

Share this post


Link to post

Then you've been using the "blackhole" method in Radarr which is deprecated and no longer supported.  Setting the paths to match will allow Radarr & Sab to communicate via their API's

Share this post


Link to post

hi guys,

 

I'm getting really frustrated trying to sort an error, everything seems to be working fine, however, this error is always present no matter what i try.

 

 

screencapture-192-168-1-200-7878-radarr-system-status-2018-07-22-20_05_33.png

screencapture-b4fd9fb505226e1d2422be93a9c2f61cb5f9fe8a-unraid-net-Dashboard-UpdateContainer-2018-07-22-20_08_11.png

Share this post


Link to post

I never used it, but you have an error in your volume mapping for /media. I guess radarr is looking for a Movies folder inside /media, but you used /mnt/user/media/Movies as the host path. If you want the movies folder to be available in /media, you must change the host path to /mnt/user/media

Share this post


Link to post
On 7/20/2018 at 8:08 PM, Squid said:

Then you've been using the "blackhole" method in Radarr which is deprecated and no longer supported.  Setting the paths to match will allow Radarr & Sab to communicate via their API's

 

Worked for about an hour and now I'm getting the same error, on your recommend settings...

 

Import failed, path does not exist or is not accessible by Radarr: 

Share this post


Link to post
On 7/22/2018 at 8:08 PM, Greygoose said:

hi guys,

 

I'm getting really frustrated trying to sort an error, everything seems to be working fine, however, this error is always present no matter what i try.

 

 

screencapture-192-168-1-200-7878-radarr-system-status-2018-07-22-20_05_33.png

screencapture-b4fd9fb505226e1d2422be93a9c2f61cb5f9fe8a-unraid-net-Dashboard-UpdateContainer-2018-07-22-20_08_11.png

 

Did you use @binhex's version at some point?  he uses /media by default.

Share this post


Link to post
59 minutes ago, Rick Sanchez said:

 

Worked for about an hour and now I'm getting the same error, on your recommend settings...

 


Import failed, path does not exist or is not accessible by Radarr: 

 

Post your docker run commands for both containers and screenshots of your sabnzbd and radarr configurations.

Share this post


Link to post
12 minutes ago, CHBMB said:

 

Post your docker run commands for both containers and screenshots of your sabnzbd and radarr configurations.

image.thumb.png.b03521bbd51d5e8f44a0cfa5c09aa498.png

 

Sonarr

 

image.png.d2021f8ce027e4e1536fbd837dbb6082.png

 

image.thumb.png.c4218e914ebdd510270cac3d4e58908d.png

Radarr

 

image.png.a3ccaf4b899e3d3f0206f95a26a0f645.png

Edited by Rick Sanchez

Share this post


Link to post

What's the path that's not accessible to Radarr?

 

Share this post


Link to post

/downloads

 

It is not a continuous error. It seems to appear randomly and states it is not accessible.

Share this post


Link to post

New downloads or old ones already queued before you made the adjustments.

/downloads
 
It is not a continuous error. It seems to appear randomly and states it is not accessible.


Sent via Tapatalk because my laptop doesn't fit in my pocket

Share this post


Link to post
On 7/23/2018 at 10:28 PM, CHBMB said:

 

Did you use @binhex's version at some point?  he uses /media by default.

 

I did, I have changed my host path to the following but im still getting the error

 

 

screencapture-b4fd9fb505226e1d2422be93a9c2f61cb5f9fe8a-unraid-net-Dashboard-UpdateContainer-2018-07-31-18_31_05.png

Share this post


Link to post
3 hours ago, Greygoose said:

 

I did, I have changed my host path to the following but im still getting the error 

 

 

screencapture-b4fd9fb505226e1d2422be93a9c2f61cb5f9fe8a-unraid-net-Dashboard-UpdateContainer-2018-07-31-18_31_05.png

 

It's a remnant of that, no idea how to fix it, might be worth asking the Radarr guys.....

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now