[Support] Linuxserver.io - Radarr


Recommended Posts

On 11/9/2020 at 2:03 AM, NMGMarques said:

Oh, snap! I missed that. Thanks for pointing it out. However, I am now left with a different dilemma as I have no idea how to downgrade a docker container and the support page doesn't seem to mention how to downgrade. I'll keep googling for the answer. Much appreciated. 

 

EDIT: 

Should anyone else end up looking for the solution to downgrade, I found out you could add the desired version at the end of the repository field. Click on the desired docker container icon, click Edit, then in the Repository field replace the linuxserver/qbittorrent with:


linuxserver/qbittorrent:14.2.5.99202004250119-7015-2c65b79ubuntu18.04.1-ls93

Then hit apply. This will pull the desired 4.2.5 version.

Just to add to this. The latest versions of Sonarr/Radarr (v3) have fixed this issue.

Link to comment
  • 2 weeks later...
20 hours ago, L0rdRaiden said:

How can I fix this error?

More or less everything works fine, but I no longer see Radarr working automatically, I mean it don't upgrade or download wanted movies automatically unless I do it manually in the webui

Did you change the path in the docker template?

What is the path for all your movies in the Movie Editor?

Link to comment

So I've been mulling over the idea of jumping from 2 to 3 for a while now, but I decided not to pull the trigger because my setup was working well and I didn't have much time available to deal with it if things went awry. Today, I started to fix some pending issues I had, specifically creating a backup for my appdata and usb drives (which I still haven't been able to offload from the disk share to a usb or online storage since I can't get rclone running on my headless server).

 

But I digress. Thing is today, amidst whatever changes I made, though I am 90% sure I hadn't changed anything to the dockers, I notice Radarr has shifted to the preview version. It does seem to be working so it's not the worst of things, though the webui on mobile is atrocious. 

 

The thing is, now I kinda want to change over Sonarr as well. How do I do that? I don't even know what I did to change over Radarr. Can someone offer any insight?

Link to comment
6 hours ago, NMGMarques said:

So I've been mulling over the idea of jumping from 2 to 3 for a while now, but I decided not to pull the trigger because my setup was working well and I didn't have much time available to deal with it if things went awry. Today, I started to fix some pending issues I had, specifically creating a backup for my appdata and usb drives (which I still haven't been able to offload from the disk share to a usb or online storage since I can't get rclone running on my headless server).

 

But I digress. Thing is today, amidst whatever changes I made, though I am 90% sure I hadn't changed anything to the dockers, I notice Radarr has shifted to the preview version. It does seem to be working so it's not the worst of things, though the webui on mobile is atrocious. 

 

The thing is, now I kinda want to change over Sonarr as well. How do I do that? I don't even know what I did to change over Radarr. Can someone offer any insight?

Change your repository to:

linuxserver/sonarr:preview

 

Link to comment
9 hours ago, NMGMarques said:

So I've been mulling over the idea of jumping from 2 to 3 for a while now, but I decided not to pull the trigger because my setup was working well and I didn't have much time available to deal with it if things went awry. Today, I started to fix some pending issues I had, specifically creating a backup for my appdata and usb drives (which I still haven't been able to offload from the disk share to a usb or online storage since I can't get rclone running on my headless server).

 

But I digress. Thing is today, amidst whatever changes I made, though I am 90% sure I hadn't changed anything to the dockers, I notice Radarr has shifted to the preview version. It does seem to be working so it's not the worst of things, though the webui on mobile is atrocious. 

 

The thing is, now I kinda want to change over Sonarr as well. How do I do that? I don't even know what I did to change over Radarr. Can someone offer any insight?

Radarr switched to V3 because it's now official and the latest version https://github.com/Radarr/Radarr/releases

Link to comment
1 hour ago, Fatmonk8 said:

Anyone know why I am getting the following error even tho I am pretty sure I have the path in my container entered correctly?

 

770841320_Capture3.thumb.PNG.8cebcbab09b5ed7aaeff602a71560c3f.PNG

 

2063546998_Capture2.PNG.a5379da02a37893e7b962218a933f44d.PNG

Yes, the error message is correct. Both Radarr and Deluge need to have the same container path for downloads. Now Radarr have /downloads and Deluge have /data/completed. You have two options, either you change the container path for Deluge downloads to /downloads or you change Radarr container path from /downloads to /data/completed.

  • Like 1
Link to comment
21 minutes ago, Hogwind said:

Yes, the error message is correct. Both Radarr and Deluge need to have the same container path for downloads. Now Radarr have /downloads and Deluge have /data/completed. You have two options, either you change the container path for Deluge downloads to /downloads or you change Radarr container path from /downloads to /data/completed.

Thank you! that did the trick!

  • Like 1
Link to comment
On 11/30/2020 at 11:45 AM, mgworek said:

This is a question for radarr in general. My docker updated to 3.x this weekend. Has anyone on 3.x noticed the search takes forever and is pulling way to many results and seems like just random movies are getting found. 2.x was not doing that.

 

Is there a new setting I need to fix?

Having this same issue. Often will take so long on a manual search (er, "interactive search" as it may now be called?) that the browser page goes unresponsive.

Link to comment
17 minutes ago, Serein said:

Having this same issue. Often will take so long on a manual search (er, "interactive search" as it may now be called?) that the browser page goes unresponsive.

Same issue.  I'm also running into issues where when trying to add a searched movie, the icon just rotates, and never adds the request movie.

Link to comment

UnRaid, Docker, Radarr, "Folder is not writable by user ***" :/ Any clues on how to troubleshoot?

If I enter the container shell i'm perfectly able to create files and folders in the target folder.

Running Sonarr (by hotio), Plex, Bazarr, using same target folder (which is a windows SMB). works just fine with no issues, but all versions of Radarr fails with this error: "Folder is not writable by user **" where depends on who release the container.

Example of a container build (this is by hotio, but error is the same on all tried releases of Radarr, including the one by linuxserver.


"root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='radarr' --net='br0' -e TZ="Europe/Paris" -e HOST_OS="Unraid" -e 'TCP_PORT_7878'='7878' -e 'PUID'='99' -e 'PGID'='100' -e 'UMASK'='002' -e 'ARGS'='' -e 'DEBUG'='no' -v '/mnt/user/appdata/radarr':'/config':'rw' -v '/mnt/disks/SERVER.INT.CONTOSO.COM_mount':'/media':'rw' 'hotio/radarr' 71598c7ea19bd54d2bb8b81f6cd8699248dd67af3439ebc989f6e8894f4edbb7"

Link to comment

So I just noticed since I have updated to v3 that Radarr is not functioning correctly remotely.

 

When I click "Add Movie" nothing happens. When I attempt to make changes to the settings I cannot save them. It always says there are unsaved changes despite hitting save.

This all works correctly when accessing radarr locally. I have not made any changes to my reverse proxy  or organizr settings.

 

Any ideas?

 

Thanks.

Link to comment

This worked for me for not being able to add movies remotely, whether it works for you, I don't know. But if it does, great.

Link to discord post https://discord.com/channels/354974912613449730/506925392603512839/785253299129286666

 

In the text below where it says "got the new files", that was in reference to this

https://discord.com/channels/354974912613449730/506925392603512839/785242013289283624

Quote

you may want to try deleted the proxy.conf and ssl.conf files and your radarr.subdomain.conf, then do a pull again, you should get some updated versions; customize the radarr.subdomain.conf.sample (new one) as you need and rename. then restart and try again

 

 

Text from post

Quote

ok wow, that was a pain. I deleted and forced an install. got the new files. Wasn't working. was seeing some diffs in the proxy_set_header statements.

I was reading this https://wiki.servarr.com/Radarr_Installation#NGINX_Reverse_Proxy trying to make sense of the note underneath. Then saw an error in the log that nginx didn't know the var connection_upgrade in this statement

proxy_set_header Connection $connection_upgrade;.

Did a search, found this https://github.com/jupyterhub/jupyterhub/issues/781 then

added this to ngnix.conf

map $http_upgrade $connection_upgrade {
        default upgrade;
        '' close;
    }
Quote

restarted and it was working again. Might be something to pin in case it happens to anyone.

 

you also can't remove that statement because signalR will break.

 

Edited by dbinott
Link to comment
2 hours ago, vvolfpack said:

I'm also facing the same issues since upgrading to the latest versions for lists imported via Trakt. Movies are getting monoitored, but not auto-downloading.

 

I tried to follow instructions from dbinott posted above, but my illiteracy is showing. Can't find ngnix.conf in my appdata folder. Could someone post steps on how to fix this? Really appreciate it!

Are you using SWAG for your webserver/reverse proxy? You will find all that info in the appdata folder for swag.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.