Jump to content
linuxserver.io

[Support] Linuxserver.io - Radarr

575 posts in this topic Last Reply

Recommended Posts

So, I’m getting the “No files found are eligible for import in /config/Downloads/complete/“ message for everything Radarr is trying to rename & move from SAB.

 

I’m sure its my hosts and paths but I can’t seem to figure it out..

 

What’s funny is that Sonarr is setup the exact same way and it works fine.

 

Here are screen shots of my setup for Radarr, SAB, and Sonarr, does anyone mind taking a look?  Thanks!

 

 

Screen Shot 2017-03-23 at 12.34.34 PM.png

Screen Shot 2017-03-23 at 12.32.32 PM.png

Screen Shot 2017-03-23 at 12.33.22 PM.png

Share this post


Link to post
12 minutes ago, brisimmons105 said:

What’s funny is that Sonarr is setup the exact same way and it works fine.

No it's not. Edit host path 2 for radarr and change the host path from cache to user, and container path to /MediaDL instead of /downloads

Then it will be setup the exact same way.

Edited by jonathanm

Share this post


Link to post
4 minutes ago, jonathanm said:

No it's not. Edit host path 2 for radarr and change the host path from cache to user, and container path to /MediaDL instead of /downloads

Then it will be setup the exact same way.

 

Thanks jonathanm.  So forgive me if I'm missing something, but Host Path 2 for radar is "container path: /downloads" and that's where it should look for the completed downloads. In the sonarr config (according to the config overview), the "/data" folder is where it should look for the downloads folder.  Both the "container path: /downloads" and the "/data" folders are pointing to the same path "/mnt/cache/Media/"

 

What's even weirder is that "/mnt/cache/Dockers/SAB/Downloads/complete" is where SAB actually puts the completed downloads...Somehow sonarr is still able to pickup the files and move them though even though that directory is not mapped.  

Share this post


Link to post
34 minutes ago, brisimmons105 said:

 

Thanks jonathanm.  So forgive me if I'm missing something, but Host Path 2 for radar is "container path: /downloads" and that's where it should look for the completed downloads. In the sonarr config (according to the config overview), the "/data" folder is where it should look for the downloads folder.  Both the "container path: /downloads" and the "/data" folders are pointing to the same path "/mnt/cache/Media/"

Ok, so you see what I am talking about though, right? /downloads =! /data. You must match BOTH the host and container paths in the two containers, so they are pointing to the same file both inside the container and outside.

 

I assumed since you had /downloads mapped to MediaDL, that was where you wanted the downloads to live.

 

For your data download location, pick a container path and an array location for your downloads, and use the same path for both for all your media containers. Either downloads or data or whatever, doesn't matter, just pick one and use it for everything. Don't map folders you don't need, and don't map subfolders for different apps. If you want to specify subfolders, do it inside the app itself, referencing the common path. For example, if you decide to map /downloads to /mnt/user/appdata/downloads (what I use) then you can have the nzb downloader put stuff in /downloads/nzb/incomplete and move it to /downloads/nzb/complete/tv, which shows up in the array as /mnt/user/appdata/downloads/nzb/complete/tv, but to all your media apps it's still /downloads/nzb/complete/tv

 

Container mapping is one of those things that is extremely difficult to wrap your head around until suddenly it clicks and then it's easy.

Share this post


Link to post

Just a quick question.  Right now in sabnzbd I have the 'movies' category move the downloads to my movie folder.  I assume with Radarr, I was to just leave the downloaded movies in the download folder as Radarr will move it to my movies folder, right?

Share this post


Link to post
6 minutes ago, danith said:

Just a quick question.  Right now in sabnzbd I have the 'movies' category move the downloads to my movie folder.  I assume with Radarr, I was to just leave the downloaded movies in the download folder as Radarr will move it to my movies folder, right?

I'm unclear on exactly what you are doing, but I'll make an assumption and say that yes, you probably want to let radarr do the final moving and renaming, especially since you can tell it to clean up the download and only move the files you want instead of all the scene stuff that tends to come along for the ride.

 

Personally, my nzb/torrent apps don't have access to the final destination path, they only drop off the bundle for further processing by sonarr/radarr/cp/etc.

Share this post


Link to post
7 hours ago, jonathanm said:

Container mapping is one of those things that is extremely difficult to wrap your head around until suddenly it clicks and then it's easy.

 

Wow.  I had this spiderweb of incorrect docker setups that actually made everything work.  Sonarr was never setup to see the SAB downloads properly, but because SAB was applying categories to everything sonarr pushed into it (from the indexers), SAB moved it into a place sonarr could find it, completely on accident, and then sonarr was renaming and moving it.

 

Thanks for the clarification!  I have seen the light. 

Edited by brisimmons105

Share this post


Link to post
26 minutes ago, brisimmons105 said:

Thanks for the clarification!  I have seen the light. 

Congrats!

Now you can simplify all your docker mappings, for example, downloaders like nzbget or deluge only need access to their configs in appdata and your download location, wherever that is. fetchers and categorizers like sonarr and radarr only need access to their configs, the download location, and their destination folder trees. Player apps like emby and plex only need their configs and media destinations. The simpler you can make it, the easier it is to maintain and troubleshoot. Keep everything referencing /mnt/user locations if possible, never reference specific disks like /mnt/disk2 or /mnt/cache unless the container author mandates it for some reason.

Share this post


Link to post

EDIT: Disregard post. I'm leaving it up in case anyone else comes across the issue. I was able to fix issue by adding year name of the film in parentheses in the file name (folder name did not need to be changed). Source of fix was this Reddit thread. I think the AVI format was a red herring...a lot of those files just happened to be very old and not organized as well as they should have been.

Thanks so much for putting this together.

 

I noticed that some of my movies aren't being recognized. From what I can tell, it looks like it's only AVI files with Codecs that are either MSMPEG4V3 or MPEG4.  However, other AVI files with MPEG4 show up without issue. I searched this thread for AVI but didn't find any hits.

 

Anyone else noticing similar behavior?

Edited by imagoodusername

Share this post


Link to post

Hey yall, 

I'm having a bit of a problem connecting this docker to my offsite seedbox running latest rutorrent. I've nailed it down to a TLS handshake problem

System.Net.WebException: Error writing headers ---> System.IO.IOException: The authentication or decryption has failed. ---> Mono.Security.Protocol.Tls.TlsException: The authentication or decryption has failed.
  at Mono.Security.Protocol.Tls.RecordProtocol.EndReceiveRecord (IAsyncResult asyncResult) <0x4142a070 + 0x00103> in <filename unknown>:0 
  at Mono.Security.Protocol.Tls.SslClientStream.SafeEndReceiveRecord (IAsyncResult ar, Boolean ignoreEmpty) <0x41429fb0 + 0x0002b> in <filename unknown>:0 
  at Mono.Security.Protocol.Tls.SslClientStream.NegotiateAsyncWorker (IAsyncResult result) <0x414276b0 + 0x00227> in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at System.Net.WebConnection.EndWrite (System.Net.HttpWebRequest request, Boolean throwOnError, IAsyncResult result) <0x412d55c0 + 0x00207> in <filename unknown>:0 
  at System.Net.WebConnectionStream+<SetHeadersAsync>c__AnonStorey1.<>m__0 (IAsyncResult r) <0x412d4ea0 + 0x00143> in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) <0x412daf60 + 0x001a7> in <filename unknown>:0 
  at System.Net.HttpWebRequest.GetResponse () <0x412d8bd0 + 0x0005a> in <filename unknown>:0 
  at CookComputing.XmlRpc.XmlRpcClientProtocol.GetWebResponse (System.Net.WebRequest request) <0x414232a0 + 0x00032> in <filename unknown>:0 

Couchpotato docker has no problem connecting to the same service with the same credentials.

 

Any help would be appreciated. 

Share this post


Link to post
3 hours ago, Darqfallen said:

Hey yall, 

I'm having a bit of a problem connecting this docker to my offsite seedbox running latest rutorrent. I've nailed it down to a TLS handshake problem


System.Net.WebException: Error writing headers ---> System.IO.IOException: The authentication or decryption has failed. ---> Mono.Security.Protocol.Tls.TlsException: The authentication or decryption has failed.
  at Mono.Security.Protocol.Tls.RecordProtocol.EndReceiveRecord (IAsyncResult asyncResult) <0x4142a070 + 0x00103> in <filename unknown>:0 
  at Mono.Security.Protocol.Tls.SslClientStream.SafeEndReceiveRecord (IAsyncResult ar, Boolean ignoreEmpty) <0x41429fb0 + 0x0002b> in <filename unknown>:0 
  at Mono.Security.Protocol.Tls.SslClientStream.NegotiateAsyncWorker (IAsyncResult result) <0x414276b0 + 0x00227> in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at System.Net.WebConnection.EndWrite (System.Net.HttpWebRequest request, Boolean throwOnError, IAsyncResult result) <0x412d55c0 + 0x00207> in <filename unknown>:0 
  at System.Net.WebConnectionStream+<SetHeadersAsync>c__AnonStorey1.<>m__0 (IAsyncResult r) <0x412d4ea0 + 0x00143> in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) <0x412daf60 + 0x001a7> in <filename unknown>:0 
  at System.Net.HttpWebRequest.GetResponse () <0x412d8bd0 + 0x0005a> in <filename unknown>:0 
  at CookComputing.XmlRpc.XmlRpcClientProtocol.GetWebResponse (System.Net.WebRequest request) <0x414232a0 + 0x00032> in <filename unknown>:0 

Couchpotato docker has no problem connecting to the same service with the same credentials.

 

Any help would be appreciated. 

Might be better aimed at the Radarr devs tbh.  Docker is just a packaging format.

Share this post


Link to post
4 hours ago, CHBMB said:

Might be better aimed at the Radarr devs tbh.  Docker is just a packaging format.

Okay, will do, will let you guys know of an developments from this.

Share this post


Link to post

We keep an eye on the Radarr stuff and the container is rebuilt weekly so don't worry. ;)

Share this post


Link to post
On 4/3/2017 at 8:36 AM, CHBMB said:

We keep an eye on the Radarr stuff and the container is rebuilt weekly so don't worry. ;)

They came back with

Quote

Yeah you either need an updated mono or libcurl version.

So is there any chance of doing that?

Share this post


Link to post
Any eta of when this Radarr docker will support a single movie folder for all movie media files?


You should ask the radarr devs on their github

Share this post


Link to post

Hi guys, i have a weird issue with Radarr/Sonarr and the drone factory not picking up folder for processing (not sure if it's even still ment to be working as there was talk of depreciating it?) My paths are set as below in unraid:

 

Sonarr (Unraid config)

 

/downloads  --> /mnt/user/appdata/downloads/sonardrone/

 

Radarr (Unraid config) 

 

/downloads --> /mnt/user/appdata/downloads/radardrone/

 

And within Radarr/Sonarr GUI, under dronefactory, there set as follows:

 

Sonarr Drone Factory (Sonarr GUI)

 

/downloads/sonardrone/

 

Radarr Drone Factory (Radarr GUI)

 

/downloads/radardrone/

 

Everything's on the same server (192.168.1.125) and i'm fresh out of ideas! nothing in the logs corresponding to anything useable! :)

 

I threw some attachments in to show, i can browse to the folders from within Radar and Sonar and can see the folders of films waiting to be processed but for some reason nothing happens when i manually trigger the dronefactory? Does the config look right to you? I'm starting to think the feature has been quietly depreciated... Can you see anything strange in the screenshots below?

 

 

1.png

2.png

3.png

4.png

Share this post


Link to post

Just to satisfy my curiosity try changing /downloads to point to /mnt/cache/appdata/downloads/

Share this post


Link to post

Pretty sure i've tried it but i'll give it a go now! I take it you mean change it on radarr, sonarr and sab?

 

UPDATE:

 

Just turned off radarr. Remapped the /downloads -> /mnt/cache/appdata/downloads/

 

Havn't done sabnzbd or sonarr yet as they shouldn't have anything to do with this test.

 

and still nothing. 

 

Clicking on the drone factory button under "wanted" did take a minute or so to finish but nothing was processed. I have around 160 folders (each a movie in the drone factory at the moment for what it's worth, ive also tried moving them all out and keeping 1 film in the folder and restarting) Nothing.

 

Can anyone post there container mappings, radarr/sonarr drone factory path and potentially there remote mappings for me to try emulating?

 

UPDATE:

 

Renamed the old radar drone factory -> radardrone2)

created a new folder called radardrone.

Copied 1 movie with a reasonably nice name into this folder for the radardrone to post process.

Nothing. And no mention in the logs about it from forcing the radardrone factory to scan :(

 

 

 

 

 

radardrone.PNG

Edited by thestraycat

Share this post


Link to post

From your first post:

3 hours ago, thestraycat said:

/downloads  --> /mnt/user/appdata/downloads/sonardrone/

 

3 hours ago, thestraycat said:

/downloads/sonardrone/

 

This setup tell sonar to ultimately look in /mnt/user/appdata/downloads/sonardrone/sonardrone (since /downloads is a shortcut to /mnt/user/appdata/downloads/sonardrone)

 

Same thing with Radarr.

 

Like @chbmb said, if you set the mapping for /downloads to the exact same mapping on every container applicable, it should all work fine.  As a matter of fact, once its all set up correctly, any new downloads won't have to go through the drone factory, and the intercommunication via the API's will automatically begin the imports once they are completed.  But, I don't ever use deluge.  But it will work no problems with Sab/nzbget

Share this post


Link to post

Hi Squid - Totally agree and that side is fine.

 

Importing and processing of media works like a dream between radarr, sonarr, sabnzbd and deluge that's not the problem for me.

 

It's using the dronefactory feature as auto-processing watch folder for downloads that happen outside of radarr/sonarr that is the issue. :( 

Share this post


Link to post

I'm assuming that radarr's dronefactory wont process folders/files that havn't been created within Radarr. As in radarr wont auto process and auto import content from the dronefactory and make an entry for the movie unless it was prestaged in radarr?

Share this post


Link to post

Hi guys,

 

I have the container set up and working but I noticed once it downloads a movie, along side the movie there is a file with the same name and size that has a .partial~ extension.

 

So it looks like

 

movie.mkv

movie.mkv.partial~

 

Does anyone know why that file is there?

 

Thanks.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.