Jump to content
linuxserver.io

[Support] Linuxserver.io - Radarr

580 posts in this topic Last Reply

Recommended Posts

Something like /moviesA mapped to /mnt/user/BluRay and /moviesB mapped to /mnt/user/DVD

 

Add movies within Radarr from both /moviesA and /moviesB

Share this post


Link to post

I'm moving my data from my windows computer to unraid. How do I go about keeping the settings/movie library/history, etc.? Thanks!

Share this post


Link to post

Great docker! Thanks for the hard work -I much prefer over CouchP... 

 

Questions:

 

1) Can an Indexer be weighted or preferred. When two very similar results are found from I would prefer to download from my primary private tracker (IPTorrents) 

 

2) If I have my DL client (ruTorrentVPN docker by Binhex) configured to "move completed DL's via Hardlink" -which copy does Radarr import from? The original (still seeding) location in my /incomplete folder, or the moved & completed copy in my /completed folder?  Ideally after Radarr grabs a movie I want to move (hard-link) it off my smallish SSD cache drive to a "completed" share on UnRaid. From there import the movie into Radarr & my library... The goal is to download active torrents on the SSD cache drive them move & continue seeding the completed torrent from a regular UnRaid share. 

 

(Beer fund donation sent!)

 

BR 

 

Share this post


Link to post

Well I am officially at my wits end. I have been having the same issue many others have been having with radarr/sab searching for/finding/downloading a file but I get the infamous 

Import failed, path does not exist or is not accessible by Radarr: /data/Complete/Logan.2017.NOIR.EDITION.BDRip.x264-SNOW English

I have read the docker FAQ here and I've ensured that my /data is mapped consistently across each platform of sonarr/radarr/sabnzbd. Sonarr works without issue. Radarr cannot find the file when its time to move the file. 

 

I have tried both mnt/user/Downloads and mnt/cache/Downloads. My setup is as follows:

 

5a2d3946b5cf3_ScreenShot2017-12-10at7_37_10AM.thumb.png.0d4bf78c6260887d211ac713d06e7636.png

 

At a complete loss of how to fix this issue from here with wha I've read so far. The file will successfully go from the /Downloads/Incomplete to the /Downloads/Complete folder where it will just sit. 

Share this post


Link to post

Might help if you posted in binhex's support thread, this is for our version (linuxserver) the mappings are different.

Share this post


Link to post

So it turns out immediately after I posted this, I restarted in the docker for all three and tested it out to a successful outcome. It turns out switching the mapping from /mnt/user/Downloads/ to /mnt/cache/Downloads/ fixed the issue, it just needed to be restarted. I'm going to leave both these posts here for the future. Good luck future.

 

I actually went back and forth between linuxserver and binhex to see if the issue was separate and the issue initially arose on this version. Just wanted others to know there should be an issue.

 

I do have one remaining issue to contend with. I reinstalled radarr several times in order to try fixing my old problem. My uninstall process consisted of uninstall the docker and removing the image, then ensuring the folders were deleted out of /mnt/user/appdata/radarr and /mnt/cache/appdata/radarr. After reinstall, any movie I added would have random artwork. Way far off, as if it was randomly selecting something from my previous library somehow. If I removed a movie then readded it, it would have a different random piece of artwork. The 'background' image is correct, it's only the movie cover artwork that is wrong both in the preview and also once clicked into the movie. Any suggestions for a healthy uninstall so I can start from scratch?

 

 

 

[SOLVED]   

 

It appears that when you wipe everything and reinstall, the posters for the movies metadata is stored in your browser cache. Clearing your browser cache will resolve normalcy.

 

Thanks.

Edited by Exos

Share this post


Link to post

Having trouble with Radarr . It is no longer importing some movies from /downloads. Normally in this scenario, I would manually import and they would be reasonably matched based on the file name. It is no longer coming up with a potential match for any of the files and worse, wont let me search in the selection screen to assign them. Worse yet is that the selection screen of all potential movie titles in Radarr is not in alphabetical order and wont sort. I'm quite lost.

https://imgur.com/OoVfwxX

4.PNG.35fa469e86ab657232f21e78eb73af4e.PNG

Edited by navickas12

Share this post


Link to post

Did Radarr grab the files and send them to the DL client?  Or are you manually adding the NZBs to the DL client?

Are you using Radarr's Blackhole to import the files?

Share this post


Link to post

Everything has been searched and downloaded by Radarr. This only happens for some files, others are grabbed and imported automatically without issue.

 

Share this post


Link to post

But what about this

35 minutes ago, Squid said:

Are you using Radarr's Blackhole to import the files?

aka drone factory

Share this post


Link to post

I thought DF was irrelevant now

"Drone Factory is deprecated and should be disabled, use Wanted -> Manual Import to manually import arbitrary directories"

Edited by navickas12

Share this post


Link to post
8 minutes ago, navickas12 said:

I thought DF was irrelevant now

"Drone Factory is deprecated and should be disabled, use Wanted -> Manual Import to manually import arbitrary directories"

Understand.  Why I asked if you were using it.

Share this post


Link to post

IDK  Once in a very blue moon I get the same thing.  Usually I just manually move the file to the array, and delete the movie from the wanted list.  Probably you're going to be best off hitting the support threads on Radarr's site.https://radarr.video/#support

Share this post


Link to post

I posted this in Radaar and Sonaar support forums but it looks to me this is a Docker issue...

 

Something is off and I can't find where the issue lies... Radarr and Sonarr are not looking for the downloads folder in the correct path.

 

Sonarr log message:

Import failed, path does not exist or is not accessible by Sonarr: /config/Downloads/complete/tv/

Radarr log message:

Import failed, path does not exist or is not accessible by Radarr: /config/Downloads/complete/movies/

For some reason Raddar and Sonnar are looking under the config folder instead of the path defined for the downloads folder. Here are the details of my setup:

  • Both Sabnzbd and Radarr are installed dockers in an UNRAID box
  • Sabnzbd path to downloads folder as defined in the docker: /downloads -> /mnt/user/appdata/sabnzbd/Downloads/complete/
  • Raddar path to downloads folder as defined in the docker: /downloads -> /mnt/user/appdata/sabnzbd/Downloads/complete/
  • Host for Sabnzbd in Raddar is the local IP address, "localhost" didn't work
  • Permissions for completed downloads under Sabnzbd: 775
  • File chmod mask in Raddar: 0775
  • Any file browser within Raddar is able to see the correct downloads folder

Screenshot of Docker settings:

Screenshot of UNRAID setup

 

Screenshot of a file browser window within Sonarr showing it can see the /downloads folder and its content:

image.thumb.png.c8a2497f60408904cb168339f472f1dc.png

 

Any idea where to look?

 

Radarr Version:

Version: 0.2.0.870
Mono Version: 5.4.1.6 (tarball Wed Nov 8 20:37:08 UTC 2017)
AppData directory: /config
Startup directory: /opt/radarr

 

Sonarr Version:

Version: 2.0.0.5085
Mono Version: 5.4.1.6
AppData directory: /config
Startup directory: /opt/NzbDrone

 

Edited by Mesias
Typo

Share this post


Link to post
/config/Downloads/complete/movies/

Is the key to this, somewhere, possibly sabnzbd, you haven't configured something correctly.

 

It's not a docker container issue, it's a config issue

 

I'm guessing sabnzbd is telling sonarr/radarr to look in /config/Downloads/complete/movies or /config/Downloads/complete/tv

 

Whereas it should be telling them to look in /downloads/movies or /downloads/tv

 

 

Edited by CHBMB

Share this post


Link to post

I'm going to try changing the path of Sabnzbd categories to absolute paths. Right now they are using the default, relative folders are based on: /config/Downloads/complete. This should fix it... Thanks for pointing this out!

Share this post


Link to post

I changed the path to the Sabnzbd categories and it didn't help. I then changed its download folders to absolute paths but it didn't resolve the issue. Logs continue showing the default path. Note I restarted all three dockers.

 

Screenshot to User Folders in Sabnzbd:

image.png.d69a0a7d7a4694d2719f10a5e4cfb65c.png

 

Previous step changed the path for the categories folders. They are now relative to /downloads:

image.thumb.png.c84d66b52e8afeaf98e8b7e825d55f58.png

 

After all this, the logs keep showing the default path:

 

image.png.038cdd18d98e4568337dce4cfc0248ea.png

 

image.thumb.png.ec7fc2a06808c1f24a7f52adcde582ca.png

 

Is there any other log I can enable that can provide more info?

Share this post


Link to post
16 minutes ago, Mesias said:

image.png.d69a0a7d7a4694d2719f10a5e4cfb65c.png

 

Previous step changed the path for the categories folders. They are now relative to /downloads:

image.thumb.png.c84d66b52e8afeaf98e8b7e825d55f58.png

 

Check out that first screenshot.  Default Base Folder: /config

 

I don't use sabnzbd, but that would account for your problem.  Somewhere else possibly in Sonarr/Radarr you must have configured something to look in

/config/Downloads/complete/tv  / /config/Downloads/complete/movies

Edited by CHBMB

Share this post


Link to post

How you've got it set up now is correct.  BUT, IIRC SabNZBd is a tad strange in that if you change things when stuff is already queued, the queued items still go into the original places, which account for the problems you're having.  

 

Clear out the queue, have Sonarr / Radarr send over a new download and then see what happens

Share this post


Link to post

Have radarr installed and running but am having an issue importing bulk movie list gives me an error folder is not writable user abc

Edited by brettm357

Share this post


Link to post
On 12/16/2017 at 6:24 PM, Squid said:

How you've got it set up now is correct.  BUT, IIRC SabNZBd is a tad strange in that if you change things when stuff is already queued, the queued items still go into the original places, which account for the problems you're having.  

 

Clear out the queue, have Sonarr / Radarr send over a new download and then see what happens

 

That's exactly what's happening... I tried a fresh request and it worked just fine. On the other hand, Sonaar and Radarr are still looking for releases already downloaded. Not sure how to clear that queue.

Thanks for all the help!

Share this post


Link to post
2 minutes ago, Mesias said:

Sonaar and Radarr are still looking for releases already downloaded.

Rescan the drives for episodes should fix it.

Share this post


Link to post
34 minutes ago, Squid said:

Rescan the drives for episodes should fix it.

 

That didn't help... The import service is looking for versions never downloaded... all releases in both libraries (Radaar and Sonaar) are flagged "downloaded". I'm stuck, I don't understand yet the process of importing. Why, if a release is already flagged as downloaded, the import service continues trying to retrieve it from the download folder? 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.