[Support] binhex - Radarr


469 posts in this topic Last Reply

Recommended Posts

1 hour ago, trurl said:

In case this isn't a typo I thought you should be made aware that linux is case-sensitive. A user share named Plex is at /mnt/user/Plex. The path /mnt/User/Plex would actually be some newly created folder that isn't mounted storage and so would be in RAM like the rest of the Unraid OS.

 

So you might check all your path specifications and make sure you have the correct upper/lower case everywhere.

 

Also this post from the Docker FAQ may be relevant:

Yeah my case is correct everywhere.  So it ended up being the fact that I had categories set in nzbget which nothing like.  

Link to post
  • Replies 468
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

ok, a new image has been built, works for me guys!, please pull it down (force update), let me know if its still causing issues.

It looks like v3 has now dropped and therefore I need to modify some bits and pieces to to get the image working again. I shall take a look at this tonight. Sent from my CLT-L09 using Tapatalk

Hi I have made a video guide about how to setup radaar   It shows how to prepare your existing movie catalogue to be compatible with Radarr.  How to install the container then finally how to co

Posted Images

Hello - 

 

I was wondering why it was not finding my current movie share.  It wants to look in /media/movie name and I have the following set up as

image.png.936adbb8bc99641e6a5a30360ae85196.png

 

Is it weird? Like it doesn't see all of the current movies that I have in the share. I had figured that /media/ would signal to Radarr to look in the /mnt/user/Movies folder...*shrug* I'm just curious is all. 

Edited by cbr600ds2
Link to post
1 minute ago, wgstarks said:

This is proper behavior. The app inside the container sees /media/<name of movie>. The actual location on your server will be /mnt/user/Complete/<name of movie>

hahaha Thanks WG!  It's working so I'm not going to trip about it.  One last weird question - if the movie is "monitored" it still seems like I have to go in to it and click on the glasses to search for it.  What setting am I missing to do this ish automatically? 

 

 

Link to post
2 minutes ago, cbr600ds2 said:

hahaha Thanks WG!  It's working so I'm not going to trip about it.  One last weird question - if the movie is "monitored" it still seems like I have to go in to it and click on the glasses to search for it.  What setting am I missing to do this ish automatically? 

 

 

A monitored movie will download a “new” torrent when someone posts it after the monitoring has started. If you want to download a torrent that was posted before the monitoring started you will need to use one of the search buttons.

Link to post
  • 2 weeks later...

If choose a non-binhex downloader docker, for example deluge docker from linuxserver, the raddrr will report error of 

 

Quote

You are using docker; download client Deluge-docker places downloads in /downloads/complete but this directory does not appear to exist inside the container. Review your remote path mappings and container volume settings.    

 

The path and folder actually exists inside the container

Link to post
1 hour ago, jonathanm said:

How are you verifying that?

I just open the console for this docker and check the inside. the /downloads/complete is there.

 

I think the thing is with linuxserver's deluge docker image, by default the settings for the docker when installing it will ask you to map your real download path in the host to  container's /downloads

so I'll map my actual-download-path to /downloads, then it will have

/downloads/complete

/downloads/incomplete  inside the docker. 

 

but binhex's deluege vpn docker image by default want 

/data/complete

/data/incomplete inside the dokcer. 

 

And binhex's radarr sonarr prefer or hard coded to look for downloading / downloaded files in /data/complete, and it reports it can not find 

/downloads/complete. Which is a wrong report. I guess it just report 'can't find DEFINED_DOWNLOAD_PATH' or something like this , so it wrongly reported 

to '/downloads/complete' can not be find. 

 

here a tricky is :

with linuxserver's deluge docker image, just map your real download path to /data again. 

This way binhex's radarr sonarr will find the downloaded files and won't complain. 

 

Or a real fix could be binhex's radarr sonarr don't use hardcoded download path /data/complete to look for downloaded files. But looking in the DEFINED_DOWNLOAD_PATH ?

Link to post

I tried out linuxserver's deluge image because it use the release version 2.0.3 not the dev version with the binhex delugevpn. 

Some PT only allows up to 2.0.3 because that's the last release version. 

 

Also plugins DefaultTrackers-0.2-py3.6.egg and YaRSS2-2.1.4-py3.6.egg can not be installed, I thought it was because binhex delugevpn has python 3.8. 

I tried linuxserver's which has python 3.6.9, but they still can not be installed. Might be a docker thing, not python version problem. 

Link to post
7 hours ago, rampage said:

And binhex's radarr sonarr prefer or hard coded to look for downloading / downloaded files in /data/complete

this is not true, i do not specify in any way what path to use for downloading/downloaded with sonarr or radarr, there is a volume mapping of /data but its not forced or referenced in either app.

Link to post

pls halp

 

I'm new to radarr so this might be a little confusion from my side, but I've tried to tweak around and nothing seems to work

 

My downloads are renamed correctly but and transferred to the wrong location: to /data/[movie]/ instead of /movies[movie]/

 

At first I thought the default qbittorrent destination (#7 below) would be the problem, but I noticed that the /data/[movie]/ gets created while the file is still downloading (due to #9 - so OK), but when it's completed radarr moves the files to /data/[movie]/ regardless ☹️

 

both qbittorrent and radarr are binhex's

 

references:

 

radarr-troubleshooting.thumb.png.d4782435a87ba5851bcef1b4644b2705.png

Edited by timmyx
wording
Link to post

Pic #3.  Just change the path.  Radarr uses "root" folders, and it uses the last one you've set as a default.  Add a new movie, Add a new path for a root folder and it'll use that one going forward by default.

Link to post

Edit: Now working! Apparently all I had to do was delete and create a new list for trakt.

tks for the help Squid 😃

 

 

2 hours ago, Squid said:

Pic #3.  Just change the path.  Radarr uses "root" folders, and it uses the last one you've set as a default.  Add a new movie, Add a new path for a root folder and it'll use that one going forward by default.

 Thanks! It did the trick for manually added movies, but it's not working for the trakt list ☹️

 

I did this: manually added a new movie and let radarr do its thing -- all good: files renamed, moved to the correct folder I added manually

 

So next I added a new movie to my trakt list and had radarr fetch it

 

the "old" folder is there as default

 

2020-12-30_134320.png.8da952f518343abbf38f4a3c3e96af0a.png

 

but if I add manually it defaults to the correct one

 

2020-12-30_134516.png.cfff326e94a56ee51181c9c0e0523d50.png

 

 

Edited by timmyx
works now
Link to post

does downloaded media file hardlink work with radarr/sonarr running in docker, and the download client say delugevpn runnning in another docker.

 

radarr has docker mapping of:

/media to host /mnt/user/media

will store movies in /mnt/user/media/movie

 

sonarr has docker mapping of:

/media to host /mnt/user/media

will store tvshows in /mnt/user/media/tvshow

 

delugevpn has:

/media to host /mnt/user/media

will download files into /mnt/user/media/download

 

Edit:

Ok, this should be the case, my above idea should work fine according to 

https://trash-guides.info/Misc/how-to-set-up-hardlinks-and-atomic-moves/

Will give a try. 

Edited by rampage
Link to post
  • 4 weeks later...

Just wanted to say I love Radarr. But the new UI is terrible. It is so displeasing to the eye. The last one where everything was along the top was so much cleaner. Is there a way to go back to that?

Link to post
On 1/31/2021 at 9:12 PM, jagr200 said:

Just wanted to say I love Radarr. But the new UI is terrible. It is so displeasing to the eye. The last one where everything was along the top was so much cleaner. Is there a way to go back to that?

There probally is but this is the one that will be getting all the support from the devs so I dont suggest it personally.

Link to post
On 1/31/2021 at 9:12 PM, jagr200 said:

Just wanted to say I love Radarr. But the new UI is terrible. It is so displeasing to the eye. The last one where everything was along the top was so much cleaner. Is there a way to go back to that?

I completely agree.. they (radarr/sonarr) are terrible. Not as easy to use either.

 

You CAN go back by reverting to an older build, but like Urban said.. the new ones are going to be the ones that are most worked on.  

 

It's kind of adapt or get left behind, but if you want to you can change your repository to linuxserver/radarr:v0.2.0.1504-ls37 and pull it down again.. that was the last version I had before they changed the GUI.   The databases converted for the new UI version as well so if you go back you'll lose any changes that you've had since going to the new UI.

Link to post
5 hours ago, Urban said:

There probally is but this is the one that will be getting all the support from the devs so I dont suggest it personally.

 

1 hour ago, Energen said:

I completely agree.. they (radarr/sonarr) are terrible. Not as easy to use either.

 

You CAN go back by reverting to an older build, but like Urban said.. the new ones are going to be the ones that are most worked on.  

 

It's kind of adapt or get left behind, but if you want to you can change your repository to linuxserver/radarr:v0.2.0.1504-ls37 and pull it down again.. that was the last version I had before they changed the GUI.   The databases converted for the new UI version as well so if you go back you'll lose any changes that you've had since going to the new UI.

 

 

Ya I don't want to get left behind. It is just a shame. It looked so good. Now it looks terrible.

Link to post
  • 4 weeks later...

[SOLVED] thanks Cessquill

 

hi, i upgraded to 3.0.2.4552 of radarr (binhex version) but after a reboot radarr says all my download clients are unavailable.

[v3.0.2.4552] NzbDrone.Core.Download.Clients.DownloadClientUnavailableException: Unable to connect to Deluge, please check your settings ---> System.Net.WebException: The operation has timed out.: 'http://192.168.10.20:8112/json' ---> System.Net.WebException: The operation has timed out.

 

Strange as it uses same setup as sonarr and have been working with the same config. Any pointers?

EDIT: seems radarr is also refusing incomming api calls... have not changed that either... strange

 

Edited by orlando500
Link to post
1 hour ago, orlando500 said:

hi, i upgraded to 3.0.2.4552 of radarr (binhex version) but after a reboot radarr says all my download clients are unavailable.

[v3.0.2.4552] NzbDrone.Core.Download.Clients.DownloadClientUnavailableException: Unable to connect to Deluge, please check your settings ---> System.Net.WebException: The operation has timed out.: 'http://192.168.10.20:8112/json' ---> System.Net.WebException: The operation has timed out.

 

Strange as it uses same setup as sonarr and have been working with the same config. Any pointers?

EDIT: seems radarr is also refusing incomming api calls... have not changed that either... strange

 

If you're using Deluge as a privoxy then this is down to a Deluge update.  Check in that thread for what you need to do (pinned post, plus posts from the last few days).

Link to post
2 minutes ago, Cessquill said:

If you're using Deluge as a privoxy then this is down to a Deluge update.  Check in that thread for what you need to do (pinned post, plus posts from the last few days).

 

ah thanks.. yes i was using the binhex-delugevpn with proxy functions. And had it on radarr. Have not been in the forums for a week so have not gotten the memo :-) guess i should read up before upgrading. 

Link to post
On 2/27/2021 at 4:23 PM, Cessquill said:

If you're using Deluge as a privoxy then this is down to a Deluge update.  Check in that thread for what you need to do (pinned post, plus posts from the last few days).

Sorry,

Where is this pinned post? 

Link to post

all of a sudden maybe after update i am unable to connect to sab. sonarr connects just fine.

 

Test was aborted due to an error: Unable to connect to SABnzbd, HTTP request failed: [503:ServiceUnavailable] [GET] at [https://192.168.1.12:8080/api?mode=get_config&apikey=REMOVED&output=json]

 

any help would be appreciated. i am not running deluge vpn

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.