[Support] cheesemarathons repo


642 posts in this topic Last Reply

Recommended Posts

  • Replies 641
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: Bitwarden Description: This is a Bitwarden server API implementation written in Rust compatible with upstream Bitwarden clients*, perfect for self-hosted deployment where runnin

Hello, Nice work on steamcachebundle, makes LAN parties a breeze. Would it be possible to add Xbox download cache to the docker as well?

Thought I'd post this here as it might be useful to some.  I worte a brief guide on how to setup bitwarden with a reverse proxy using our LetsEncrypt container.  It's on the LinuxServer.io blog.  It's

Posted Images

So I've been able to get the BitWarden container installed and working via LE/reverse proxy.  I was having the same issue as those on the previous page, so thanks for the tips on that.  I was able to get a new user registered using Chrome as well.  The one thing I was curious about was whenever you go to the URL for BitWarden, it comes up to a login page and anyone can register.  I'm not sure if anyone will come across my instance, but anything is possible.  I did some searching, and it is possible to turn off registrations:

 

https://github.com/bitwarden/core/issues/131

 

I looked through some of the directories in the docker, but I wasn't able to find the location or file they're referring to.  Is it possible to do this in this docker container?  Also, I was wondering if there was an admin portal, and I found another document that said the admin portal should be available at https://bitwarden-domain.com/admin, however when I go to /admin I get a 404 error.  I am assuming that was not included in the docker container?  Is it possible to have it added?

Link to post
13 hours ago, mlounsbury said:

So I've been able to get the BitWarden container installed and working via LE/reverse proxy.  I was having the same issue as those on the previous page, so thanks for the tips on that.  I was able to get a new user registered using Chrome as well.  The one thing I was curious about was whenever you go to the URL for BitWarden, it comes up to a login page and anyone can register.  I'm not sure if anyone will come across my instance, but anything is possible.  I did some searching, and it is possible to turn off registrations:

 

https://github.com/bitwarden/core/issues/131

 

I looked through some of the directories in the docker, but I wasn't able to find the location or file they're referring to.  Is it possible to do this in this docker container?  Also, I was wondering if there was an admin portal, and I found another document that said the admin portal should be available at https://bitwarden-domain.com/admin, however when I go to /admin I get a 404 error.  I am assuming that was not included in the docker container?  Is it possible to have it added?

For your first point see here I'll update the template tonight to add that option.

Unfortunately there is no admin panel with the docker image I use.

Link to post
34 minutes ago, cheesemarathon said:

For your first point see here I'll update the template tonight to add that option.

Unfortunately there is no admin panel with the docker image I use.

Ah, my bad.  Totally forgot to check the github.  Thanks for the information and the update to the template.  Much appreciated.

Link to post
On 9/18/2018 at 8:07 AM, mlounsbury said:

Ah, my bad.  Totally forgot to check the github.  Thanks for the information and the update to the template.  Much appreciated.

I got my instance up and running behind my proxy and it works great. Also confirming that by adding that variable to my template manually, it works perfectly! just be aware that the value of "false" is case sensitive, so keep it all lower case and name the variable with the name from the documentation and it works as expected.

Link to post

Thank you for the great work, just a question windows update doesn't work , any reason for that ? I don't see it pulling anything from cache or giving "MISS" even, also any plan to added Nvidia updates container or a container for all downloads maybe :) ? I am happy to donate, great work 

Link to post
1 hour ago, Tweak3D said:

I got my instance up and running behind my proxy and it works great. Also confirming that by adding that variable to my template manually, it works perfectly! just be aware that the value of "false" is case sensitive, so keep it all lower case and name the variable with the name from the documentation and it works as expected.

Fantastic! I have updated the template now so users should be able to easilly disable signups

Link to post
42 minutes ago, fakh2006 said:

Thank you for the great work, just a question windows update doesn't work , any reason for that ? I don't see it pulling anything from cache or giving "MISS" even, also any plan to added Nvidia updates container or a container for all downloads maybe :) ? I am happy to donate, great work 

I have opened an issue with the makers of the docker image regarding windows updates not caching. As for adding Nvidea, open an issue here suggesting it.

Link to post
26 minutes ago, plantsandbinary said:

With the Ghost docker container is there a way to persist changes because every time I update, I lose the ability to have comments on my blog and I have to edit the theme file to put the comment box back. This is highly annoying. Is there an easier way to enable comments permanently on the blog that survives updates?

Hmm I have this working, let me look at how I set it up and I'll get back to you!

Link to post
16 minutes ago, cheesemarathon said:

Hmm I have this working, let me look at how I set it up and I'll get back to you!

@plantsandbinaryI created a modified theme and placed it in the theme folder. There is a guide to modifying themes here. Once modified place it in the theme folder. That folder will be persistent so long as you haven't modified the default mapped container directory. Let me know if your still unsure what to do.

Edited by cheesemarathon
Link to post

@cheesemarathon Thanks for the reply mate. I am a little confused.

 

I have already edited the default casper theme post.hbs file to include the Facebook comments developer's script.

 

From the documentation it looks as though I could just zip the whole 'casper' folder and upload it into the admin panel and the code would survive an update or did I assume something wrong here?

Edited by plantsandbinary
Link to post
5 minutes ago, plantsandbinary said:

@cheesemarathon Thanks for the reply mate. I am a little confused.

 

I have already edited the default casper theme post.hbs file to include the Facebook comments developer's script.

 

From the documentation it looks as though I could just zip the whole 'casper' folder and upload it into the admin panel and the code would survive an update or did I assume something wrong here?

You can put your modified caspar folder in the themes folder.

So /appdata/ghost/themes/caspar/ would contain the assests and partials folder and all the other hbs files.

 

image.thumb.png.21356aa863e107a632236ccba07b72d1.png

Link to post
1 minute ago, plantsandbinary said:

So just copy the casper folder and name it casper-comments like you did or something and set that as the theme in the Ghost admin panel?

 

Alright I'll try that, but won't that stop the edited theme from being updated when I update the container?

Yes that will work. Yes it won't get updates if you ghost creates updates for it. But you can always add those in manually. The default theme in the container will get updates so you can download that from the admin page and merge updates manually. It's one or the other to be honest. I wouldn't want my theme changing without me changing it, but that's personal preference.

Link to post
13 hours ago, plantsandbinary said:

Alright mate thanks! At least with it set up like this I can just check for changes with the theme by applying the updated default in the admin panel and if there has been good changes I'll merge the comments code over as well.

 

I really appreciate the fast response! Have a coffee on me!

Yeh, that's probably the best way! Not a problem, I'm here to help! Thanks for the coffee, unfortunately I'm an idiot and set it up with the wrong pay pal email. So they payment will bounce back in 30 days. Thanks anyway though!

Link to post
  • 2 weeks later...
28 minutes ago, kortina said:

Any plans to support https://github.com/buzzfeed/sso ?

 

Looks like the oauthproxy2 project is dead.

 

 

Yes I'm well aware that oauthproxy is no longer being developed by the owners. There is an issue that I'm subscribed to that is discusing how the project will go forward, whether that is new owners for the project or moving official support to a new fork. I'm reluctant to move to a new fork until official agreement has been made as buzzfeed sso only supports Google as an auth provider at the moment.

Link to post
  • 2 weeks later...
On 10/4/2018 at 6:08 AM, Johnoldiges said:

Hello, Nice work on steamcachebundle, makes LAN parties a breeze. Would it be possible to add Xbox download cache to the docker as well?

Have you tried to see if this works already? The DNS forwarding should already work. If not, open an issue here as i'm not the author of the software, I just create the template with the help of @mlebjerg

Link to post
  • 3 weeks later...
On 9/19/2018 at 6:52 PM, fakh2006 said:

Thank you for the great work, just a question windows update doesn't work , any reason for that ? I don't see it pulling anything from cache or giving "MISS" even, also any plan to added Nvidia updates container or a container for all downloads maybe :) ? I am happy to donate, great work 

This is not fixed yet however the issue is being looked into. There does seem to be a fix for now. Add the environment variable "DISABLE_WSUS" and set it to "true". The issue is being tracked here: https://github.com/uklans/cache-domains/issues/39

Link to post

So I've been using this fine for a while, but recently one of my machines seems to have developed some sort of "loop" which is causing some seriously awful timeouts on everything from web pages to updates to... anything DNS and network related.  Here's a small sample of the horrifying loop that is created, and keeps adding extra *.*.*.150 addresses to the entries over, and over, and over.  I'm somewhat at a loss here for what to do to fix this, so any troubleshooting you could provide would be more than welcome.

 

 

[02/Nov/2018:23:42:05 -0500] "GET / HTTP/1.0" 504 585 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36" "MISS" "192.168.1.150" "bytes=0-1048575"
192.168.1.150 / 192.168.1.190, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150 - - [02/Nov/2018:23:42:10 -0500] "GET / HTTP/1.0" 504 585 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36" "MISS" "192.168.1.150" "bytes=0-1048575"
192.168.1.150 / 192.168.1.190, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150 - - [02/Nov/2018:23:42:15 -0500] "GET / HTTP/1.0" 504 585 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36" "MISS" "192.168.1.150" "bytes=0-1048575"
192.168.1.150 / 192.168.1.190, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150, 192.168.1.150 - - 

 

Link to post

I've been setting up SteamCacheBundle on UnRaid 6.6.2 and I have been following this guide https://squishedmooo.com/the-new-and-easier-all-in-one-steamcache/ but I've not been able to get past the part where it says to "Run the following command in an SSH session to your unRAID server:

docker exec -it SteamCacheBundle tail -f /data/logs/access.log". I've typed it in on the server itself, I've used the remote terminal from the UnRaid dashboard, and I've downloaded PuTTY and tryed to do it that way and I've had no luck. I'll type it in and nothing else will happen. I'm still fairly new to UnRaid, Docker and the like, anyone know what I'm doing wrong? I've gotten past the point of running the powershell cmd but haven't been able to get further. 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.