[Support] cheesemarathons repo


653 posts in this topic Last Reply

Recommended Posts

  • Replies 652
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: Bitwarden Description: This is a Bitwarden server API implementation written in Rust compatible with upstream Bitwarden clients*, perfect for self-hosted deployment where runnin

Hello, Nice work on steamcachebundle, makes LAN parties a breeze. Would it be possible to add Xbox download cache to the docker as well?

Thought I'd post this here as it might be useful to some.  I worte a brief guide on how to setup bitwarden with a reverse proxy using our LetsEncrypt container.  It's on the LinuxServer.io blog.  It's

Posted Images

55 minutes ago, Danuel said:

does anyone have a Minio.conf.sample file for letsencrypt ?

server {
	listen 80;
	server_name minio.yourdomain.com;
	return 301 https://$server_name$request_uri;
}

server {
    listen 443 ssl;
    server_name  minio.yourdomain.com;
    
    ssl_certificate /config/keys/letsencrypt/fullchain.pem;
    ssl_certificate_key /config/keys/letsencrypt/privkey.pem;
    ssl_prefer_server_ciphers on;

    # To allow special characters in headers
	 ignore_invalid_headers off;
	 # Allow any size file to be uploaded.  
	 # Set to a value such as 1000m; to restrict file size to a specific value
	 client_max_body_size 0;
	 # To disable buffering
	 proxy_buffering off;
	
	location / {
		proxy_set_header Host $http_host;
		proxy_pass http://X.X.X.X:9768;
	}
}

 

Link to post
On 8/3/2020 at 8:43 PM, cheesemarathon said:

server {
	listen 80;
	server_name minio.yourdomain.com;
	return 301 https://$server_name$request_uri;
}

server {
    listen 443 ssl;
    server_name  minio.yourdomain.com;
    
    ssl_certificate /config/keys/letsencrypt/fullchain.pem;
    ssl_certificate_key /config/keys/letsencrypt/privkey.pem;
    ssl_prefer_server_ciphers on;

    # To allow special characters in headers
	 ignore_invalid_headers off;
	 # Allow any size file to be uploaded.  
	 # Set to a value such as 1000m; to restrict file size to a specific value
	 client_max_body_size 0;
	 # To disable buffering
	 proxy_buffering off;
	
	location / {
		proxy_set_header Host $http_host;
		proxy_pass http://X.X.X.X:9768;
	}
}

 

thank you, worked

 

but, there is any way to add more users ?

Link to post
25 minutes ago, cheesemarathon said:

i did saw that guide but does not help me 

 

from minio terminal,  mc admin user add myminio newuser newuser123

if i type minio -h in terminal 

/ # minio -h
NAME:
  minio - High Performance Object Storage

DESCRIPTION:
  Build high performance data infrastructure for machine learning, analytics and application data workloads with MinIO

USAGE:
  minio [FLAGS] COMMAND [ARGS...]

COMMANDS:
  server   start object storage server
  gateway  start object storage gateway
  
FLAGS:
  --certs-dir value, -S value  path to certs directory (default: "/root/.minio/certs")
  --quiet                      disable startup information
  --anonymous                  hide sensitive information from logging
  --json                       output server logs and startup information in json format
  --help, -h                   show help
  --version, -v                print the version

 

so i don't see  any option to add more users

Link to post
2 minutes ago, Danuel said:

i did saw that guide but does not help me 

 

from minio terminal,  mc admin user add myminio newuser newuser123

if i type minio -h in terminal 

/ # minio -h
NAME:
  minio - High Performance Object Storage

DESCRIPTION:
  Build high performance data infrastructure for machine learning, analytics and application data workloads with MinIO

USAGE:
  minio [FLAGS] COMMAND [ARGS...]

COMMANDS:
  server   start object storage server
  gateway  start object storage gateway
  
FLAGS:
  --certs-dir value, -S value  path to certs directory (default: "/root/.minio/certs")
  --quiet                      disable startup information
  --anonymous                  hide sensitive information from logging
  --json                       output server logs and startup information in json format
  --help, -h                   show help
  --version, -v                print the version

 

so i don't see  any option to add more users

Minio is controlled via minio client

https://docs.min.io/docs/minio-client-quickstart-guide.html

Read those then you should better understand how to add users. 

 

FYI I've not done this myself

Link to post
  • 1 month later...

Hi, 

 

I was hoping someone could give me a nudge in the right direction. 

 

I'm trying to setup OAuth2 and have followed the guide here; OAuth2 Guide

 

My problem however is that I am receiving a "Failed to load config: unable to load config file: While parsing config: (1, 1): unexpected token" error. I've gone over the config file several times and I can't see where I have formatted it incorrectly. 

 

For reference, I am trying to set this up for my remote access to bitwarden. Once I get it working I hope to expand it to my other containers. 

 

I have included some screenshots below in the hopes that someone can point out my mistake.

 

Many thanks. 

 

 

20200914_120124.jpg

 

20200914_115629.jpg

 

20200914_120208.jpg

 

20200914_115650.jpg

20200914_115923.jpg

20200914_115957.jpg

Edited by LoneTraveler
Link to post
On 9/14/2020 at 12:09 PM, LoneTraveler said:

Hi, 

 

I was hoping someone could give me a nudge in the right direction. 

 

I'm trying to setup OAuth2 and have followed the guide here; OAuth2 Guide

 

My problem however is that I am receiving a "Failed to load config: unable to load config file: While parsing config: (1, 1): unexpected token" error. I've gone over the config file several times and I can't see where I have formatted it incorrectly. 

 

For reference, I am trying to set this up for my remote access to bitwarden. Once I get it working I hope to expand it to my other containers. 

 

I have included some screenshots below in the hopes that someone can point out my mistake.

 

Many thanks. 

 

 

20200914_120124.jpg

 

20200914_115629.jpg

 

20200914_120208.jpg

 

20200914_115650.jpg

20200914_115923.jpg

20200914_115957.jpg

Everything there looks ok. Have you put an email in the emails.cfg file to authenticate against?

Link to post
21 minutes ago, cheesemarathon said:

Everything there looks ok. Have you put an email in the emails.cfg file to authenticate against?

Hi, 

 

Many thanks for replying.

 

I have just the one email address in the emails.cfg file, and it's the same one that I use to login to my Google account to obtain the client ID. 

 

20200915_131556.jpg

 

***Edit - Just to add a little further, I've completed up to step 12 of "OAuth2 Proxy Setup", however it is here that I am getting stuck as the container will not start, preventing me from moving on to the next step of "configuring NGINX". 

Edited by LoneTraveler
Link to post
22 hours ago, LoneTraveler said:

Hi, 

 

Many thanks for replying.

 

I have just the one email address in the emails.cfg file, and it's the same one that I use to login to my Google account to obtain the client ID. 

 

20200915_131556.jpg

 

***Edit - Just to add a little further, I've completed up to step 12 of "OAuth2 Proxy Setup", however it is here that I am getting stuck as the container will not start, preventing me from moving on to the next step of "configuring NGINX". 

Can you confirm what files you have in /mnt/user/appdata/oauth2/

 

You should have emails.cfg and oauth2_proxy.cfg

I couldn't tell from your screenshot.

Link to post
1 minute ago, cheesemarathon said:

Can you confirm what files you have in /mnt/user/appdata/oauth2/

 

You should have emails.cfg and oauth2_proxy.cfg

I couldn't tell from your screenshot.

Hi, 

 

Yes, those are the only two files I have in that folder; emails.cfg and oauth2_proxy.cfg

 

Regards. 

Link to post
18 minutes ago, LoneTraveler said:

Hi, 

 

Yes, those are the only two files I have in that folder; emails.cfg and oauth2_proxy.cfg

 

Regards. 

Then the only thing I can think is that perhaps your line endings have gone wrong. I have attached my config, minus my secrets. I marked the values that you need to replace with REPLACE_ME then replace your existing config with my one, as I know mine works.

 

Make sure you use an editor that adheres to linux file line endings such as notepad++

oauth2_proxy.cfg

Link to post
13 minutes ago, cheesemarathon said:

Then the only thing I can think is that perhaps your line endings have gone wrong. I have attached my config, minus my secrets. I marked the values that you need to replace with REPLACE_ME then replace your existing config with my one, as I know mine works.

 

Make sure you use an editor that adheres to linux file line endings such as notepad++

oauth2_proxy.cfg 1.8 kB · 0 downloads

You're a gent, thank you very much! 

Link to post
1 hour ago, LoneTraveler said:

Worked like a charm, thank you very much! 

 

Can I just clarify a small point please, in the "cookie_domains" field, do you put your top level domain url (ie mydomain.com) or do you list each page you want to protect (ie nextcloud.mydomain.com, bitwarden.mydomain.com etc)? 

20200916_123254.jpg

Top level domain only

Link to post
  • 2 months later...

Can someone please advise me on how to pass my postgres docker to the Taskcafe docker template? 

I have a postgres11 docker named "postgres-taskcafe" running on <my_unraid_ip>:5433

In the Taskcafe template I have tried passing the following into TASKCAFE_DATABASE_HOST: postgres-taskcafe; <my_unraid_ip>:5433
 

With the following error: error="dial tcp: lookup postgres-taskcafe on 1.1.1.1:53: no such host"

Network Type set to "Bridge" like the rest of my dockers. I'm sure I'm making a noob mistake. Thanks in advance!

Link to post
  • 3 weeks later...
On 11/20/2020 at 10:18 PM, njdowdy said:

Can someone please advise me on how to pass my postgres docker to the Taskcafe docker template? 

I have a postgres11 docker named "postgres-taskcafe" running on <my_unraid_ip>:5433

In the Taskcafe template I have tried passing the following into TASKCAFE_DATABASE_HOST: postgres-taskcafe; <my_unraid_ip>:5433
 

With the following error: error="dial tcp: lookup postgres-taskcafe on 1.1.1.1:53: no such host"

Network Type set to "Bridge" like the rest of my dockers. I'm sure I'm making a noob mistake. Thanks in advance!

Set the Postgresql docker to 'host' for network type. The default port 5432 is used in the TASKCAFE docker for Postgres and that can not be changed currently.

 

Also, make sure to set the DB_NAME to 'taskcafe' in the Postgresql docker

 

NOTE: I am stuck at the login screen and not able register a new user. That option does not work yet. I also, do not get the 'first start install' to happen.

Link to post
  • 1 month later...

I managed to get the Ghost docker running with MariaDB. After an initial hiccup with logging into Ghost admin (a Firefox restart fixed it), everything seems fine from mydomain.net/blog and mydomain.net/blog/ghost.

 

But if I tried to access it internally at my.ip/blog or my.ip/blog/ghost, I get this Firefox error:

 

Error code: SSL_ERROR_RX_RECORD_TOO_LONG

 

Safari says it can't establish a secure connection to my IP.

 

Has anyone encountered this? I'm guessing it's related to Nginx but my other dockers are accessible.

Edited by vurt
Link to post
On 2/3/2021 at 12:32 AM, vurt said:

I managed to get the Ghost docker running with MariaDB. After an initial hiccup with logging into Ghost admin (a Firefox restart fixed it), everything seems fine from mydomain.net/blog and mydomain.net/blog/ghost.

 

But if I tried to access it internally at my.ip/blog or my.ip/blog/ghost, I get this Firefox error:

 


Error code: SSL_ERROR_RX_RECORD_TOO_LONG

 

Safari says it can't establish a secure connection to my IP.

 

Has anyone encountered this? I'm guessing it's related to Nginx but my other dockers are accessible.

I believe it is because ghost is expecting a connection over https. Your ssl cert is bound to your domain name so browsing to it via internal IP things are not gonna match up.

 

Just browse it via your domain and you will be fine. You haven't  done anything wrong.

Link to post
  • 4 weeks later...
On 2/5/2021 at 3:52 AM, cheesemarathon said:

I believe it is because ghost is expecting a connection over https. Your ssl cert is bound to your domain name so browsing to it via internal IP things are not gonna match up.

 

Just browse it via your domain and you will be fine. You haven't  done anything wrong.

 

Ah interesting, that makes sense but the error it gave doesn't seem related to the cause. This will be the first time I haven't done anything wrong—I always default to user (me) error  😅

 

Thank you and sorry for the extremely late response! The forum doesn't email notifications and I don't come here much.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.