Capital letters in avahi service name


Recommended Posts

The SMB and AFP avahi services are showing in capital letters, and I've verified this is not a Finder issue (searched bonjour services and confirmed same thing). The unRAID server identifier name, and the hostname of the server, isn't capitalised.

 

Example: Storage -> STORAGE

 

I've had this problem for as long as I can remember, on multiple macOS client machines over multiple OS versions. Anyone else experience this? I see it's just taking the %h var in the avahi service config, that may be the culprit.

 

Just my OCD, but it occasionally annoys me  ;D

Screen_Shot_2017-01-27_at_10_15.44_PM.png.47a848ecbdc63b52ae3c95a66084d385.png

Link to comment

The SMB and AFP avahi services are showing in capital letters, and I've verified this is not a Finder issue (searched bonjour services and confirmed same thing). The unRAID server identifier name, and the hostname of the server, isn't capitalised.

 

Example: Storage -> STORAGE

 

I've had this problem for as long as I can remember, on multiple macOS client machines over multiple OS versions. Anyone else experience this? I see it's just taking the %h var in the avahi service config, that may be the culprit.

 

Just my OCD, but it occasionally annoys me  ;D

 

See if this works: edit the one of the /etc/avahi/services files, eg, /etc/avahi/services/smb.service and change:

 

 <name replace-wildcards='yes'>%h</name>

 

to

 

 <name>Tower</name>

 

(of course use your server name instead of "Tower")

 

I think avahi should see the file change and restart itself.  Then check if name shows up like you want.

Link to comment

Looking into this a bit, I don't think it's an avahi issue; changing the %h to the actual server name does not affect the string shown in Finder.  I've noticed the server name shows up in all caps under windows 10 Network as well.

 

If you look at /etc/samba/smb-names.conf the server name is set to mixed case, but if you use the 'testparm -sv' command it looks like Samba is internally setting the string to upper case.  ???

Link to comment

Hey I should tell you about a little 'undocumented' feature  :o

 

If you look in /boot/config/share.cfg file you should see these lines:

 

shareAvahiEnabled="yes"
shareAvahiSMBName="%h"
shareAvahiSMBModel="Xserve"
shareAvahiAFPName="%h-AFP"
shareAvahiAFPModel="Xserve"

 

Those strings are what get put into the /etc/avahi/services/smb.service and afp.service files.  Never got around to creating a webGui control for those, but you should be able to edit the file and change the "%h" to "Storage" or anything you want.

 

I don't know if this is relevant to the issue at hand.

Link to comment

Strange, but it's now working. Avahi services must cache, even after a reload. Changing the hostname manually fixed the issue.

 

cat /etc/avahi/avahi-daemon.conf

.....

host-name=Storage

You're think it's ahahi?  That package has not changed in almost a year.

 

Not sure - would need to do some testing. I doubt it's Avahi...  would be interesting to see what you see if you use

avahi-browse -a

at your end. Use

dns-sd -B

if you have a Mac to test with as well.

 

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.