Jump to content
limetech

unRAID OS version 6.3.0 Stable Release Available

324 posts in this topic Last Reply

Recommended Posts

Upgraded without issue. Everything is acting as it should. I do have one question, what is the correct ssh cmd to safety shutdown the server? I tried "/sbin/shutdown now" but that caused my server to hang. If I use the web GUI to shutdown it works fine so I am assuming I am doing something wrong from the cmd.

Share this post


Link to post

Upgraded without issue. Everything is acting as it should. I do have one question, what is the correct ssh cmd to safety shutdown the server? I tried "/sbin/shutdown now" but that caused my server to hang. If I use the web GUI to shutdown it works fine so I am assuming I am doing something wrong from the cmd.

powerdown

will do a safe shutdown

Share this post


Link to post

Perfect.  Check the flash for corruption (and also look at what's in config/plugins/dockerMan/templates-user)  You might have to copy from that folder in the backup to the flash drive.  *Should* bring everything back after a reboot

 

Squid, looking in templates-user I see that it's empty. Heh..

 

Ok.. so it sounds like you're saying:

 

1) Shut the server down and pull the flash

2) Check flash in Windows for errors

3) Copy the contents of templates-user back to the flash

4) Restart server and do the parity check

 

Am I understanding that correctly?

 

And thanks again for the help

Share this post


Link to post

Upgraded without issue. Everything is acting as it should. I do have one question, what is the correct ssh cmd to safety shutdown the server? I tried "/sbin/shutdown now" but that caused my server to hang. If I use the web GUI to shutdown it works fine so I am assuming I am doing something wrong from the cmd.

powerdown

will do a safe shutdown

 

Perfect, that worked. Thanks Squid. I was under the wrong understanding that the powerdown command was deprecated with the powerdown plugin. Glad I was wrong.

Share this post


Link to post

Perfect.  Check the flash for corruption (and also look at what's in config/plugins/dockerMan/templates-user)  You might have to copy from that folder in the backup to the flash drive.  *Should* bring everything back after a reboot

 

Squid, looking in templates-user I see that it's empty. Heh..

 

Ok.. so it sounds like you're saying:

 

1) Shut the server down and pull the flash

2) Check flash in Windows for errors

3) Copy the contents of templates-user back to the flash

4) Restart server and do the parity check

 

Am I understanding that correctly?

 

And thanks again for the help

You got it.  (Although step 2A is going to be to restart the server so you can copy them from the backup share)

Share this post


Link to post

Just upgraded to latest 6.3.0 and for some reason now I have no user shares?

 

I see my shares listed under:

 

NAS:/boot/config/shares# ls

Apps.cfg*        Movies.cfg*  Pictures.cfg*  appdata.cfg*

Documentary.cfg*  Music.cfg*  TV.cfg*        domains.cfg*

Games.cfg*        Nokdim.cfg*  VM.cfg*        system.cfg*

 

but in the web gui and browsing by samba I only see the disk shares not the user shares...

Share this post


Link to post

more /etc/samba/smb-shares.conf

 

        path = /boot

        comment = unRAID Server OS boot device

        browseable = yes

        # Public

        public = yes

        writeable = yes

        map archive = no

        map system = no

        map hidden = no

        map readonly = yes

        create mask = 0777

        directory mask = 0777

        vfs objects =

[disk1]

        path = /mnt/disk1

        comment =

        browseable = yes

        # Public

        public = yes

        writeable = yes

        ea support = yes

        vfs objects = catia fruit streams_xattr

        fruit:resource = file

        fruit:metadata = netatalk

        fruit:locking = none

        fruit:encoding = native

[disk2]

        path = /mnt/disk2

        comment =

        browseable = yes

        # Public

        public = yes

        writeable = yes

        ea support = yes

        vfs objects = catia fruit streams_xattr

        fruit:resource = file

        fruit:metadata = netatalk

        fruit:locking = none

        fruit:encoding = native

[disk3]

        path = /mnt/disk3

        comment =

        browseable = yes

        # Public

        public = yes

        writeable = yes

        ea support = yes

        vfs objects = catia fruit streams_xattr

        fruit:resource = file

        fruit:metadata = netatalk

        fruit:locking = none

        fruit:encoding = native

[disk4]

        path = /mnt/disk4

        comment =

        browseable = yes

        # Public

        public = yes

        writeable = yes

        ea support = yes

        vfs objects = catia fruit streams_xattr

        fruit:resource = file

        fruit:metadata = netatalk

        fruit:locking = none

        fruit:encoding = native

[disk5]

        path = /mnt/disk5

        comment =

        browseable = yes

        # Public

        public = yes

        writeable = yes

        ea support = yes

        vfs objects = catia fruit streams_xattr

        fruit:resource = file

        fruit:metadata = netatalk

        fruit:locking = none

        fruit:encoding = native

[cache]

        path = /mnt/cache

        comment =

        browseable = yes

        # Public

        public = yes

        writeable = yes

        ea support = yes

        vfs objects = catia fruit streams_xattr

        fruit:resource = file

        fruit:metadata = netatalk

        fruit:locking = none

        fruit:encoding = native

 

Share this post


Link to post

You got it.  (Although step 2A is going to be to restart the server so you can copy them from the backup share)

 

Thanks Squid!  Looks like we're good now. 

 

EDIT: Although I have no idea why the upgrade to 6.3.0 hung in the first place :)

Share this post


Link to post

more /etc/samba/smb-shares.conf

 

        path = /boot

        comment = unRAID Server OS boot device

        browseable = yes

        # Public

        public = yes

        writeable = yes

        map archive = no

        map system = no

        map hidden = no

        map readonly = yes

        create mask = 0777

        directory mask = 0777

        vfs objects =

[disk1]

        path = /mnt/disk1

        comment =

        browseable = yes

        # Public

        public = yes

        writeable = yes

        ea support = yes

        vfs objects = catia fruit streams_xattr

        fruit:resource = file

        fruit:metadata = netatalk

        fruit:locking = none

        fruit:encoding = native

[disk2]

        path = /mnt/disk2

        comment =

        browseable = yes

        # Public

        public = yes

        writeable = yes

        ea support = yes

        vfs objects = catia fruit streams_xattr

        fruit:resource = file

        fruit:metadata = netatalk

        fruit:locking = none

        fruit:encoding = native

[disk3]

        path = /mnt/disk3

        comment =

        browseable = yes

        # Public

        public = yes

        writeable = yes

        ea support = yes

        vfs objects = catia fruit streams_xattr

        fruit:resource = file

        fruit:metadata = netatalk

        fruit:locking = none

        fruit:encoding = native

[disk4]

        path = /mnt/disk4

        comment =

        browseable = yes

        # Public

        public = yes

        writeable = yes

        ea support = yes

        vfs objects = catia fruit streams_xattr

        fruit:resource = file

        fruit:metadata = netatalk

        fruit:locking = none

        fruit:encoding = native

[disk5]

        path = /mnt/disk5

        comment =

        browseable = yes

        # Public

        public = yes

        writeable = yes

        ea support = yes

        vfs objects = catia fruit streams_xattr

        fruit:resource = file

        fruit:metadata = netatalk

        fruit:locking = none

        fruit:encoding = native

[cache]

        path = /mnt/cache

        comment =

        browseable = yes

        # Public

        public = yes

        writeable = yes

        ea support = yes

        vfs objects = catia fruit streams_xattr

        fruit:resource = file

        fruit:metadata = netatalk

        fruit:locking = none

        fruit:encoding = native

 

If that is the complete file, you have a flash, disk shares, a cache and no user shares.  That's why you can't see them.

 

Check your shares setup and verify they are enabled for SMB sharing.  If that is ok, I would suggest turning off the disk shares and see if the user shares will show up.

Share this post


Link to post

Just to verify: please boot server once in 'Safe Mode' and see if same behavior exists.  Also make sure "netbios over tcp/ip" is enabled for your win10 PC in network adaptor Properties / Internet Protocol Version 4 (TCP/IPv4) / Advanced / WINS tab

 

To confirm you are talking about booting the unRAID server in maintenance mode or my PC in safe mode?

Share this post


Link to post

Yes that is the whole file.

 

Prior to the upgrade I had user shares, after the upgrade I do not.

 

I will try disabling disk shares and see if user shares show up.

It seems you can have disk and user shares enabled so one should not stop the other.

 

All I want is my shares back to the way it was prior to the upgrade.

Share this post


Link to post

Just to verify: please boot server once in 'Safe Mode' and see if same behavior exists.  Also make sure "netbios over tcp/ip" is enabled for your win10 PC in network adaptor Properties / Internet Protocol Version 4 (TCP/IPv4) / Advanced / WINS tab

 

To confirm you are talking about booting the unRAID server in maintenance mode or my PC in safe mode?

Boot unRAID OS in 'safe mode' - the boot menu option that skips installing plugins.  This is just a sanity check to verify  a plugin is not doing something.

Share this post


Link to post

Yes that is the whole file.

 

Prior to the upgrade I had user shares, after the upgrade I do not.

 

I will try disabling disk shares and see if user shares show up.

It seems you can have disk and user shares enabled so one should not stop the other.

 

All I want is my shares back to the way it was prior to the upgrade.

 

Please post diagnostics.zip file: Tools / Diagnostics

Share this post


Link to post

Yes that is the whole file.

 

Prior to the upgrade I had user shares, after the upgrade I do not.

 

I will try disabling disk shares and see if user shares show up.

It seems you can have disk and user shares enabled so one should not stop the other.

 

All I want is my shares back to the way it was prior to the upgrade.

 

Yes, you should be able to have both disk and user shares.  The user shares checked out?  You might toggle the SMB share export off and then back on.

 

Can you post one of your share.cfg files from the flash and let's see if there is an issue there.

Share this post


Link to post

Yes that is the whole file.

 

Prior to the upgrade I had user shares, after the upgrade I do not.

 

I will try disabling disk shares and see if user shares show up.

It seems you can have disk and user shares enabled so one should not stop the other.

 

All I want is my shares back to the way it was prior to the upgrade.

 

One of the reasons I asked to see the smb-shares.conf file is that the new recycle bin plugin re-writes this file and I wanted to be sure it was not corrupting the file if you have the recycle bin plugin installed.

Share this post


Link to post

I believe Tom has enough information with your diagnostics to figure out the problem.  Your shares look to me to be defined properly, but are not being included in the smb-shares.conf file that tells samba what to share.

Share this post


Link to post

shareUser="e"

 

on file share.cfg

 

 

I think thats the issue... please confirm...

That's normal, the 'e' means 'export'.

What's not normal is log shows /dev/sdh1 is assigned to cache and gets mounted but then a strange entry:

 

Feb  5 15:30:44 Nokdim-NAS preclear.disk: Resuming preclear of disk 'sdh'

 

Something not right about that.

 

Try booting in 'unRAID OS safe mode' and see if user shares appear.

Share this post


Link to post

yep all user shares show up in safe mode...

 

I did also update the pre-clear plugin just before upgrading in case that helps.

Share this post


Link to post

What's not normal is log shows /dev/sdh1 is assigned to cache and gets mounted but then a strange entry:

 

Feb  5 15:30:44 Nokdim-NAS preclear.disk: Resuming preclear of disk 'sdh'

 

Something not right about that.

 

Try booting in 'unRAID OS safe mode' and see if user shares appear.

 

That's a Preclear bug spotted and reported to gfjardim earlier.  In the earlier case, it was harmless, in that the resumed preclear was of sdp, a symbol that did not and had never existed on that user's system.  In this case, you need to reboot as quickly as possible, then check whether your Cache drive has been partially cleared.  I would uninstall the Preclear plugin.

Share this post


Link to post

Just to verify: please boot server once in 'Safe Mode' and see if same behavior exists.  Also make sure "netbios over tcp/ip" is enabled for your win10 PC in network adaptor Properties / Internet Protocol Version 4 (TCP/IPv4) / Advanced / WINS tab

 

To confirm you are talking about booting the unRAID server in maintenance mode or my PC in safe mode?

 

Boot unRAID OS in 'safe mode' - the boot menu option that skips installing plugins.  This is just a sanity check to verify  a plugin is not doing something.

 

 

Ok, don't wait around for it.  I'm off to work and with the server buried in a basement closet with no monitor or keyboard it's going to take some time.

 

Unless there is a way I can reboot into safe mode via a console session or the webgui.

Share this post


Link to post

What's not normal is log shows /dev/sdh1 is assigned to cache and gets mounted but then a strange entry:

 

Feb  5 15:30:44 Nokdim-NAS preclear.disk: Resuming preclear of disk 'sdh'

 

Something not right about that.

 

Try booting in 'unRAID OS safe mode' and see if user shares appear.

 

That's a Preclear bug spotted and reported to gfjardim earlier.  In the earlier case, it was harmless, in that the resumed preclear was of sdp, a symbol that did not and had never existed on that user's system.  In this case, you need to reboot as quickly as possible, then check whether your Cache drive has been partially cleared.  I would uninstall the Preclear plugin.

 

I removed the preclear plugin and rebooted and still dont see user shares.

Also I dont care about data loss on cache drive worse comes to worse a show I had on DVR will get lost.

I just want my user shares back...

Share this post


Link to post

What's not normal is log shows /dev/sdh1 is assigned to cache and gets mounted but then a strange entry:

 

Feb  5 15:30:44 Nokdim-NAS preclear.disk: Resuming preclear of disk 'sdh'

 

Something not right about that.

 

Try booting in 'unRAID OS safe mode' and see if user shares appear.

 

That's a Preclear bug spotted and reported to gfjardim earlier.  In the earlier case, it was harmless, in that the resumed preclear was of sdp, a symbol that did not and had never existed on that user's system.  In this case, you need to reboot as quickly as possible, then check whether your Cache drive has been partially cleared.  I would uninstall the Preclear plugin.

 

I removed the preclear plugin and rebooted and still dont see user shares.

Also I dont care about data loss on cache drive worse comes to worse a show I had on DVR will get lost.

I just want my user shares back...

Try stopping the array, and selecting No Device for the cache drive and then restarting the array

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.