Jump to content
craigr

upgraded to 6.3 now can't access private shares ?!? HELP!

13 posts in this topic Last Reply

Recommended Posts

So I upgraded to 6.3 last night and now cannot access SMB private shares anymore on my DUNE media players.  I can access the private shares on Windows 7 still.

 

If I make a share public I can access it from the DUNE players again... I don't want my shares to be public.

 

If I go back to version 6.2.4 everything works fine again, but my Docker is messed up when I copy the files from the "previous" directory over the root on /boot/

 

I have tried resetting the passwords on my users.  I have tried creating new users.  Nothing I can think of works.

 

Is there some way to preserve Docker and go back to 6.2.4?  I will do this at least until I can sort out what's going on with private shares.  Anyone have any suggestions on fixing my DUNE problem with private shares?

 

This has consumed about 10 hours of my life already  :-\

 

Thanks,

craigr

Share this post


Link to post

Well, I managed to get back to 6.2.4 and saved my entire config including docker and apps.  Everything works perfectly with the DUNE players on 6.2.4, but with 6.3 the DUNE players cannot access private shares.

 

Any ideas?

 

Thanks again,

craigr

Share this post


Link to post

There are other threads where this has been discussed since the release, including the release thread itself.

Share this post


Link to post

Thank, your search link helps :)

 

Hopefully I will find a solution, but at least I can report.

 

craigr

Share this post


Link to post

I was initially going to post that my DuneHD was working, but I realized I had my shares set to "secure" not "private".

 

To get it working in "Private" mode, add

ntlm auth = yes

 

to your samba.conf in settings -> SMB and restart samba.

Share this post


Link to post

I was initially going to post that my DuneHD was working, but I realized I had my shares set to "secure" not "private".

 

To get it working in "Private" mode, add

ntlm auth = yes

 

to your samba.conf in settings -> SMB and restart samba.

 

Howdy SnickySnacks, do you feel this may be a general answer to the problems a number of users are having accessing shares from other devices?  If so, I'd like to post it more visibly.  And can you add to your post how new users would restart Samba?

Share this post


Link to post

I was initially going to post that my DuneHD was working, but I realized I had my shares set to "secure" not "private".

 

To get it working in "Private" mode, add

ntlm auth = yes

 

to your samba.conf in settings -> SMB and restart samba.

 

Howdy SnickySnacks, do you feel this may be a general answer to the problems a number of users are having accessing shares from other devices?  If so, I'd like to post it more visibly.  And can you add to your post how new users would restart Samba?

 

 

I'm not sure it's a general answer (I was able to connect on Windows 10 in private mode regardless). It likely only affects devices that use the older NTLM1 authentication.

 

My debugging steps went like this:

Added to samba.conf:

log level=2

syslog=3

 

reloaded config from telnet:

smbcontrol smbd reload-config

 

Saw in the syslog:

"NTLMv1 passwords NOT PERMITTED for user"

 

This indicated that my device was using the older protocol which was likely disabled for security reasons.

 

Adding

ntlm auth = yes

then:

smbcontrol smbd reload-config

 

allowed the older authentication.

 

This shouldn't make a difference for like windows 10 (which people seem to be having a problem with), but some devices that don't support NTLMv2 may require it.

 

From the smb.conf manpage

https://www.samba.org/samba/docs/man/manpages-3/smb.conf.5.html

 

ntlm auth (G)

 

This parameter determines whether or not smbd(8) will attempt to authenticate users using the NTLM encrypted password response. If disabled, either the lanman password hash or an NTLMv2 response will need to be sent by the client.

 

If this option, and lanman auth are both disabled, then only NTLMv2 logins will be permited. Not all clients support NTLMv2, and most will require special configuration to use it.

 

Default: ntlm auth = yes

 

Looks like unraid or a more recent samba version is defaulting this to "no".

Share this post


Link to post

I'm having the same type of issues with my wdtv live box and private shares.  And activating ntlm in the config didn't help either.  I'm probably going to have to go back to 6.2.4 till all this is resolved...

Share this post


Link to post

I'm having the same type of issues with my wdtv live box and private shares.  And activating ntlm in the config didn't help either.  I'm probably going to have to go back to 6.2.4 till all this is resolved...

 

Feel free to enable the syslog/log level settings and see what the syslog says about why your connection is failing.

It may give some insight.

Share this post


Link to post

I'm having the same type of issues with my wdtv live box and private shares.  And activating ntlm in the config didn't help either.  I'm probably going to have to go back to 6.2.4 till all this is resolved...

 

Feel free to enable the syslog/log level settings and see what the syslog says about why your connection is failing.

It may give some insight.

 

Thanks, good idea!  I'll try and look at this tomorrow when I get some time.

Share this post


Link to post

I have a “WD TV Live Streaming Media Player (3rd Generation)” and to add “ntlm auth = yes” on my samba.conf works for me.

After a restart of my Media Player and my Unraid Server it access private Shares like before on Version 6.2.4.

Share this post


Link to post

I have a “WD TV Live Streaming Media Player (3rd Generation)” and to add “ntlm auth = yes” on my samba.conf works for me.

After a restart of my Media Player and my Unraid Server it access private Shares like before on Version 6.2.4.

 

Thanks for posting.  I just did a factory reset of my wdtv live box and now everything is working again.

Share this post


Link to post

I was initially going to post that my DuneHD was working, but I realized I had my shares set to "secure" not "private".

 

To get it working in "Private" mode, add

ntlm auth = yes

 

to your samba.conf in settings -> SMB and restart samba.

 

Woohoo this got my DUNE's working with private shares again!  Thank you, thank you, thank you!!!

 

unRAID_SMB.jpg

 

craigr

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now