[6.2.4]Minor: Appdata not showing as cache only but works right


2 posts in this topic Last Reply

Recommended Posts

Description:

When I go into the appdata share, it should be set to only cache but it isn't. It seems to be only using the cache right now.

Although it may just be because the folder was already there and it continues to fill data into the same folder because the tree settings don't allow it to go into data. This may be the case even though the help description says "No prohibits new files and subdirectories from being written onto the Cache disk/pool."

How to reproduce:

I have no idea...

Expected results:

Should show "Only" in cache section

Actual results:

Says "No" for cache

Other information:

Not sure when it got moved from "Only" to "No", maybe during an upgrade of unraid or maybe when I upgraded the cache drive but I went and reset it back to Only.

unraid-diagnostics-20170209-1848.zip

Share.JPG.16faf06b41a11560f934dac8a96cd443.JPG

Index_of_Share.JPG.374fffc6fdc15595e9eb5ccc38ce4627.JPG

Link to post

No idea why the setting should have changed to 'no'

 

A setting of 'no' does not mean existing files get moved to the data disks.    In fact it means that NEW files are written to the data disks but existing files on the cache disk are NEVER moved to the data disks.

 

You probably want a value of "Prefer' instead of 'only' as this would ensure that if any files have been created on the data disks they will get moved to the cache disk.  If there are no files for the share on the data disks then 'prefer' is functionally equivalent to 'only'.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.