[6.3.1] Kernel Panic - USB Passthru


4 posts in this topic Last Reply

Recommended Posts

Hi,

 

The following lines used to work before 6.3.1 upgrade.

 

    <hostdev mode='subsystem' type='pci' managed='yes'>

      <driver name='vfio'/>

      <source>

        <address domain='0x0000' bus='0x81' slot='0x0' function='0x0'/>

      </source>

    </hostdev>

 

With 6.3.1, I get server restarts as soon as I launch my Win7 VM.

 

Thanks,

Ruben

Link to post

I'm afraid there's practically no information here, for us to even comment on what may or may not be wrong.  Please see Need help? Read me first!, and attach the diagnostics zip.

 

With nothing to go on, this will probably be moved to a support thread.  If it is determined there is a system defect here, then we can move it back.

Link to post

This is the USB card I was trying to pass

IOMMU group 35

[RESET] 81:00.0 USB controller [0c03]: Fresco Logic FL1100 USB 3.0 Host Controller [1b73:1100] (rev 10)

 

Last line from /var/log/libvirt/qemu/Win7.log

2017-02-16T02:31:22.989230Z qemu-system-x86_64: -device vfio-pci,host=81:00.0,id=hostdev0,bus=pci.0,addr=0x6: Failed to mmap 0000:81:00.0 BAR 2. Performance may be slow

 

Once I get the error a hard reboot is required.

 

Thanks,

Ruben

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.