"Error: layers from manifest don't match image configuration"


madpoet

7 posts in this topic Last Reply

Recommended Posts

So I upgraded to the latest unRaid stable, and was futzing around with my Docker images and checked for updates.  They all say they need an update but when I try and do it I get the following after it pulls the image: "Error: layers from manifest don't match image configuration".  I don't know what I did wrong (I assume it was my fault somewhere) but now I'm stuck unable to perform any upgrades.  Normally I'd shrug it off and try to start over but I've got a pretty massive Plex config in there that I really, really don't want to lose.  Any suggestions?

 

Thanks,

Paul

Link to post

Refering to this: http://lime-technology.com/forum/index.php?topic=51874.msg497876#msg497876

Quote

- Those having Docker issues (such as no Docker tab, "layers from manifest" error, no working dockers, all Dockers need upgrade, etc), the common solution recommended seems to be the same - in Docker configuration, delete your docker.img, recreate it again (not on an unassigned drive!), then reinstall your Docker apps through Community Application's Previous Apps section or via the my* templates.  Your apps will be back the exact same way as before, with no adjustment of the volume mappings, ports, etc required.  This should be easy, fairly quick, a one-time operation.

Link to post
  • 6 months later...

Hi there, I just went to Settings -> Docker and can't see anywhere to delete docker.img?  Or is this done via the command line/console?  I am having issues updating Plex.

 

Docker storage location: /mnt/cache/Docker

Appdata storage:   /mnt/user/appdata/

 

Are these paths correct?  I'm running the latest version of Unraid.

Link to post
3 hours ago, Bizarro said:

Hi there, I just went to Settings -> Docker and can't see anywhere to delete docker.img?  Or is this done via the command line/console?  I am having issues updating Plex.

 

Docker storage location: /mnt/cache/Docker

Appdata storage:   /mnt/user/appdata/

 

Are these paths correct?  I'm running the latest version of Unraid.

Stop Docker.  Turn on advanced view in top right.  Delete image.  Restart Docker.

 

Re-add your applications:

 

Link to post

That did the trick, just had to delete the Plex docker entirely.  Re-downloaded via Community Applications vs the templates, and had to set up all the paths again.  Hopefully it doesn't need to rescan all my media, I have kept the path to the existing config file.  Thanks for your help :)

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.