Virtual Windows 10 display set at 800 x 600


JohnSnyder

17 posts in this topic Last Reply

Recommended Posts

I have the latest version of unRAID.  I've installed a Windows 10 virtual machine.  When I connect to the virtual machine with the Windows RDP, the screen resolution of the virtual machine adjusts itself to the size of the window in which I run it - all the way up to 3840 x 2160.  However, when I use NoMachine to connect, I can only connect with an 800 x 600 resolution.  In its control panel, the virtual machine shows a display resolution of 800 x 600 and no other.  Apparently the VirtIO display driver has decided that this is the proper resolution and won't allow any other.

 

The resolution isn't a problem when I connect with Windows RDP.  However, I've also got Linux virtual machines, some of which I cannot get to connect with Windows RDP.  Therefore my interest in NoMachine.

 

How can I convince the VirtIO display driver to allow me to change the screen resolution of my virtual machines beyond the 800 x 600 that it has so far offered to me? 

 

Edited by JohnSnyder
Clarify the wording in the title
Link to post

You need to install the graphics driver for the display adapter. Open device manager, look for the display adapter (should say Microsoft Basic Display Adapter). Right click it and select update driver. Point it to the qxl folder on your Virtio ISO disk and let 'er rip!

Sent from my SM-G930P using Tapatalk

Link to post
I've done that, and still all I get is the 800 x 600 option - nothing more.
 
Anything else I can do?


There has to be a step missing or something else as I do the exact same thing and the option to increase the resolution is available under display properties.

Sent from my SM-G930P using Tapatalk

Link to post
13 hours ago, Skir said:

Hi JohnSnyder,

 

wich BIOS do you use?  OVFM or SeaBIOS ?

 

On my Unraid i can only install Windows 10 with SeaBIOS and all Resulutions.

 

I just installed a WS 2016. Used OVFM Bios, and after installing drivers for the display adapter i can change resolution. Shouldn't be a problem.

Link to post
  • 1 month later...
On 2/24/2017 at 1:30 PM, JohnSnyder said:

I've done that, and still all I get is the 800 x 600 option - nothing more.

 

Anything else I can do?

@JohnSnyder did you ever end up resolving this? I'm having the same issue, except with TeamViewer rather thanNoMachine. Additionally, I'm not able to RDP to my Windows 10 box, it's on a different network than either my server or my desktop, so not sure what the deal is there. Any help would be appreciated.

Link to post
  • 3 months later...
On 09/04/2017 at 3:13 AM, master.h said:

@JohnSnyder Additionally, I'm not able to RDP to my Windows 10 box, it's on a different network than either my server or my desktop, so not sure what the deal is there. Any help would be appreciated.

This will be because you have the network for the VM set to use virbr0 which is a NAT style connection.    If you want the VM visible on the network you need to use a bridged connection (typically called br0).  You do need to have enabled bridged networking under the unRAID network settings to have this offered as an option.

Link to post
  • 7 months later...

I'm also having this same problem, although I have 3 resolutions (800x600, 1024x768, 1280x1024).

 

I'm using SeaBIOS (I can get Windows to pass the startup screen if I use the other one), Windows 10 (latest as of 3/22/2018--took a LONG time to update once installed), and the latest virtio drivers.

 

I'm stuck and a bit frustrated. I've built Windows 10 VM's in UNRAID before and this never happened.

 

Thoughts?

Link to post
  • 1 year later...
  • 8 months later...
  • 1 month later...
On 2/11/2020 at 11:00 AM, imyourdaddy said:

Hey,

 

I know this is way late to the party, but I had the same issue as OP - initially. However, I looked and saw the "qxldod" folder and that worked for me. I was able to get 1920 x 1080. It seems the "qxl" folder doesn't contain Win 10 drivers.

 

I hope this helps!

I tried everything else, but this tip was the one that did the trick!

Link to post
  • 1 month later...
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.