Jump to content
ninthwalker

[Support] Ninthwalker Docker Repository [plexReport, slack-invite, DashBtn]

36 posts in this topic Last Reply

Recommended Posts

dockerrepoimg.png

 

 

Support for the following dockers can be discussed here.

 

App name: DashBtn

Docker Hub: https://hub.docker.com/r/ninthwalker/dashbtn/

Github: https://github.com/ninthwalker/DashBtn

 

This is a Docker for use with Amazon Dash Button's.

It intercepts the button press and allows you to do various home automation tasks.

ie: Turn on lights, start a movie for your kid, notifications, order a pizza, etc.

Use this docker to create your own scripts using Python, Shell, curl, & the plexapi.

 

_________________________________________________


 

App name: slack-invite

Docker Hub: https://hub.docker.com/r/ninthwalker/slack-invite/

Github: https://github.com/ninthwalker/slack-invite

Original Application site: https://github.com/outsideris/slack-invite-automation

 

This docker generates a simple website to allow users to invite themselves to your slack team.

Created by 'outsideris', this is just an unRAID template with extra non-unRAID items stripped out.

 

_________________________________________________

 

This app is no longer maintained.

We have created a newer, better, faster docker called NowShowing.

Please follow the new thread created for NowShowing Support.

 

App name: plexReport

Docker Hub: https://hub.docker.com/r/ninthwalker/plexreport/

Github: https://github.com/ninthwalker/plexReport

Original Application site: https://github.com/bstascavage/plexReport

 

This docker generates an email summary of new additions to Plex to send to your users.

This is a dockerized version of bstascavage's plexReport app which has fallen by the wayside. Similar in nature to the current PlexEmail, but I personally think this email is a lot better looking and doesn't rely on external image site support.

 

_________________________________________________

 

Installation:

 

Preferred installation method: From the Community Applications 'APPS' section in unRAID.

You can also install by adding the following template repository:

https://github.com/ninthwalker/docker-templates/

 

Edited by ninthwalker

Share this post


Link to post

Hi,

 

Has there been another change to the plexreport docker? seems to have broken with the last update, I got the error;

/usr/local/sbin/plexreport:374:in `initialize': No such file or directory - /config/web_email_body.erb (Errno::ENOENT)                                                from /usr/local/sbin/plexreport:374:in `new'
        from /usr/local/sbin/plexreport:374:in `main'
        from /usr/local/sbin/plexreport:390:in `<main>'


I copied my old email_body.erb to web_email_body.erb and it seems to be working again.

 

Is there a difference with the new file, should I be removing my config files and re-running the ./initial_setup.sh?

 

I don't want to be critical, but it would be nice if you could flag any changes that will need user intervention, I really only notice this docker is broken when my scheduled email doesn't show up.

 

Thanks,

Beau

Share this post


Link to post
11 minutes ago, Wob76 said:

Hi,

 

Has there been another change to the plexreport docker? seems to have broken with the last update, I got the error;


/usr/local/sbin/plexreport:374:in `initialize': No such file or directory - /config/web_email_body.erb (Errno::ENOENT)                                                from /usr/local/sbin/plexreport:374:in `new'
        from /usr/local/sbin/plexreport:374:in `main'
        from /usr/local/sbin/plexreport:390:in `<main>'


I copied my old email_body.erb to web_email_body.erb and it seems to be working again.

 

Is there a difference with the new file, should I be removing my config files and re-running the ./initial_setup.sh?

 

I don't want to be critical, but it would be nice if you could flag any changes that will need user intervention, I really only notice this docker is broken when my scheduled email doesn't show up.

 

Thanks,

Beau

 

I just updated my PlexReport docker and it populated the web_email_body.erb correctly. Running a -t test worked as well without having to re-run any setup.

 

Not sure what the differences are as I don't see any changelog, but it looks like it might of been an issue with the new file being committed vs when the docker file was updated.

Share this post


Link to post

@Wob76

Sorry for the confusion. I think you were unlucky and updated in between my docker push's.

 

The idea behind the additional files is that I am phasing in a new feature of having a webpage as well. This slight update was to add part of that in, but be transparent to the end user. (Obviously it wasn't for you =\ )

 

No initial_setup is needed again.

 

 

 

Edited by ninthwalker

Share this post


Link to post

Ahhh ok, No big drama, it worked again when I copied over my existing erb file, but by the sounds of it I'll need a fresh install if I wish to use the new feature.

 

Thanks,

Wob

Share this post


Link to post

There are some nice plans for the future. I've also begun collaborating with someone else on a rework of plexReport for additional functionality and ease of use. 

 

- Ninthwalker

Share this post


Link to post

@ninthwalker

 

I saw that your new app "NowShowing" has come up as a "Random App of the Day" and thought that I would give it a try running side-by-side with PlexReport. I chose the "dev" branch, because the "Default" one fails to install. Anyway I seem to run into an issue where the file '/config/noshowing_schedule.cron' does not exist - at least that is what the log is showing. Is there an initialization step that needs to be performed prior to use?

 

Logfile Data:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] setup.sh: executing...
cat: can't open '/config/nowshowing_schedule.cron': No such file or directory

Edited by StanC

Share this post


Link to post

@StanC

 

it was unfortunate that the new app got chosen for today's 'app of the day' as it's not quite ready for primetime. Still some more work and features being added which is why it's marked as dev. 

 

Keep using the old plexReport for now as that is working fine. Thanks. 

 

Edit: Although the correct 'dev' branch should be working. I'm wondering if even though you chose dev, it didn't actually change the docker hub repository. It should change it to say ninthwalker/nowshowing:dev in the docker template repository field under advanced settings. 

 

 - Ninthwalker 

Edited by ninthwalker

Share this post


Link to post

Got a warning from Fix Common Problems-

 

Quote

 


Event: Fix Common Problems
Subject: Errors have been found with your server.
Description: Investigate at Settings / User Utilities / Fix Common Problems
Importance

 

**** Docker Application plexReport is currently set up to run in host mode ****   **** Docker Application plexReport, Container Port 8080 not found or changed on installed application ****
 

 

 

Just wondering if there is really some issue with the docker (it is working) or if I should just ignore the warning?

Share this post


Link to post

@wgstarks

 

Ignore those alerts for now.

we will be releasing a new version soon. 

 

But for informations sake, the two alerts are due to the following:

 

port 8080: The next version will feature a webpage component so that alert is due to that not being fully featured yet. 

 

Host mode: This docker has been setup since the beginning in host mode which is not really needed. We are switching it to bridge mode as that is more preferred/secure in dockers eyes. 

 

Hope that helps. Thanks. 

 

- Ninthwalker

Share this post


Link to post

A new App has been added to the Repository:

 

App name: DashBtn

Docker Hub: https://hub.docker.com/r/ninthwalker/dashbtn/

Github: https://github.com/ninthwalker/DashBtn

 

This is a Docker for use with Amazon Dash Button's.

It intercepts the button press and allows you to do various home automation tasks.

ie: Turn on lights, start a movie for your kid, notifications, order a pizza, etc.

Use this docker to create your own scripts using Python, Shell, & curl.

Share this post


Link to post

I'm seeing this error repeated in my docker log-


http: response.WriteHeader on hijacked connection

Logs don't show which docker is generating the error, but based on the time it looks like it must be PlexReport.

Share this post


Link to post
3 hours ago, wgstarks said:

I'm seeing this error repeated in my docker log-

 


http: response.WriteHeader on hijacked connection

 

Logs don't show which docker is generating the error, but based on the time it looks like it must be PlexReport.

I haven't seen that error before, and not sure if it's plexReport or not. A quick search seems more related to a go docker instance, but possibly docker exec related as well. Some more info would help. 

 

The only time plexReport runs is when the report goes out. If you run it with the "-t" option to test then look at the log does it happen right then? Can you duplicate it happening twice?

 

to test:

"docker exec plexReport plexreport -t"

 

if it does happen during those exact few minutes it runs, does the report still go out? Also, check if you can docker exec into it normally and if just that even triggers the error. 

 

"docker exec -it plexReport /bin/bash"

Share this post


Link to post
18 hours ago, ninthwalker said:

to test:

"docker exec plexReport plexreport -t"

This DOES result in the error repeatedly. Report is still going out as expected though.

 

 

 

18 hours ago, ninthwalker said:

Also, check if you can docker exec into it normally and if just that even triggers the error. 

 

"docker exec -it plexReport /bin/bash"

This is also resulting in the error.

Share this post


Link to post
2 hours ago, wgstarks said:

This DOES result in the error repeatedly. Report is still going out as expected though.

 

 

 

This is also resulting in the error.

 

I cant reproduce the error on my side. 

 

Seems like a docker exec issue than the program generating the issue though. Could be related to the base docker image, or possible your unraid/docker version. What is your docker/unraid version?

 

If the report is still sending out, I probably won't look into it much more. We are close to releasing a new docker to replace plexreport anyways so time is being spent on that right now. 

Share this post


Link to post

Was wondering if there is a way besides editing the .erb file to limit the new release info that is shown?

 

Share this post


Link to post
Was wondering if there is a way besides editing the .erb file to limit the new release info that is shown?
 


In what way would you like to limit the release info?


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
1 minute ago, GroxyPod said:

 


In what way would you like to limit the release info?


Sent from my iPhone using Tapatalk Pro

 

I just set this up and sent a test email to myself and have like 30 movies and around 40 episodes. Then new TV series. Sending that much info out on an email is too much. I thought maybe to limit both to around 5 each. This would limit the amount of info and make sending the email quicker.

Share this post


Link to post
26 minutes ago, Harro said:

I just set this up and sent a test email to myself and have like 30 movies and around 40 episodes. Then new TV series. Sending that much info out on an email is too much. I thought maybe to limit both to around 5 each. This would limit the amount of info and make sending the email quicker.

 

We are about to release a new spinoff of this docker actually. It incorporates an advanced file for better customization, as well as additional features like a web page.

 

Specifically for your question, there is not currently a way to do exactly what you describe. The current plexReport docker was hard coded and reports 7 days worth of media.

However in this new advanced file, you can specify the period of days to report on from 1-7.

 

If that is too much, you could select say 2 day's worth to report on, and then send that out once a week.

That will sort of achieve what you are trying to do, although it won't let you pick and choose what Items to report.

 

Share this post


Link to post
1 minute ago, ninthwalker said:

 

We are about to release a new spinoff of this docker actually. It incorporates an advanced file for better customization, as well as additional features like a web page.

 

Specifically for your question, there is not currently a way to do exactly what you describe. The current plexReport docker was hard coded and reports 7 days worth of media.

However in this new advanced file, you can specify the period of days to report on from 1-7.

 

If that is too much, you could select say 2 day's worth to report on, and then send that out once a week.

That will sort of achieve what you are trying to do, although it won't let you pick and choose what Items to report.

 

That sounds excellent. The report as it is now works fine , just that I have too much crap. With the new features I could set it for delivering an email every 2 days and that would sort of keep everything fresh for my family members to see.

 

Thanks .

Share this post


Link to post

NowShowing, the successor to plexReport has been released.

We suggest everyone to install the new NowShowing docker as plexReport will no longer be maintained.

NowShowing provides a lot more features and customization including a web page!

 

See this post for support:

 

 

Share this post


Link to post

I recently had to reformat my cache drive and then reinstall my dockers. I never reinstalled plexreport because I knew it had been replaced, but now I'm seeing these errors-

 

IMG_0964.PNG

Share this post


Link to post
2 hours ago, wgstarks said:

I recently had to reformat my cache drive and then reinstall my dockers. I never reinstalled plexreport because I knew it had been replaced, but now I'm seeing these errors-

 

IMG_0964.PNG

 

It looks like that is probably the cron job from plexReport trying to run but you don't have the plexReport docker installed anymore.

 

If you followed the instructions you probably have a 'plexreport_schedule.cron file on your flash drive in config/plugins somewhere that got loaded at startup. Find the file, delete it and then at the console type 'update_cron' .

 

you can check that it's been removed, by running the below command. You can also manually edit the below file if 'update_cron' didn't work. 

 

'cat /etc/cron.d/root'

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.