Jump to content
ninthwalker

[Support] Ninthwalker - NowShowing

371 posts in this topic Last Reply

Recommended Posts

Just now, GroxyPod said:

 


Were you expecting it to come out at the same time? Because you set it to be two hours after.


Sent from my iPhone using Tapatalk Pro

 

No. Changed the time so that it would run about 10 minutes after I made the change.

Share this post


Link to post
16 minutes ago, wgstarks said:
No. Changed the time so that it would run about 10 minutes after I made the change.

 


Do you see any errors in the docker log after it runs?

 

EDIT: Is the email you are specifying in the advanced config an email address associated with a plex account or separate? If separate, I think the issue has to do with not using -n as a command line switch.

 

Can you run an emailreport test with -n -t? (this just has to do with preventing plex members from getting emailed)



Sent from my iPhone using Tapatalk Pro

 

Edited by GroxyPod

Share this post


Link to post
28 minutes ago, wgstarks said:

According to wikipedia 0 and 7 are both Sunday. Tried changing the cron to 7 though, just to see. Still no email.

 

You're right, my bad. 0-6 would be the correct settings.

Share this post


Link to post

I've been testing with various setting from the command line. It looks like anytime I use report type = combinedreport the email is sent.

If I use emailreport I get this-

root@Brunnhilde:~# docker exec nowshowing emailreport -t -v
/usr/lib/ruby/2.3.0/net/protocol.rb:211:in `write': Connection reset by peer (Errno::ECONNRESET)
	from /usr/lib/ruby/2.3.0/net/protocol.rb:211:in `write0'
	from /usr/lib/ruby/2.3.0/net/protocol.rb:193:in `block in writeline'
	from /usr/lib/ruby/2.3.0/net/protocol.rb:202:in `writing'
	from /usr/lib/ruby/2.3.0/net/protocol.rb:192:in `writeline'
	from /usr/lib/ruby/2.3.0/net/smtp.rb:931:in `block in getok'
	from /usr/lib/ruby/2.3.0/net/smtp.rb:956:in `critical'
	from /usr/lib/ruby/2.3.0/net/smtp.rb:930:in `getok'
	from /usr/lib/ruby/2.3.0/net/smtp.rb:831:in `helo'
	from /usr/lib/ruby/2.3.0/net/smtp.rb:605:in `do_helo'
	from /usr/lib/ruby/2.3.0/net/smtp.rb:557:in `do_start'
	from /usr/lib/ruby/2.3.0/net/smtp.rb:521:in `start'
	from /usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/network/delivery_methods/smtp.rb:112:in `deliver!'
	from /usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/message.rb:252:in `deliver!'
	from /var/lib/nowshowing/mailReport.rb:98:in `block in sendMail'
	from /var/lib/nowshowing/mailReport.rb:89:in `each'
	from /var/lib/nowshowing/mailReport.rb:89:in `sendMail'
	from /usr/local/sbin/emailreport:385:in `main'
	from /usr/local/sbin/emailreport:389:in `<main>'

No email is sent.

Share this post


Link to post

I just tested emailing to an iCloud account using the plex email section and it worked without issue. What email provider are you trying to send with out of curiosity.


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
My ISP (TimeWarner).


Can you try using a gmail account if you have one? I want to see if there is a potential provider issue since you're getting connection reset.


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
37 minutes ago, GroxyPod said:

 


Can you try using a gmail account if you have one? I want to see if there is a potential provider issue since you're getting connection reset.


Sent from my iPhone using Tapatalk Pro

 

Set up a gmail account. Getting a different error-

root@Brunnhilde:~# docker exec nowshowing emailreport -t
/usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/check_delivery_params.rb:5:in `check_delivery_params': An SMTP From address is required to send a message. Set the message smtp_envelope_from, return_path, sender, or from address. (ArgumentError)
	from /usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/network/delivery_methods/smtp.rb:98:in `deliver!'
	from /usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/message.rb:252:in `deliver!'
	from /var/lib/nowshowing/mailReport.rb:98:in `block in sendMail'
	from /var/lib/nowshowing/mailReport.rb:89:in `each'
	from /var/lib/nowshowing/mailReport.rb:89:in `sendMail'
	from /usr/local/sbin/emailreport:385:in `main'
	from /usr/local/sbin/emailreport:389:in `<main>'

 

Share this post


Link to post
Set up a gmail account. Getting a different error-
root@Brunnhilde:~# docker exec nowshowing emailreport -t/usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/check_delivery_params.rb:5:in `check_delivery_params': An SMTP From address is required to send a message. Set the message smtp_envelope_from, return_path, sender, or from address. (ArgumentError)from /usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/network/delivery_methods/smtp.rb:98:in `deliver!'from /usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/message.rb:252:in `deliver!'from /var/lib/nowshowing/mailReport.rb:98:in `block in sendMail'from /var/lib/nowshowing/mailReport.rb:89:in `each'from /var/lib/nowshowing/mailReport.rb:89:in `sendMail'from /usr/local/sbin/emailreport:385:in `main'from /usr/local/sbin/emailreport:389:in `<main>'

 



Can you post a redacted picture of what's in your docker template? Please make sure not to redact it too much (example: you use user for your email address instead of user@email.com)


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
7 hours ago, GroxyPod said:

 


Can you post a redacted picture of what's in your docker template? Please make sure not to redact it too much (example: you use user for your email address instead of user@email.com)


Sent from my iPhone using Tapatalk Pro

 

 

SafariScreenSnapz022.jpg

Share this post


Link to post
 
SafariScreenSnapz022.thumb.jpg.81845f4e2a7732c7a2e4718b5d0a8722.jpg


Can you change the following and re-test?
Email port from 465 to 587
Email username: add @gmail.com to it.


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
7 hours ago, GroxyPod said:

Can you change the following and re-test?
Email port from 465 to 587
Email username: add @gmail.com to it.

 

Didn't work-

 

root@Brunnhilde:~# docker exec nowshowing emailreport -d -t
/usr/lib/ruby/2.3.0/net/smtp.rb:977:in `check_auth_response': 534-5.7.14 <https://accounts.google.com/signin/continue?sarp=1&scc=1&plt=AKgnsbsS (Net::SMTPAuthenticationError)
	from /usr/lib/ruby/2.3.0/net/smtp.rb:741:in `auth_plain'
	from /usr/lib/ruby/2.3.0/net/smtp.rb:733:in `authenticate'
	from /usr/lib/ruby/2.3.0/net/smtp.rb:568:in `do_start'
	from /usr/lib/ruby/2.3.0/net/smtp.rb:521:in `start'
	from /usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/network/delivery_methods/smtp.rb:112:in `deliver!'
	from /usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/message.rb:252:in `deliver!'
	from /var/lib/nowshowing/mailReport.rb:98:in `block in sendMail'
	from /var/lib/nowshowing/mailReport.rb:89:in `each'
	from /var/lib/nowshowing/mailReport.rb:89:in `sendMail'
	from /usr/local/sbin/emailreport:385:in `main'
	from /usr/local/sbin/emailreport:389:in `<main>'

 

 

If I use port 465 as Google specifies for SSL I get this-

 

root@Brunnhilde:~# docker exec nowshowing emailreport -d -t
/usr/local/sbin/emailreport: end of file reached (EOFError)

 

Edited by wgstarks

Share this post


Link to post
 
Didn't work-
 
root@Brunnhilde:~# docker exec nowshowing emailreport -d -t/usr/lib/ruby/2.3.0/net/smtp.rb:977:in `check_auth_response': 534-5.7.14 <https://accounts.google.com/signin/continue?sarp=1&scc=1&plt=AKgnsbsS (Net::SMTPAuthenticationError)from /usr/lib/ruby/2.3.0/net/smtp.rb:741:in `auth_plain'from /usr/lib/ruby/2.3.0/net/smtp.rb:733:in `authenticate'from /usr/lib/ruby/2.3.0/net/smtp.rb:568:in `do_start'from /usr/lib/ruby/2.3.0/net/smtp.rb:521:in `start'from /usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/network/delivery_methods/smtp.rb:112:in `deliver!'from /usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/message.rb:252:in `deliver!'from /var/lib/nowshowing/mailReport.rb:98:in `block in sendMail'from /var/lib/nowshowing/mailReport.rb:89:in `each'from /var/lib/nowshowing/mailReport.rb:89:in `sendMail'from /usr/local/sbin/emailreport:385:in `main'from /usr/local/sbin/emailreport:389:in `<main>'

 
 
If I use port 465 as Google specifies for SSL I get this-
 

root@Brunnhilde:~# docker exec nowshowing emailreport -d -t/usr/local/sbin/emailreport: end of file reached (EOFError)

 



You're getting smtp authentication error. This can be caused by one of two things. 1) the gmail account is not setup to allow insecure apps. 2) the account information entered is incorrect.

Can you check your google account to see if it allows insecure apps? I can provide a screenshot later if needed.


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
3 minutes ago, GroxyPod said:

You're getting smtp authentication error. This can be caused by one of two things. 1) the gmail account is not setup to allow insecure apps. 2) the account information entered is incorrect.

Can you check your google account to see if it allows insecure apps? I can provide a screenshot later if needed.

You're right. Just got a email from Google regarding possible unauthorized access. I've changed the settings in my Google account. I'm guessing I should try 587 again?

Share this post


Link to post
You're right. Just got a email from Google regarding possible unauthorized access. I've changed the settings in my Google account. I'm guessing I should try 587 again?


Yes please.


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post

Worked from the command line. Not working on the schedule though. I set up an hourly schedule. The nowshowing log shows that the script started but never completed.

Share this post


Link to post
Worked from the command line. Not working on the schedule though. I set up an hourly schedule. The nowshowing log shows that the script started but never completed.



Please rename advanved_config.ymal to .bak and rename advanced_config.ymal.example to advanced_config.ymal and stop/start the docker.


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
1 hour ago, GroxyPod said:

 

 


Please rename advanved_config.ymal to .bak and rename advanced_config.ymal.example to advanced_config.ymal and stop/start the docker.


Sent from my iPhone using Tapatalk Pro

 

 

Done. We'll see what happens on Friday.

Share this post


Link to post
Done. We'll see what happens on Friday.


Sounds like a plan. If you want, you can change the 5 to * on the email cron and stop/start the docker to see if it generates each day. Just trying to rule out things because the cron job only runs the command so in theory there shouldn't be any issues


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
14 hours ago, GroxyPod said:

If you want, you can change the 5 to * on the email cron and stop/start the docker to see if it generates each day.

Did as you suggested. I'm not at home right now, but judging from the lack of an email it appears this failed.

Share this post


Link to post
Did as you suggested. I'm not at home right now, but judging from the lack of an email it appears this failed.


What version of unRaid are you using?


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
Just now, GroxyPod said:

 


What version of unRaid are you using?


Sent from my iPhone using Tapatalk Pro

 

6.3.3

Share this post


Link to post
6.3.3


In the testing I have done, I haven't had an issue with sending to iCloud accounts or any other account using both a gmail account and my own personal hosting email account.

There may be something external to the docker that is blocking the email from going out or arriving. Unfortunately that is not something we can assist with if that is the case.

Can you try running the combined report using the -d flag without -t and see if you get the email?


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
1 hour ago, GroxyPod said:

 


In the testing I have done, I haven't had an issue with sending to iCloud accounts or any other account using both a gmail account and my own personal hosting email account.

There may be something external to the docker that is blocking the email from going out or arriving. Unfortunately that is not something we can assist with if that is the case.

Can you try running the combined report using the -d flag without -t and see if you get the email?


Sent from my iPhone using Tapatalk Pro

 

Looks like it failed-

root@Brunnhilde:~# docker exec nowshowing combinedreport -d
/var/lib/nowshowing/mailReport.rb:60:in `sendMail': undefined method `each' for nil:NilClass (NoMethodError)
	from /usr/local/sbin/combinedreport:386:in `main'
	from /usr/local/sbin/combinedreport:394:in `<main>'
root@Brunnhilde:~# 

 

Share this post


Link to post
Looks like it failed-
root@Brunnhilde:~# docker exec nowshowing combinedreport -d/var/lib/nowshowing/mailReport.rb:60:in `sendMail': undefined method `each' for nil:NilClass (NoMethodError)from /usr/local/sbin/combinedreport:386:in `main'from /usr/local/sbin/combinedreport:394:in `<main>'root@Brunnhilde:~# 

 



Looks like it is having an issue with one of the users you have on your server. Not quite sure why (maybe special characters or a weird email address attached to the account).

You'll need to utilize the advanced config to troubleshoot each individual user and then run the same -d command in order to test.


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now