6.3.3 Chrome out of memory on unRaid "main" tab


13 posts in this topic Last Reply

Recommended Posts

Pretty sure this is new to 6.3.3, as I've usually left my tower web page open to the "Main" page for months at a time previously.
Now after <48 hours I get:


Aw, Snap!

Google Chrome ran out of memory while trying to display this webpage.

 

May be related to the recent UI changes for background updates or something? I'm not really sure, but I don't recall ever seeing this pre-6.3.3

When this happens, the unRaid tab is the only one that is out of memory, my other chrome tab (I only have 2 open at the moment) is fine.
 

Google Chrome 57.0.2987.133

Windows 10 Pro 64-bit fully updated (creator update), 16GB RAM on my PC. Can provide other specs if needed.

 

Not sure diagnostics for my unraid system matter, but including anyways.

 

Let me know what other information I can provide.
 

tower-diagnostics-20170415-1832.zip

Link to post

I been noticing something similar, it hasn't ran out of memory yet because I close it after a few hours when I notice my VM getting slower because chrome memory usage keeps creeping up until it uses all available RAM.

Link to post

Maybe, but I've been keeping my tower page open in chrome for at least the last year or two and it's only post 6.3.3 that I notice it running out of memory.

 

Given that this happens fairly quickly (every ~2 days) I'm sure I'd have remembered if this was a common occurrence before now.


Plus, it's only the unraid tab that runs out of memory. I usually have a youtube tab open, which is fine even after the unraid tab runs out of memory.

However, at the moment I am testing this with no other tabs open and I see that since posting yesterday it's already gone up to ~1.6gb of memory used for this one chrome tab.

 

Most of my day to day browsing is done in Firefox so it's usually only tower and sometimes youtube that's open in chrome.

 

Of course, maybe Chrome updated at some point and now has it's own unrelated memory leak. I don't sit on one youtube page nearly as long as I sit on the unraid dashboard.

Edited by SnickySnacks
Link to post

I haven't been able to reproduce this on Firefox and I can't seem to find anything within the chrome memory reporting that points to any specific issue with the unraid page so this may just be a quirk in chrome itself. (which is to say, the memory usage is definitely tied to the unraid tab, but doesn't appear to be allocated to anything specific, such as JS or DOM objects or anything that I know about)

 

If anyone has any suggestions on how to test this, I'd be happy to try whatever.

Link to post

I have Chrome version 59 (64-bit) running and left the main page open for a day. I don't see any substantial increase in memory usage by Chrome.

 

Perhaps it depends on the version of Chrome used?

 

Link to post
3 hours ago, bonienl said:

I have Chrome version 59 (64-bit) running and left the main page open for a day. I don't see any substantial increase in memory usage by Chrome.

 

Perhaps it depends on the version of Chrome used?

 

you prompted me to check what version I was on as after opening my machine this morning to the same error message.  I was on v57 and I've just upgraded to v58 - will report back on if I still have problems.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.