Jump to content
dlandon

[support] dlandon - Zoneminder 1.32

409 posts in this topic Last Reply

Recommended Posts

I think I am having a similar issue.  My zoneminder seems to be working and I can log into the web interface however I am not able to get it to accept requests from Home Assistant.  Not sure if this is related but it happened after I updated Zoneminder docker. 

Share this post


Link to post
4 hours ago, mgranger said:

I think I am having a similar issue.  My zoneminder seems to be working and I can log into the web interface however I am not able to get it to accept requests from Home Assistant.  Not sure if this is related but it happened after I updated Zoneminder docker. 

How does Hkme Assistant access Zoneminder?

Share this post


Link to post

I'm have the same issue with  Home Assistant. I have tried setting SSL in  Home Assistant but still has not corrected the issue.

"HTTPSConnectionPool(host='192.168.1.150', port=9091): Max retries exceeded with url: /zm/index.php (Caused by SSLError(SSLError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:841)'),))" 

Any help on this would be great THANKS.

Share this post


Link to post
11 hours ago, naughtytester said:

I'm have the same issue with  Home Assistant. I have tried setting SSL in  Home Assistant but still has not corrected the issue.

"HTTPSConnectionPool(host='192.168.1.150', port=9091): Max retries exceeded with url: /zm/index.php (Caused by SSLError(SSLError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:841)'),))" 

Any help on this would be great THANKS.

Because insecure access is no longer available for Zoneminder, you need to switch to secure access - https.  I don't know how Home Assistant works, but secure access to a device should not be a problem.  Be sure to use the same url you use to access the webui.  Zoneminder has a self signed certificate that is used for secure access.

Share this post


Link to post

For those of you having issues with Home Assistant, I would suggest getting a free Let's Encrypt certificate.  Install your certificate in the keys/ folder.  Be sure to change the keys/ServerName file to your FQDN so the Apache server name will match the certificate.

Share this post


Link to post

@dlandon I have tried adding the certificate and changing the ServerName file to my FQDN (although I may have done this wrong) and I still can't get home assistant to view Zoneminder.  I will monitor the Home Assistant forum and see if anyone figures it out.

Share this post


Link to post
5 hours ago, mgranger said:

@dlandon I have tried adding the certificate and changing the ServerName file to my FQDN (although I may have done this wrong) and I still can't get home assistant to view Zoneminder.  I will monitor the Home Assistant forum and see if anyone figures it out.

See if this discussion helps:  https://github.com/dlandon/zoneminder/issues/17

Share this post


Link to post
1 minute ago, mgranger said:

@dlandon Awesome that seemed to fix it.  I was missing the verify_ssl: false and didn't quite have the host: line set up correctly.

Someone should post the solution to this situation on the Home Assistant forum so others can see how to resolve it.

Share this post


Link to post

@dlandon I posted the link that you posted in the Home Assistant forum I ran across so hopefully that helps

Share this post


Link to post

I have been trying to get this to load for 3 days now so I can check it out.  I think it is time i reach out for help.  I can't the UI to load at all.  I keep getting "The site can't be reached."  I have tried about 6 different ports and forwarded in my router, I have tried bridge, host and br0, with no luck either.  Any advice?

Share this post


Link to post
7 hours ago, jbrown705 said:

I have been trying to get this to load for 3 days now so I can check it out.  I think it is time i reach out for help.  I can't the UI to load at all.  I keep getting "The site can't be reached."  I have tried about 6 different ports and forwarded in my router, I have tried bridge, host and br0, with no luck either.  Any advice?

Install using the default template.  Left click on the Docker icon and select WebUiI.  Be sure you are not using port 8443 for Unraid.  If you still cannot get it going, post your diagnostics.

Share this post


Link to post
9 hours ago, dlandon said:

Install using the default template.  Left click on the Docker icon and select WebUiI.  Be sure you are not using port 8443 for Unraid.  If you still cannot get it going, post your diagnostics.

I am not using 8443 for unraid, but I am using it for a WDMyCloud on different IP.  I have tried changing the port and still can't get in.  I set a bunch of different port and forwarded them all as well.  I installed using the app via CA.  Should i be using a different one?

Edited by jbrown705

Share this post


Link to post
2 hours ago, jbrown705 said:

I am not using 8443 for unraid, but I am using it for a WDMyCloud on different IP.  I have tried changing the port and still can't get in.  I set a bunch of different port and forwarded them all as well.  I installed using the app via CA.  Should i be using a different one?

CA is the right place to get the docker.  Please just use the template defaults and get it working before changing things.  Show me a screen shot of what happens when you click on the docker WebUI.

Share this post


Link to post
2 hours ago, dlandon said:

CA is the right place to get the docker.  Please just use the template defaults and get it working before changing things.  Show me a screen shot of what happens when you click on the docker WebUI.

I switched the port back to the default 8443 and tried again.  Here is a screenshot of my settings and what happens when I click WebUI.

 

 

zoneminder1.jpg

zoneminder2.jpg

Share this post


Link to post
9 minutes ago, jbrown705 said:

I switched the port back to the default 8443 and tried again.  Here is a screenshot of my settings and what happens when I click WebUI.

 

 

zoneminder1.jpg

zoneminder2.jpg

When you set a static IP address, use port 443.

Share this post


Link to post
7 minutes ago, dlandon said:

When you set a static IP address, use port 443.

would you recommend using static or bridge?

 

**Update**

That got me in but with bridge and 8443 or static and 443, it doesn't come thru as secure for some reason (chrome on mac)?

 

Edited by jbrown705

Share this post


Link to post
9 hours ago, jbrown705 said:

would you recommend using static or bridge?

 

**Update**

That got me in but with bridge and 8443 or static and 443, it doesn't come thru as secure for some reason (chrome on mac)?

 

I prefer a static ip address.  Because the certificate in Zonemonder is self generated, browsers will complain about the connection not being secure.  It is secure, but the browser is warning you about the certificate not being certified.

Share this post


Link to post
4 hours ago, darrenyorston said:

I have tried adding cameras to Zoneminder but they remain red in the console.

 

My cameras are Dlink DCS-4602EC. I utilised the settings per https://wiki.zoneminder.com/D-Link#DCS-4602EV

 

The log file is attached.

 

I know the cameras work

 

 

zm-log.txt

Your best bet for help with camera setup is the Zoneminder forums.  The link is in the first post.

Share this post


Link to post

Hi All,

 

I'm having a problem getting into the webui of zoneminder, actually getting it working.  It has been working great all along until unraid 6.6.6 update.  I'm getting a site cannot be reached.  Well I noticed that my unassigned devices were unmounted after the unraid update.  So I mounted the disk thinking that would fix it.  No luck with that.  I still can't access it.  Any idea what can be going on? I've attached my configuration.  

Screen Shot 2019-01-06 at 12.09.47 AM.png

Share this post


Link to post
4 hours ago, Mlatx said:

Hi All,

 

I'm having a problem getting into the webui of zoneminder, actually getting it working.  It has been working great all along until unraid 6.6.6 update.  I'm getting a site cannot be reached.  Well I noticed that my unassigned devices were unmounted after the unraid update.  So I mounted the disk thinking that would fix it.  No luck with that.  I still can't access it.  Any idea what can be going on? I've attached my configuration.  

Screen Shot 2019-01-06 at 12.09.47 AM.png

It's not a 6.6.6 issue.  The Zoneminder docker has been changed to only allow https: access.  Your template is set up for http: access that Zoneminder no longer allows.  Go to CA and find Zoneminder.  Then use the default template to setup Zoneminder.  Go to the Dockers and left click the Zoneminder icon and choose WebUI.  You can the access Zoneminder.

Share this post


Link to post

That's good to know.  So would I have to reconfigure zoneminder and all of the settings?  Or if I just download the new zm template from CA it will pickup the existing settings from appdata?

Share this post


Link to post
13 minutes ago, Mlatx said:

Or if I just download the new zm template from CA it will pickup the existing settings from appdata?

Yes.  It just configures the Docker, not Zoneminder.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now