Xeoma - Surveillance Software


215 posts in this topic Last Reply

Recommended Posts

I moved the image to Alpine linux, which drops the size from 229MB to 64MB.

 

I also added the ability to configure it using env vars instead of the config file.

 

This is a pretty big change, so let me know if you guys see any issues.

Link to post
  • Replies 214
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Xeoma is surveillance software. It has low CPU usage (about 3% CPU when idle) and an easy-to-use user interface.   I tried ZoneMinder, which was very clunky to use, and had very high CPU usa

I messed around a bit with things and switching to the beta and proper config removal fixed the libx11 error.   Now I'm in the same boat as bokchoy and simply cannot connect to it from my de

Also running docker 1.12.6   When I get time either later tonight or this weekend I plan on comparing the xeoma files that were installed in the VM vs he files installed in the docker config

Posted Images

Hi coppit.

 

I updated Xeoma docker to the newest version and after that I can't connect any client to the xeoma server.

Logs are OK. here they are:

 

Configuration:
PASSWORD=<hidden>
VERSION=latest
2018-08-16 09:18:00 Determining version of Xeoma to use
2018-08-16 09:18:00 Config version is "latest"
2018-08-16 09:18:00 Fetching version information from Felenasoft at http://felenasoft.com/xeoma/downloads/version2.xml
2018-08-16 09:18:01 Using Xeoma version 18.7.10 (the latest stable version)
2018-08-16 09:18:01 Downloaded file /config/downloads/xeoma_18.7.10.tgz already exists. Skipping download
2018-08-16 09:18:01 Installing Xeoma from /config/downloads/xeoma_18.7.10.tgz
2018-08-16 09:18:02 Installation complete
[Aug 16 09:18:02] Setting the password


Password set successfull
Started runsvdir, PID is 56. Waiting for processes to start....
[Aug 16 09:18:02] Starting the server in 5 seconds. See the log directory in your config directory for server logs.
run: cron: (pid 61) 5s
run: xeoma: (pid 60) 5s

My xeoma docker configuration is simple but I pass new port for xeoma web service.

Link to post

Server and clients versions are OK. Clients (on windows computers and iphones) doesn't connect at all to the specified port: 8090.

And I can't connect to the 10090 port via web browser.

 

I run your docker from scratch and the problem with no connection still exists.

Edited by w^w
Update info
Link to post

Ive got the same, but now its like:

bash: /etc/my_init.d/40_install_xeoma.sh: No such file or directory
 

I will never understand why some dockers break every time and other just work for years without any problems.... 

 

My dockers restart every day bc of backup, still this docker broke another time. It downloads an update, but says it doesnt need to be updated (???)

 

My guess its this piece of crap xeoma rather then the docker image, but it still sucks.

 

After restarting and deleting of the update, it starts without any error. But you can no longer connect via mobile or desktop to it. Mobile fuggs about "server zertificate" (i hate this whole sh1t so hard), desktop says its not reachable.

 

It seems like the docker just not listening on the port anymore.

 

2018-08-16 21:15:44 Determining version of Xeoma to use
2018-08-16 21:15:44 Config version is "latest"
2018-08-16 21:15:44 Fetching version information from Felenasoft at http://felenasoft.com/xeoma/downloads/version2.xml
2018-08-16 21:15:45 Using Xeoma version 18.7.10 (the latest stable version)
2018-08-16 21:15:45 Deleting files in /config/downloads to reclaim space...
2018-08-16 21:15:45 Downloading from http://felenasoft.com/xeoma/downloads/xeoma_linux64.tgz into /config/downloads
2018-08-16 21:15:45 Downloading from http://felenasoft.com/xeoma/downloads/xeoma_linux64.tgz
2018-08-16 21:16:26 Downloaded to /config/downloads/xeoma_18.7.10.tgz
2018-08-16 21:16:26 Skipping installation because the currently installed version is the correct one

Edited by nuhll
Link to post
  • 4 months later...

I have installed Xeoma today but I only get at "HTTP error: 404" when I open the WebUI at http://myIP:10090/

Any Idea?

 

Here the log:

 

*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/10_syslog-ng.init...
Dec 25 10:48:19 Tower syslog-ng[16]: syslog-ng starting up; version='3.13.2'
*** Running /etc/my_init.d/30_parse_config_file.sh...
/etc/my_init.d/30_parse_config_file.sh: line 82: Please: No such file or directory
grep: Please: No such file or directory
declare -x DEBIAN_FRONTEND="teletype"
declare -x HOSTNAME="Tower"
declare -x HOST_OS="Unraid"
declare -x INITRD="no"
declare -x LANG="en_US.UTF-8"
declare -x LANGUAGE="en_US:en"
declare -x LC_ALL="en_US.UTF-8"
declare -x LC_CTYPE="en_US.UTF-8"
declare -x OLDPWD
declare -x PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
declare -x PWD="/"
declare -x SHLVL="1"
declare -x TCP_PORT_10090="10090"
declare -x TCP_PORT_8091="8091"
declare -x TERM="xterm-256color"
declare -x TZ="Europe/Paris"
Missing required settings, which must be provided in the config file or by environment variables:
PASSWORD
*** Running /etc/my_init.d/40_install_xeoma.py...
2018-12-25 10:48:19 Determining version of Xeoma to use
/bin/bash: /etc/envvars.merged: No such file or directory
2018-12-25 10:48:19 Config version is ""
2018-12-25 10:48:19 Fetching version information from Felenasoft at http://felenasoft.com/xeoma/downloads/version2.xml
2018-12-25 10:48:19 Using Xeoma version 18.11.21 (the latest stable version)
2018-12-25 10:48:19 Downloaded file /config/downloads/xeoma_18.11.21.tgz already exists. Skipping download
2018-12-25 10:48:20 Installing Xeoma from /config/downloads/xeoma_18.11.21.tgz
2018-12-25 10:48:21 Installation complete
*** Running /etc/my_init.d/50_configure_xeoma.sh...
/etc/my_init.d/50_configure_xeoma.sh: line 7: /etc/envvars.merged: No such file or directory
[Dec 25 10:48:21 AM] Setting the password
Failed to open 'libX11'
Failed to open 'libX11'
! XWindow graphical shell is not available in console mode
! You must run Xeoma with available parameters, i.e. to run server: -core
! Type '-help' for read parameters list.

*** Booting runit daemon...
*** Runit started as PID 63
[Dec 25 10:48:25 AM] Starting the server in 5 seconds. See the log directory in your config directory for server logs.
Dec 25 10:48:25 Tower cron[68]: (CRON) INFO (pidfile fd = 3)
Dec 25 10:48:25 Tower cron[68]: (CRON) INFO (Running @reboot jobs)

Edited by blaess
Link to post
On 12/25/2018 at 12:55 PM, blaess said:

I have installed Xeoma today but I only get at "HTTP error: 404" when I open the WebUI at http://myIP:10090/

Any Idea?

 

Here the log:

 

*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/10_syslog-ng.init...
Dec 25 10:48:19 Tower syslog-ng[16]: syslog-ng starting up; version='3.13.2'
*** Running /etc/my_init.d/30_parse_config_file.sh...
/etc/my_init.d/30_parse_config_file.sh: line 82: Please: No such file or directory
grep: Please: No such file or directory
declare -x DEBIAN_FRONTEND="teletype"
declare -x HOSTNAME="Tower"
declare -x HOST_OS="Unraid"
declare -x INITRD="no"
declare -x LANG="en_US.UTF-8"
declare -x LANGUAGE="en_US:en"
declare -x LC_ALL="en_US.UTF-8"
declare -x LC_CTYPE="en_US.UTF-8"
declare -x OLDPWD
declare -x PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
declare -x PWD="/"
declare -x SHLVL="1"
declare -x TCP_PORT_10090="10090"
declare -x TCP_PORT_8091="8091"
declare -x TERM="xterm-256color"
declare -x TZ="Europe/Paris"
Missing required settings, which must be provided in the config file or by environment variables:
PASSWORD
*** Running /etc/my_init.d/40_install_xeoma.py...
2018-12-25 10:48:19 Determining version of Xeoma to use
/bin/bash: /etc/envvars.merged: No such file or directory
2018-12-25 10:48:19 Config version is ""
2018-12-25 10:48:19 Fetching version information from Felenasoft at http://felenasoft.com/xeoma/downloads/version2.xml
2018-12-25 10:48:19 Using Xeoma version 18.11.21 (the latest stable version)
2018-12-25 10:48:19 Downloaded file /config/downloads/xeoma_18.11.21.tgz already exists. Skipping download
2018-12-25 10:48:20 Installing Xeoma from /config/downloads/xeoma_18.11.21.tgz
2018-12-25 10:48:21 Installation complete
*** Running /etc/my_init.d/50_configure_xeoma.sh...
/etc/my_init.d/50_configure_xeoma.sh: line 7: /etc/envvars.merged: No such file or directory
[Dec 25 10:48:21 AM] Setting the password
Failed to open 'libX11'
Failed to open 'libX11'
! XWindow graphical shell is not available in console mode
! You must run Xeoma with available parameters, i.e. to run server: -core
! Type '-help' for read parameters list.

*** Booting runit daemon...
*** Runit started as PID 63
[Dec 25 10:48:25 AM] Starting the server in 5 seconds. See the log directory in your config directory for server logs.
Dec 25 10:48:25 Tower cron[68]: (CRON) INFO (pidfile fd = 3)
Dec 25 10:48:25 Tower cron[68]: (CRON) INFO (Running @reboot jobs)

Same here...

Anyone?

Link to post

anyone got intels quick sync working?

 

added --device=/dev/dri:/dev/dri to extra parameters

 

and run

root@Unraid-Server:~# modprobe i915
root@Unraid-Server:~# chmod -R 777 /dev/dri
root@Unraid-Server:~# vi /dev/dri/
by-path/    card0       renderD128

Link to post
  • 2 weeks later...

I was wondering if we could have a parameter for the license server added to the docker?  I am having a hell of a time getting that configured.

 

I setup a raspberry pi running as a license server using these instructions:

https://felenasoft.com/xeoma/en/description/#activation_license_server

 

I was able to activate the server with my serial number using a commandline argument from the shell:

sudo ./Xeoma.app --activateOnline 'serial number here'

 

The problem arises when trying to point the docker xeoma at the new license server.  

Using Bridge networking I get the right option but UI greys out the box to change to server IP so I can't point the docker to my license server (see image):

 

Using Host networking mode I don't get the option at all.

 

The command line arguments allow you to specify a license server:

-licenseServer [LicenseServer]license server for online activation. For example: 192.168.0.1::8090

 

However, I can't figure out how to insert this command in the docker to specify the license server.  

1) Any help appreciated trying to execute the command line licenseServer command in the docker would be appreciated

2) Maybe the licenseServer should be a docker parameter?

 

ty

 

 

Screenshot_20190118-234143.png

Link to post

The pi was recommended to use when running xeoma from vm/docker.  That way you can change the docker all you want and it doesn't impact the license.  

 

It looks like the following would need to be modified:

/etc/service/xeomoa/run

 

add the -licenseServer parameter and server value to the startup:

/usr/bin/xeoma -core -service -log -startdelay 5

 

I am curious why this docker uses a config file instead of just docker variables.  

Link to post

Hi

 

I've installed the Docker, but I just get a 404 error on the 10090 port....nothing substantial in the logs expect for this....

 

Password set successfull
*** Booting runit daemon...
*** Runit started as PID 48
[Jan 21 10:22:40 AM] Starting the server in 5 seconds. See the log directory in your config directory for server logs.
Jan 21 10:22:40 f23f404389f9 cron[53]: (CRON) INFO (pidfile fd = 3)
Jan 21 10:22:40 f23f404389f9 cron[53]: (CRON) INFO (Skipping @reboot jobs -- not system startup)

 

I would be grateful for any assistance.

 

Kind regards,

 

Leo

Link to post
  • 1 month later...

It does work....what you have to do is run the docker, then install the Xeoma desktop software, access the server via the desktop, create a camera, and then you can access the web UI.

 

Unfortunately tho, Xeoma is a terrible product and you get much, much more functionality with Zoneminder, its looks dated.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.