2 Drives "Missing" After Reboot

Recommended Posts

Hello - after many years of happy, broadly uninterrupted usage of my Unraid box, I rebooted tonight after finding the server had crashed.  When it came back online, I found both of my dual parity drives are "missing" in the drive list. 


Hmmmm... seems unlikely they would have both failed at exactly the same time, so restarted again, and took photos of the boot screen, and as expected, they are showing up as connected drives to the BIOS.  But low and behold, still not showing up in the GUI.


Attached are screenshots of the GUI, the BIOS output, and log.  I was going to try to run SMART test, but don't have a [sdx] designation I can see to run it against.

Thinking that perhaps it's a bad backplane?  Just seems strange it's showing up ok on the BIOS screen if that's the case.


Any assistance in diagnosing this would be very very gratefully appreciated.  Please let me know if there's anything else I can share.  Thank you!!

Screen Shot 2017-05-02 at 10.33.55 PM.png


IMG_1472 (2017-05-02).JPG

IMG_5188 (2017-05-02).JPG

Link to comment

The syslog shows that Linux tried to get the 8TB drives to respond but they did not and were thus disabled.     Quite why I am not sure.   I would carefully check all the cabling and make sure the controller is properly seated into the motherboard.  


It is possible that whatever caused the original crash HAS affected both drives.   Do you have another PC you could plug the drives into to run the manufacturer's test tools against them to confirm the drives are Ok?

Link to comment

I had the same problem Months ago - BIOS showed the drive but unraid kicked it - Reason: A bad SATA-Cable.

I changed the cable and all was fine.

I never had problems with unraid (or SATA-Cabeling) since 7 years, but since v6.2.x it seems, unraid is a little bit bitchy xD

What i do now when changing a Disk, i also change the SATA-Cable too to prevent this "kickoffs".

Edited by Zonediver
Link to comment

Thank you all.  After posting this, I moved the drives to different slots, and rebooted.  When the Unraid management page came up, everything was normal.


So then I started parity check (as I'd had an unclean shutdown), which went off and started, then I went to bed.  Woke up this morning, and the web interface on the sever is non-responsive (refresh the page and it says "Waiting for".  Can't access via SMB either.  Tried to go onto the actual terminal, but that has completely crashed too.


Something not right here... any guidance as to how to diagnose why the server is crashing?  I'm thinking perhaps it's all connected to this issue, and I've either got faulty cable(s) or backplane gone bad.


Again, very much appreciated all!

Edited by christuf
Link to comment

Did a restart, and all still ok.  No issues on any drives. 


I have noticed that memory usage is creeping up - wondering if a docker I have has a leak or something.  I'm going to keep the Dashboard and Logging window open, and will leave it for the day and see what's happened when I get home tonight.


Can't for the life of me seem to find any way to look at what processes are using memory.  Can anyone point me to the right place in the GUI or on the terminal please?


Still a lot suspicious of the drive errors from yesterday too...


Thank you all!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.