Jump to content

Boot issue(I think) with Unraid 6 usb drive


audioguy61

Recommended Posts

I believe I am having an issue with the boot usb drive of my system, I could not access the web admin page of the system and all my shares were not visible on my network. The last issue I had like this was hardware related to the motherboard of my system and I have, in the past, had the bios not recognize the usb as the boot drive.

 

I did a hard reset on the system and still had the problem, when I hooked up the server to a monitor it did seem to boot up at least part of the way although the shares and the web admin page were still not available. I am able to see just the "flash" folder on the network and it looks like all the config files etc. are still there although I am unable to telnet or ssh into the server to create a syslog.

 

I powered down and put the usb key into my Windows machine and I get the message "There is a problem with this usb device, would you like to scan and fix errors?" I didn't want Windows to possibly make things worse so I didn't let it.

 

Let me know if there are any files on the usb drive that might be helpful in diagnosing this and I will post them here. Thanks in advance.

Link to comment

Let Windows do its thing...I have not heard of it making things worst.  And often it can fix the issues. After all, this is Windows formatted disk and all of the files were put there by a Window program.  

 

If there does not fix the problem, on your next post, have a monitor connected to the server and tell us exactly what you see  You should see that unRAID boot menu, a line of countdown to boot and then it will load two files.  After the second file loads, the boot process will start and lines of information will  race down the screen.  It should end when the boot process is finished with a login prompt available.  IF you don't get this, you need to post up what you see at the bottom (or take a non-blurry, in-focus picture of the screen). 

Link to comment
3 hours ago, johnnie.black said:

You need to disable array auto start and run xfs_repair on disk1.

 

Thanks, my attempts to find this info are not working, any idea if there is a thread that says how to do this? I've tried searching the manual Frank wrote and this site.

Link to comment

Thank you johnie.black,

 

I did what you suggested and here is what I got when I tried to check the file system on disk 1:

 

"root@UNRAID:~# xfs_repair -v /dev/md1
Phase 1 - find and verify superblock...
        - block cache size set to 1472440 entries
Phase 2 - using internal log
        - zero log...
zero_log: head block 2942888 tail block 2942567
ERROR: The filesystem has valuable metadata changes in a log which needs to
be replayed.  Mount the filesystem to replay the log, and unmount it before
re-running xfs_repair.  If you are unable to mount the filesystem, then use
the -L option to destroy the log and attempt a repair.
Note that destroying the log may cause corruption -- please attempt a mount
of the filesystem before doing this."

 

I did what this suggested and tried to mount the file system so it could replay the log file but after 20 minutes or so the web gui was still unable to mount the file system. Right now the system is stuck trying to mount the file system so I can't even take the array back to maintenance mode, any suggestion would be appreciated.

 

I could add the -L switch to the command string but wanted to make sure there wasn't something else to do before that as it looks like I might lose some data. Also, I wanted to find out where in the string, "xfs_repair -v /dev/md1", the "-L" should go. Many thanks in advance.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...