Jump to content
Djoss

[Support] Djoss - HandBrake

501 posts in this topic Last Reply

Recommended Posts

2 hours ago, Djoss said:

In HandBrake, make sure the destination folder for your file is set to "/output".

Damn I feel like an idiot! Thanks for the reply/solution.

Share this post


Link to post

Hi, I'm struggling with my audio default. I've been looking for a while and can't figure it out.

I just want the audio to be untouched with only the video compressed. I set all "Auto passthru behaviour" to checked but when I look at the GUI it always shows that it is going to convert it to AAC (which it does to the file in the output folder)

I exported the preset file and it shows as:

      "AlignAVStart": false,
      "AudioCopyMask": [
        "copy:aac",
        "copy:ac3",
        "copy:dtshd",
        "copy:dts",
        "copy:mp3",
        "copy:truehd",
        "copy:flac",
        "copy:eac3"

But I have to manually alter the GUI for every file. This is also happening on my Windows computer so I guess it's a preset fault rather than a docker fault but I wonder if someone here could help.

Thanks

 

Share this post


Link to post
32 minutes ago, figrin_dan said:

Hi, I'm struggling with my audio default. I've been looking for a while and can't figure it out.

I just want the audio to be untouched with only the video compressed. I set all "Auto passthru behaviour" to checked but when I look at the GUI it always shows that it is going to convert it to AAC (which it does to the file in the output folder)

I exported the preset file and it shows as:


      "AlignAVStart": false,
      "AudioCopyMask": [
        "copy:aac",
        "copy:ac3",
        "copy:dtshd",
        "copy:dts",
        "copy:mp3",
        "copy:truehd",
        "copy:flac",
        "copy:eac3"

But I have to manually alter the GUI for every file. This is also happening on my Windows computer so I guess it's a preset fault rather than a docker fault but I wonder if someone here could help.

Thanks

 

Here is how the audio settings should be configured:

 

image.thumb.png.a5670d1c5be719c960f8076a4a85bda6.png

 

Share this post


Link to post

Ah thank you!

For some reason I had misunderstood that lower section as "definitely mixing down" due to the DPL box. I'll give it a go tonight :)

Share this post


Link to post
On 11/3/2018 at 7:01 PM, Taddeusz said:

 

I realize QSV isn't really about quality. I tried that video but apparently in later versions of Handbrake they removed the "Extra Settings" box when you select a QSV encoder.

 

Here is the output from the log when the HEVC encoder fails after finishing a previous encode:


[16:36:21] scan: decoding previews for title 1
[16:36:21] scan: audio 0x1: dca, rate=48000Hz, bitrate=1536000 English (DTS-HD MA) (5.1 ch)
[16:36:23] scan: 10 previews, 1920x1080, 23.976 fps, autocrop = 138/138/0/0, aspect 16:9, PAR 1:1
[16:36:23] scan: supported video decoders: avcodec qsv
[16:36:23] libhb: scan thread found 1 valid title(s)
[16:36:23] starting job
[16:36:23] job configuration:
[16:36:23]  * source
[16:36:23]    + /storage/Output/Atomic_Blonde/Atomic_Blonde_t00.mkv
[16:36:23]    + title 1, chapter(s) 1 to 2
[16:36:23]    + container: matroska,webm
[16:36:23]  * destination
[16:36:23]    + /output/Atomic_Blonde_t01.mkv
[16:36:23]    + container: Matroska (libavformat)
[16:36:23]      + chapter markers
[16:36:23]  * video track
[16:36:23]    + decoder: h264
[16:36:23]    + filters
[16:36:23]      + Framerate Shaper (mode=1)
[16:36:23]        + frame rate: 23.976 fps -> constant 23.976 fps
[16:36:23]      + Crop and Scale (width=1920:height=804:crop-top=138:crop-bottom=138:crop-left=0:crop-right=0)
[16:36:23]        + source: 1920 * 1080, crop (138/138/0/0): 1920 * 804, scale: 1920 * 804
[16:36:23]    + Output geometry
[16:36:23]      + storage dimensions: 1920 x 804
[16:36:23]      + pixel aspect ratio: 1 : 1
[16:36:23]      + display dimensions: 1920 x 804
[16:36:23]    + encoder: H.265 (Intel Media SDK)
[16:36:23]      + preset:  quality
[16:36:23]      + profile: auto
[16:36:23]      + level:   auto
[16:36:23]      + quality: 15.00 (QP)
[16:36:23]  * audio track 1
[16:36:23]    + decoder: English (DTS-HD MA) (5.1 ch) (track 1, id 0x1)
[16:36:23]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[16:36:23]    + mixdown: 5.1 Channels
[16:36:23]    + encoder: AC3 (libavcodec)
[16:36:23]      + bitrate: 640 kbps, samplerate: 48000 Hz
[16:36:23] sync: expecting 15900 video frames
libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 1
libva error: va_getDriverName() failed with operation failed,driver_name=i965
[16:36:23] encqsvInit: MFXVideoENCODE_Init failed (-16)
[16:36:23] Failure to initialise thread 'Quick Sync Video encoder (Intel Media SDK)'
[16:36:23] vfr: 0 frames output, 0 dropped and 0 duped for CFR/PFR
[16:36:23] vfr: lost time: 0 (0 frames)
[16:36:23] vfr: gained time: 0 (0 frames) (0 not accounted for)
[16:36:23] dca-decoder done: 0 frames, 0 decoder errors
[16:36:23] h264-decoder done: 0 frames, 0 decoder errors
[16:36:23] sync: got 0 frames, 15900 expected
[16:36:23] libhb: work result = 3

 

 

Do you want to test a new image for me?  Since I don't have a CPU that supports H265 QSV, I cannot validate a potential myself...

If yes, just use the docker image tag "v1.14.10-beta1" (in container's settings, change the repo to jlesage/handbrake:v1.14.10-beta1).

Share this post


Link to post
35 minutes ago, Djoss said:

 

Do you want to test a new image for me?  Since I don't have a CPU that supports H265 QSV, I cannot validate a potential myself...

If yes, just use the docker image tag "v1.14.10-beta1" (in container's settings, change the repo to jlesage/handbrake:v1.14.10-beta1).

Ok, I've started a test. Going to take longer than normal because my wife is watching Plex at the same time. It's configured for QSV as well. Nice that the fixed function hardware can multitask different applications.

Share this post


Link to post
3 minutes ago, Taddeusz said:

Ok, I've started a test. Going to take longer than normal because my wife is watching Plex at the same time. It's configured for QSV as well. Nice that the fixed function hardware can multitask different applications.

Great thanks for you help.  So just to be clear, what I would like you to verify is that you can encode, from the UI, 2 videos using H265 QSV without having to restart the container.

Edited by Djoss

Share this post


Link to post
8 minutes ago, Djoss said:

Great thanks for you help.  So just to be clear, what I would like you to verify is that you can encode, from the UI, 2 videos using H265 QSV without having to restart the container.

Ok, that's what I queued up. 👍

Share this post


Link to post
59 minutes ago, Djoss said:

Great thanks for you help.  So just to be clear, what I would like you to verify is that you can encode, from the UI, 2 videos using H265 QSV without having to restart the container.

Second encode still failed with the "libva info: va_getDriverName() returns 1" error.

Share this post


Link to post
15 hours ago, Taddeusz said:

Second encode still failed with the "libva info: va_getDriverName() returns 1" error.

Thanks for confirming!  Could you now try "v1.14.10-beta2" ?

Share this post


Link to post
11 minutes ago, Djoss said:

@Taddeusz, test with "v1.14.10-beta3" instead :)

Ok, I tried beta 3 and still got the same error on the second file. BTW, H.264 QSV encoding is still distorted.

Share this post


Link to post
5 hours ago, Taddeusz said:

Ok, I tried beta 3 and still got the same error on the second file. BTW, H.264 QSV encoding is still distorted.

Thanks for confirming.  Note that since I suspect the h265 QSV issue to be on HandBrake side, I reported it on their GitHub: https://github.com/HandBrake/HandBrake/issues/1701.

 

For h264 QSV, do you have the same issue with any preset, any quality setting?

Share this post


Link to post
44 minutes ago, Djoss said:

Thanks for confirming.  Note that since I suspect the h265 QSV issue to be on HandBrake side, I reported it on their GitHub: https://github.com/HandBrake/HandBrake/issues/1701.

 

For h264 QSV, do you have the same issue with any preset, any quality setting?

I can't actually get it to work in any other preset other than "quality". If I try "speed" or "balanced" it makes one of my cores go to 100% and nothing happens.

Share this post


Link to post

Is it possible to run multiple encodings at the same time with the same container? handbrake only uses ~20% of my cpu at max

Share this post


Link to post
20 hours ago, Nosirus said:

Is it possible to run multiple encodings at the same time with the same container? handbrake only uses ~20% of my cpu at max

To my knowledge this is not possible.

Which preset are you using?  It is encoding at how much frame/second ?

Share this post


Link to post

@Taddeusz, can you try with v1.14.10-beta4 ?  HandBrake should now use the new VAAPI driver, I hope it could improve things.

Share this post


Link to post
1 hour ago, Djoss said:

@Taddeusz, can you try with v1.14.10-beta4 ?  HandBrake should now use the new VAAPI driver, I hope it could improve things.

Looks like it's working like it should now. H.264 QSV encoding is even working without the distortion.

Share this post


Link to post
6 hours ago, Taddeusz said:

Looks like it's working like it should now. H.264 QSV encoding is even working without the distortion.

Great news :).  Could you do a final quick test with v1.14.10-beta5?  This version will probably become the official one.

Share this post


Link to post
11 hours ago, Djoss said:

To my knowledge this is not possible.

Which preset are you using?  It is encoding at how much frame/second ?

I use x265 presset medium and crf 19, about 25 fps for a 1080p movie

my CPU pinning, on 32 threads, just 6 are not assign

 

nothing to do with, to preserve the most quality to re-encode, what do you propose in video and audio settings?

Share this post


Link to post
11 hours ago, Djoss said:

Great news :).  Could you do a final quick test with v1.14.10-beta5?  This version will probably become the official one.

It's still working as expected.

Share this post


Link to post
10 hours ago, Nosirus said:

I use x265 presset medium and crf 19, about 25 fps for a 1080p movie

my CPU pinning, on 32 threads, just 6 are not assign

I would expect a significant amount of CPU usage for x264 encoding...  Make sure to look at usage of each core (not at the overall CPU usage).

10 hours ago, Nosirus said:

nothing to do with, to preserve the most quality to re-encode, what do you propose in video and audio settings?

For audio, you can definitely configure the preset to passthrough all tracks (no need to re-encode them).  For the video, what you are using right now seems to be a good compromise.

Share this post


Link to post
3 hours ago, Taddeusz said:

It's still working as expected.

Perfect!.  Other than H.264 and H.265, do you have other QSV enabled encoders listed ?

Share this post


Link to post
21 minutes ago, Djoss said:

Perfect!.  Other than H.264 and H.265, do you have other QSV enabled encoders listed ?

Yes, I have an i5 8400 Coffee Lake CPU so "H.265 10-bit (Intel QSV)" is also listed. It is working fine as well.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now