Jump to content
GFRoSTY

(Solved) Help - updated to 6.3.5 and unable to boot off USB

7 posts in this topic Last Reply

Recommended Posts

Hi everyone, I really need some help here.

 

6.3.4 was ruining fine, logged into the browser GUI today and saw a 6.3.5 version available, so clicked on update and after it did its patching as I have done several times before I rebooted...  and now my issue which I don't believe is down to the upgrade but...

 

I left it a few minutes and then refreshed the webpage to unRaid and still a blank screen not connecting, pinged the IP of the server and no response.. hmm I thought.

I then plugged in a VGA Cable and connected it a monitor... the bios was sat trying to enable network boot at which point I thought that's not right it should have booted the USB drive.

Rebooted again and when into the bios, all drives show including the boot drive a Kingston Datatraveler 3.0 so forced a boot of the USB drive when the screen went blank for a couple of seconds and then the network boot kicked I bypassing the USB boot. That's not good I thought...

 

So I took the USB drive out of the server and connected it to my win 10 desktop when it presented me with a  "drive unrecognised do you want to format it" error, at that point I thought crap its corrupted. unplugged and re plugged in each time saying the same error, looks like it has failed.  I am now trying to create an image of the usb drive using R-Studio and it is giving me so lots of read disk errors and so going to take another 6hrs o I can see what data is on here.

 

I searched for a backup of the USB disk and I know I have one on the array... but so far haven't found another.. ?

 

How can I boot my server and mount the array, I don't want to just go ahead and try a default install on a different USB stick as not sure that would affect the array negativity.

 

Please help, what can I do?

 

Share this post


Link to post

Do you have a copy of your Registration Key file?   If you do, you can Install a virgin copy of unRAID on a new Flash Drive.  Then replace the old .key file with one linked to your new Flash Drive using the GUI.  see here:

 

   https://lime-technology.com/replace-key/

 

If you have a printout of your Drive assignment, you can assign the drives and start the array.  Otherwise, assign all of the drives as data drives and see which one is unformatted,.  That will be your parity drive.  (Your Data will be safe by doing this.)

 

As you probably realize by now (and more as a note to other folks who may read this), you should not made your only backups of your Flash Drive to the array but to a computer that you can access when the server is not available! 

Edited by Frank1940

Share this post


Link to post

Hello Frank1940, thanks for the quick reply.

 

I do have the reg key as I made a concerted  effort to save that by my mailing that to myself, pitty I didn't do that with config info... learning note to self!!!

Funny thing is I have been transferring data to the cloud, just not got to the folder that my unRaid saved files are in.. yes muppet award ?

 

I know what my drive arrays are as I labelled the drives in the server so know what's parity and drives1-6 plus ssd cache drive.

 

So, going to grab a fresh USB and see what happens...

 

 

 

 

Share this post


Link to post

Oh, actual order of the data drives is not important (with single parity)  although it may screw up things a tiny bit if you wanted to certain shares assigned to specific disks.  In that case, just don't save anything to the array until you recover your backup of the original Flash Drive.  Here is good guide to the files you will need to restore to your new Flash Drive:

 

   https://wiki.lime-technology.com/Upgrading_to_UnRAID_v6#Files_on_flash_drive

 

Another important item.  Make sure you made a backup copy of your new key file before you do any restore! 

Share this post


Link to post

Ok...  managed to get the server booted with 6.3.5 with my previous config data copied over and updated the reg key with the new guid of the USB drive and registration.

 

Couple of strange things though...

 

The server booted ok , parity, drives, shares however viewing the shares via the browser and its contents are ok I can see the folders, files and open files no issue.

But, when trying to connect to the server from windows and login it is not recognising my credentials. 

I even created a test user and test share adding test user to the share and still cannot log into the server/share with any account.

 

Has something gone screwy with the smb shares somehow... WELL... no,  I rebooted my win 10 pc and when logged into windows tried the share, it prompts me for a password and after about 10secs the folder appears and all files accessible. 

So, I wanted to add this so people are aware that sometimes a windows reboot can reset things. ?

 

I have made multiple backups both cloud and On-perm of my USB drive so should I get another failure I can restore easier.

 

2nd strange thing was that even after copying all my config data to the new USB the server name and identification went back to the defaults namely being named 'Tower'.

Not sure why that is... I just entered the same name and details I used previously and all was fine.

 

Thanks

 

Share this post


Link to post

You are not the only one who has had issues with Win10 and Samba in recent days.  I not sure if the source of the problem is with Samba or Win10.  With Win10's automatic updates (that often happen behind the scenes so folks are not even aware of them)  and the rapid sequences of Linux Samba updates these days, it is difficult to sort these problems out.  (Plus, Samba is a kludge and solving the problems that occur often seems more like Witchcraft than Engineering...)

Share this post


Link to post

That's true, and what with the WannaCry (Ransomware) issues globally and SMB amongst other things best to stay patched up all the time on all systems

 

Thanks for your comments and assistance today, back to normal operation :)

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.