Jump to content
dlandon

[support] dlandon - ownCloud

143 posts in this topic Last Reply

Recommended Posts

2 minutes ago, Squid said:

 

sorry, now I get it, but still no access.

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='ownCloud' --net='br0' --ip='192.168.1.25' --cpuset-cpus='0,1,2,3,4,5,6,7' -e TZ="Europe/Berlin" -e HOST_OS="Unraid" -e 'TCP_PORT_443'='443' -e 'PUID'='99' -e 'PGID'='100' -e 'DB_PASS'='owncloud' -v '/mnt/user/appdata/ownCloud/data':'/data':'rw' -v '/mnt/user/appdata/ownCloud':'/config':'rw' --log-opt max-size=50m --log-opt max-file=1 'dlandon/owncloud' 

a86eff774d57772e65e06894f5d53647b386711251fa28d68819075d99f60cf1

The command finished successfully!

 

Share this post


Link to post
Just now, cracksilver said:

sorry, now I get it, but still no access.

Your original problem was that there was an orphan.  Since that's now solved, I'm letting dlandon take over.

Share this post


Link to post
1 minute ago, Squid said:

Your original problem was that there was an orphan.  Since that's now solved, I'm letting dlandon take over.

What does orphan mean? Is there somethin broken in the image? What the best way to solve, just reinstall plugin with the same name?

 

thx

Share this post


Link to post
1 hour ago, Squid said:

An orphaned image only happens when an error occurs on the docker run.

IE: the container cannot execute because you've made a mistake somewhere in entering values on the template.  Usual cause is re-using a port that's already in use et al.

Share this post


Link to post
21 minutes ago, cracksilver said:

What does orphan mean? Is there somethin broken in the image? What the best way to solve, just reinstall plugin with the same name?

 

thx

Start over.

Remove the docker image and any orphans.

 

Delete the appdata/owncloud folder.

 

Use CA to find the docker and apply the default template.  Don’t make any changes.

Share this post


Link to post
10 minutes ago, dlandon said:

Start over.

Remove the docker image and any orphans.

 

Delete the appdata/owncloud folder.

 

Use CA to find the docker and apply the default template.  Don’t make any changes.

Did it. Same game. 

 

Shall I delete everything including DB and start again?

Share this post


Link to post
12 minutes ago, cracksilver said:

Did it. Same game. 

 

Shall I delete everything including DB and start again?

Yes.  Deleting the appdata folder removes everything.

 

Show me a screen shot where you see the error.

Share this post


Link to post
Quote
2 minutes ago, dlandon said:

Yes.  Deleting the appdata folder removes everything.

 

Show me a screen shot where you see the error.

 

thats what I did before... still not reachable..

screenshot_76.thumb.png.5327157e203fcc37e3233cfdd21a0ea7.png

Share this post


Link to post
13 minutes ago, cracksilver said:

thats what I did before... still not reachable..

screenshot_76.thumb.png.5327157e203fcc37e3233cfdd21a0ea7.png

That's a connection refused message.  That will occur if you try to access ownCloud with http:// which is what the nginx log showed earlier.  If you look at the address bar you should see a lock or https:// indicating secure access.  ownCloud refuses a http:// connection.  It has to be https://.

 

What shows when you click on the "DETAILS" button?

 

Try another browser or computer.  I suspect a browser issue.

Share this post


Link to post

I'm probably too stupid. I don't know anymore....

 

I set the network settings of my Unraid server (HP Gen8) on just one interface. No bridging, no bonding. Just standard, no extras. All other containers are reachable. 

 

Tried everything out. Bridge, Host, Custom-eth0. Same issue again.

 

Strangely, the installation via the WebGUI worked last night. Today when reinstalling I never had access to the WebGUI. Even after deleting all app data, browser cache and so on.

 

 

Share this post


Link to post
15 minutes ago, cracksilver said:

Like a wonder, after trying again.... I'm having fun again...

 

screenshot_78.thumb.png.78fb842128f99af5430035a86d93c1b0.png

 

bammmmm!!! like a hammer in the face:

screenshot_79.thumb.png.df255802b052f2a138eb31c43b67e670.png

 

I don’t remember the :443 on the database ip address.  Did you add that?

Share this post


Link to post
10 minutes ago, cracksilver said:

i really don't know, where exactly do you mean?

Change the 172.17.0.2:443 to 'localhost'.  Like this:

 

1853631416_ownClouddatabasesetup.png.58e4a18b8b4c46df3df1d2f851f67471.png

Share this post


Link to post

It is unbelievable. I'M IN THE WEBGUI FROM OWNCLOUD !!!!

 

That "localhost" was wrong. But yesterday get an error with that. After that I allways wrote the IP with Port there... 

 

Thank you VERY MUCH for not giving up with me !!! Wish you a good day/night, wherever you are at home ;-) i'm from Switzerland.

 

cracksilver

Share this post


Link to post
2 minutes ago, cracksilver said:

It is unbelievable. I'M IN THE WEBGUI FROM OWNCLOUD !!!!

 

That "localhost" was wrong. But yesterday get an error with that. After that I allways wrote the IP with Port there... 

 

Thank you VERY MUCH for not giving up with me !!! Wish you a good day/night, wherever you are at home ;-) i'm from Switzerland.

 

cracksilver

Glad you finally got it going.  I hail from the US.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now