Jump to content
Djoss

[Support] Djoss - MakeMKV

439 posts in this topic Last Reply

Recommended Posts

Hey Guys,

 

I've been using this container for some time now and have a pretty sizable media library, so thanks for your efforts. Recently however, I've lost my ability to rip discs. The hard stop seems to be that it doesn't recognize my fairly new optical drive with the auto ripper (nothing shows up) and in the GUI (says no optical drives), despite this being in the log on start up:

 

Registration key already up-to-date.
[cont-init.d] 90-makemkv.sh: exited 0.
[cont-init.d] 95-check-optical-drive.sh: executing...
[cont-init.d] 95-check-optical-drive.sh: looking for usable optical drives...
[cont-init.d] 95-check-optical-drive.sh: found optical drive [/dev/sr0, /dev/sg3], group 19.
[cont-init.d] 95-check-optical-drive.sh: exited 0.
[cont-init.d] 96-install-autodiscripper-srv.sh: executing...
[cont-init.d] 96-install-autodiscripper-srv.sh: installing automatic disc ripper service...
[cont-init.d] 96-install-autodiscripper-srv.sh: exited 0.

 

Now there are tons of errors related to fontconfigs that I assume are unrelated as I have been ripping despite them without issue until now. Thanks for any help you can provide.

Share this post


Link to post
15 hours ago, Tergo247 said:

Hey Guys,

 

I've been using this container for some time now and have a pretty sizable media library, so thanks for your efforts. Recently however, I've lost my ability to rip discs. The hard stop seems to be that it doesn't recognize my fairly new optical drive with the auto ripper (nothing shows up) and in the GUI (says no optical drives), despite this being in the log on start up:

 

Registration key already up-to-date.
[cont-init.d] 90-makemkv.sh: exited 0.
[cont-init.d] 95-check-optical-drive.sh: executing...
[cont-init.d] 95-check-optical-drive.sh: looking for usable optical drives...
[cont-init.d] 95-check-optical-drive.sh: found optical drive [/dev/sr0, /dev/sg3], group 19.
[cont-init.d] 95-check-optical-drive.sh: exited 0.
[cont-init.d] 96-install-autodiscripper-srv.sh: executing...
[cont-init.d] 96-install-autodiscripper-srv.sh: installing automatic disc ripper service...
[cont-init.d] 96-install-autodiscripper-srv.sh: exited 0.

 

Now there are tons of errors related to fontconfigs that I assume are unrelated as I have been ripping despite them without issue until now. Thanks for any help you can provide.

This same drive was recognized in the past?

Share this post


Link to post
17 minutes ago, Djoss said:

This same drive was recognized in the past?

Yes, I've ripped in something to the tune of 50 discs with it.

Share this post


Link to post
On 7/7/2019 at 9:15 PM, Tergo247 said:

Yes, I've ripped in something to the tune of 50 discs with it.

Could you provide the output of the following commands:

docker exec MakeMKV lsscsi -g -k

docker exec MakeMKV env HOME=/config s6-applyuidgid -u 99 -g 100 -G 19 /opt/makemkv/bin/makemkvcon -r --cache=1 info disc:9999

Share this post


Link to post
root@GowingNAS:~# docker exec MakeMKV lsscsi -g -k
[0:0:0:0]    disk    SanDisk  Cruzer Fit       1.00  /dev/sda   /dev/sg0
[1:0:0:0]    disk    ATA      WDC WD40EFRX-68N 0A82  /dev/sdb   /dev/sg1
[2:0:0:0]    disk    ATA      WDC WD40EFRX-68N 0A82  /dev/sdc   /dev/sg2
[3:0:0:0]    cd/dvd  ASUS     BC-12B1ST   b    3.00  /dev/sr0   /dev/sg3
[4:0:0:0]    disk    ATA      Samsung SSD 840  4B0Q  /dev/sdd   /dev/sg4
root@GowingNAS:~# docker exec MakeMKV env HOME=/config s6-applyuidgid -u 99 -g 100 -G 19 /opt/makemkv/bin/makemkvcon -r --cache=1 info disc:9999
MSG:1005,0,1,"MakeMKV v1.14.4 linux(x64-release) started","%1 started","MakeMKV v1.14.4 linux(x64-release)"
MSG:5042,0,0,"The program can't find any usable optical drives.","The program can't find any usable optical drives."
DRV:0,256,999,0,"","",""
DRV:1,256,999,0,"","",""
DRV:2,256,999,0,"","",""
DRV:3,256,999,0,"","",""
DRV:4,256,999,0,"","",""
DRV:5,256,999,0,"","",""
DRV:6,256,999,0,"","",""
DRV:7,256,999,0,"","",""
DRV:8,256,999,0,"","",""
DRV:9,256,999,0,"","",""
DRV:10,256,999,0,"","",""
DRV:11,256,999,0,"","",""
DRV:12,256,999,0,"","",""
DRV:13,256,999,0,"","",""
DRV:14,256,999,0,"","",""
DRV:15,256,999,0,"","",""
MSG:5010,0,0,"Failed to open disc","Failed to open disc"

Here's what I got. I ordered an external 5.25 enclosure. I'll be able to test the drive on another computer when it arrives.

Share this post


Link to post
22 hours ago, Tergo247 said:

root@GowingNAS:~# docker exec MakeMKV lsscsi -g -k
[0:0:0:0]    disk    SanDisk  Cruzer Fit       1.00  /dev/sda   /dev/sg0
[1:0:0:0]    disk    ATA      WDC WD40EFRX-68N 0A82  /dev/sdb   /dev/sg1
[2:0:0:0]    disk    ATA      WDC WD40EFRX-68N 0A82  /dev/sdc   /dev/sg2
[3:0:0:0]    cd/dvd  ASUS     BC-12B1ST   b    3.00  /dev/sr0   /dev/sg3
[4:0:0:0]    disk    ATA      Samsung SSD 840  4B0Q  /dev/sdd   /dev/sg4
root@GowingNAS:~# docker exec MakeMKV env HOME=/config s6-applyuidgid -u 99 -g 100 -G 19 /opt/makemkv/bin/makemkvcon -r --cache=1 info disc:9999
MSG:1005,0,1,"MakeMKV v1.14.4 linux(x64-release) started","%1 started","MakeMKV v1.14.4 linux(x64-release)"
MSG:5042,0,0,"The program can't find any usable optical drives.","The program can't find any usable optical drives."
DRV:0,256,999,0,"","",""
DRV:1,256,999,0,"","",""
DRV:2,256,999,0,"","",""
DRV:3,256,999,0,"","",""
DRV:4,256,999,0,"","",""
DRV:5,256,999,0,"","",""
DRV:6,256,999,0,"","",""
DRV:7,256,999,0,"","",""
DRV:8,256,999,0,"","",""
DRV:9,256,999,0,"","",""
DRV:10,256,999,0,"","",""
DRV:11,256,999,0,"","",""
DRV:12,256,999,0,"","",""
DRV:13,256,999,0,"","",""
DRV:14,256,999,0,"","",""
DRV:15,256,999,0,"","",""
MSG:5010,0,0,"Failed to open disc","Failed to open disc"

Here's what I got. I ordered an external 5.25 enclosure. I'll be able to test the drive on another computer when it arrives.

Could you also provide the output of:

ls -l /dev/sr0 /dev/sg3

 

Do you know if the problem started after an updated version of MakeMKV ?

Share this post


Link to post

Hey guys I'm having a problem where, when I start the MakeMKV docker, several of my CPU threads go to 100%. This is on unraid 6.7.2 and wasn't happening before. Latest versions of community applications and MakeMKV. Also have Plex and Handbrake dockers. Any ideas?

Share this post


Link to post
On 7/19/2019 at 1:57 PM, thorkull said:

Hey guys I'm having a problem where, when I start the MakeMKV docker, several of my CPU threads go to 100%. This is on unraid 6.7.2 and wasn't happening before. Latest versions of community applications and MakeMKV. Also have Plex and Handbrake dockers. Any ideas?

Does MakeMKV is ripping a disc?

Share this post


Link to post
18 hours ago, Djoss said:

Does MakeMKV is ripping a disc?

No, just starting the Docker is enough to cause this to happen.

Share this post


Link to post
5 hours ago, thorkull said:

No, just starting the Docker is enough to cause this to happen.

You can try to run "htop" to see which process is using the cpu.

Share this post


Link to post
On 7/21/2019 at 7:23 PM, Djoss said:

You can try to run "htop" to see which process is using the cpu.


 

 1  [|                                                                       0.7%]   5  [                                                                        0.0%]
  2  [|                                                                       0.7%]   6  [                                                                        0.0%]
  3  [|                                                                       0.7%]   7  [                                                                        0.0%]
  4  [                                                                        0.0%]   8  [                                                                        0.0%]
  Mem[|||||||||||||||||||||||||||||||||||||||||||||||||||||            1.69G/31.4G]   Tasks: 89, 179 thr; 2 running
  Swp[                                                                       0K/0K]   Load average: 5.27 4.97 3.58
                                                                                      Uptime: 6 days, 00:19:12

  PID USER      PRI  NI  VIRT   RES   SHR S CPU% MEM%   TIME+  Command
 9412 root       20   0  6364  4468  3100 R  0.7  0.0  0:09.21 htop
 3310 root       20   0 1090M 58452 35252 S  0.7  0.2 19:31.76 /usr/bin/dockerd -p /var/run/dockerd.pid --storage-driver=btrfs --log-level=error
 2997 nobody     20   0  146M  8480  3980 S  0.7  0.0  1:31.73 nginx: worker process
20334 root       20   0  111M 13384  7840 S  0.7  0.0  0:00.06 php-fpm: pool www
 3325 root       20   0 1090M 58452 35252 S  0.7  0.2  0:38.14 /usr/bin/dockerd -p /var/run/dockerd.pid --storage-driver=btrfs --log-level=error
16951 root       20   0  603M 29588 21656 S  0.7  0.1  0:37.50 containerd --config /var/run/docker/containerd/containerd.toml --log-level error
11372 nobody     20   0  290M 42356 31744 S  0.0  0.1  0:02.96 /opt/makemkv/bin makemkv
20307 root       20   0  111M 13388  7840 S  0.0  0.0  0:00.07 php-fpm: pool www
 4277 nobody     35  15 1666M 53828 10396 S  0.0  0.2  2:05.64 Plex Plug-in [com.plexapp.system] /usr/lib/plexmediaserver/Resources/Plug-ins-ad17d5f9e/Framework.bundle/Conte
 4122 nobody     20   0 2227M  175M 38540 S  0.0  0.5 15:31.46 /usr/lib/plexmediaserver/Plex Media Server
 3329 root       20   0  603M 29588 21656 S  0.0  0.1 15:36.14 containerd --config /var/run/docker/containerd/containerd.toml --log-level error
 3350 root       20   0 1090M 58452 35252 S  0.0  0.2  0:57.34 /usr/bin/dockerd -p /var/run/dockerd.pid --storage-driver=btrfs --log-level=error
 4304 nobody     20   0 2386M  605M 19044 S  0.0  1.9 22:41.17 /usr/lib/plexmediaserver/Plex DLNA Server
 2993 root       20   0 13272  4308  3240 S  0.0  0.0 12:49.19 ttyd -d 0 -i /var/run/ttyd.sock login -f root
11363 root       20   0 19412  7684  3132 S  0.0  0.0  0:01.14 /usr/bin/x11vnc -display :0 -rfbport 5900 -rfbportv6 -1 -no6 -noipv6 -httpportv6 -1 -forever -desktop MakeMKV
11399 nobody     20   0  521M 11464  9408 S  0.0  0.0  0:01.16 /opt/makemkv/bin/makemkvcon guiserver G0012
 4512 nobody     20   0 2386M  605M 19044 S  0.0  1.9  2:13.55 /usr/lib/plexmediaserver/Plex DLNA Server
 3803 nobody     20   0 2386M  605M 19044 S  0.0  1.9  3:27.77 /usr/lib/plexmediaserver/Plex DLNA Server
32558 nobody     20   0 1666M 53828 10396 S  0.0  0.2  0:03.78 Plex Plug-in [com.plexapp.system] /usr/lib/plexmediaserver/Resources/Plug-ins-ad17d5f9e/Framework.bundle/Conte
 3346 root       20   0  603M 29588 21656 S  0.0  0.1  0:47.32 containerd --config /var/run/docker/containerd/containerd.toml --log-level error
 3345 root       20   0  603M 29588 21656 S  0.0  0.1  0:48.73 containerd --config /var/run/docker/containerd/containerd.toml --log-level error
 4151 nobody     35  15 1666M 53828 10396 S  0.0  0.2  8:14.22 Plex Plug-in [com.plexapp.system] /usr/lib/plexmediaserver/Resources/Plug-ins-ad17d5f9e/Framework.bundle/Conte
 4432 nobody     20   0 2386M  605M 19044 S  0.0  1.9  0:03.96 /usr/lib/plexmediaserver/Plex DLNA Server
 4123 nobody     20   0 2227M  175M 38540 S  0.0  0.5  0:36.17 /usr/lib/plexmediaserver/Plex Media Server
 3324 root       20   0 1090M 58452 35252 S  0.0  0.2  1:01.52 /usr/bin/dockerd -p /var/run/dockerd.pid --storage-driver=btrfs --log-level=error
 4494 nobody     20   0 2386M  605M 19044 S  0.0  1.9  0:02.92 /usr/lib/plexmediaserver/Plex DLNA Server
 4282 nobody     20   0 2227M  175M 38540 S  0.0  0.5  2:30.99 /usr/lib/plexmediaserver/Plex Media Server
11398 nobody     20   0  521M 11464  9408 S  0.0  0.0  0:01.31 /opt/makemkv/bin/makemkvcon guiserver G0012
 3328 root       20   0 1090M 58452 35252 S  0.0  0.2  1:02.94 /usr/bin/dockerd -p /var/run/dockerd.pid --storage-driver=btrfs --log-level=error
14723 root       20   0 1090M 58452 35252 S  0.0  0.2  0:58.13 /usr/bin/dockerd -p /var/run/dockerd.pid --storage-driver=btrfs --log-level=error
 3338 root       20   0  603M 29588 21656 S  0.0  0.1  0:41.69 containerd --config /var/run/docker/containerd/containerd.toml --log-level error
11640 root       20   0  603M 29588 21656 S  0.0  0.1  0:48.19 containerd --config /var/run/docker/containerd/containerd.toml --log-level error
 4507 nobody     20   0 2386M  605M 19044 S  0.0  1.9  2:13.35 /usr/lib/plexmediaserver/Plex DLNA Server

Note that the above doesn't match the GUI:

 

Unraid_MakeMKV_HighCPU.png.76828758855acc6c3c21f9528d6ad9a3.png

Share this post


Link to post

Is the UI always showing 100% ?  Or it's only spikes?

Share this post


Link to post

Hi guys.

 

Does anybody know how to fix the 'your application has temporarily expired' issue? This is the first time I have seen it. It asks about a beta registration key or something. 

 

Thanks!

Share this post


Link to post
21 hours ago, Typhoon said:

Hi guys.

 

Does anybody know how to fix the 'your application has temporarily expired' issue? This is the first time I have seen it. It asks about a beta registration key or something. 

 

Thanks!

The beta key you had probably expired.  Try to restart the container to get the latest one.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.